Bug 275488

Summary: Spell check for multiple languages
Product: [I don't know] kde Reporter: Sergey Malkin <adresatt>
Component: generalAssignee: Unassigned bugs mailing-list <unassigned-bugs>
Status: RESOLVED DUPLICATE    
Severity: wishlist CC: okitain
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Arch Linux   
OS: Linux   
Latest Commit: Version Fixed In:

Description Sergey Malkin 2011-06-12 21:25:40 UTC
Version:           unspecified (using KDE 4.6.3) 
OS:                Linux

I'm from Russia and my primary language is russian. But if I select it as a deafult language for spell check in system settings, all english text is marked as misspelled. Besides it's just annoying, it seems that spell checking is possible only for one language at once, and a lot of people, including me, aren't satisfied by that. As a workaround, I created combined aspell dictionary containing both russian and english words, but It'd be far more handy to have an option in system settings for selecting more than one language for spell check.

Reproducible: Always
Comment 1 okitain 2011-06-12 21:59:47 UTC
I'd be satisfied with a switch on the fly, like in browsers.
Comment 2 Alexey Bondarchuk 2011-06-12 22:33:08 UTC
*** This bug has been confirmed by popular vote. ***
Comment 3 Christoph Feck 2011-06-13 00:28:40 UTC

*** This bug has been marked as a duplicate of bug 125506 ***