Bug 275310

Summary: Plasma crashed during shutdown while Amarok was open
Product: plasma4 Reporter: Pieter Botha <info>
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: andresbajotierra
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: openSUSE RPMs   
OS: Linux   
Latest Commit: Version Fixed In:

Description Pieter Botha 2011-06-09 22:55:44 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.3 (4.6.3) "release 4"
Qt Version: 4.7.3
Operating System: Linux 2.6.37.1-1.2-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
Amarok was open when I clicked shutdown from the menu. This crash does not happen always. Please validate backtrace for possible duplication.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Plasma Desktop Shell (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fc52ab7b760 (LWP 3311))]

Thread 2 (Thread 0x7fc5098d7700 (LWP 3364)):
#0  0x00007fc52826a503 in poll () from /lib64/libc.so.6
#1  0x00007fc5250c5114 in ?? () from /lib64/libglib-2.0.so.0
#2  0x00007fc5250c5650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007fc529860286 in QEventDispatcherGlib::processEvents (this=0x7fc5040008b0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fc5298348d2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fc529834ae5 in QEventLoop::exec (this=0x7fc5098d6de0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fc5297497a4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007fc529816008 in QInotifyFileSystemWatcherEngine::run (this=0xb588d0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fc52974c095 in QThreadPrivate::start (arg=0xb588d0) at thread/qthread_unix.cpp:320
#9  0x00007fc5294bba3f in start_thread () from /lib64/libpthread.so.0
#10 0x00007fc52827367d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fc52ab7b760 (LWP 3311)):
[KCrash Handler]
#6  0x00007fc52a4c3f7f in QString (this=0x13c0075, group=0, state=0) at /usr/include/QtCore/qstring.h:728
#7  KIconEffect::fingerprint (this=0x13c0075, group=0, state=0) at /usr/src/debug/kdelibs-4.6.3/kdeui/icons/kiconeffect.cpp:169
#8  0x00007fc52a4c5500 in KIconLoaderPrivate::makeCacheKey (this=<value optimized out>, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at /usr/src/debug/kdelibs-4.6.3/kdeui/icons/kiconloader.cpp:782
#9  0x00007fc52a5f3331 in KIconLoader::loadIcon (this=0xcbf0d0, _name=<value optimized out>, group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at /usr/src/debug/kdelibs-4.6.3/kdeui/icons/kiconloader.cpp:1226
#10 0x00007fc52a5f4410 in KIconEngine::pixmap (this=<value optimized out>, size=..., mode=<value optimized out>, state=<value optimized out>) at /usr/src/debug/kdelibs-4.6.3/kdeui/icons/kiconengine.cpp:93
#11 0x00007fc528a87a65 in QIcon::pixmap (this=<value optimized out>, size=<value optimized out>, mode=<value optimized out>, state=<value optimized out>) at image/qicon.cpp:676
#12 0x00007fc52062fc41 in Plasma::IconWidgetPrivate::decoration (this=0x1763f90, option=<value optimized out>, useHoverEffect=false, usePressedEffect=false) at /usr/src/debug/kdelibs-4.6.3/plasma/widgets/iconwidget.cpp:812
#13 0x00007fc520635aab in Plasma::IconWidget::paint (this=0x15f5980, painter=0x7fff593426e0, option=0x6c6c98, widget=<value optimized out>) at /usr/src/debug/kdelibs-4.6.3/plasma/widgets/iconwidget.cpp:1128
#14 0x00007fc50fc74c19 in ?? () from /usr/lib64/kde4/plasma_applet_systemtray.so
#15 0x00007fc528fc5eed in _q_paintItem (item=<value optimized out>, painter=0x7fff593426e0, option=0x6c6c98, widget=0x0, useWindowOpacity=<value optimized out>, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4314
#16 0x00007fc528fc6200 in _q_paintIntoCache (pix=0x7fff59342c30, item=0x15f5990, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x6c6c98, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4352
#17 0x00007fc528fda192 in QGraphicsScenePrivate::drawItemHelper (this=0x6c6a70, item=0x15f5990, painter=0x7fff59344cb0, option=<value optimized out>, widget=<value optimized out>, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4690
#18 0x00007fc528fdacf8 in QGraphicsScenePrivate::draw (this=0x6c6a70, item=0x15f5990, painter=0x7fff59344cb0, viewTransform=0x7fff59344a40, transformPtr=0x7fff59343300, exposedRegion=0x11cd3f0, widget=0x1097b40, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4962
#19 0x00007fc528fdb957 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x6c6a70, item=0x15f5990, painter=0x7fff59344cb0, viewTransform=0x7fff59344a40, exposedRegion=0x11cd3f0, widget=0x1097b40, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#20 0x00007fc528fdab70 in QGraphicsScenePrivate::draw (this=0x6c6a70, item=0xa0e0c0, painter=0x7fff59344cb0, viewTransform=0x7fff59344a40, transformPtr=0x7fff59343910, exposedRegion=0x11cd3f0, widget=0x1097b40, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#21 0x00007fc528fdb957 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x6c6a70, item=0xa0e0c0, painter=0x7fff59344cb0, viewTransform=0x7fff59344a40, exposedRegion=0x11cd3f0, widget=0x1097b40, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#22 0x00007fc528fdab70 in QGraphicsScenePrivate::draw (this=0x6c6a70, item=0x950810, painter=0x7fff59344cb0, viewTransform=0x7fff59344a40, transformPtr=0x7fff59343f20, exposedRegion=0x11cd3f0, widget=0x1097b40, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#23 0x00007fc528fdb957 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x6c6a70, item=0x950810, painter=0x7fff59344cb0, viewTransform=0x7fff59344a40, exposedRegion=0x11cd3f0, widget=0x1097b40, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#24 0x00007fc528fdab70 in QGraphicsScenePrivate::draw (this=0x6c6a70, item=0x81e650, painter=0x7fff59344cb0, viewTransform=0x7fff59344a40, transformPtr=0x7fff59344530, exposedRegion=0x11cd3f0, widget=0x1097b40, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#25 0x00007fc528fdb957 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x6c6a70, item=0x81e650, painter=0x7fff59344cb0, viewTransform=0x7fff59344a40, exposedRegion=0x11cd3f0, widget=0x1097b40, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#26 0x00007fc528fdc1ec in QGraphicsScenePrivate::drawItems (this=0x6c6a70, painter=0x7fff59344cb0, viewTransform=0x7fff59344a40, exposedRegion=0x11cd3f0, widget=0x1097b40) at graphicsview/qgraphicsscene.cpp:4735
#27 0x00007fc528ff949c in QGraphicsView::paintEvent (this=<value optimized out>, event=<value optimized out>) at graphicsview/qgraphicsview.cpp:3469
#28 0x00007fc528a31c0e in QWidget::event (this=0xee8030, event=0x7fff59345600) at kernel/qwidget.cpp:8405
#29 0x00007fc528dd6a86 in QFrame::event (this=0xee8030, e=0x7fff59345600) at widgets/qframe.cpp:557
#30 0x00007fc528ffa73b in QGraphicsView::viewportEvent (this=0xee8030, event=0x7fff59345600) at graphicsview/qgraphicsview.cpp:2864
#31 0x00007fc529835607 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x1097b40, event=0x7fff59345600) at kernel/qcoreapplication.cpp:846
#32 0x00007fc5289e0111 in QApplicationPrivate::notify_helper (this=0x6c8b70, receiver=0x1097b40, e=0x7fff59345600) at kernel/qapplication.cpp:4458
#33 0x00007fc5289e86fa in QApplication::notify (this=<value optimized out>, receiver=0x1097b40, e=0x7fff59345600) at kernel/qapplication.cpp:4341
#34 0x00007fc52a4db006 in KApplication::notify (this=0x6aea40, receiver=0x1097b40, event=0x7fff59345600) at /usr/src/debug/kdelibs-4.6.3/kdeui/kernel/kapplication.cpp:311
#35 0x00007fc52983547c in QCoreApplication::notifyInternal (this=0x6aea40, receiver=0x1097b40, event=0x7fff59345600) at kernel/qcoreapplication.cpp:731
#36 0x00007fc528a2eae2 in sendSpontaneousEvent (this=0x10312a0, pdev=0x11650a8, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xbcb730) at ../../src/corelib/kernel/qcoreapplication.h:218
#37 QWidgetPrivate::drawWidget (this=0x10312a0, pdev=0x11650a8, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xbcb730) at kernel/qwidget.cpp:5492
#38 0x00007fc528a2f6af in QWidgetPrivate::paintSiblingsRecursive (this=0x11ccf60, pdev=0x11650a8, siblings=<value optimized out>, index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xbcb730) at kernel/qwidget.cpp:5699
#39 0x00007fc528a2e84a in QWidgetPrivate::drawWidget (this=0x11ccf60, pdev=0x11650a8, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0xbcb730) at kernel/qwidget.cpp:5545
#40 0x00007fc528bf1cf1 in QWidgetBackingStore::sync (this=0xbcb730) at painting/qbackingstore.cpp:1333
#41 0x00007fc528a24720 in QWidgetPrivate::syncBackingStore (this=0x11ccf60) at kernel/qwidget.cpp:1842
#42 0x00007fc528a32112 in QWidget::event (this=0xee8030, event=0xcbf0d0) at kernel/qwidget.cpp:8552
#43 0x00007fc528dd6a86 in QFrame::event (this=0xee8030, e=0xcbf0d0) at widgets/qframe.cpp:557
#44 0x00007fc528e57bab in QAbstractScrollArea::event (this=0xee8030, e=0xcbf0d0) at widgets/qabstractscrollarea.cpp:996
#45 0x00007fc5185e9a90 in ?? () from /usr/lib64/libkdeinit4_plasma-desktop.so
#46 0x00007fc5289e0144 in QApplicationPrivate::notify_helper (this=0x6c8b70, receiver=0xee8030, e=0xcbf0d0) at kernel/qapplication.cpp:4462
#47 0x00007fc5289e86fa in QApplication::notify (this=<value optimized out>, receiver=0xee8030, e=0xcbf0d0) at kernel/qapplication.cpp:4341
#48 0x00007fc52a4db006 in KApplication::notify (this=0x6aea40, receiver=0xee8030, event=0xcbf0d0) at /usr/src/debug/kdelibs-4.6.3/kdeui/kernel/kapplication.cpp:311
#49 0x00007fc52983547c in QCoreApplication::notifyInternal (this=0x6aea40, receiver=0xee8030, event=0xcbf0d0) at kernel/qcoreapplication.cpp:731
#50 0x00007fc529838c75 in sendEvent (receiver=0xee8030, event_type=77, data=0x6103e0) at kernel/qcoreapplication.h:215
#51 QCoreApplicationPrivate::sendPostedEvents (receiver=0xee8030, event_type=77, data=0x6103e0) at kernel/qcoreapplication.cpp:1372
#52 0x00007fc528fd2a6a in dispatchPendingUpdateRequests (this=0x6c6a70) at ../../src/gui/graphicsview/qgraphicsview_p.h:189
#53 QGraphicsScenePrivate::_q_processDirtyItems (this=0x6c6a70) at graphicsview/qgraphicsscene.cpp:510
#54 0x00007fc528fd2e6a in QGraphicsScene::qt_metacall (this=0x6cf390, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x148d1b0) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#55 0x00007fc5205834a5 in Plasma::Corona::qt_metacall (this=0x6cf390, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x148d1b0) at /usr/src/debug/kdelibs-4.6.3/build/plasma/corona.moc:109
#56 0x00007fc5185dd735 in ?? () from /usr/lib64/libkdeinit4_plasma-desktop.so
#57 0x00007fc52984937a in QObject::event (this=0x6cf390, e=<value optimized out>) at kernel/qobject.cpp:1217
#58 0x00007fc528fdfb40 in QGraphicsScene::event (this=0x6cf390, event=0x17bbbe0) at graphicsview/qgraphicsscene.cpp:3544
#59 0x00007fc5289e0144 in QApplicationPrivate::notify_helper (this=0x6c8b70, receiver=0x6cf390, e=0x17bbbe0) at kernel/qapplication.cpp:4462
#60 0x00007fc5289e86fa in QApplication::notify (this=<value optimized out>, receiver=0x6cf390, e=0x17bbbe0) at kernel/qapplication.cpp:4341
#61 0x00007fc52a4db006 in KApplication::notify (this=0x6aea40, receiver=0x6cf390, event=0x17bbbe0) at /usr/src/debug/kdelibs-4.6.3/kdeui/kernel/kapplication.cpp:311
#62 0x00007fc52983547c in QCoreApplication::notifyInternal (this=0x6aea40, receiver=0x6cf390, event=0x17bbbe0) at kernel/qcoreapplication.cpp:731
#63 0x00007fc529838c75 in sendEvent (receiver=0x0, event_type=0, data=0x6103e0) at kernel/qcoreapplication.h:215
#64 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x6103e0) at kernel/qcoreapplication.cpp:1372
#65 0x00007fc529860093 in sendPostedEvents (s=0x6cc760) at kernel/qcoreapplication.h:220
#66 postEventSourceDispatch (s=0x6cc760) at kernel/qeventdispatcher_glib.cpp:277
#67 0x00007fc5250c4bd3 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#68 0x00007fc5250c53b0 in ?? () from /lib64/libglib-2.0.so.0
#69 0x00007fc5250c5650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#70 0x00007fc52986022f in QEventDispatcherGlib::processEvents (this=0x6cab60, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#71 0x00007fc528a85bae in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#72 0x00007fc5298348d2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#73 0x00007fc529834ae5 in QEventLoop::exec (this=0x7fff59347680, flags=...) at kernel/qeventloop.cpp:201
#74 0x00007fc529838f2b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#75 0x00007fc5185e42bd in kdemain () from /usr/lib64/libkdeinit4_plasma-desktop.so
#76 0x00000000004075c9 in launch (argc=1, _name=0x67d9a8 "/usr/bin/plasma-desktop", args=<value optimized out>, cwd=0x0, envc=<value optimized out>, envs=<value optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x40b357 "0") at /usr/src/debug/kdelibs-4.6.3/kinit/kinit.cpp:734
#77 0x00000000004080bd in handle_launcher_request (sock=8, who=<value optimized out>) at /usr/src/debug/kdelibs-4.6.3/kinit/kinit.cpp:1226
#78 0x000000000040885a in handle_requests (waitForPid=<value optimized out>) at /usr/src/debug/kdelibs-4.6.3/kinit/kinit.cpp:1419
#79 0x00000000004094b0 in main (argc=4, argv=0x7fff59348ba8, envp=0x7fff59348bd0) at /usr/src/debug/kdelibs-4.6.3/kinit/kinit.cpp:1907

This bug may be a duplicate of or related to bug 275246.

Possible duplicates by query: bug 275246, bug 275227, bug 275138, bug 275086, bug 275005.

Reported using DrKonqi
Comment 1 Dario Andres 2011-06-11 17:52:45 UTC
[Comment from a bug triager]
The bug is fixed in KDE SC 4.6.4. The issue was being tracked at bug 258706, merging.
Thanks

*** This bug has been marked as a duplicate of bug 258706 ***