Bug 274424

Summary: invert effect causes shadow to become 'white band'
Product: [Plasma] kwin Reporter: Mohd Asif Ali Rizwaan <maarizwan>
Component: effects-variousAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED FIXED    
Severity: normal    
Priority: NOR    
Version: 0.2   
Target Milestone: ---   
Platform: Archlinux   
OS: Linux   
Latest Commit: Version Fixed In: 4.7.0

Description Mohd Asif Ali Rizwaan 2011-05-29 14:59:53 UTC
Version:           0.2 (using Devel) 
OS:                Linux

using kde 4.7beta1, qt 4.7.3, archlinux kernel 2.6.39
nouveau-dri 7.10.99.git20110526-1
xf86-video-nouveau 0.0.16_git20110316-2
---
please see the video; the new shadow becomes 'opaque' bands instead of being transparent when inverted.

Inverted shadows are opaque instead of being transparent. It applies to all widget, kwin, lineedit, menu shadows.

video: 
http://www.mediafire.com/?fbb4wsszvbyaa8v

Reproducible: Always

Steps to Reproduce:
1. enable invert feature in kwin effects
2. open 1 or two application windows
3. press ctrl+meta+i (or) ctrl+meta+u to invert colors
4. observe the shadows, the transparent blue shadows become while blocks around the window



Expected Results:  
inverted shadows should also be transparent.

OS: Linux (i686) release 2.6.39-ARCH
Compiler: gcc
Comment 1 Martin Flöser 2011-05-29 15:04:12 UTC
There seems to be an overall problem with invert effect
Comment 2 Martin Flöser 2011-06-02 11:41:55 UTC
Git commit f224a69a820daf5b934022a2b9d29427176773cb by Martin Gräßlin.
Committed on 02/06/2011 at 11:40.
Pushed by graesslin into branch 'master'.

Fix blending issue with invert effect

Actually it's more a hack and should be addressed in the next
release cycle by allowing effects to modify the scene's blend
equation.
BUG: 274424
FIXED-IN: 4.7.0

M  +1    -0    kwin/effects/invert/data/invert.frag     

http://commits.kde.org/kde-workspace/f224a69a820daf5b934022a2b9d29427176773cb