Bug 273575

Summary: Plasma crashed after wake up from suspending state
Product: [Plasma] plasma4 Reporter: Bikov Rinat <becase>
Component: widget-devicenotifierAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: asraniel, lamarque, wilderkde
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description Bikov Rinat 2011-05-18 18:23:21 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.39-pure-emerald-alt1.rc6 i686
Distribution: "ALT Linux Sisyphus (20081222)"

-- Information about the crash:
- What I was doing when the application crashed:

When I try to wake up from suspending state, computer after login suspends again and after consecutive second wake up plasma crashed.

-- Backtrace:
Application: Оболочка Plasma (plasma-desktop), signal: Segmentation fault
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0xb32c8b60 (LWP 5939))]

Thread 2 (Thread 0xaa776b70 (LWP 5995)):
#0  0xb4396d56 in clock_gettime (clock_id=1, tp=0xaa775f40) at ../sysdeps/unix/clock_gettime.c:100
#1  0xb6ade1b8 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb6b99952 in updateCurrentTime (this=0xa9e00b74, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0xa9e00b74, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb6b98172 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xaa77602c) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb6b98205 in timerSourcePrepare (source=0xa9e00b40, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb42fab2e in g_main_context_prepare (context=<value optimized out>, priority=0xaa77609c) at gmain.c:2761
#8  0xb42fba5b in g_main_context_iterate (context=0x975dd18, block=1, dispatch=1, self=<value optimized out>) at gmain.c:3071
#9  0xb42fc158 in g_main_context_iteration (context=0x975dd18, may_block=1) at gmain.c:3154
#10 0xb6b98967 in QEventDispatcherGlib::processEvents (this=0x975d5c0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb6b6e529 in QEventLoop::processEvents (this=0xaa7761f4, flags=...) at kernel/qeventloop.cpp:149
#12 0xb6b6e7d2 in QEventLoop::exec (this=0xaa7761f4, flags=...) at kernel/qeventloop.cpp:197
#13 0xb6a89f42 in QThread::exec (this=0x975c9a0) at thread/qthread.cpp:492
#14 0xb6b542fb in QInotifyFileSystemWatcherEngine::run (this=0x975c9a0) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb6a8c364 in QThreadPrivate::start (arg=0x975c9a0) at thread/qthread_unix.cpp:320
#16 0xb6a1a940 in start_thread (arg=0xaa776b70) at pthread_create.c:297
#17 0xb778480e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb32c8b60 (LWP 5939)):
[KCrash Handler]
#6  0x00000001 in ?? ()
#7  0xb49cd603 in QExplicitlySharedDataPointer<Solid::DevicePrivate>::~QExplicitlySharedDataPointer (this=0x9f4ee44, __in_chrg=<value optimized out>) at /usr/include/qt4/QtCore/qshareddata.h:161
#8  0xab29f7dc in ?? () from /usr/lib/kde4/plasma_engine_hotplug.so
#9  0xab29f816 in ?? () from /usr/lib/kde4/plasma_engine_hotplug.so
#10 0xab29fba8 in ?? () from /usr/lib/kde4/plasma_engine_hotplug.so
#11 0xab29e081 in ?? () from /usr/lib/kde4/plasma_engine_hotplug.so
#12 0xab29f008 in ?? () from /usr/lib/kde4/plasma_engine_hotplug.so
#13 0xb6b74f3e in QMetaObject::metacall (object=0x9902690, cl=QMetaObject::InvokeMetaMethod, idx=25, argv=0xbfabaec8) at kernel/qmetaobject.cpp:237
#14 0xb6b82dda in QMetaObject::activate (sender=0x97527e0, m=0xb4a26cf0, local_signal_index=1, argv=0xbfabaec8) at kernel/qobject.cpp:3283
#15 0xb49cde53 in Solid::DeviceNotifier::deviceRemoved (this=0x97527e0, _t1=...) at /usr/src/debug/kdelibs-4.6.2/BUILD-i586-alt-linux/solid/solid/devicenotifier.moc:94
#16 0xb49ce5b5 in Solid::DeviceManagerPrivate::_k_deviceRemoved (this=0x97527e0, udi=...) at /usr/src/debug/kdelibs-4.6.2/solid/solid/devicemanager.cpp:207
#17 0xb49cea09 in Solid::DeviceManagerPrivate::qt_metacall (this=0x97527e0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfabb048) at /usr/src/debug/kdelibs-4.6.2/BUILD-i586-alt-linux/solid/solid/devicemanager_p.moc:80
#18 0xb6b74f3e in QMetaObject::metacall (object=0x97527e0, cl=QMetaObject::InvokeMetaMethod, idx=7, argv=0xbfabb048) at kernel/qmetaobject.cpp:237
#19 0xb6b82dda in QMetaObject::activate (sender=0x975d680, m=0xb4a27c10, local_signal_index=1, argv=0xbfabb048) at kernel/qobject.cpp:3283
#20 0xb49dc362 in Solid::Ifaces::DeviceManager::deviceRemoved (this=0x975d680, _t1=...) at /usr/src/debug/kdelibs-4.6.2/BUILD-i586-alt-linux/solid/solid/ifaces/devicemanager.moc:94
#21 0xb4a05e92 in slotDeviceRemoved (this=0x975d680, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfabb31c) at /usr/src/debug/kdelibs-4.6.2/solid/solid/backends/upower/upowermanager.cpp:164
#22 Solid::Backends::UPower::UPowerManager::qt_metacall (this=0x975d680, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfabb31c) at /usr/src/debug/kdelibs-4.6.2/BUILD-i586-alt-linux/solid/solid/backends/upower/upowermanager.moc:78
#23 0xb6b74f3e in QMetaObject::metacall (object=0x975d680, cl=QMetaObject::InvokeMetaMethod, idx=7, argv=0xbfabb31c) at kernel/qmetaobject.cpp:237
#24 0xb6b82dda in QMetaObject::activate (sender=0x975d68c, m=0x976c6a8, local_signal_index=4, argv=0xbfabb31c) at kernel/qobject.cpp:3283
#25 0xb6c6ec0d in QDBusInterfacePrivate::metacall (this=0x975da38, c=QMetaObject::InvokeMetaMethod, id=4, argv=0xbfabb31c) at qdbusinterface.cpp:278
#26 0xb6c5dcec in QDBusConnectionPrivate::deliverCall (this=0x910e160, object=0x975d68c, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:941
#27 0xb6c667f7 in QDBusCallDeliveryEvent::placeMetaCall (this=0x9ebfb68, object=0x975d68c) at qdbusintegrator_p.h:103
#28 0xb6b82907 in QObject::event (this=0x975d68c, e=0x9ebfb68) at kernel/qobject.cpp:1222
#29 0xb62af59c in QApplicationPrivate::notify_helper (this=0x9079ce0, receiver=0x975d68c, e=0x9ebfb68) at kernel/qapplication.cpp:4462
#30 0xb62b3ee8 in QApplication::notify (this=0x906e860, receiver=0x975d68c, e=0x9ebfb68) at kernel/qapplication.cpp:3862
#31 0xb6fe6ac7 in KApplication::notify (this=0x906e860, receiver=0x975d68c, event=0x9ebfb68) at /usr/src/debug/kdelibs-4.6.2/kdeui/kernel/kapplication.cpp:311
#32 0xb6b6f2d8 in QCoreApplication::notifyInternal (this=0x906e860, receiver=0x975d68c, event=0x9ebfb68) at kernel/qcoreapplication.cpp:731
#33 0xb6b7215a in sendEvent (receiver=0x0, event_type=0, data=0x90410a0) at ../../src/corelib/kernel/qcoreapplication.h:215
#34 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x90410a0) at kernel/qcoreapplication.cpp:1369
#35 0xb6b7222d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1265
#36 0xb6b987d4 in sendPostedEvents (s=0x90798a8) at ../../src/corelib/kernel/qcoreapplication.h:220
#37 postEventSourceDispatch (s=0x90798a8) at kernel/qeventdispatcher_glib.cpp:277
#38 0xb42fb68a in g_main_dispatch (context=0x9079818) at gmain.c:2440
#39 g_main_context_dispatch (context=0x9079818) at gmain.c:3013
#40 0xb42fbe88 in g_main_context_iterate (context=0x9079818, block=1, dispatch=1, self=<value optimized out>) at gmain.c:3091
#41 0xb42fc158 in g_main_context_iteration (context=0x9079818, may_block=1) at gmain.c:3154
#42 0xb6b9892c in QEventDispatcherGlib::processEvents (this=0x9040e08, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#43 0xb6354395 in QGuiEventDispatcherGlib::processEvents (this=0x9040e08, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#44 0xb6b6e529 in QEventLoop::processEvents (this=0xbfabbb44, flags=...) at kernel/qeventloop.cpp:149
#45 0xb6b6e7d2 in QEventLoop::exec (this=0xbfabbb44, flags=...) at kernel/qeventloop.cpp:197
#46 0xb6b722f7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#47 0xb62ad837 in QApplication::exec () at kernel/qapplication.cpp:3736
#48 0xb7849583 in kdemain () from /usr/lib/libkdeinit4_plasma-desktop.so
#49 0x080485db in _start ()

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-06-25 14:56:46 UTC

*** This bug has been marked as a duplicate of bug 273075 ***