Bug 273423

Summary: Adding a possibility to disable windows gradient.
Product: Oxygen Reporter: Alexander <vo.zaeb>
Component: styleAssignee: Hugo Pereira Da Costa <hugo.pereira.da.costa>
Status: RESOLVED FIXED    
Severity: wishlist CC: hugo.pereira.da.costa, perso
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Archlinux Packages   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: Example

Description Alexander 2011-05-16 17:37:41 UTC
Version:           unspecified (using KDE 4.6.2) 
OS:                Linux

It would be great to have something like this. Moreover, kwin style has the possibility to make window decorations flat.

Reproducible: Didn't try
Comment 1 Alexander 2011-05-16 17:38:36 UTC
Sorry, forgot to mark this report as a wish.
Comment 2 Hugo Pereira Da Costa 2011-05-17 10:40:34 UTC
Hello Alexander

You can go to system-settings->applications appearance->colors
then click the "Options" tab, and set the "shading" slider to 0.
This does exactly what you want, I think.
So ... closing as invalid, but feel free to reopen if I misunderstood.

Hugo
Comment 3 Alexander 2011-05-17 11:00:08 UTC
Created attachment 60073 [details]
Example

No, it's not what I meant. Even when slider on the 0 point oxygen still adds some gradient. Also, I want to have some shading in widgets but fully flat windows at the same time. So, it just should be an option above shading slider, that allows me to disable windows gradient for whole window but leave it for widjets (as shading settings).
Comment 4 Hugo Pereira Da Costa 2011-05-17 11:06:04 UTC
Alexander:

ok correct. There is still some remaining gradient, and yes I understand your wish better.

re-oppening as "wish" then. but can't guaranty when I'll find time to actually implement.
Comment 5 Alexander 2011-05-17 11:43:47 UTC
Ok, thx. I hope someday it will happen :)
Comment 6 Christoph Feck 2011-05-17 14:46:56 UTC
Reopening, see comment #4.
Comment 7 ariasuni 2012-07-26 14:21:01 UTC
It's a great idea for low end PC or for those who wants speed over appareance. The only way I know to do that is to use another widget style, like QtCurve but It's not as beautiful as Oxygen…
Comment 8 Hugo Pereira Da Costa 2012-07-26 14:48:09 UTC
@eichi
Comment 9 Hugo Pereira Da Costa 2012-07-26 14:50:09 UTC
@eichi
From the measurement I have made (using callgrind) you will not get much improvements by disabling window background gradient. A very small amount of time is spent there.
Oxygen spends much more time rendering button gradients, glows, arrows, etc, than the actual window background. Everything that makes the style good looking, pretty much ...
Comment 10 ariasuni 2013-04-11 19:14:25 UTC
> From the measurement I have made (using callgrind) you will not get much improvements by disabling window background gradient. A very small amount of time is spent there. Oxygen spends much more time rendering button gradients, glows, arrows, etc, than the actual window background. Everything that makes the style good looking, pretty much ...

Button gradients and glows are disabled in my conf, but arrows are allowed. So maybe It can gives a slight speed improvement on heavy loads — it’s not bad to offer ways to slow computers and/or laptops. However, I can’t disable some effects like many shadows because with that colors, contrast is very bad. So, it isn’t worth it?
Comment 11 Hugo Pereira Da Costa 2013-12-17 17:19:41 UTC
Git commit 3df4f12933bcef941effc4270b1763410c6914c9 by Hugo Pereira Da Costa.
Committed on 15/12/2013 at 11:33.
Pushed by hpereiradacosta into branch 'KDE/4.11'.

Removed background blend style option.
Background gradient is now always decided based on window flag.

Added option in oxygenrc to disable window background:

[Common]
UseBackgroundGradient=true

Option is hidden (no UI element) because of string freeze
Also removed decoration blend style option.
Background gradient is now always decided based on window flag.

M  +6    -1    kstyles/oxygen/oxygen.kcfg
M  +3    -0    kstyles/oxygen/oxygenstyle.cpp
M  +33   -1    kstyles/oxygen/oxygenstylehelper.cpp
M  +11   -5    kstyles/oxygen/oxygenstylehelper.h
M  +0    -4    kwin/clients/oxygen/config/oxygenconfigwidget.cpp
M  +0    -5    kwin/clients/oxygen/config/oxygenexceptiondialog.cpp
M  +33   -66   kwin/clients/oxygen/config/ui/oxygenconfigurationui.ui
M  +17   -64   kwin/clients/oxygen/config/ui/oxygenexceptiondialog.ui
M  +5    -9    kwin/clients/oxygen/oxygenclient.cpp
M  +0    -9    kwin/clients/oxygen/oxygenconfigdata.kcfg
M  +0    -1    kwin/clients/oxygen/oxygendecorationdefines.h
M  +0    -1    kwin/clients/oxygen/oxygenexceptionlist.cpp

http://commits.kde.org/kde-workspace/3df4f12933bcef941effc4270b1763410c6914c9
Comment 12 Hugo Pereira Da Costa 2013-12-17 17:19:41 UTC
Git commit 3df4f12933bcef941effc4270b1763410c6914c9 by Hugo Pereira Da Costa.
Committed on 15/12/2013 at 11:33.
Pushed by hpereiradacosta into branch 'KDE/4.11'.

Removed background blend style option.
Background gradient is now always decided based on window flag.

Added option in oxygenrc to disable window background:

[Common]
UseBackgroundGradient=true

Option is hidden (no UI element) because of string freeze
Also removed decoration blend style option.
Background gradient is now always decided based on window flag.

M  +6    -1    kstyles/oxygen/oxygen.kcfg
M  +3    -0    kstyles/oxygen/oxygenstyle.cpp
M  +33   -1    kstyles/oxygen/oxygenstylehelper.cpp
M  +11   -5    kstyles/oxygen/oxygenstylehelper.h
M  +0    -4    kwin/clients/oxygen/config/oxygenconfigwidget.cpp
M  +0    -5    kwin/clients/oxygen/config/oxygenexceptiondialog.cpp
M  +33   -66   kwin/clients/oxygen/config/ui/oxygenconfigurationui.ui
M  +17   -64   kwin/clients/oxygen/config/ui/oxygenexceptiondialog.ui
M  +5    -9    kwin/clients/oxygen/oxygenclient.cpp
M  +0    -9    kwin/clients/oxygen/oxygenconfigdata.kcfg
M  +0    -1    kwin/clients/oxygen/oxygendecorationdefines.h
M  +0    -1    kwin/clients/oxygen/oxygenexceptionlist.cpp

http://commits.kde.org/kde-workspace/3df4f12933bcef941effc4270b1763410c6914c9
Comment 13 Hugo Pereira Da Costa 2013-12-17 17:38:57 UTC
Git commit 0725ddb42271b6c16e14bc80c663f25613a25ce8 by Hugo Pereira Da Costa.
Committed on 15/12/2013 at 11:33.
Pushed by hpereiradacosta into branch 'master'.

Added option in oxygenrc to disable window background:

[Common]
UseBackgroundGradient=true

Option is hidden (no UI element) because of string freeze
Also removed decoration blend style option.
Background gradient is now always decided based on window flag.

M  +6    -1    kstyles/oxygen/oxygen.kcfg
M  +3    -0    kstyles/oxygen/oxygenstyle.cpp
M  +33   -1    kstyles/oxygen/oxygenstylehelper.cpp
M  +11   -5    kstyles/oxygen/oxygenstylehelper.h
M  +0    -4    kwin/clients/oxygen/config/oxygenconfigwidget.cpp
M  +0    -5    kwin/clients/oxygen/config/oxygenexceptiondialog.cpp
M  +15   -66   kwin/clients/oxygen/config/ui/oxygenconfigurationui.ui
M  +44   -89   kwin/clients/oxygen/config/ui/oxygenexceptiondialog.ui
M  +5    -9    kwin/clients/oxygen/oxygenclient.cpp
M  +0    -9    kwin/clients/oxygen/oxygenconfigdata.kcfg
M  +0    -1    kwin/clients/oxygen/oxygendecorationdefines.h
M  +0    -1    kwin/clients/oxygen/oxygenexceptionlist.cpp

http://commits.kde.org/kde-workspace/0725ddb42271b6c16e14bc80c663f25613a25ce8
Comment 14 Hugo Pereira Da Costa 2013-12-17 17:38:57 UTC
Git commit f371688e093b8d0be281c246d3e296eff6cf85ec by Hugo Pereira Da Costa.
Committed on 17/12/2013 at 17:37.
Pushed by hpereiradacosta into branch 'master'.

added UI option for UseBackgroundGradient

M  +4    -0    kstyles/oxygen/config/oxygenstyleconfig.cpp
M  +7    -0    kstyles/oxygen/config/ui/oxygenstyleconfig.ui

http://commits.kde.org/kde-workspace/f371688e093b8d0be281c246d3e296eff6cf85ec
Comment 15 Hugo Pereira Da Costa 2014-01-10 09:36:33 UTC
Closing.
For KDE4, add "UseBackgroundGradient=false" in .kde/share/config/oxygenrc (in [common] section)
in KF5 there is a gui option for this.