Bug 273078

Summary: kwin crash after suspend
Product: [Plasma] kwin Reporter: Kuyo <claovares>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description Kuyo 2011-05-11 22:24:16 UTC
Application: kwin (4.6.2 (4.6.2))
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic i686
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:
On resume after suspend kwin crashes, always.; whether there are any programs running or not.

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb76ff720 (LWP 7412))]

Thread 3 (Thread 0xb29c9b70 (LWP 7418)):
#0  0x00a85416 in __kernel_vsyscall ()
#1  0x00b5e681 in select () from /lib/i386-linux-gnu/libc.so.6
#2  0x01c0b38b in qt_safe_select (nfds=26, fdread=0x995b5c0, fdwrite=0x995b7d4, fdexcept=0x995b9e8, orig_timeout=0x0) at kernel/qcore_unix.cpp:82
#3  0x01c0f6e9 in QEventDispatcherUNIX::select (this=0x9a3b6a8, nfds=26, readfds=0x995b5c0, writefds=0x995b7d4, exceptfds=0x995b9e8, timeout=0x0) at kernel/qeventdispatcher_unix.cpp:632
#4  0x01c1066b in QEventDispatcherUNIXPrivate::doSelect (this=0x995b4c8, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:219
#5  0x01c11326 in QEventDispatcherUNIX::processEvents (this=0x9a3b6a8, flags=...) at kernel/qeventdispatcher_unix.cpp:919
#6  0x01be0289 in QEventLoop::processEvents (this=0xb29c9280, flags=...) at kernel/qeventloop.cpp:149
#7  0x01be0522 in QEventLoop::exec (this=0xb29c9280, flags=...) at kernel/qeventloop.cpp:201
#8  0x01aea2a0 in QThread::exec (this=0x99e01b8) at thread/qthread.cpp:492
#9  0x01bc1fdb in QInotifyFileSystemWatcherEngine::run (this=0x99e01b8) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x01aecda2 in QThreadPrivate::start (arg=0x99e01b8) at thread/qthread_unix.cpp:320
#11 0x0172ce99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x00b6573e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xb21c8b70 (LWP 7419)):
#0  0x00a85416 in __kernel_vsyscall ()
#1  0x0173148c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x00b733fd in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x00d7d817 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0xe911c0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#4  0x00d7d851 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0xe911c0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#5  0x0172ce99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0x00b6573e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb76ff720 (LWP 7412)):
[KCrash Handler]
#7  intel_region_buffer (intel=0x9425680, region=0x0, flag=2) at intel_regions.c:514
#8  0x023b5742 in intelClearWithBlit (ctx=0x9425680, mask=2) at intel_blit.c:262
#9  0x023ae670 in intelClear (ctx=0x9425680, mask=2) at intel_clear.c:177
#10 0x02672512 in _mesa_Clear (mask=<value optimized out>) at main/clear.c:241
#11 0x004a484b in KWin::SceneOpenGL::paintBackground (this=0x9454098, region=...) at ../../kwin/scene_opengl.cpp:921
#12 0x0049b562 in KWin::Scene::paintGenericScreen (this=0x9454098, orig_mask=32) at ../../kwin/scene.cpp:188
#13 0x004a4a31 in KWin::SceneOpenGL::paintGenericScreen (this=0x9454098, mask=32, data=...) at ../../kwin/scene_opengl.cpp:909
#14 0x004987c0 in KWin::Scene::finalPaintScreen (this=0x9454098, mask=32, region=..., data=...) at ../../kwin/scene.cpp:178
#15 0x004ba0fc in KWin::EffectsHandlerImpl::paintScreen (this=0x972fab0, mask=32, region=..., data=...) at ../../kwin/effects.cpp:173
#16 0x04fb60e9 in KWin::StartupFeedbackEffect::paintScreen (this=0x99eeb88, mask=32, region=..., data=...) at ../../../kwin/effects/startupfeedback/startupfeedback.cpp:166
#17 0x004ba172 in KWin::EffectsHandlerImpl::paintScreen (this=0x972fab0, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#18 0x00a1f256 in KWin::Effect::paintScreen (this=0x9923bd8, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#19 0x004ba172 in KWin::EffectsHandlerImpl::paintScreen (this=0x972fab0, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#20 0x04f5807f in KWin::LogoutEffect::paintScreen (this=0x9870c20, mask=32, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:207
#21 0x004ba172 in KWin::EffectsHandlerImpl::paintScreen (this=0x972fab0, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#22 0x04f73b10 in KWin::ShadowEffect::paintScreen (this=0x997ac30, mask=32, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:189
#23 0x004ba172 in KWin::EffectsHandlerImpl::paintScreen (this=0x972fab0, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#24 0x04f88013 in KWin::BlurEffect::paintScreen (this=0x97b5448, mask=32, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:230
#25 0x004ba172 in KWin::EffectsHandlerImpl::paintScreen (this=0x972fab0, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#26 0x04f5ce6f in KWin::PresentWindowsEffect::paintScreen (this=0x97b4c88, mask=0, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:205
#27 0x004ba172 in KWin::EffectsHandlerImpl::paintScreen (this=0x972fab0, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#28 0x00a1f256 in KWin::Effect::paintScreen (this=0x98fc310, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#29 0x004ba172 in KWin::EffectsHandlerImpl::paintScreen (this=0x972fab0, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#30 0x00a1f256 in KWin::Effect::paintScreen (this=0x987caa8, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#31 0x004ba172 in KWin::EffectsHandlerImpl::paintScreen (this=0x972fab0, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#32 0x00a1f256 in KWin::Effect::paintScreen (this=0x9862040, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#33 0x004ba172 in KWin::EffectsHandlerImpl::paintScreen (this=0x972fab0, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#34 0x00a1f256 in KWin::Effect::paintScreen (this=0x97f8878, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#35 0x004ba172 in KWin::EffectsHandlerImpl::paintScreen (this=0x972fab0, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#36 0x04f437e9 in KWin::DesktopGridEffect::paintScreen (this=0x97b3fd0, mask=0, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:155
#37 0x004ba172 in KWin::EffectsHandlerImpl::paintScreen (this=0x972fab0, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#38 0x04f7ace2 in KWin::SlideEffect::paintScreen (this=0x9810ca0, mask=0, region=..., data=...) at ../../../kwin/effects/slide/slide.cpp:86
#39 0x004ba172 in KWin::EffectsHandlerImpl::paintScreen (this=0x972fab0, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#40 0x04f3c799 in KWin::BoxSwitchEffect::paintScreen (this=0x9829788, mask=0, region=..., data=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:143
#41 0x004ba172 in KWin::EffectsHandlerImpl::paintScreen (this=0x972fab0, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#42 0x04f96bcc in KWin::CubeEffect::paintScreen (this=0x99e52c8, mask=0, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:698
#43 0x004ba172 in KWin::EffectsHandlerImpl::paintScreen (this=0x972fab0, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#44 0x00a1f256 in KWin::Effect::paintScreen (this=0x9928a28, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#45 0x004ba172 in KWin::EffectsHandlerImpl::paintScreen (this=0x972fab0, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#46 0x00a1f256 in KWin::Effect::paintScreen (this=0x987b6a8, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#47 0x004ba172 in KWin::EffectsHandlerImpl::paintScreen (this=0x972fab0, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#48 0x04f8fa0c in KWin::CoverSwitchEffect::paintScreen (this=0x99351d0, mask=0, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:126
#49 0x004ba172 in KWin::EffectsHandlerImpl::paintScreen (this=0x972fab0, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#50 0x00a1f256 in KWin::Effect::paintScreen (this=0x978f270, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#51 0x004ba172 in KWin::EffectsHandlerImpl::paintScreen (this=0x972fab0, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#52 0x00a1f256 in KWin::Effect::paintScreen (this=0x985d110, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#53 0x004ba172 in KWin::EffectsHandlerImpl::paintScreen (this=0x972fab0, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#54 0x0049998c in KWin::Scene::paintScreen (this=0x9454098, mask=0xbfc75a48, region=0xbfc75ad0) at ../../kwin/scene.cpp:137
#55 0x004b0962 in KWin::SceneOpenGL::paint (this=0x9454098, damage=..., toplevels=...) at ../../kwin/scene_opengl.cpp:772
#56 0x00495886 in KWin::Workspace::performCompositing (this=0x9750570) at ../../kwin/composite.cpp:448
#57 0x01bf6214 in QObject::event (this=0x9750570, e=0xbfc75ffc) at kernel/qobject.cpp:1190
#58 0x0591fd24 in QApplicationPrivate::notify_helper (this=0x936b480, receiver=0x9750570, e=0xbfc75ffc) at kernel/qapplication.cpp:4462
#59 0x059248ce in QApplication::notify (this=0xbfc76314, receiver=0x9750570, e=0xbfc75ffc) at kernel/qapplication.cpp:3862
#60 0x006d03ca in KApplication::notify (this=0xbfc76314, receiver=0x9750570, event=0xbfc75ffc) at ../../kdeui/kernel/kapplication.cpp:311
#61 0x00424abf in KWin::Application::notify (this=0xbfc76314, o=0x9750570, e=0xbfc75ffc) at ../../kwin/main.cpp:376
#62 0x01be10bb in QCoreApplication::notifyInternal (this=0xbfc76314, receiver=0x9750570, event=0xbfc75ffc) at kernel/qcoreapplication.cpp:731
#63 0x01c111e4 in sendEvent (this=0x936be68) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#64 QTimerInfoList::activateTimers (this=0x936be68) at kernel/qeventdispatcher_unix.cpp:604
#65 0x01c11338 in QEventDispatcherUNIX::processEvents (this=0x9329ac0, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#66 0x059d47ea in QEventDispatcherX11::processEvents (this=0x9329ac0, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#67 0x01be0289 in QEventLoop::processEvents (this=0xbfc76254, flags=...) at kernel/qeventloop.cpp:149
#68 0x01be0522 in QEventLoop::exec (this=0xbfc76254, flags=...) at kernel/qeventloop.cpp:201
#69 0x01be4ecc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#70 0x0591d8e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#71 0x004275b2 in kdemain (argc=3, argv=0xbfc76594) at ../../kwin/main.cpp:542
#72 0x080485bb in main (argc=3, argv=0xbfc76594) at kwin_dummy.cpp:3

Possible duplicates by query: bug 273067, bug 273066, bug 272846, bug 272829, bug 272826.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2011-05-11 22:26:39 UTC
driver bug - turn off "suspend compositing for fullscreen windows" in the
advanced tab of "kcmshell4 kwincompositing" to work around (this has a
performance drawback)

(probably screensaver related)

*** This bug has been marked as a duplicate of bug 252817 ***