Bug 272745

Summary: KWin Crash
Product: [Plasma] kwin Reporter: Alex <alex_117_c>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Compiled Sources   
OS: Linux   
Latest Commit: Version Fixed In:

Description Alex 2011-05-07 23:58:38 UTC
Application: kwin (4.6.2 (4.6.2))
KDE Platform Version: 4.6.2 (4.6.2) (Compiled from sources)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
I was listening to music using XBMC Media Center. Also, whenever my computer goes into Sleep, my system crashes.

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fd4644b07a0 (LWP 5240))]

Thread 3 (Thread 0x7fd448fcd700 (LWP 5246)):
#0  0x00007fd4600e05e8 in QEventDispatcherUNIXPrivate::doSelect (this=0x1f440c0, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:207
#1  0x00007fd4600e104a in QEventDispatcherUNIX::processEvents (this=0x1fbfe40, flags=...) at kernel/qeventdispatcher_unix.cpp:919
#2  0x00007fd4600b2882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#3  0x00007fd4600b2abc in QEventLoop::exec (this=0x7fd448fccdb0, flags=...) at kernel/qeventloop.cpp:201
#4  0x00007fd45ffc9924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#5  0x00007fd460094c2f in QInotifyFileSystemWatcherEngine::run (this=0x203f3d0) at io/qfilesystemwatcher_inotify.cpp:248
#6  0x00007fd45ffcc175 in QThreadPrivate::start (arg=0x203f3d0) at thread/qthread_unix.cpp:320
#7  0x00007fd45a6bfd8c in start_thread (arg=0x7fd448fcd700) at pthread_create.c:304
#8  0x00007fd463d0504d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fd4487cc700 (LWP 5247)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fd462b642a2 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7fd462e7d180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007fd462b642d9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7fd462e8b254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007fd45a6bfd8c in start_thread (arg=0x7fd4487cc700) at pthread_create.c:304
#4  0x00007fd463d0504d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fd4644b07a0 (LWP 5240)):
[KCrash Handler]
#6  intel_region_buffer (intel=0xc69510, region=0x0, flag=2) at intel_regions.c:514
#7  0x00007fd44bd0c6c2 in intelClearWithBlit (ctx=0xc69510, mask=2) at intel_blit.c:262
#8  0x00007fd44bd0ed2a in intelClear (ctx=0xc69510, mask=2) at intel_clear.c:177
#9  0x00007fd46407bce7 in KWin::SceneOpenGL::paintBackground (this=<value optimized out>, region=<value optimized out>) at ../../kwin/scene_opengl.cpp:921
#10 0x00007fd46407388f in KWin::Scene::paintGenericScreen (this=0xc57e50, orig_mask=40) at ../../kwin/scene.cpp:188
#11 0x00007fd464070c7a in KWin::Scene::finalPaintScreen (this=0xc57e50, mask=40, region=<value optimized out>, data=<value optimized out>) at ../../kwin/scene.cpp:178
#12 0x00007fd46408ef19 in KWin::EffectsHandlerImpl::paintScreen (this=0xf79920, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:173
#13 0x00007fd44ad365a6 in KWin::StartupFeedbackEffect::paintScreen (this=0x1ed6b40, mask=40, region=<value optimized out>, data=...) at ../../../kwin/effects/startupfeedback/startupfeedback.cpp:166
#14 0x00007fd46408efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0xf79920, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#15 0x00007fd46214ea18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=40, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#16 0x00007fd46408efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0xf79920, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#17 0x00007fd44acdd44d in KWin::LogoutEffect::paintScreen (this=0x1fb4900, mask=40, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:207
#18 0x00007fd46408efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0xf79920, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#19 0x00007fd44acf857b in KWin::ShadowEffect::paintScreen (this=0x1dd3260, mask=40, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:189
#20 0x00007fd46408efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0xf79920, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#21 0x00007fd44ad0ae68 in KWin::BlurEffect::paintScreen (this=<value optimized out>, mask=40, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:230
#22 0x00007fd46408efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0xf79920, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#23 0x00007fd44ace1fbd in KWin::PresentWindowsEffect::paintScreen (this=0x200d4e0, mask=8, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:205
#24 0x00007fd46408efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0xf79920, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#25 0x00007fd46214ea18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#26 0x00007fd46408efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0xf79920, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#27 0x00007fd46214ea18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#28 0x00007fd46408efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0xf79920, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#29 0x00007fd46214ea18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#30 0x00007fd46408efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0xf79920, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#31 0x00007fd46214ea18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#32 0x00007fd46408efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0xf79920, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#33 0x00007fd44ad28c05 in KWin::FlipSwitchEffect::paintScreen (this=0x1e07640, mask=8, region=..., data=...) at ../../../kwin/effects/flipswitch/flipswitch.cpp:148
#34 0x00007fd46408efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0xf79920, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#35 0x00007fd44acc9365 in KWin::DesktopGridEffect::paintScreen (this=0x1ef0ef0, mask=8, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:155
#36 0x00007fd46408efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0xf79920, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#37 0x00007fd46214ea18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#38 0x00007fd46408efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0xf79920, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#39 0x00007fd44acc2bad in KWin::BoxSwitchEffect::paintScreen (this=0x2265ee0, mask=8, region=..., data=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:143
#40 0x00007fd46408efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0xf79920, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#41 0x00007fd44ad19256 in KWin::CubeEffect::paintScreen (this=<value optimized out>, mask=8, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:698
#42 0x00007fd46408efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0xf79920, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#43 0x00007fd46214ea18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#44 0x00007fd46408efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0xf79920, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#45 0x00007fd46214ea18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#46 0x00007fd46408efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0xf79920, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#47 0x00007fd46214ea18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#48 0x00007fd46408efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0xf79920, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#49 0x00007fd44ad11d86 in KWin::CoverSwitchEffect::paintScreen (this=0x1e76fa0, mask=8, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:126
#50 0x00007fd46408efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0xf79920, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#51 0x00007fd46214ea18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#52 0x00007fd46408efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0xf79920, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#53 0x00007fd46214ea18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#54 0x00007fd46408efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0xf79920, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#55 0x00007fd46214ea18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#56 0x00007fd46408efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0xf79920, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#57 0x00007fd44ad0839b in KWin::ZoomEffect::paintScreen (this=0x1f86ec0, mask=8, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:341
#58 0x00007fd46408efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0xf79920, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#59 0x00007fd4640730af in KWin::Scene::paintScreen (this=0xc57e50, mask=0x7fff2e9f687c, region=0x7fff2e9f6940) at ../../kwin/scene.cpp:137
#60 0x00007fd464086ef3 in KWin::SceneOpenGL::paint (this=0xc57e50, damage=..., toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:772
#61 0x00007fd46406e396 in KWin::Workspace::performCompositing (this=0xf813b0) at ../../kwin/composite.cpp:448
#62 0x00007fd4600c71c9 in QObject::event (this=0xf813b0, e=<value optimized out>) at kernel/qobject.cpp:1190
#63 0x00007fd45f4749e4 in QApplicationPrivate::notify_helper (this=0xb39e20, receiver=0xf813b0, e=0x7fff2e9f70d0) at kernel/qapplication.cpp:4462
#64 0x00007fd45f4793aa in QApplication::notify (this=<value optimized out>, receiver=0xf813b0, e=0x7fff2e9f70d0) at kernel/qapplication.cpp:4341
#65 0x00007fd463800866 in KApplication::notify (this=0x7fff2e9f74d0, receiver=0xf813b0, event=0x7fff2e9f70d0) at ../../kdeui/kernel/kapplication.cpp:311
#66 0x00007fd4600b349c in QCoreApplication::notifyInternal (this=0x7fff2e9f74d0, receiver=0xf813b0, event=0x7fff2e9f70d0) at kernel/qcoreapplication.cpp:731
#67 0x00007fd4600e0f12 in sendEvent (this=0xb3a860) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#68 QTimerInfoList::activateTimers (this=0xb3a860) at kernel/qeventdispatcher_unix.cpp:604
#69 0x00007fd4600e105b in QEventDispatcherUNIX::processEvents (this=0xade340, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#70 0x00007fd45f51cc0c in QEventDispatcherX11::processEvents (this=0xade340, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#71 0x00007fd4600b2882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#72 0x00007fd4600b2abc in QEventLoop::exec (this=0x7fff2e9f7410, flags=...) at kernel/qeventloop.cpp:201
#73 0x00007fd4600b6ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#74 0x00007fd46400c1ec in kdemain (argc=<value optimized out>, argv=0x7fff2e9f7b68) at ../../kwin/main.cpp:542
#75 0x00007fd463c3deff in __libc_start_main (main=0x400740 <main(int, char**)>, argc=3, ubp_av=0x7fff2e9f7b68, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff2e9f7b58) at libc-start.c:226
#76 0x0000000000400669 in _start ()

Possible duplicates by query: bug 272727, bug 272726, bug 272704, bug 272699, bug 272696.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2011-05-08 00:16:21 UTC
driver bug

*** This bug has been marked as a duplicate of bug 252817 ***