Bug 272524

Summary: KWin crashed after closing warzone2100
Product: [Plasma] kwin Reporter: Voldemar <vmagius>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description Voldemar 2011-05-05 12:43:41 UTC
Application: kwin (4.6.2 (4.6.2))
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:
I open warzone2100 and than close.
Crashing sometime depend on number of opening windows.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f46776b27a0 (LWP 7545))]

Thread 3 (Thread 0x7f4657fff700 (LWP 7550)):
#0  0x00007f4676efc143 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f46732da32c in qt_safe_select (nfds=17, fdread=0x2773c30, fdwrite=0x2773ec8, fdexcept=0x2774160, orig_timeout=<value optimized out>) at kernel/qcore_unix.cpp:82
#2  0x00007f46732df3d0 in QEventDispatcherUNIXPrivate::doSelect (this=0x2773a70, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:219
#3  0x00007f46732e004a in QEventDispatcherUNIX::processEvents (this=0x26ddcb0, flags=...) at kernel/qeventdispatcher_unix.cpp:919
#4  0x00007f46732b1882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f46732b1abc in QEventLoop::exec (this=0x7f4657ffedb0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f46731c8924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007f4673293c2f in QInotifyFileSystemWatcherEngine::run (this=0x2966300) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f46731cb175 in QThreadPrivate::start (arg=0x2966300) at thread/qthread_unix.cpp:320
#9  0x00007f466d8bed8c in start_thread (arg=0x7f4657fff700) at pthread_create.c:304
#10 0x00007f4676f0404d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f46577fe700 (LWP 7551)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f4675d632a2 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f467607c180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f4675d632d9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f467608a254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f466d8bed8c in start_thread (arg=0x7f46577fe700) at pthread_create.c:304
#4  0x00007f4676f0404d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f46776b27a0 (LWP 7545)):
[KCrash Handler]
#6  intel_region_buffer (intel=0x13fefa0, region=0x0, flag=2) at intel_regions.c:514
#7  0x00007f465ed8d6c2 in intelClearWithBlit (ctx=0x13fefa0, mask=2) at intel_blit.c:262
#8  0x00007f465ed8fd2a in intelClear (ctx=0x13fefa0, mask=2) at intel_clear.c:177
#9  0x00007f467727ace7 in KWin::SceneOpenGL::paintBackground (this=<value optimized out>, region=<value optimized out>) at ../../kwin/scene_opengl.cpp:921
#10 0x00007f467727288f in KWin::Scene::paintGenericScreen (this=0x13f8610, orig_mask=40) at ../../kwin/scene.cpp:188
#11 0x00007f467726fc7a in KWin::Scene::finalPaintScreen (this=0x13f8610, mask=40, region=<value optimized out>, data=<value optimized out>) at ../../kwin/scene.cpp:178
#12 0x00007f467728df19 in KWin::EffectsHandlerImpl::paintScreen (this=0x2522e20, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:173
#13 0x00007f465de215a6 in KWin::StartupFeedbackEffect::paintScreen (this=0x2759520, mask=40, region=<value optimized out>, data=...) at ../../../kwin/effects/startupfeedback/startupfeedback.cpp:166
#14 0x00007f467728dfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2522e20, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#15 0x00007f467534da18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=40, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#16 0x00007f467728dfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2522e20, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#17 0x00007f465ddc844d in KWin::LogoutEffect::paintScreen (this=0x258c230, mask=40, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:207
#18 0x00007f467728dfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2522e20, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#19 0x00007f465dde357b in KWin::ShadowEffect::paintScreen (this=0x28af1f0, mask=40, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:189
#20 0x00007f467728dfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2522e20, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#21 0x00007f465ddf5e68 in KWin::BlurEffect::paintScreen (this=<value optimized out>, mask=40, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:230
#22 0x00007f467728dfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2522e20, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#23 0x00007f465ddccfbd in KWin::PresentWindowsEffect::paintScreen (this=0x26c2950, mask=8, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:205
#24 0x00007f467728dfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2522e20, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#25 0x00007f467534da18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#26 0x00007f467728dfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2522e20, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#27 0x00007f467534da18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#28 0x00007f467728dfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2522e20, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#29 0x00007f467534da18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#30 0x00007f467728dfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2522e20, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#31 0x00007f465de13c05 in KWin::FlipSwitchEffect::paintScreen (this=0x2581f70, mask=8, region=..., data=...) at ../../../kwin/effects/flipswitch/flipswitch.cpp:148
#32 0x00007f467728dfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2522e20, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#33 0x00007f465ddb4365 in KWin::DesktopGridEffect::paintScreen (this=0x26c42f0, mask=8, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:155
#34 0x00007f467728dfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2522e20, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#35 0x00007f465ddadbad in KWin::BoxSwitchEffect::paintScreen (this=0x27b84d0, mask=8, region=..., data=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:143
#36 0x00007f467728dfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2522e20, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#37 0x00007f465de04256 in KWin::CubeEffect::paintScreen (this=<value optimized out>, mask=8, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:698
#38 0x00007f467728dfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2522e20, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#39 0x00007f467534da18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#40 0x00007f467728dfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2522e20, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#41 0x00007f465de0dfa4 in KWin::CubeSlideEffect::paintScreen (this=<value optimized out>, mask=8, region=..., data=...) at ../../../kwin/effects/cube/cubeslide.cpp:111
#42 0x00007f467728dfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2522e20, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#43 0x00007f467534da18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#44 0x00007f467728dfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2522e20, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#45 0x00007f467534da18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#46 0x00007f467728dfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2522e20, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#47 0x00007f465ddfcd86 in KWin::CoverSwitchEffect::paintScreen (this=0x2758cf0, mask=8, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:126
#48 0x00007f467728dfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2522e20, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#49 0x00007f467534da18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#50 0x00007f467728dfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2522e20, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#51 0x00007f467534da18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#52 0x00007f467728dfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2522e20, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#53 0x00007f465ddf339b in KWin::ZoomEffect::paintScreen (this=0x27b8f70, mask=8, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:341
#54 0x00007f467728dfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2522e20, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#55 0x00007f46772720af in KWin::Scene::paintScreen (this=0x13f8610, mask=0x7fffcd267e1c, region=0x7fffcd267ee0) at ../../kwin/scene.cpp:137
#56 0x00007f4677285ef3 in KWin::SceneOpenGL::paint (this=0x13f8610, damage=..., toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:772
#57 0x00007f467726d396 in KWin::Workspace::performCompositing (this=0x7f4658354030) at ../../kwin/composite.cpp:448
#58 0x00007f46732c61c9 in QObject::event (this=0x7f4658354030, e=<value optimized out>) at kernel/qobject.cpp:1190
#59 0x00007f46726739e4 in QApplicationPrivate::notify_helper (this=0x12d8ec0, receiver=0x7f4658354030, e=0x7fffcd268670) at kernel/qapplication.cpp:4462
#60 0x00007f46726783aa in QApplication::notify (this=<value optimized out>, receiver=0x7f4658354030, e=0x7fffcd268670) at kernel/qapplication.cpp:4341
#61 0x00007f46769ff866 in KApplication::notify (this=0x7fffcd268a70, receiver=0x7f4658354030, event=0x7fffcd268670) at ../../kdeui/kernel/kapplication.cpp:311
#62 0x00007f46732b249c in QCoreApplication::notifyInternal (this=0x7fffcd268a70, receiver=0x7f4658354030, event=0x7fffcd268670) at kernel/qcoreapplication.cpp:731
#63 0x00007f46732dff12 in sendEvent (this=0x12dbff0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#64 QTimerInfoList::activateTimers (this=0x12dbff0) at kernel/qeventdispatcher_unix.cpp:604
#65 0x00007f46732e005b in QEventDispatcherUNIX::processEvents (this=0x127e340, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#66 0x00007f467271bc0c in QEventDispatcherX11::processEvents (this=0x127e340, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#67 0x00007f46732b1882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#68 0x00007f46732b1abc in QEventLoop::exec (this=0x7fffcd2689b0, flags=...) at kernel/qeventloop.cpp:201
#69 0x00007f46732b5ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#70 0x00007f467720b1ec in kdemain (argc=<value optimized out>, argv=0x7fffcd269108) at ../../kwin/main.cpp:542
#71 0x00007f4676e3ceff in __libc_start_main (main=0x400740 <main(int, char**)>, argc=3, ubp_av=0x7fffcd269108, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fffcd2690f8) at libc-start.c:226
#72 0x0000000000400669 in _start ()

Possible duplicates by query: bug 272506, bug 272484, bug 272448, bug 272331, bug 272323.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2011-05-05 14:36:26 UTC
driver bug

*** This bug has been marked as a duplicate of bug 252817 ***