Bug 272448

Summary: kwin crashes - fullscreen flash video
Product: [Plasma] kwin Reporter: Pablo <pdruszcz>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description Pablo 2011-05-04 15:27:36 UTC
Application: kwin (4.6.2 (4.6.2))
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed: When I  enlarge window with films on youtube Kwin crashes ...

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fb5724a67a0 (LWP 1360))]

Thread 3 (Thread 0x7fb552c77700 (LWP 1386)):
#0  0x00007fb571ced143 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007fb56e0cb32c in qt_safe_select (nfds=17, fdread=0x26246a0, fdwrite=0x2624938, fdexcept=0x2624bd0, orig_timeout=<value optimized out>) at kernel/qcore_unix.cpp:82
#2  0x00007fb56e0d03d0 in QEventDispatcherUNIXPrivate::doSelect (this=0x26244e0, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:219
#3  0x00007fb56e0d104a in QEventDispatcherUNIX::processEvents (this=0x26243b0, flags=...) at kernel/qeventdispatcher_unix.cpp:919
#4  0x00007fb56e0a2882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fb56e0a2abc in QEventLoop::exec (this=0x7fb552c76db0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fb56dfb9924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007fb56e084c2f in QInotifyFileSystemWatcherEngine::run (this=0x26db9d0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fb56dfbc175 in QThreadPrivate::start (arg=0x26db9d0) at thread/qthread_unix.cpp:320
#9  0x00007fb5686afd8c in start_thread (arg=0x7fb552c77700) at pthread_create.c:304
#10 0x00007fb571cf504d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fb552466700 (LWP 1387)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fb570b542a2 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7fb570e6d180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007fb570b542d9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7fb570e7b254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007fb5686afd8c in start_thread (arg=0x7fb552466700) at pthread_create.c:304
#4  0x00007fb571cf504d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fb5724a67a0 (LWP 1360)):
[KCrash Handler]
#6  intel_region_buffer (intel=0x41b7220, region=0x0, flag=2) at intel_regions.c:514
#7  0x00007fb559a7b6c2 in intelClearWithBlit (ctx=0x41b7220, mask=2) at intel_blit.c:262
#8  0x00007fb559a7dd2a in intelClear (ctx=0x41b7220, mask=2) at intel_clear.c:177
#9  0x00007fb57206bce7 in KWin::SceneOpenGL::paintBackground (this=<value optimized out>, region=<value optimized out>) at ../../kwin/scene_opengl.cpp:921
#10 0x00007fb57206388f in KWin::Scene::paintGenericScreen (this=0x28189a0, orig_mask=32) at ../../kwin/scene.cpp:188
#11 0x00007fb572060c7a in KWin::Scene::finalPaintScreen (this=0x28189a0, mask=32, region=<value optimized out>, data=<value optimized out>) at ../../kwin/scene.cpp:178
#12 0x00007fb57207ef19 in KWin::EffectsHandlerImpl::paintScreen (this=0x24e01e0, mask=32, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:173
#13 0x00007fb558afb5a6 in KWin::StartupFeedbackEffect::paintScreen (this=0x3ba66a0, mask=32, region=<value optimized out>, data=...) at ../../../kwin/effects/startupfeedback/startupfeedback.cpp:166
#14 0x00007fb57207efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x24e01e0, mask=32, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#15 0x00007fb57013ea18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#16 0x00007fb57207efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x24e01e0, mask=32, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#17 0x00007fb558aa244d in KWin::LogoutEffect::paintScreen (this=0x41f09a0, mask=32, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:207
#18 0x00007fb57207efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x24e01e0, mask=32, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#19 0x00007fb558abd57b in KWin::ShadowEffect::paintScreen (this=0x24dde90, mask=32, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:189
#20 0x00007fb57207efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x24e01e0, mask=32, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#21 0x00007fb558acfe68 in KWin::BlurEffect::paintScreen (this=<value optimized out>, mask=32, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:230
#22 0x00007fb57207efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x24e01e0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#23 0x00007fb558aa6fbd in KWin::PresentWindowsEffect::paintScreen (this=0x3baacf0, mask=0, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:205
#24 0x00007fb57207efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x24e01e0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#25 0x00007fb57013ea18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#26 0x00007fb57207efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x24e01e0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#27 0x00007fb57013ea18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#28 0x00007fb57207efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x24e01e0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#29 0x00007fb57013ea18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#30 0x00007fb57207efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x24e01e0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#31 0x00007fb57013ea18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#32 0x00007fb57207efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x24e01e0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#33 0x00007fb558a8e365 in KWin::DesktopGridEffect::paintScreen (this=0x2618cf0, mask=0, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:155
#34 0x00007fb57207efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x24e01e0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#35 0x00007fb558a87bad in KWin::BoxSwitchEffect::paintScreen (this=0x3e71b50, mask=0, region=..., data=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:143
#36 0x00007fb57207efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x24e01e0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#37 0x00007fb558ade256 in KWin::CubeEffect::paintScreen (this=<value optimized out>, mask=0, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:698
#38 0x00007fb57207efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x24e01e0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#39 0x00007fb57013ea18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#40 0x00007fb57207efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x24e01e0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#41 0x00007fb558ae7fa4 in KWin::CubeSlideEffect::paintScreen (this=<value optimized out>, mask=0, region=..., data=...) at ../../../kwin/effects/cube/cubeslide.cpp:111
#42 0x00007fb57207efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x24e01e0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#43 0x00007fb57013ea18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#44 0x00007fb57207efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x24e01e0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#45 0x00007fb57013ea18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#46 0x00007fb57207efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x24e01e0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#47 0x00007fb558ad6d86 in KWin::CoverSwitchEffect::paintScreen (this=0x3b98fb0, mask=0, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:126
#48 0x00007fb57207efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x24e01e0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#49 0x00007fb57013ea18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#50 0x00007fb57207efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x24e01e0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#51 0x00007fb57013ea18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#52 0x00007fb57207efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x24e01e0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#53 0x00007fb57013ea18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#54 0x00007fb57207efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x24e01e0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#55 0x00007fb558acd39b in KWin::ZoomEffect::paintScreen (this=0x3d430f0, mask=0, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:341
#56 0x00007fb57207efa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x24e01e0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#57 0x00007fb5720630af in KWin::Scene::paintScreen (this=0x28189a0, mask=0x7fffbdcb98fc, region=0x7fffbdcb99c0) at ../../kwin/scene.cpp:137
#58 0x00007fb572076ef3 in KWin::SceneOpenGL::paint (this=0x28189a0, damage=..., toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:772
#59 0x00007fb57205e396 in KWin::Workspace::performCompositing (this=0x7fb554353eb0) at ../../kwin/composite.cpp:448
#60 0x00007fb56e0b71c9 in QObject::event (this=0x7fb554353eb0, e=<value optimized out>) at kernel/qobject.cpp:1190
#61 0x00007fb56d4649e4 in QApplicationPrivate::notify_helper (this=0x122c8b0, receiver=0x7fb554353eb0, e=0x7fffbdcba150) at kernel/qapplication.cpp:4462
#62 0x00007fb56d4693aa in QApplication::notify (this=<value optimized out>, receiver=0x7fb554353eb0, e=0x7fffbdcba150) at kernel/qapplication.cpp:4341
#63 0x00007fb5717f0866 in KApplication::notify (this=0x7fffbdcba550, receiver=0x7fb554353eb0, event=0x7fffbdcba150) at ../../kdeui/kernel/kapplication.cpp:311
#64 0x00007fb56e0a349c in QCoreApplication::notifyInternal (this=0x7fffbdcba550, receiver=0x7fb554353eb0, event=0x7fffbdcba150) at kernel/qcoreapplication.cpp:731
#65 0x00007fb56e0d0f12 in sendEvent (this=0x122e3c0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#66 QTimerInfoList::activateTimers (this=0x122e3c0) at kernel/qeventdispatcher_unix.cpp:604
#67 0x00007fb56e0d105b in QEventDispatcherUNIX::processEvents (this=0x11d1340, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#68 0x00007fb56d50cc0c in QEventDispatcherX11::processEvents (this=0x11d1340, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#69 0x00007fb56e0a2882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#70 0x00007fb56e0a2abc in QEventLoop::exec (this=0x7fffbdcba490, flags=...) at kernel/qeventloop.cpp:201
#71 0x00007fb56e0a6ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#72 0x00007fb571ffc1ec in kdemain (argc=<value optimized out>, argv=0x7fffbdcbabe8) at ../../kwin/main.cpp:542
#73 0x00007fb571c2deff in __libc_start_main (main=0x400740 <main(int, char**)>, argc=3, ubp_av=0x7fffbdcbabe8, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fffbdcbabd8) at libc-start.c:226
#74 0x0000000000400669 in _start ()

Possible duplicates by query: bug 272331, bug 272323, bug 272304, bug 272201, bug 272118.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2011-05-04 15:34:54 UTC
driver bug, see dupe

*** This bug has been marked as a duplicate of bug 252817 ***