Bug 272304

Summary: KWin crash after full screen flash movie
Product: [Plasma] kwin Reporter: Neil Oosthuizen <nlsthzn>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description Neil Oosthuizen 2011-05-03 08:17:42 UTC
Application: kwin (4.6.2 (4.6.2))
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic i686
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:

Watching a movie clip on Youtube using FireFox fullscreen, went back to normal windowed view and KWin crashed

The crash can be reproduced some of the time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77de720 (LWP 1911))]

Thread 3 (Thread 0xb2db4b70 (LWP 1917)):
#0  0x05f98d41 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x01c9edd8 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x01d6b4f2 in updateCurrentTime (this=0xb2400b38, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0xb2400b38, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x01d6d3a3 in QEventDispatcherUNIX::processEvents (this=0xb2400488, flags=...) at kernel/qeventdispatcher_unix.cpp:906
#6  0x01d3c289 in QEventLoop::processEvents (this=0xb2db4280, flags=...) at kernel/qeventloop.cpp:149
#7  0x01d3c522 in QEventLoop::exec (this=0xb2db4280, flags=...) at kernel/qeventloop.cpp:201
#8  0x01c462a0 in QThread::exec (this=0x962af18) at thread/qthread.cpp:492
#9  0x01d1dfdb in QInotifyFileSystemWatcherEngine::run (this=0x962af18) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x01c48da2 in QThreadPrivate::start (arg=0x962af18) at thread/qthread_unix.cpp:320
#11 0x00e48e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x00f5073e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xb23ffb70 (LWP 1918)):
#0  0x00999416 in __kernel_vsyscall ()
#1  0x00e4d48c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x00f5e3fd in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x01168817 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x127c1c0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#4  0x01168851 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x127c1c0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#5  0x00e48e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0x00f5073e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb77de720 (LWP 1911)):
[KCrash Handler]
#7  0x02e6d900 in intel_region_buffer () from /usr/lib/dri/i915_dri.so
#8  0x02e76742 in intelClearWithBlit () from /usr/lib/dri/i915_dri.so
#9  0x02e6f670 in ?? () from /usr/lib/dri/i915_dri.so
#10 0x08522512 in _mesa_Clear () from /usr/lib/dri/libdricore.so
#11 0x00bf284b in KWin::SceneOpenGL::paintBackground (this=0x9471da8, region=...) at ../../kwin/scene_opengl.cpp:921
#12 0x00be9562 in KWin::Scene::paintGenericScreen (this=0x9471da8, orig_mask=32) at ../../kwin/scene.cpp:188
#13 0x00bf2a31 in KWin::SceneOpenGL::paintGenericScreen (this=0x9471da8, mask=32, data=...) at ../../kwin/scene_opengl.cpp:909
#14 0x00be67c0 in KWin::Scene::finalPaintScreen (this=0x9471da8, mask=32, region=..., data=...) at ../../kwin/scene.cpp:178
#15 0x00c080fc in KWin::EffectsHandlerImpl::paintScreen (this=0x9484670, mask=32, region=..., data=...) at ../../kwin/effects.cpp:173
#16 0x02dcd0e9 in KWin::StartupFeedbackEffect::paintScreen (this=0x95219f8, mask=32, region=..., data=...) at ../../../kwin/effects/startupfeedback/startupfeedback.cpp:166
#17 0x00c08172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9484670, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#18 0x0080a256 in KWin::Effect::paintScreen (this=0x94b7a48, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#19 0x00c08172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9484670, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#20 0x02d6f07f in KWin::LogoutEffect::paintScreen (this=0x94b8598, mask=32, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:207
#21 0x00c08172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9484670, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#22 0x02d8ab10 in KWin::ShadowEffect::paintScreen (this=0x94b0820, mask=32, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:189
#23 0x00c08172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9484670, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#24 0x02d9f013 in KWin::BlurEffect::paintScreen (this=0x97be588, mask=32, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:230
#25 0x00c08172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9484670, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#26 0x02d73e6f in KWin::PresentWindowsEffect::paintScreen (this=0x94bbc50, mask=0, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:205
#27 0x00c08172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9484670, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#28 0x0080a256 in KWin::Effect::paintScreen (this=0x95309a0, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#29 0x00c08172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9484670, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#30 0x0080a256 in KWin::Effect::paintScreen (this=0x9538c98, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#31 0x00c08172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9484670, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#32 0x0080a256 in KWin::Effect::paintScreen (this=0x952a110, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#33 0x00c08172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9484670, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#34 0x0080a256 in KWin::Effect::paintScreen (this=0x94b32e8, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#35 0x00c08172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9484670, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#36 0x02d5a7e9 in KWin::DesktopGridEffect::paintScreen (this=0x94b30c0, mask=0, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:155
#37 0x00c08172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9484670, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#38 0x02d91ce2 in KWin::SlideEffect::paintScreen (this=0x94c2c48, mask=0, region=..., data=...) at ../../../kwin/effects/slide/slide.cpp:86
#39 0x00c08172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9484670, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#40 0x02d53799 in KWin::BoxSwitchEffect::paintScreen (this=0x94cade8, mask=0, region=..., data=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:143
#41 0x00c08172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9484670, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#42 0x02dadbcc in KWin::CubeEffect::paintScreen (this=0x950cc70, mask=0, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:698
#43 0x00c08172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9484670, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#44 0x0080a256 in KWin::Effect::paintScreen (this=0x952ca18, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#45 0x00c08172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9484670, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#46 0x0080a256 in KWin::Effect::paintScreen (this=0x9531850, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#47 0x00c08172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9484670, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#48 0x0080a256 in KWin::Effect::paintScreen (this=0x952b2a0, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#49 0x00c08172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9484670, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#50 0x02da6a0c in KWin::CoverSwitchEffect::paintScreen (this=0x952a9f0, mask=0, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:126
#51 0x00c08172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9484670, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#52 0x0080a256 in KWin::Effect::paintScreen (this=0x94d4d20, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#53 0x00c08172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9484670, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#54 0x0080a256 in KWin::Effect::paintScreen (this=0x94e4810, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#55 0x00c08172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9484670, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#56 0x02d9c0c1 in KWin::ZoomEffect::paintScreen (this=0x94be198, mask=0, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:341
#57 0x00c08172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9484670, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#58 0x00be798c in KWin::Scene::paintScreen (this=0x9471da8, mask=0xbf979cf8, region=0xbf979d80) at ../../kwin/scene.cpp:137
#59 0x00bfe962 in KWin::SceneOpenGL::paint (this=0x9471da8, damage=..., toplevels=...) at ../../kwin/scene_opengl.cpp:772
#60 0x00be3886 in KWin::Workspace::performCompositing (this=0x917f790) at ../../kwin/composite.cpp:448
#61 0x01d52214 in QObject::event (this=0x917f790, e=0xbf97a2ac) at kernel/qobject.cpp:1190
#62 0x01fa7d24 in QApplicationPrivate::notify_helper (this=0x908e160, receiver=0x917f790, e=0xbf97a2ac) at kernel/qapplication.cpp:4462
#63 0x01fac8ce in QApplication::notify (this=0xbf97a5c4, receiver=0x917f790, e=0xbf97a2ac) at kernel/qapplication.cpp:3862
#64 0x006333ca in KApplication::notify (this=0xbf97a5c4, receiver=0x917f790, event=0xbf97a2ac) at ../../kdeui/kernel/kapplication.cpp:311
#65 0x00b72abf in KWin::Application::notify (this=0xbf97a5c4, o=0x917f790, e=0xbf97a2ac) at ../../kwin/main.cpp:376
#66 0x01d3d0bb in QCoreApplication::notifyInternal (this=0xbf97a5c4, receiver=0x917f790, event=0xbf97a2ac) at kernel/qcoreapplication.cpp:731
#67 0x01d6d1e4 in sendEvent (this=0x908eb50) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#68 QTimerInfoList::activateTimers (this=0x908eb50) at kernel/qeventdispatcher_unix.cpp:604
#69 0x01d6d338 in QEventDispatcherUNIX::processEvents (this=0x904caa8, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#70 0x0205c7ea in QEventDispatcherX11::processEvents (this=0x904caa8, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#71 0x01d3c289 in QEventLoop::processEvents (this=0xbf97a504, flags=...) at kernel/qeventloop.cpp:149
#72 0x01d3c522 in QEventLoop::exec (this=0xbf97a504, flags=...) at kernel/qeventloop.cpp:201
#73 0x01d40ecc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#74 0x01fa58e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#75 0x00b755b2 in kdemain (argc=3, argv=0xbf97a844) at ../../kwin/main.cpp:542
#76 0x080485bb in main (argc=3, argv=0xbf97a844) at kwin_dummy.cpp:3

This bug may be a duplicate of or related to bug 252817.

Possible duplicates by query: bug 272201, bug 272106, bug 272102, bug 272069, bug 272011.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2011-05-03 11:43:41 UTC
driver bug

*** This bug has been marked as a duplicate of bug 252817 ***