Bug 271256

Summary: kde crash during closure of applciations
Product: plasma4 Reporter: terry pavlis <tlpavlis>
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: andresbajotierra, bugzilla, sam
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Fedora RPMs   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: New crash information added by DrKonqi
New crash information added by DrKonqi

Description terry pavlis 2011-04-19 00:30:37 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.1 (4.6.1)
Qt Version: 4.7.1
Operating System: Linux 2.6.35.12-88.fc14.x86_64 x86_64
Distribution: "Fedora release 14 (Laughlin)"

-- Information about the crash:
- What I was doing when the application crashed:
I was running three applications:  a firefox browser, amarok playing music, and oracle virtual box running an xp virtual machine.  I gave the windows shutdown command to the virtual machine, then wen to amarok, and attempted to shut down amarok.  Then I got a kde crash report, and the virtual machine was listed as as an aborted shutdown.  I am virtually certain it was amarok that was the culprit.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[KCrash Handler]
#6  0x00007fcd1326600f in QString (this=0x9c0075, group=0, state=0) at /usr/include/QtCore/qstring.h:728
#7  KIconEffect::fingerprint (this=0x9c0075, group=0, state=0) at /usr/src/debug/kdelibs-4.6.1/kdeui/icons/kiconeffect.cpp:169
#8  0x00007fcd1326bb4b in KIconLoaderPrivate::makeCacheKey (this=<value optimized out>, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at /usr/src/debug/kdelibs-4.6.1/kdeui/icons/kiconloader.cpp:782
#9  0x00007fcd13272c21 in KIconLoader::loadIcon (this=0xc450c0, _name=<value optimized out>, group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at /usr/src/debug/kdelibs-4.6.1/kdeui/icons/kiconloader.cpp:1226
#10 0x00007fcd1326a7f0 in KIconEngine::pixmap (this=<value optimized out>, size=..., mode=<value optimized out>, state=<value optimized out>) at /usr/src/debug/kdelibs-4.6.1/kdeui/icons/kiconengine.cpp:93
#11 0x0000003af9a5e585 in QIcon::pixmap (this=<value optimized out>, size=<value optimized out>, mode=<value optimized out>, state=<value optimized out>) at image/qicon.cpp:676
#12 0x00007fcd14f7d7c1 in Plasma::IconWidgetPrivate::decoration (this=0x1bbe3c0, option=<value optimized out>, useHoverEffect=false, usePressedEffect=false) at /usr/src/debug/kdelibs-4.6.1/plasma/widgets/iconwidget.cpp:812
#13 0x00007fcd14f8365b in Plasma::IconWidget::paint (this=0x1bd17e0, painter=0x7fff556e45a0, option=0x9510a8, widget=<value optimized out>) at /usr/src/debug/kdelibs-4.6.1/plasma/widgets/iconwidget.cpp:1128
#14 0x00007fcd02f8f719 in SystemTray::DBusSystemTrayWidget::paint (this=0x1bd17e0, painter=0x7fff556e45a0, option=0x9510a8, widget=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.1/plasma/generic/applets/systemtray/protocols/dbussystemtray/dbussystemtraywidget.cpp:189
#15 0x0000003af9fa2f3d in _q_paintItem (item=<value optimized out>, painter=0x7fff556e45a0, option=0x9510a8, widget=0x0, useWindowOpacity=<value optimized out>, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4314
#16 0x0000003af9fa3250 in _q_paintIntoCache (pix=0x7fff556e4af0, item=0x1bd17f0, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x9510a8, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4352
#17 0x0000003af9fb71a2 in QGraphicsScenePrivate::drawItemHelper (this=0x950e80, item=0x1bd17f0, painter=0x7fff556e69f0, option=<value optimized out>, widget=<value optimized out>, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4690
#18 0x0000003af9fb78c1 in QGraphicsScenePrivate::draw (this=0x950e80, item=0x1bd17f0, painter=0x7fff556e69f0, viewTransform=0x7fff556e6780, transformPtr=0x7fff556e5160, exposedRegion=0x15cbf10, widget=0x1246f70, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4931
#19 0x0000003af9fb84b7 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x950e80, item=0x1bd17f0, painter=0x7fff556e69f0, viewTransform=0x7fff556e6780, exposedRegion=0x15cbf10, widget=0x1246f70, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#20 0x0000003af9fb7958 in QGraphicsScenePrivate::draw (this=0x950e80, item=0xc9e8a0, painter=0x7fff556e69f0, viewTransform=0x7fff556e6780, transformPtr=0x7fff556e5710, exposedRegion=0x15cbf10, widget=0x1246f70, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4945
#21 0x0000003af9fb84b7 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x950e80, item=0xc9e8a0, painter=0x7fff556e69f0, viewTransform=0x7fff556e6780, exposedRegion=0x15cbf10, widget=0x1246f70, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#22 0x0000003af9fb7958 in QGraphicsScenePrivate::draw (this=0x950e80, item=0xcf7770, painter=0x7fff556e69f0, viewTransform=0x7fff556e6780, transformPtr=0x7fff556e5cc0, exposedRegion=0x15cbf10, widget=0x1246f70, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4945
#23 0x0000003af9fb84b7 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x950e80, item=0xcf7770, painter=0x7fff556e69f0, viewTransform=0x7fff556e6780, exposedRegion=0x15cbf10, widget=0x1246f70, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#24 0x0000003af9fb7958 in QGraphicsScenePrivate::draw (this=0x950e80, item=0xc104f0, painter=0x7fff556e69f0, viewTransform=0x7fff556e6780, transformPtr=0x7fff556e6270, exposedRegion=0x15cbf10, widget=0x1246f70, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4945
#25 0x0000003af9fb84b7 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x950e80, item=0xc104f0, painter=0x7fff556e69f0, viewTransform=0x7fff556e6780, exposedRegion=0x15cbf10, widget=0x1246f70, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#26 0x0000003af9fb8d6c in QGraphicsScenePrivate::drawItems (this=0x950e80, painter=0x7fff556e69f0, viewTransform=0x7fff556e6780, exposedRegion=0x15cbf10, widget=0x1246f70) at graphicsview/qgraphicsscene.cpp:4735
#27 0x0000003af9fd5e2c in QGraphicsView::paintEvent (this=0x12d5860, event=<value optimized out>) at graphicsview/qgraphicsview.cpp:3469
#28 0x0000003af9a08f9a in QWidget::event (this=0x12d5860, event=0x7fff556e7340) at kernel/qwidget.cpp:8346
#29 0x0000003af9db3906 in QFrame::event (this=0x12d5860, e=0x7fff556e7340) at widgets/qframe.cpp:557
#30 0x0000003af9fd70bb in QGraphicsView::viewportEvent (this=0x12d5860, event=0x7fff556e7340) at graphicsview/qgraphicsview.cpp:2864
#31 0x0000003af795b937 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x1246f70, event=0x7fff556e7340) at kernel/qcoreapplication.cpp:847
#32 0x0000003af99b7891 in QApplicationPrivate::notify_helper (this=0x94ffd0, receiver=0x1246f70, e=0x7fff556e7340) at kernel/qapplication.cpp:4441
#33 0x0000003af99bc3da in QApplication::notify (this=<value optimized out>, receiver=0x1246f70, e=0x7fff556e7340) at kernel/qapplication.cpp:4324
#34 0x00007fcd132c1466 in KApplication::notify (this=0x92e370, receiver=0x1246f70, event=0x7fff556e7340) at /usr/src/debug/kdelibs-4.6.1/kdeui/kernel/kapplication.cpp:311
#35 0x0000003af795b7ac in QCoreApplication::notifyInternal (this=0x92e370, receiver=0x1246f70, event=0x7fff556e7340) at kernel/qcoreapplication.cpp:732
#36 0x0000003af9a05e68 in sendSpontaneousEvent (this=0x158df00, pdev=0x11c5258, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xa9f3d0) at ../../src/corelib/kernel/qcoreapplication.h:218
#37 QWidgetPrivate::drawWidget (this=0x158df00, pdev=0x11c5258, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xa9f3d0) at kernel/qwidget.cpp:5433
#38 0x0000003af9a06a2f in QWidgetPrivate::paintSiblingsRecursive (this=0x15cba80, pdev=0x11c5258, siblings=<value optimized out>, index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xa9f3d0) at kernel/qwidget.cpp:5640
#39 0x0000003af9a068ec in QWidgetPrivate::paintSiblingsRecursive (this=0x15cba80, pdev=0x11c5258, siblings=..., index=4, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xa9f3d0) at kernel/qwidget.cpp:5627
#40 0x0000003af9a05baa in QWidgetPrivate::drawWidget (this=0x15cba80, pdev=0x11c5258, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0xa9f3d0) at kernel/qwidget.cpp:5486
#41 0x0000003af9bc8fe9 in QWidgetBackingStore::sync (this=0xa9f3d0) at painting/qbackingstore.cpp:1333
#42 0x0000003af99fc1b0 in QWidgetPrivate::syncBackingStore (this=0x15cba80) at kernel/qwidget.cpp:1816
#43 0x0000003af9a094a2 in QWidget::event (this=0x12d5860, event=0xc450c0) at kernel/qwidget.cpp:8493
#44 0x0000003af9db3906 in QFrame::event (this=0x12d5860, e=0xc450c0) at widgets/qframe.cpp:557
#45 0x0000003af9e34cab in QAbstractScrollArea::event (this=0x12d5860, e=0xc450c0) at widgets/qabstractscrollarea.cpp:996
#46 0x00007fcd166fff30 in PanelView::event (this=0x12d5860, event=0xc450c0) at /usr/src/debug/kdebase-workspace-4.6.1/plasma/desktop/shell/panelview.cpp:1561
#47 0x0000003af99b78c4 in QApplicationPrivate::notify_helper (this=0x94ffd0, receiver=0x12d5860, e=0xc450c0) at kernel/qapplication.cpp:4445
#48 0x0000003af99bc3da in QApplication::notify (this=<value optimized out>, receiver=0x12d5860, e=0xc450c0) at kernel/qapplication.cpp:4324
#49 0x00007fcd132c1466 in KApplication::notify (this=0x92e370, receiver=0x12d5860, event=0xc450c0) at /usr/src/debug/kdelibs-4.6.1/kdeui/kernel/kapplication.cpp:311
#50 0x0000003af795b7ac in QCoreApplication::notifyInternal (this=0x92e370, receiver=0x12d5860, event=0xc450c0) at kernel/qcoreapplication.cpp:732
#51 0x0000003af795ef95 in sendEvent (receiver=0x12d5860, event_type=77, data=0x900540) at kernel/qcoreapplication.h:215
#52 QCoreApplicationPrivate::sendPostedEvents (receiver=0x12d5860, event_type=77, data=0x900540) at kernel/qcoreapplication.cpp:1373
#53 0x0000003af9fafaaa in dispatchPendingUpdateRequests (this=0x950e80) at ../../src/gui/graphicsview/qgraphicsview_p.h:189
#54 QGraphicsScenePrivate::_q_processDirtyItems (this=0x950e80) at graphicsview/qgraphicsscene.cpp:510
#55 0x0000003af9fafeba in QGraphicsScene::qt_metacall (this=0x954f60, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x1883c20) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#56 0x00007fcd14ed0815 in Plasma::Corona::qt_metacall (this=0x954f60, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x1883c20) at /usr/src/debug/kdelibs-4.6.1/x86_64-redhat-linux-gnu/plasma/corona.moc:109
#57 0x00007fcd166f4255 in DesktopCorona::qt_metacall (this=0x954f60, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x1883c20) at /usr/src/debug/kdebase-workspace-4.6.1/x86_64-redhat-linux-gnu/plasma/desktop/shell/desktopcorona.moc:101
#58 0x0000003af796fb4a in QObject::event (this=0x954f60, e=<value optimized out>) at kernel/qobject.cpp:1211
#59 0x0000003af9fbc5f0 in QGraphicsScene::event (this=0x954f60, event=0x1ae91c0) at graphicsview/qgraphicsscene.cpp:3544
#60 0x0000003af99b78c4 in QApplicationPrivate::notify_helper (this=0x94ffd0, receiver=0x954f60, e=0x1ae91c0) at kernel/qapplication.cpp:4445
#61 0x0000003af99bc3da in QApplication::notify (this=<value optimized out>, receiver=0x954f60, e=0x1ae91c0) at kernel/qapplication.cpp:4324
#62 0x00007fcd132c1466 in KApplication::notify (this=0x92e370, receiver=0x954f60, event=0x1ae91c0) at /usr/src/debug/kdelibs-4.6.1/kdeui/kernel/kapplication.cpp:311
#63 0x0000003af795b7ac in QCoreApplication::notifyInternal (this=0x92e370, receiver=0x954f60, event=0x1ae91c0) at kernel/qcoreapplication.cpp:732
#64 0x0000003af795ef95 in sendEvent (receiver=0x0, event_type=0, data=0x900540) at kernel/qcoreapplication.h:215
#65 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x900540) at kernel/qcoreapplication.cpp:1373
#66 0x0000003af7986723 in sendPostedEvents (s=0x956010) at kernel/qcoreapplication.h:220
#67 postEventSourceDispatch (s=0x956010) at kernel/qeventdispatcher_glib.cpp:277
#68 0x000000357c441e33 in g_main_dispatch (context=0x953920) at gmain.c:2149
#69 g_main_context_dispatch (context=0x953920) at gmain.c:2702
#70 0x000000357c442610 in g_main_context_iterate (context=0x953920, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2780
#71 0x000000357c4428ad in g_main_context_iteration (context=0x953920, may_block=1) at gmain.c:2843
#72 0x0000003af79868bf in QEventDispatcherGlib::processEvents (this=0x8ffc30, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#73 0x0000003af9a5c59e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#74 0x0000003af795ab42 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#75 0x0000003af795ad8c in QEventLoop::exec (this=0x7fff556e9560, flags=...) at kernel/qeventloop.cpp:201
#76 0x0000003af795f24b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#77 0x00007fcd166fabd8 in kdemain (argc=1, argv=0x7fff556e9958) at /usr/src/debug/kdebase-workspace-4.6.1/plasma/desktop/shell/main.cpp:118
#78 0x000000357a41ee5d in __libc_start_main (main=0x400990 <main(int, char**)>, argc=1, ubp_av=0x7fff556e9958, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff556e9948) at libc-start.c:226
#79 0x00000000004008b9 in _start ()

This bug may be a duplicate of or related to bug 258706.

Possible duplicates by query: bug 271223, bug 270801, bug 270780, bug 270352, bug 270186.

Reported using DrKonqi
Comment 1 sam 2011-04-22 02:38:30 UTC
Created attachment 59192 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.0

- What I was doing when the application crashed:

Used the Quit command from the Amarok icon in the Task Tray to try to exit Amarok

- Unusual behavior I noticed:

Plasma desktop crashed.

-- Backtrace (Reduced):
#6  0x00007f9eb1559a7a in QString (this=0x3ac0075, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:727
#7  KIconEffect::fingerprint (this=0x3ac0075, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:169
#8  0x00007f9eb155d4be in KIconLoaderPrivate::makeCacheKey (this=<value optimized out>, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at ../../kdeui/icons/kiconloader.cpp:782
#9  0x00007f9eb1565544 in KIconLoader::loadIcon (this=0x3a3d580, _name=<value optimized out>, group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1226
#10 0x00007f9eb155c070 in KIconEngine::pixmap (this=<value optimized out>, size=..., mode=<value optimized out>, state=<value optimized out>) at ../../kdeui/icons/kiconengine.cpp:93
Comment 2 Dario Andres 2011-04-22 22:49:50 UTC
[Comment from a bug report cleaner]
This is related/duplicate of bug 258706 or bug 226596. Regards
Comment 3 bugzilla 2011-04-26 02:35:45 UTC
Created attachment 59316 [details]
New crash information added by DrKonqi

playing music with Amarok then I stopped playing and closed Amarok, then Plasma crashed.
Comment 4 Christoph Feck 2011-05-03 16:52:01 UTC

*** This bug has been marked as a duplicate of bug 258706 ***