Bug 271197

Summary: KWin crashes
Product: [Plasma] kwin Reporter: Hans Reisner <hans>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description Hans Reisner 2011-04-18 09:42:41 UTC
Application: kwin (4.5.1 (KDE 4.5.1))
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-28-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

I only pressed CTRL key; the maximized window moved and kwin crashed. I've got active effects, maybe this is a hint. Can I help somehow otherwise?

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f2448d467a0 (LWP 31855))]

Thread 2 (Thread 0x7f2423281700 (LWP 31861)):
#0  0x00007f24485c52c3 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f2444e0b76e in qt_safe_select (nfds=35, fdread=0x1b11390, fdwrite=0x1b11628, fdexcept=0x1b118c0, orig_timeout=0x0) at kernel/qcore_unix.cpp:82
#2  0x00007f2444e10beb in QEventDispatcherUNIXPrivate::doSelect (this=0x1b111d0, flags=<value optimized out>, timeout=<value optimized out>) at kernel/qeventdispatcher_unix.cpp:219
#3  0x00007f2444e1181b in QEventDispatcherUNIX::processEvents (this=0x1a04df0, flags=) at kernel/qeventdispatcher_unix.cpp:919
#4  0x00007f2444de0a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007f2444de0dec in QEventLoop::exec (this=0x7f2423280cb0, flags=) at kernel/qeventloop.cpp:201
#6  0x00007f2444ceb2fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007f2444dc05f8 in QInotifyFileSystemWatcherEngine::run (this=0x1a5a640) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f2444cee27e in QThreadPrivate::start (arg=0x1a5a640) at thread/qthread_unix.cpp:266
#9  0x00007f2446313953 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#10 0x00007f2444a63971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#11 0x00007f24485cc92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f2448d467a0 (LWP 31855)):
[KCrash Handler]
#6  0x00007f242655d64a in KWin::DesktopGridEffect::finish (this=0x1997770) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:1322
#7  0x00007f24265601b1 in KWin::DesktopGridEffect::prePaintScreen (this=0x1997770, data=<value optimized out>, time=16) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:146
#8  0x00007f244893bb1b in KWin::EffectsHandlerImpl::prePaintScreen (this=0x1489330, data=..., time=16) at ../../kwin/effects.cpp:158
#9  0x00007f244893bb1b in KWin::EffectsHandlerImpl::prePaintScreen (this=0x1489330, data=..., time=16) at ../../kwin/effects.cpp:158
#10 0x00007f244893bb1b in KWin::EffectsHandlerImpl::prePaintScreen (this=0x1489330, data=..., time=16) at ../../kwin/effects.cpp:158
#11 0x00007f244893bb1b in KWin::EffectsHandlerImpl::prePaintScreen (this=0x1489330, data=..., time=16) at ../../kwin/effects.cpp:158
#12 0x00007f244893bb1b in KWin::EffectsHandlerImpl::prePaintScreen (this=0x1489330, data=..., time=16) at ../../kwin/effects.cpp:158
#13 0x00007f244893bb1b in KWin::EffectsHandlerImpl::prePaintScreen (this=0x1489330, data=..., time=16) at ../../kwin/effects.cpp:158
#14 0x00007f244893bb1b in KWin::EffectsHandlerImpl::prePaintScreen (this=0x1489330, data=..., time=16) at ../../kwin/effects.cpp:158
#15 0x00007f244893bb1b in KWin::EffectsHandlerImpl::prePaintScreen (this=0x1489330, data=..., time=16) at ../../kwin/effects.cpp:158
#16 0x00007f24265710a4 in KWin::LoginEffect::prePaintScreen (this=0x1970450, data=..., time=14) at ../../../kwin/effects/login/login.cpp:52
#17 0x00007f244893bb1b in KWin::EffectsHandlerImpl::prePaintScreen (this=0x1489330, data=..., time=16) at ../../kwin/effects.cpp:158
#18 0x00007f244893bb1b in KWin::EffectsHandlerImpl::prePaintScreen (this=0x1489330, data=..., time=16) at ../../kwin/effects.cpp:158
#19 0x00007f244893bb1b in KWin::EffectsHandlerImpl::prePaintScreen (this=0x1489330, data=..., time=16) at ../../kwin/effects.cpp:158
#20 0x00007f244892309a in KWin::Scene::paintScreen (this=0x14b7540, mask=0x7fff5499be0c, region=0x7fff5499bf30) at ../../kwin/scene.cpp:116
#21 0x00007f2448934450 in KWin::SceneOpenGL::paint (this=0x14b7540, damage=<value optimized out>, toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:754
#22 0x00007f244891e2a7 in KWin::Workspace::performCompositing (this=<value optimized out>) at ../../kwin/composite.cpp:454
#23 0x00007f244889f7dd in KWin::Workspace::qt_metacall (this=0x7f242c0f44f0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff5499c0e0) at ./workspace.moc:583
#24 0x00007f2444df9b27 in QMetaObject::activate (sender=0x7f242c0f49b8, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x1efdb30) at kernel/qobject.cpp:3280
#25 0x00007f2444df38f9 in QObject::event (this=0x7f242c0f49b8, e=0x1ee5830) at kernel/qobject.cpp:1183
#26 0x00007f2443f2bfdc in QApplicationPrivate::notify_helper (this=0x14e1f50, receiver=0x7f242c0f49b8, e=0x7fff5499c830) at kernel/qapplication.cpp:4396
#27 0x00007f2443f31aed in QApplication::notify (this=0x7fff5499cc20, receiver=0x7f242c0f49b8, e=0x7fff5499c830) at kernel/qapplication.cpp:4277
#28 0x00007f24480c8156 in KApplication::notify (this=0x7fff5499cc20, receiver=0x7f242c0f49b8, event=0x7fff5499c830) at ../../kdeui/kernel/kapplication.cpp:310
#29 0x00007f2444de1cdc in QCoreApplication::notifyInternal (this=0x7fff5499cc20, receiver=0x7f242c0f49b8, event=0x7fff5499c830) at kernel/qcoreapplication.cpp:732
#30 0x00007f2444e116f2 in sendEvent (this=0x14e2960) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#31 QTimerInfoList::activateTimers (this=0x14e2960) at kernel/qeventdispatcher_unix.cpp:602
#32 0x00007f2444e1182c in QEventDispatcherUNIX::processEvents (this=0x14bde20, flags=) at kernel/qeventdispatcher_unix.cpp:923
#33 0x00007f2443fdfc2f in QEventDispatcherX11::processEvents (this=<value optimized out>, flags=) at kernel/qeventdispatcher_x11.cpp:152
#34 0x00007f2444de0a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#35 0x00007f2444de0dec in QEventLoop::exec (this=0x7fff5499cb60, flags=) at kernel/qeventloop.cpp:201
#36 0x00007f2444de4ebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#37 0x00007f24488bbf9d in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../kwin/main.cpp:531
#38 0x00007f2448504d8e in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff5499d228) at libc-start.c:226
#39 0x0000000000400669 in _start ()

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2011-04-18 11:02:33 UTC

*** This bug has been marked as a duplicate of bug 244813 ***