Bug 270801

Summary: Amarok crashed on exit
Product: plasma4 Reporter: Reartes Guillermo <rtguille>
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: andresbajotierra
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Fedora RPMs   
OS: Linux   
Latest Commit: Version Fixed In:

Description Reartes Guillermo 2011-04-12 23:09:45 UTC
Version:           2.4.0 (using KDE 4.6.1) 
OS:                Linux

I closed amarok (quit) and it crashed.
-----------------

Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[KCrash Handler]
#6  QString (other=..., this=0x7fff0f1893b0) at /usr/include/QtCore/qstring.h:728
#7  KIconEffect::fingerprint (this=0x24c0075, group=0, state=0) at /usr/src/debug/kdelibs-4.6.1/kdeui/icons/kiconeffect.cpp:169
#8  0x00000039a9deb05b in KIconLoaderPrivate::makeCacheKey (this=<optimized out>, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at /usr/src/debug/kdelibs-4.6.1/kdeui/icons/kiconloader.cpp:782
#9  0x00000039a9df234e in KIconLoader::loadIcon (this=0x249ee20, _name=<optimized out>, group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at /usr/src/debug/kdelibs-4.6.1/kdeui/icons/kiconloader.cpp:1226
#10 0x00000039a9de9dd9 in KIconEngine::pixmap (this=<optimized out>, size=..., mode=<optimized out>, state=<optimized out>) at /usr/src/debug/kdelibs-4.6.1/kdeui/icons/kiconengine.cpp:93
#11 0x00000039a785be15 in QIcon::pixmap (this=<optimized out>, size=<optimized out>, mode=<optimized out>, state=<optimized out>) at image/qicon.cpp:676
#12 0x00000039b1be7d24 in Plasma::IconWidgetPrivate::decoration (this=0x27c51a0, option=<optimized out>, useHoverEffect=false, usePressedEffect=false) at /usr/src/debug/kdelibs-4.6.1/plasma/widgets/iconwidget.cpp:812
#13 0x00000039b1bed9f1 in Plasma::IconWidget::paint (this=0x1dac2a0, painter=0x7fff0f189fa0, option=0x1664618, widget=<optimized out>) at /usr/src/debug/kdelibs-4.6.1/plasma/widgets/iconwidget.cpp:1128
#14 0x00007f813a65b5f9 in SystemTray::DBusSystemTrayWidget::paint (this=0x1dac2a0, painter=0x7fff0f189fa0, option=0x1664618, widget=<optimized out>) at /usr/src/debug/kdebase-workspace-4.6.1/plasma/generic/applets/systemtray/protocols/dbussystemtray/dbussystemtraywidget.cpp:189
#15 0x00000039a7d9117d in _q_paintItem (item=<optimized out>, painter=0x7fff0f189fa0, option=0x1664618, widget=0x0, useWindowOpacity=<optimized out>, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4314
#16 0x00000039a7d91a7a in _q_paintIntoCache (pix=0x7fff0f18a530, item=0x1dac2b0, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x1664618, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4352
#17 0x00000039a7da9d88 in QGraphicsScenePrivate::drawItemHelper (this=0x16643f0, item=0x1dac2b0, painter=0x7fff0f18c510, option=0x1664618, widget=<optimized out>, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4690
#18 0x00000039a7daa83d in QGraphicsScenePrivate::draw (this=0x16643f0, item=0x1dac2b0, painter=0x7fff0f18c510, viewTransform=0x7fff0f18c1e0, transformPtr=0x7fff0f18aae0, exposedRegion=0x23adfd0, widget=0x21ec0c0, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4962
#19 0x00000039a7dab605 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x16643f0, item=0x1dac2b0, painter=0x7fff0f18c510, viewTransform=0x7fff0f18c1e0, exposedRegion=0x23adfd0, widget=0x21ec0c0, parentOpacity=<optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#20 0x00000039a7daa8f0 in QGraphicsScenePrivate::draw (this=0x16643f0, item=0x18b1490, painter=0x7fff0f18c510, viewTransform=0x7fff0f18c1e0, transformPtr=0x7fff0f18b0d0, exposedRegion=0x23adfd0, widget=0x21ec0c0, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#21 0x00000039a7dab605 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x16643f0, item=0x18b1490, painter=0x7fff0f18c510, viewTransform=0x7fff0f18c1e0, exposedRegion=0x23adfd0, widget=0x21ec0c0, parentOpacity=<optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#22 0x00000039a7daa8f0 in QGraphicsScenePrivate::draw (this=0x16643f0, item=0x1929cd0, painter=0x7fff0f18c510, viewTransform=0x7fff0f18c1e0, transformPtr=0x7fff0f18b6c0, exposedRegion=0x23adfd0, widget=0x21ec0c0, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#23 0x00000039a7dab605 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x16643f0, item=0x1929cd0, painter=0x7fff0f18c510, viewTransform=0x7fff0f18c1e0, exposedRegion=0x23adfd0, widget=0x21ec0c0, parentOpacity=<optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#24 0x00000039a7daa8f0 in QGraphicsScenePrivate::draw (this=0x16643f0, item=0x176b520, painter=0x7fff0f18c510, viewTransform=0x7fff0f18c1e0, transformPtr=0x7fff0f18bcb0, exposedRegion=0x23adfd0, widget=0x21ec0c0, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#25 0x00000039a7dab605 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x16643f0, item=0x176b520, painter=0x7fff0f18c510, viewTransform=0x7fff0f18c1e0, exposedRegion=0x23adfd0, widget=0x21ec0c0, parentOpacity=<optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#26 0x00000039a7dabe21 in QGraphicsScenePrivate::drawItems (this=0x16643f0, painter=0x7fff0f18c510, viewTransform=0x7fff0f18c1e0, exposedRegion=0x23adfd0, widget=0x21ec0c0) at graphicsview/qgraphicsscene.cpp:4735
#27 0x00000039a7dc4aa0 in QGraphicsView::paintEvent (this=0x1d96220, event=<optimized out>) at graphicsview/qgraphicsview.cpp:3469
#28 0x00000039a7807a46 in QWidget::event (this=0x1d96220, event=0x7fff0f18ceb0) at kernel/qwidget.cpp:8405
#29 0x00000039a7ba4cb6 in QFrame::event (this=0x1d96220, e=0x7fff0f18ceb0) at widgets/qframe.cpp:557
#30 0x00000039a7dc5e2b in QGraphicsView::viewportEvent (this=0x1d96220, event=0x7fff0f18ceb0) at graphicsview/qgraphicsview.cpp:2864
#31 0x00000039a475a338 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0x21ec0c0, event=0x7fff0f18ceb0) at kernel/qcoreapplication.cpp:846
#32 0x00000039a77b739f in notify_helper (e=0x7fff0f18ceb0, receiver=0x21ec0c0, this=0x157a060) at kernel/qapplication.cpp:4458
#33 QApplicationPrivate::notify_helper (this=0x157a060, receiver=0x21ec0c0, e=0x7fff0f18ceb0) at kernel/qapplication.cpp:4434
#34 0x00000039a77bc261 in QApplication::notify (this=0x1567b20, receiver=0x21ec0c0, e=0x7fff0f18ceb0) at kernel/qapplication.cpp:4341
#35 0x00000039a9e40e66 in KApplication::notify (this=0x1567b20, receiver=0x21ec0c0, event=0x7fff0f18ceb0) at /usr/src/debug/kdelibs-4.6.1/kdeui/kernel/kapplication.cpp:311
#36 0x00000039a475a1ac in QCoreApplication::notifyInternal (this=0x1567b20, receiver=0x21ec0c0, event=0x7fff0f18ceb0) at kernel/qcoreapplication.cpp:731
#37 0x00000039a7804960 in sendSpontaneousEvent (event=0x7fff0f18ceb0, receiver=0x21ec0c0) at ../../src/corelib/kernel/qcoreapplication.h:218
#38 QWidgetPrivate::drawWidget (this=0x1e6d390, pdev=0x1a7b588, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x1d94e90) at kernel/qwidget.cpp:5492
#39 0x00000039a7805530 in QWidgetPrivate::paintSiblingsRecursive (this=0x23adb40, pdev=0x1a7b588, siblings=..., index=<optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x1d94e90) at kernel/qwidget.cpp:5699
#40 0x00000039a7805410 in QWidgetPrivate::paintSiblingsRecursive (this=0x23adb40, pdev=0x1a7b588, siblings=..., index=4, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x1d94e90) at kernel/qwidget.cpp:5686
#41 0x00000039a78046bc in QWidgetPrivate::drawWidget (this=0x23adb40, pdev=0x1a7b588, rgn=..., offset=..., flags=<optimized out>, sharedPainter=0x0, backingStore=0x1d94e90) at kernel/qwidget.cpp:5545
#42 0x00000039a79c0800 in QWidgetBackingStore::sync (this=0x1d94e90) at painting/qbackingstore.cpp:1333
#43 0x00000039a77fac90 in QWidgetPrivate::syncBackingStore (this=0x23adb40) at kernel/qwidget.cpp:1842
#44 0x00000039a7807f5c in QWidget::event (this=0x1d96220, event=0x249ee20) at kernel/qwidget.cpp:8552
#45 0x00000039a7ba4cb6 in QFrame::event (this=0x1d96220, e=0x249ee20) at widgets/qframe.cpp:557
#46 0x00000039a7c26063 in QAbstractScrollArea::event (this=0x1d96220, e=0x249ee20) at widgets/qabstractscrollarea.cpp:996
#47 0x00000039b5244126 in PanelView::event (this=0x1d96220, event=0x249ee20) at /usr/src/debug/kdebase-workspace-4.6.1/plasma/desktop/shell/panelview.cpp:1561
#48 0x00000039a77b73d4 in notify_helper (e=0x249ee20, receiver=0x1d96220, this=0x157a060) at kernel/qapplication.cpp:4462
#49 QApplicationPrivate::notify_helper (this=0x157a060, receiver=0x1d96220, e=0x249ee20) at kernel/qapplication.cpp:4434
#50 0x00000039a77bc261 in QApplication::notify (this=0x1567b20, receiver=0x1d96220, e=0x249ee20) at kernel/qapplication.cpp:4341
#51 0x00000039a9e40e66 in KApplication::notify (this=0x1567b20, receiver=0x1d96220, event=0x249ee20) at /usr/src/debug/kdelibs-4.6.1/kdeui/kernel/kapplication.cpp:311
#52 0x00000039a475a1ac in QCoreApplication::notifyInternal (this=0x1567b20, receiver=0x1d96220, event=0x249ee20) at kernel/qcoreapplication.cpp:731
#53 0x00000039a475d774 in sendEvent (event=0x249ee20, receiver=0x1d96220) at kernel/qcoreapplication.h:215
#54 QCoreApplicationPrivate::sendPostedEvents (receiver=0x1d96220, event_type=77, data=0x1520cd0) at kernel/qcoreapplication.cpp:1372
#55 0x00000039a7da0cda in dispatchPendingUpdateRequests (this=0x23adb40) at ../../src/gui/graphicsview/qgraphicsview_p.h:189
#56 QGraphicsScenePrivate::_q_processDirtyItems (this=0x16643f0) at graphicsview/qgraphicsscene.cpp:510
#57 0x00000039a7da10fa in QGraphicsScene::qt_metacall (this=0x1578a00, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x27ef1b0) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#58 0x00000039b1b352d5 in Plasma::Corona::qt_metacall (this=0x1578a00, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x27ef1b0) at /usr/src/debug/kdelibs-4.6.1/x86_64-redhat-linux-gnu/plasma/corona.moc:109
#59 0x00000039b52383e5 in DesktopCorona::qt_metacall (this=0x1578a00, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x27ef1b0) at /usr/src/debug/kdebase-workspace-4.6.1/x86_64-redhat-linux-gnu/plasma/desktop/shell/desktopcorona.moc:101
#60 0x00000039a4770a7a in QObject::event (this=0x1578a00, e=<optimized out>) at kernel/qobject.cpp:1217
#61 0x00000039a7da7989 in QGraphicsScene::event (this=0x1578a00, event=0x23947b0) at graphicsview/qgraphicsscene.cpp:3544
#62 0x00000039a77b73d4 in notify_helper (e=0x23947b0, receiver=0x1578a00, this=0x157a060) at kernel/qapplication.cpp:4462
#63 QApplicationPrivate::notify_helper (this=0x157a060, receiver=0x1578a00, e=0x23947b0) at kernel/qapplication.cpp:4434
#64 0x00000039a77bc261 in QApplication::notify (this=0x1567b20, receiver=0x1578a00, e=0x23947b0) at kernel/qapplication.cpp:4341
#65 0x00000039a9e40e66 in KApplication::notify (this=0x1567b20, receiver=0x1578a00, event=0x23947b0) at /usr/src/debug/kdelibs-4.6.1/kdeui/kernel/kapplication.cpp:311
#66 0x00000039a475a1ac in QCoreApplication::notifyInternal (this=0x1567b20, receiver=0x1578a00, event=0x23947b0) at kernel/qcoreapplication.cpp:731
#67 0x00000039a475d774 in sendEvent (event=0x23947b0, receiver=0x1578a00) at kernel/qcoreapplication.h:215
#68 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1520cd0) at kernel/qcoreapplication.cpp:1372
#69 0x00000039a47848c3 in sendPostedEvents () at kernel/qcoreapplication.h:220
#70 postEventSourceDispatch (s=0x157f9c0) at kernel/qeventdispatcher_glib.cpp:277
#71 0x000000399ce42b6d in g_main_dispatch (context=0x157f8e0) at gmain.c:2440
#72 g_main_context_dispatch (context=0x157f8e0) at gmain.c:3013
#73 0x000000399ce43348 in g_main_context_iterate (context=0x157f8e0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3091
#74 0x000000399ce435dc in g_main_context_iteration (context=0x157f8e0, may_block=1) at gmain.c:3154
#75 0x00000039a4784d1f in QEventDispatcherGlib::processEvents (this=0x15227e0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#76 0x00000039a7859f2e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#77 0x00000039a47596c2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#78 0x00000039a47598bf in QEventLoop::exec (this=0x7fff0f18efb0, flags=...) at kernel/qeventloop.cpp:201
#79 0x00000039a475da07 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#80 0x00000039b523ed74 in kdemain (argc=1, argv=0x7fff0f18f358) at /usr/src/debug/kdebase-workspace-4.6.1/plasma/desktop/shell/main.cpp:118
#81 0x000000399aa2143d in __libc_start_main (main=0x400890 <main(int, char**)>, argc=1, ubp_av=0x7fff0f18f358, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff0f18f348) at libc-start.c:226
#82 0x00000000004008c1 in _start ()


Reproducible: Sometimes

Steps to Reproduce:
quit


Actual Results:  
crash

Expected Results:  
just quit

amarok.x86_64                    2.4.0-4.fc15           @updates-testing         
amarok-debuginfo.x86_64          2.4.0-4.fc15           @updates-testing-debuginf
amarok-libs.x86_64               2.4.0-4.fc15           @updates-testing         
amarok-utils.x86_64              2.4.0-4.fc15           @updates-testing

kdebase.x86_64                      6:4.6.1-2.fc15    @updates-testing          
kdebase-libs.x86_64                 6:4.6.1-2.fc15    @updates-testing          
kdebase-runtime.x86_64              4.6.1-3.fc15      @updates-testing          
kdebase-runtime-debuginfo.x86_64    4.6.1-3.fc15      @updates-testing-debuginfo
kdebase-runtime-flags.noarch        4.6.1-3.fc15      @updates-testing          
kdebase-runtime-libs.x86_64         4.6.1-3.fc15      @updates-testing          
kdebase-workspace.x86_64            4.6.1-7.fc15      @updates-testing          
kdebase-workspace-debuginfo.x86_64  4.6.1-7.fc15      @updates-testing-debuginfo
kdebase-workspace-libs.x86_64       4.6.1-7.fc15      @updates-testing
Comment 1 Myriam Schweingruber 2011-04-14 11:24:39 UTC
The crash appears to be in Plasma, not in Amarok, reassigning.
Comment 2 Dario Andres 2011-04-14 13:14:18 UTC
[Comment from a bug triager]
This issue is being tracked at bug 258706, merging.
Thanks

*** This bug has been marked as a duplicate of bug 258706 ***