Bug 269944

Summary: Plasma crashed after quitting Amarok
Product: plasma4 Reporter: Ron Willhoite <ronwilhoite>
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: andresbajotierra
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Ron Willhoite 2011-04-02 15:34:44 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.1 (4.6.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-28-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed: Quit Amarok using its menu. Amarok closes, and a few seconds later Plasma crashed. Plasma restarted itself. The only other application running was Firefox 4.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77ad720 (LWP 1749))]

Thread 3 (Thread 0xaf865b70 (LWP 1750)):
#0  0x00524416 in __kernel_vsyscall ()
#1  0x001d1df6 in __poll (fds=0x268ff4, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x043afa1b in g_poll () from /lib/libglib-2.0.so.0
#3  0x043a243c in ?? () from /lib/libglib-2.0.so.0
#4  0x043a2848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x0687d59f in QEventDispatcherGlib::processEvents (this=0x8d96cd8, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#6  0x0684d609 in QEventLoop::processEvents (this=0xaf865280, flags=) at kernel/qeventloop.cpp:149
#7  0x0684da8a in QEventLoop::exec (this=0xaf865280, flags=...) at kernel/qeventloop.cpp:201
#8  0x06749b7e in QThread::exec (this=0x8d96688) at thread/qthread.cpp:490
#9  0x0682c35b in QInotifyFileSystemWatcherEngine::run (this=0x8d96688) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0674cdf9 in QThreadPrivate::start (arg=0x8d96688) at thread/qthread_unix.cpp:266
#11 0x0336dcc9 in start_thread (arg=0xaf865b70) at pthread_create.c:304
#12 0x001e069e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 2 (Thread 0xadc7fb70 (LWP 1813)):
#0  0x00524416 in __kernel_vsyscall ()
#1  0x033724dc in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:169
#2  0x001edd9d in __pthread_cond_wait (cond=0x4f1b290, mutex=0x4f1b278) at forward.c:139
#3  0x04e17877 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x4f161a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#4  0x04e178c1 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x4f161a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#5  0x0336dcc9 in start_thread (arg=0xadc7fb70) at pthread_create.c:304
#6  0x001e069e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb77ad720 (LWP 1749)):
[KCrash Handler]
#7  0x01155ba7 in QString (this=0x9d50048, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:727
#8  KIconEffect::fingerprint (this=0x9d50048, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:169
#9  0x01159ad8 in KIconLoaderPrivate::makeCacheKey (this=0x9d50034, name=..., group=KIconLoader::Desktop, overlays=..., size=22, state=0) at ../../kdeui/icons/kiconloader.cpp:782
#10 0x01161f08 in KIconLoader::loadIcon (this=0x97f5a98, _name=..., group=KIconLoader::Desktop, size=22, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1226
#11 0x011583f6 in KIconEngine::pixmap (this=0x928e040, size=..., mode=QIcon::Normal, state=QIcon::Off) at ../../kdeui/icons/kiconengine.cpp:93
#12 0x02a02626 in QIcon::pixmap (this=0x9ece2f4, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:676
#13 0x00b63222 in Plasma::IconWidgetPrivate::decoration (this=0x9ece250, option=0x855ed00, useHoverEffect=false, usePressedEffect=false) at ../../plasma/widgets/iconwidget.cpp:812
#14 0x00b65cb7 in Plasma::IconWidget::paint (this=0x861f928, painter=0xbfe63c6c, option=0x855ed00, widget=0x0) at ../../plasma/widgets/iconwidget.cpp:1128
#15 0x04b7019d in ?? () from /usr/lib/kde4/plasma_applet_systemtray.so
#16 0x0300752c in _q_paintItem (item=<value optimized out>, painter=0x855ed00, option=0x855ed00, widget=0x0, useWindowOpacity=false, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4318
#17 0x03009eaa in _q_paintIntoCache (pix=<value optimized out>, item=<value optimized out>, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x855ed00, painterStateProtection=<value optimized out>) at graphicsview/qgraphicsscene.cpp:4356
#18 0x03011718 in QGraphicsScenePrivate::drawItemHelper (this=0x855ebb0, item=0x861f930, painter=0xbfe65944, option=0x855ed00, widget=0x9396e20, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4654
#19 0x030157d8 in QGraphicsScenePrivate::draw (this=0x855ebb0, item=0x861f930, painter=0xbfe65944, viewTransform=0xbfe6572c, transformPtr=0xbfe645a0, exposedRegion=0x9855c70, widget=0x9396e20, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4895
#20 0x030164a3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x855ebb0, item=0x861f930, painter=0xbfe65944, viewTransform=0xbfe6572c, exposedRegion=0x9855c70, widget=0x9396e20, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4817
#21 0x03015874 in QGraphicsScenePrivate::draw (this=0x855ebb0, item=0x8aac8b8, painter=0xbfe65944, viewTransform=0xbfe6572c, transformPtr=0xbfe64a10, exposedRegion=0x9855c70, widget=0x9396e20, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4909
#22 0x030164a3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x855ebb0, item=0x8aac8b8, painter=0xbfe65944, viewTransform=0xbfe6572c, exposedRegion=0x9855c70, widget=0x9396e20, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4817
#23 0x03015874 in QGraphicsScenePrivate::draw (this=0x855ebb0, item=0x871de58, painter=0xbfe65944, viewTransform=0xbfe6572c, transformPtr=0xbfe64e80, exposedRegion=0x9855c70, widget=0x9396e20, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4909
#24 0x030164a3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x855ebb0, item=0x871de58, painter=0xbfe65944, viewTransform=0xbfe6572c, exposedRegion=0x9855c70, widget=0x9396e20, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4817
#25 0x03015874 in QGraphicsScenePrivate::draw (this=0x855ebb0, item=0x861fe18, painter=0xbfe65944, viewTransform=0xbfe6572c, transformPtr=0xbfe652f0, exposedRegion=0x9855c70, widget=0x9396e20, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4909
#26 0x030164a3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x855ebb0, item=0x861fe18, painter=0xbfe65944, viewTransform=0xbfe6572c, exposedRegion=0x9855c70, widget=0x9396e20, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4817
#27 0x03016cce in QGraphicsScenePrivate::drawItems (this=0x855ebb0, painter=0xbfe65944, viewTransform=0xbfe6572c, exposedRegion=0x9855c70, widget=0x9396e20) at graphicsview/qgraphicsscene.cpp:4699
#28 0x03042bb9 in QGraphicsView::paintEvent (this=0x9855880, event=0xbfe66064) at graphicsview/qgraphicsview.cpp:3467
#29 0x00913224 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#30 0x0299bcc6 in QWidget::event (this=0x9855880, event=0xbfe66064) at kernel/qwidget.cpp:8333
#31 0x02dbd763 in QFrame::event (this=0x9855880, e=0xbfe66064) at widgets/qframe.cpp:557
#32 0x02e5aa82 in QAbstractScrollArea::viewportEvent (this=0xbbbbbb80, e=0x0) at widgets/qabstractscrollarea.cpp:1043
#33 0x0303eccb in QGraphicsView::viewportEvent (this=0x9855880, event=0xbfe66064) at graphicsview/qgraphicsview.cpp:2862
#34 0x02e5d4d5 in viewportEvent (this=0x94707b0, o=0x9396e20, e=0xbfe66064) at widgets/qabstractscrollarea_p.h:100
#35 QAbstractScrollAreaFilter::eventFilter (this=0x94707b0, o=0x9396e20, e=0xbfe66064) at widgets/qabstractscrollarea_p.h:116
#36 0x0684e29a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x84cf1a8, receiver=0x9396e20, event=0xbfe66064) at kernel/qcoreapplication.cpp:847
#37 0x0293dfb9 in QApplicationPrivate::notify_helper (this=0x84cf1a8, receiver=0x9396e20, e=0xbfe66064) at kernel/qapplication.cpp:4392
#38 0x029440e9 in QApplication::notify (this=0x84acfb8, receiver=0x9396e20, e=0xbfe66064) at kernel/qapplication.cpp:4361
#39 0x011bd7da in KApplication::notify (this=0x84acfb8, receiver=0x9396e20, event=0xbfe66064) at ../../kdeui/kernel/kapplication.cpp:311
#40 0x0684eb3b in QCoreApplication::notifyInternal (this=0x84acfb8, receiver=0x9396e20, event=0xbfe66064) at kernel/qcoreapplication.cpp:732
#41 0x029a2ee6 in sendSpontaneousEvent (this=0x9867fb0, pdev=0x97d289c, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x9868338) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#42 QWidgetPrivate::drawWidget (this=0x9867fb0, pdev=0x97d289c, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x9868338) at kernel/qwidget.cpp:5420
#43 0x029a3cff in QWidgetPrivate::paintSiblingsRecursive (this=0x9855920, pdev=0x97d289c, siblings=..., index=3, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x9868338) at kernel/qwidget.cpp:5627
#44 0x029a3b38 in QWidgetPrivate::paintSiblingsRecursive (this=0x9855920, pdev=0x97d289c, siblings=..., index=4, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x9868338) at kernel/qwidget.cpp:5614
#45 0x029a3b38 in QWidgetPrivate::paintSiblingsRecursive (this=0x9855920, pdev=0x97d289c, siblings=..., index=5, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x9868338) at kernel/qwidget.cpp:5614
#46 0x029a2c35 in QWidgetPrivate::drawWidget (this=0x9855920, pdev=0x97d289c, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x9868338) at kernel/qwidget.cpp:5473
#47 0x02b93c74 in QWidgetBackingStore::sync (this=0x9868338) at painting/qbackingstore.cpp:1328
#48 0x029952b3 in QWidgetPrivate::syncBackingStore (this=0x9855920) at kernel/qwidget.cpp:1805
#49 0x0299c466 in QWidget::event (this=0x9855880, event=0x9d7d9d0) at kernel/qwidget.cpp:8480
#50 0x02dbd763 in QFrame::event (this=0x9855880, e=0x9d7d9d0) at widgets/qframe.cpp:557
#51 0x02e5b487 in QAbstractScrollArea::event (this=0x9855880, e=0x9d7d9d0) at widgets/qabstractscrollarea.cpp:996
#52 0x03040ea6 in QGraphicsView::event (this=0x9855880, event=0x9d7d9d0) at graphicsview/qgraphicsview.cpp:2739
#53 0x00913d13 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#54 0x0293dfdc in QApplicationPrivate::notify_helper (this=0x84cf1a8, receiver=0x9d7d9d0, e=0x9855880) at kernel/qapplication.cpp:4396
#55 0x029440e9 in QApplication::notify (this=0x84acfb8, receiver=0x9855880, e=0x9d7d9d0) at kernel/qapplication.cpp:4361
#56 0x011bd7da in KApplication::notify (this=0x84acfb8, receiver=0x9855880, event=0x9d7d9d0) at ../../kdeui/kernel/kapplication.cpp:311
#57 0x0684eb3b in QCoreApplication::notifyInternal (this=0x84acfb8, receiver=0x9855880, event=0x9d7d9d0) at kernel/qcoreapplication.cpp:732
#58 0x06851d8b in sendEvent (receiver=0x9855880, event_type=77, data=0x84790f0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#59 QCoreApplicationPrivate::sendPostedEvents (receiver=0x9855880, event_type=77, data=0x84790f0) at kernel/qcoreapplication.cpp:1373
#60 0x06851f4d in QCoreApplication::sendPostedEvents (receiver=0x9855880, event_type=77) at kernel/qcoreapplication.cpp:1266
#61 0x03026c3e in dispatchPendingUpdateRequests (this=0x855ebb0) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:189
#62 QGraphicsScenePrivate::_q_processDirtyItems (this=0x855ebb0) at graphicsview/qgraphicsscene.cpp:510
#63 0x03027116 in QGraphicsScene::qt_metacall (this=0x852ab20, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x9bb7ec8) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#64 0x00a8fa4a in Plasma::Corona::qt_metacall (this=0x852ab20, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x9bb7ec8) at ./corona.moc:109
#65 0x00901f7a in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#66 0x068548ca in QMetaObject::metacall (object=0x852ab20, cl=3149642624, idx=0, argv=0x852ab20) at kernel/qmetaobject.cpp:237
#67 0x0685fdf6 in QMetaCallEvent::placeMetaCall (this=0x8a98798, object=0x852ab20) at kernel/qobject.cpp:534
#68 0x068616a2 in QObject::event (this=0x852ab20, e=0x0) at kernel/qobject.cpp:1219
#69 0x03023374 in QGraphicsScene::event (this=0x852ab20, event=0x8a98798) at graphicsview/qgraphicsscene.cpp:3548
#70 0x0293dfdc in QApplicationPrivate::notify_helper (this=0x84cf1a8, receiver=0x852ab20, e=0x8a98798) at kernel/qapplication.cpp:4396
#71 0x0294404e in QApplication::notify (this=0x84acfb8, receiver=0x852ab20, e=0x8a98798) at kernel/qapplication.cpp:3798
#72 0x011bd7da in KApplication::notify (this=0x84acfb8, receiver=0x852ab20, event=0x8a98798) at ../../kdeui/kernel/kapplication.cpp:311
#73 0x0684eb3b in QCoreApplication::notifyInternal (this=0x84acfb8, receiver=0x852ab20, event=0x8a98798) at kernel/qcoreapplication.cpp:732
#74 0x06851d8b in sendEvent (receiver=0x0, event_type=0, data=0x84790f0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#75 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x84790f0) at kernel/qcoreapplication.cpp:1373
#76 0x06851f4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#77 0x0687da74 in sendPostedEvents (s=0x84ceb88) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#78 postEventSourceDispatch (s=0x84ceb88) at kernel/qeventdispatcher_glib.cpp:277
#79 0x0439e855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#80 0x043a2668 in ?? () from /lib/libglib-2.0.so.0
#81 0x043a2848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#82 0x0687d565 in QEventDispatcherGlib::processEvents (this=0x8478ba0, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#83 0x029ffbe5 in QGuiEventDispatcherGlib::processEvents (this=0x8478ba0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#84 0x0684d609 in QEventLoop::processEvents (this=0xbfe67b84, flags=) at kernel/qeventloop.cpp:149
#85 0x0684da8a in QEventLoop::exec (this=0xbfe67b84, flags=...) at kernel/qeventloop.cpp:201
#86 0x0685200f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#87 0x0293ce07 in QApplication::exec () at kernel/qapplication.cpp:3672
#88 0x0090af97 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#89 0x080485bb in _start ()

This bug may be a duplicate of or related to bug 269598.

Possible duplicates by query: bug 269869, bug 269672, bug 269615, bug 269598, bug 269580.

Reported using DrKonqi
Comment 1 Dario Andres 2011-04-03 14:05:19 UTC
[Comment from a bug triager]
This issue is being tracked at bug 258706, merging.
Thanks

*** This bug has been marked as a duplicate of bug 258706 ***