Bug 268321

Summary: KWin crashes (SegFault) on return from suspend
Product: [Plasma] kwin Reporter: immerohnegott
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description immerohnegott 2011-03-12 22:15:19 UTC
Application: kwin (4.6.1 (4.6.1))
KDE Platform Version: 4.6.1 (4.6.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-27-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed: System was suspended, crashed upon re-entry fron screensaver. Error messages in backtrace spat out something about the Intel DRI stack. Possibly just an X bug? Desktop effects were enabled at the time, haven't attempted to suspend/resume without the bling.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7834720 (LWP 1730))]

Thread 3 (Thread 0xb2bc8b70 (LWP 1808)):
#0  0x01d41e36 in clock_gettime () from /lib/librt.so.1
#1  0x01e1250b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0x01ee96e5 in QTimerInfoList::updateCurrentTime (this=0x86e4d08) at kernel/qeventdispatcher_unix.cpp:339
#4  0x01ee9d55 in QEventDispatcherUNIXPrivate::doSelect (this=0x86e4668, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:182
#5  0x01eeac25 in QEventDispatcherUNIX::processEvents (this=0x85b7d30, flags=...) at kernel/qeventdispatcher_unix.cpp:919
#6  0x01eb7609 in QEventLoop::processEvents (this=0xb2bc8280, flags=) at kernel/qeventloop.cpp:149
#7  0x01eb7a8a in QEventLoop::exec (this=0xb2bc8280, flags=...) at kernel/qeventloop.cpp:201
#8  0x01db3b7e in QThread::exec (this=0x86602d0) at thread/qthread.cpp:490
#9  0x01e9635b in QInotifyFileSystemWatcherEngine::run (this=0x86602d0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x01db6df9 in QThreadPrivate::start (arg=0x86602d0) at thread/qthread_unix.cpp:266
#11 0x0470ecc9 in start_thread () from /lib/libpthread.so.0
#12 0x00eb169e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xb23c7b70 (LWP 1809)):
#0  0x00a9f416 in __kernel_vsyscall ()
#1  0x047134dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x00ebed9d in pthread_cond_wait () from /lib/libc.so.6
#3  0x00c26877 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0xd251a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#4  0x00c268c1 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0xd251a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#5  0x0470ecc9 in start_thread () from /lib/libpthread.so.0
#6  0x00eb169e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb7834720 (LWP 1730)):
[KCrash Handler]
#7  0x06034ac0 in ?? () from /usr/lib/dri/i965_dri.so
#8  0x06026016 in ?? () from /usr/lib/dri/i965_dri.so
#9  0x0602936e in ?? () from /usr/lib/dri/i965_dri.so
#10 0x0621111a in ?? () from /usr/lib/dri/i965_dri.so
#11 0x001e8a9b in KWin::SceneOpenGL::paintBackground (this=0x818dfe8, region=...) at ../../kwin/scene_opengl.cpp:921
#12 0x001db672 in KWin::Scene::paintGenericScreen (this=0x818dfe8, orig_mask=<value optimized out>) at ../../kwin/scene.cpp:188
#13 0x001e8ca5 in KWin::SceneOpenGL::paintGenericScreen (this=0x818dfe8, mask=<value optimized out>, data=...) at ../../kwin/scene_opengl.cpp:909
#14 0x001d86c0 in KWin::Scene::finalPaintScreen (this=0x818dfe8, mask=520, region=..., data=...) at ../../kwin/scene.cpp:178
#15 0x001fc3dc in KWin::EffectsHandlerImpl::paintScreen (this=0x85aed98, mask=520, region=..., data=...) at ../../kwin/effects.cpp:173
#16 0x05fd6db9 in KWin::StartupFeedbackEffect::paintScreen (this=0x8634388, mask=520, region=..., data=...) at ../../../kwin/effects/startupfeedback/startupfeedback.cpp:166
#17 0x001fc460 in KWin::EffectsHandlerImpl::paintScreen (this=0x85aed98, mask=520, region=..., data=...) at ../../kwin/effects.cpp:169
#18 0x006dd846 in KWin::Effect::paintScreen (this=0x85f4688, mask=520, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#19 0x001fc460 in KWin::EffectsHandlerImpl::paintScreen (this=0x85aed98, mask=520, region=..., data=...) at ../../kwin/effects.cpp:169
#20 0x05f8eb0f in KWin::ShadowEffect::paintScreen (this=0x85d4850, mask=<value optimized out>, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:189
#21 0x001fc460 in KWin::EffectsHandlerImpl::paintScreen (this=0x85aed98, mask=520, region=..., data=...) at ../../kwin/effects.cpp:169
#22 0x05f717af in KWin::PresentWindowsEffect::paintScreen (this=0x85d6c10, mask=520, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:205
#23 0x001fc460 in KWin::EffectsHandlerImpl::paintScreen (this=0x85aed98, mask=520, region=..., data=...) at ../../kwin/effects.cpp:169
#24 0x006dd846 in KWin::Effect::paintScreen (this=0x85ec0e8, mask=520, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#25 0x001fc460 in KWin::EffectsHandlerImpl::paintScreen (this=0x85aed98, mask=520, region=..., data=...) at ../../kwin/effects.cpp:169
#26 0x006dd846 in KWin::Effect::paintScreen (this=0x86dae70, mask=520, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#27 0x001fc460 in KWin::EffectsHandlerImpl::paintScreen (this=0x85aed98, mask=520, region=..., data=...) at ../../kwin/effects.cpp:169
#28 0x006dd846 in KWin::Effect::paintScreen (this=0x86d5bb0, mask=520, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#29 0x001fc460 in KWin::EffectsHandlerImpl::paintScreen (this=0x85aed98, mask=520, region=..., data=...) at ../../kwin/effects.cpp:169
#30 0x006dd846 in KWin::Effect::paintScreen (this=0x85ed758, mask=520, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#31 0x001fc460 in KWin::EffectsHandlerImpl::paintScreen (this=0x85aed98, mask=520, region=..., data=...) at ../../kwin/effects.cpp:169
#32 0x05f53c32 in KWin::DesktopGridEffect::paintScreen (this=0x85d9d40, mask=520, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:155
#33 0x001fc460 in KWin::EffectsHandlerImpl::paintScreen (this=0x85aed98, mask=520, region=..., data=...) at ../../kwin/effects.cpp:169
#34 0x05f4aaaf in KWin::BoxSwitchEffect::paintScreen (this=0x86cc290, mask=520, region=..., data=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:143
#35 0x001fc460 in KWin::EffectsHandlerImpl::paintScreen (this=0x85aed98, mask=520, region=..., data=...) at ../../kwin/effects.cpp:169
#36 0x05fb5374 in KWin::CubeEffect::paintScreen (this=0x86dab78, mask=520, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:698
#37 0x001fc460 in KWin::EffectsHandlerImpl::paintScreen (this=0x85aed98, mask=520, region=..., data=...) at ../../kwin/effects.cpp:169
#38 0x006dd846 in KWin::Effect::paintScreen (this=0x86cc5f8, mask=520, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#39 0x001fc460 in KWin::EffectsHandlerImpl::paintScreen (this=0x85aed98, mask=520, region=..., data=...) at ../../kwin/effects.cpp:169
#40 0x05fbccd3 in KWin::CubeSlideEffect::paintScreen (this=0x8629480, mask=520, region=..., data=...) at ../../../kwin/effects/cube/cubeslide.cpp:111
#41 0x001fc460 in KWin::EffectsHandlerImpl::paintScreen (this=0x85aed98, mask=520, region=..., data=...) at ../../kwin/effects.cpp:169
#42 0x006dd846 in KWin::Effect::paintScreen (this=0x86d6038, mask=520, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#43 0x001fc460 in KWin::EffectsHandlerImpl::paintScreen (this=0x85aed98, mask=520, region=..., data=...) at ../../kwin/effects.cpp:169
#44 0x006dd846 in KWin::Effect::paintScreen (this=0x8622e68, mask=520, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#45 0x001fc460 in KWin::EffectsHandlerImpl::paintScreen (this=0x85aed98, mask=520, region=..., data=...) at ../../kwin/effects.cpp:169
#46 0x05fab90c in KWin::CoverSwitchEffect::paintScreen (this=0x86d72c8, mask=520, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:126
#47 0x001fc460 in KWin::EffectsHandlerImpl::paintScreen (this=0x85aed98, mask=520, region=..., data=...) at ../../kwin/effects.cpp:169
#48 0x006dd846 in KWin::Effect::paintScreen (this=0x85f4730, mask=520, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#49 0x001fc460 in KWin::EffectsHandlerImpl::paintScreen (this=0x85aed98, mask=520, region=..., data=...) at ../../kwin/effects.cpp:169
#50 0x006dd846 in KWin::Effect::paintScreen (this=0x86cc988, mask=520, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#51 0x001fc460 in KWin::EffectsHandlerImpl::paintScreen (this=0x85aed98, mask=520, region=..., data=...) at ../../kwin/effects.cpp:169
#52 0x05fa0d99 in KWin::ZoomEffect::paintScreen (this=0x8640bb0, mask=520, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:341
#53 0x001fc460 in KWin::EffectsHandlerImpl::paintScreen (this=0x85aed98, mask=520, region=..., data=...) at ../../kwin/effects.cpp:169
#54 0x001d9ea4 in KWin::Scene::paintScreen (this=0x818dfe8, mask=0xbfcdc444, region=0xbfcdc4f0) at ../../kwin/scene.cpp:137
#55 0x001f084a in KWin::SceneOpenGL::paint (this=0x818dfe8, damage=..., toplevels=...) at ../../kwin/scene_opengl.cpp:772
#56 0x001d4bf7 in KWin::Workspace::performCompositing (this=0x84c1b48) at ../../kwin/composite.cpp:448
#57 0x01ecb504 in QObject::event (this=0x84c1b48, e=0x8295900) at kernel/qobject.cpp:1183
#58 0x01185fdc in QApplicationPrivate::notify_helper (this=0x80ddaf0, receiver=0x84c1b48, e=0xbfcdca30) at kernel/qapplication.cpp:4396
#59 0x0118c04e in QApplication::notify (this=0xbfcdcd54, receiver=0x84c1b48, e=0xbfcdca30) at kernel/qapplication.cpp:3798
#60 0x0043f7da in KApplication::notify (this=0xbfcdcd54, receiver=0x84c1b48, event=0xbfcdca30) at ../../kdeui/kernel/kapplication.cpp:311
#61 0x0015dd0f in KWin::Application::notify (this=0xbfcdcd54, o=0x84c1b48, e=0xbfcdca30) at ../../kwin/main.cpp:376
#62 0x01eb8b3b in QCoreApplication::notifyInternal (this=0xbfcdcd54, receiver=0x84c1b48, event=0xbfcdca30) at kernel/qcoreapplication.cpp:732
#63 0x01eeaad6 in sendEvent (this=0x80de278) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#64 QTimerInfoList::activateTimers (this=0x80de278) at kernel/qeventdispatcher_unix.cpp:602
#65 0x01eeac37 in QEventDispatcherUNIX::processEvents (this=0x80bfba0, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#66 0x012490d2 in QEventDispatcherX11::processEvents (this=0x80bfba0, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#67 0x01eb7609 in QEventLoop::processEvents (this=0xbfcdcc84, flags=) at kernel/qeventloop.cpp:149
#68 0x01eb7a8a in QEventLoop::exec (this=0xbfcdcc84, flags=...) at kernel/qeventloop.cpp:201
#69 0x01ebc00f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#70 0x01184e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#71 0x00160d00 in kdemain (argc=1, argv=0xbfcdcfd4) at ../../kwin/main.cpp:542
#72 0x080485ab in main (argc=1, argv=0xbfcdcfd4) at kwin_dummy.cpp:3

Possible duplicates by query: bug 268027, bug 267291, bug 267059, bug 266303, bug 263386.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2011-03-12 22:18:44 UTC
driver/mesa bug - to workaround, suspend/resume compositing around the STR

*** This bug has been marked as a duplicate of bug 252817 ***