Bug 267934

Summary: Konqueror always crashes when I close it
Product: plasma4 Reporter: Gatoso <gatoso>
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: aseigo
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Compiled Sources   
OS: Linux   
Latest Commit: Version Fixed In:

Description Gatoso 2011-03-08 02:27:18 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.1 (4.6.1) (Compiled from sources)
Qt Version: 4.7.2
Operating System: Linux 2.6.37-pae i686
Distribution (Platform): Archlinux Packages

-- Information about the crash:
- What I was doing when the application crashed:

When I clase Konqueror always it crashes	

- Unusual behavior I noticed:

This time, also, when konqueror crashed, the KMail window became small and the panel bar disappeared by some seconds

The crash can be reproduced every time.

-- Backtrace:
Application: Shell de escritorio Plasma (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb5859b20 (LWP 1607))]

Thread 2 (Thread 0xae167b70 (LWP 1611)):
#0  0xb5ca9ca2 in clock_gettime () from /lib/librt.so.1
#1  0xb6f05769 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb6fe2e23 in updateCurrentTime (this=0xad801174, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0xad801174, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb6fe1352 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xae1670bc) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb6fe13ed in timerSourcePrepare (source=0xad801140, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb5c1498d in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#8  0xb5c1583b in g_main_context_iterate.clone.5 () from /usr/lib/libglib-2.0.so.0
#9  0xb5c15f45 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#10 0xb6fe1bdf in QEventDispatcherGlib::processEvents (this=0x93cf230, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb6faf11a in QEventLoop::processEvents (this=0xae167280, flags=...) at kernel/qeventloop.cpp:149
#12 0xb6faf3ba in QEventLoop::exec (this=0xae167280, flags=...) at kernel/qeventloop.cpp:201
#13 0xb6ea405f in QThread::exec (this=0x9347980) at thread/qthread.cpp:492
#14 0xb6f8e672 in QInotifyFileSystemWatcherEngine::run (this=0x9347980) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb6ea70ab in QThreadPrivate::start (arg=0x9347980) at thread/qthread_unix.cpp:320
#16 0xb6e2ee31 in start_thread () from /lib/libpthread.so.0
#17 0xb616d07e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb5859b20 (LWP 1607)):
[KCrash Handler]
#7  QString::QString (this=0xbfcc660c, other=...) at /usr/include/QtCore/qstring.h:728
#8  0xb75faacf in KIconEffect::fingerprint (this=0x9cc0061, group=0, state=0) at /home/zuargo/Paquetes/kdelibs/src/kdelibs-4.6.1/kdeui/icons/kiconeffect.cpp:169
#9  0xb7605879 in KIconLoaderPrivate::makeCacheKey (this=0x9cc004d, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at /home/zuargo/Paquetes/kdelibs/src/kdelibs-4.6.1/kdeui/icons/kiconloader.cpp:782
#10 0xb7605bfc in KIconLoader::loadIcon (this=0x9b28c50, _name=..., group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at /home/zuargo/Paquetes/kdelibs/src/kdelibs-4.6.1/kdeui/icons/kiconloader.cpp:1226
#11 0xb75fed4b in KIconEngine::pixmap (this=0x9823c80, size=..., mode=QIcon::Normal, state=QIcon::Off) at /home/zuargo/Paquetes/kdelibs/src/kdelibs-4.6.1/kdeui/icons/kiconengine.cpp:93
#12 0xb64ccbf3 in QIcon::pixmap (this=0x9bef07c, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:676
#13 0xb4c0a5fc in Plasma::IconWidgetPrivate::decoration (this=0x9beefd8, option=0x914ca68, useHoverEffect=false, usePressedEffect=false) at /home/zuargo/Paquetes/kdelibs/src/kdelibs-4.6.1/plasma/widgets/iconwidget.cpp:812
#14 0xb4c0eb4e in Plasma::IconWidget::paint (this=0x9aee950, painter=0xbfcc6f2c, option=0x914ca68, widget=0x0) at /home/zuargo/Paquetes/kdelibs/src/kdelibs-4.6.1/plasma/widgets/iconwidget.cpp:1128
#15 0xae28c31d in ?? () from /usr/lib/kde4/plasma_applet_systemtray.so
#16 0xb6b0939c in _q_paintItem (item=<value optimized out>, painter=0x914ca68, option=0x914ca68, widget=0x0, useWindowOpacity=false, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4314
#17 0xb6b0973b in _q_paintIntoCache (pix=0xbfcc740c, item=0x9aee958, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x914ca68, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4352
#18 0xb6b20ac4 in QGraphicsScenePrivate::drawItemHelper (this=0x914c918, item=0x9aee958, painter=0xbfcc8c04, option=0x914ca68, widget=0x9211298, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4690
#19 0xb6b218b0 in QGraphicsScenePrivate::draw (this=0x914c918, item=0x9aee958, painter=0xbfcc8c04, viewTransform=0xbfcc89ec, transformPtr=0xbfcc77f0, exposedRegion=0x93a6f78, widget=0x9211298, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4962
#20 0xb6b22926 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x914c918, item=0x9aee958, painter=0xbfcc8c04, viewTransform=0xbfcc89ec, exposedRegion=0x93a6f78, widget=0x9211298, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#21 0xb6b21676 in QGraphicsScenePrivate::draw (this=0x914c918, item=0x92e5968, painter=0xbfcc8c04, viewTransform=0xbfcc89ec, transformPtr=0xbfcc7c90, exposedRegion=0x93a6f78, widget=0x9211298, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#22 0xb6b22926 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x914c918, item=0x92e5968, painter=0xbfcc8c04, viewTransform=0xbfcc89ec, exposedRegion=0x93a6f78, widget=0x9211298, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#23 0xb6b21676 in QGraphicsScenePrivate::draw (this=0x914c918, item=0x92ed828, painter=0xbfcc8c04, viewTransform=0xbfcc89ec, transformPtr=0xbfcc8130, exposedRegion=0x93a6f78, widget=0x9211298, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#24 0xb6b22926 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x914c918, item=0x92ed828, painter=0xbfcc8c04, viewTransform=0xbfcc89ec, exposedRegion=0x93a6f78, widget=0x9211298, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#25 0xb6b21676 in QGraphicsScenePrivate::draw (this=0x914c918, item=0x921f850, painter=0xbfcc8c04, viewTransform=0xbfcc89ec, transformPtr=0xbfcc85d0, exposedRegion=0x93a6f78, widget=0x9211298, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#26 0xb6b22926 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x914c918, item=0x921f850, painter=0xbfcc8c04, viewTransform=0xbfcc89ec, exposedRegion=0x93a6f78, widget=0x9211298, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#27 0xb6b235fe in QGraphicsScenePrivate::drawItems (this=0x914c918, painter=0xbfcc8c04, viewTransform=0xbfcc89ec, exposedRegion=0x93a6f78, widget=0x9211298) at graphicsview/qgraphicsscene.cpp:4735
#28 0xb6b45ad9 in QGraphicsView::paintEvent (this=0x9526478, event=0xbfcc9324) at graphicsview/qgraphicsview.cpp:3469
#29 0xb0dc1474 in ?? () from /usr/lib/libkdeinit4_plasma-desktop.so
#30 0xb646bec1 in QWidget::event (this=0x9526478, event=0xbfcc9324) at kernel/qwidget.cpp:8405
#31 0xb68baed4 in QFrame::event (this=0x9526478, e=0xbfcc9324) at widgets/qframe.cpp:557
#32 0xb6955ac3 in QAbstractScrollArea::viewportEvent (this=0x9526478, e=0xbfcc9324) at widgets/qabstractscrollarea.cpp:1043
#33 0xb6b47037 in QGraphicsView::viewportEvent (this=0x9526478, event=0xbfcc9324) at graphicsview/qgraphicsview.cpp:2864
#34 0xb69585f5 in viewportEvent (this=0x935d4d0, o=0x9211298, e=0xbfcc9324) at widgets/qabstractscrollarea_p.h:100
#35 QAbstractScrollAreaFilter::eventFilter (this=0x935d4d0, o=0x9211298, e=0xbfcc9324) at widgets/qabstractscrollarea_p.h:116
#36 0xb6fb0960 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x90e12c0, receiver=0x9211298, event=0xbfcc9324) at kernel/qcoreapplication.cpp:846
#37 0xb64090da in QApplicationPrivate::notify_helper (this=0x90e12c0, receiver=0x9211298, e=0xbfcc9324) at kernel/qapplication.cpp:4458
#38 0xb640e7ae in QApplication::notify (this=0x90da6c8, receiver=0x9211298, e=0xbfcc9324) at kernel/qapplication.cpp:4427
#39 0xb765f8d2 in KApplication::notify (this=0x90da6c8, receiver=0x9211298, event=0xbfcc9324) at /home/zuargo/Paquetes/kdelibs/src/kdelibs-4.6.1/kdeui/kernel/kapplication.cpp:311
#40 0xb6fb07c2 in QCoreApplication::notifyInternal (this=0x90da6c8, receiver=0x9211298, event=0xbfcc9324) at kernel/qcoreapplication.cpp:731
#41 0xb6468949 in sendSpontaneousEvent (this=0x96b03f0, pdev=0x96ce9cc, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x93e34e8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#42 QWidgetPrivate::drawWidget (this=0x96b03f0, pdev=0x96ce9cc, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x93e34e8) at kernel/qwidget.cpp:5492
#43 0xb6469702 in QWidgetPrivate::paintSiblingsRecursive (this=0x93a6c28, pdev=0x96ce9cc, siblings=..., index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x93e34e8) at kernel/qwidget.cpp:5699
#44 0xb64685f9 in QWidgetPrivate::drawWidget (this=0x93a6c28, pdev=0x96ce9cc, rgn=..., offset=..., flags=5, sharedPainter=0x0, backingStore=0x93e34e8) at kernel/qwidget.cpp:5545
#45 0xb666ffc1 in QWidgetBackingStore::sync (this=0x93e34e8) at painting/qbackingstore.cpp:1333
#46 0xb645c2bb in QWidgetPrivate::syncBackingStore (this=0x93a6c28) at kernel/qwidget.cpp:1842
#47 0xb646c753 in QWidget::event (this=0x9526478, event=0x9b28c50) at kernel/qwidget.cpp:8552
#48 0xb68baed4 in QFrame::event (this=0x9526478, e=0x9b28c50) at widgets/qframe.cpp:557
#49 0xb69579ff in QAbstractScrollArea::event (this=0x9526478, e=0x9b28c50) at widgets/qabstractscrollarea.cpp:996
#50 0xb6b39ad7 in QGraphicsView::event (this=0x9526478, event=0x9b28c50) at graphicsview/qgraphicsview.cpp:2741
#51 0xb0dc1753 in ?? () from /usr/lib/libkdeinit4_plasma-desktop.so
#52 0xb64090f1 in QApplicationPrivate::notify_helper (this=0x90e12c0, receiver=0x9526478, e=0x9b28c50) at kernel/qapplication.cpp:4462
#53 0xb640e7ae in QApplication::notify (this=0x90da6c8, receiver=0x9526478, e=0x9b28c50) at kernel/qapplication.cpp:4427
#54 0xb765f8d2 in KApplication::notify (this=0x90da6c8, receiver=0x9526478, event=0x9b28c50) at /home/zuargo/Paquetes/kdelibs/src/kdelibs-4.6.1/kdeui/kernel/kapplication.cpp:311
#55 0xb6fb07c2 in QCoreApplication::notifyInternal (this=0x90da6c8, receiver=0x9526478, event=0x9b28c50) at kernel/qcoreapplication.cpp:731
#56 0xb6fb4d05 in sendEvent (receiver=0x9526478, event_type=77, data=0x903cf20) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#57 QCoreApplicationPrivate::sendPostedEvents (receiver=0x9526478, event_type=77, data=0x903cf20) at kernel/qcoreapplication.cpp:1372
#58 0xb6fb4f3e in QCoreApplication::sendPostedEvents (receiver=0x9526478, event_type=77) at kernel/qcoreapplication.cpp:1265
#59 0xb6b17d5e in dispatchPendingUpdateRequests (this=0x914c918) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:189
#60 QGraphicsScenePrivate::_q_processDirtyItems (this=0x914c918) at graphicsview/qgraphicsscene.cpp:510
#61 0xb6b181fe in QGraphicsScene::qt_metacall (this=0x9151bc0, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x9a07e90) at .moc/debug-shared/moc_qgraphicsscene.cpp:130
#62 0xb4b49aab in Plasma::Corona::qt_metacall (this=0x9151bc0, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x9a07e90) at /home/zuargo/Paquetes/kdelibs/src/build/plasma/corona.moc:109
#63 0xb0db426a in ?? () from /usr/lib/libkdeinit4_plasma-desktop.so
#64 0xb6fb791d in QMetaObject::metacall (object=0x9151bc0, cl=QMetaObject::InvokeMetaMethod, idx=18, argv=0x9a07e90) at kernel/qmetaobject.cpp:237
#65 0xb6fc2d67 in QMetaCallEvent::placeMetaCall (this=0x9bf7630, object=0x9151bc0) at kernel/qobject.cpp:535
#66 0xb6fc8487 in QObject::event (this=0x9151bc0, e=0x9bf7630) at kernel/qobject.cpp:1217
#67 0xb6b2706c in QGraphicsScene::event (this=0x9151bc0, event=0x9bf7630) at graphicsview/qgraphicsscene.cpp:3544
#68 0xb64090f1 in QApplicationPrivate::notify_helper (this=0x90e12c0, receiver=0x9151bc0, e=0x9bf7630) at kernel/qapplication.cpp:4462
#69 0xb640e7ae in QApplication::notify (this=0x90da6c8, receiver=0x9151bc0, e=0x9bf7630) at kernel/qapplication.cpp:4427
#70 0xb765f8d2 in KApplication::notify (this=0x90da6c8, receiver=0x9151bc0, event=0x9bf7630) at /home/zuargo/Paquetes/kdelibs/src/kdelibs-4.6.1/kdeui/kernel/kapplication.cpp:311
#71 0xb6fb07c2 in QCoreApplication::notifyInternal (this=0x90da6c8, receiver=0x9151bc0, event=0x9bf7630) at kernel/qcoreapplication.cpp:731
#72 0xb6fb4d05 in sendEvent (receiver=0x0, event_type=0, data=0x903cf20) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#73 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x903cf20) at kernel/qcoreapplication.cpp:1372
#74 0xb6fb4f3e in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1265
#75 0xb6fe1a25 in sendPostedEvents (s=0x90e3310) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#76 postEventSourceDispatch (s=0x90e3310) at kernel/qeventdispatcher_glib.cpp:277
#77 0xb5c15471 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#78 0xb5c15c78 in g_main_context_iterate.clone.5 () from /usr/lib/libglib-2.0.so.0
#79 0xb5c15f45 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#80 0xb6fe1b9d in QEventDispatcherGlib::processEvents (this=0x90e1188, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#81 0xb64ca3f6 in QGuiEventDispatcherGlib::processEvents (this=0x90e1188, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#82 0xb6faf11a in QEventLoop::processEvents (this=0xbfccaba4, flags=...) at kernel/qeventloop.cpp:149
#83 0xb6faf3ba in QEventLoop::exec (this=0xbfccaba4, flags=...) at kernel/qeventloop.cpp:201
#84 0xb6fb5001 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#85 0xb6406f68 in QApplication::exec () at kernel/qapplication.cpp:3736
#86 0xb0dbb83c in kdemain () from /usr/lib/libkdeinit4_plasma-desktop.so
#87 0x0804e94f in launch (argc=1, _name=0x903d17c "/usr/bin/plasma-desktop", args=<value optimized out>, cwd=0x0, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x80527b9 "0") at /home/zuargo/Paquetes/kdelibs/src/kdelibs-4.6.1/kinit/kinit.cpp:734
#88 0x0804f785 in handle_launcher_request (sock=<value optimized out>, who=0xc <Address 0xc out of bounds>) at /home/zuargo/Paquetes/kdelibs/src/kdelibs-4.6.1/kinit/kinit.cpp:1226
#89 0x0804fbea in handle_requests (waitForPid=0) at /home/zuargo/Paquetes/kdelibs/src/kdelibs-4.6.1/kinit/kinit.cpp:1419
#90 0x0805008b in main (argc=1381654, argv=0x7400, envp=0x0) at /home/zuargo/Paquetes/kdelibs/src/kdelibs-4.6.1/kinit/kinit.cpp:1907

Reported using DrKonqi
Comment 1 Aaron J. Seigo 2011-03-08 14:44:22 UTC

*** This bug has been marked as a duplicate of bug 258706 ***