Bug 267291

Summary: Kwin crashed after return from youtube full screen mode
Product: [Plasma] kwin Reporter: Naor <naorsh>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description Naor 2011-02-28 09:44:25 UTC
Application: kwin (4.6.00 (4.6.0))
KDE Platform Version: 4.6.00 (4.6.0)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-27-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
Played a youtube clip in full screen, pressed ESC to return from full mode and KWin crashed (the internet browser was the latest Chromium for 10.10)

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7721720 (LWP 6534))]

Thread 3 (Thread 0xb1ab8b70 (LWP 6540)):
#0  0x06044e36 in clock_gettime () from /lib/librt.so.1
#1  0x046e950b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0x047c06e5 in QTimerInfoList::updateCurrentTime (this=0x8be1218) at kernel/qeventdispatcher_unix.cpp:339
#4  0x047c0d55 in QEventDispatcherUNIXPrivate::doSelect (this=0x8be0b78, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:182
#5  0x047c1c25 in QEventDispatcherUNIX::processEvents (this=0x8d41b78, flags=...) at kernel/qeventdispatcher_unix.cpp:919
#6  0x0478e609 in QEventLoop::processEvents (this=0xb1ab8280, flags=) at kernel/qeventloop.cpp:149
#7  0x0478ea8a in QEventLoop::exec (this=0xb1ab8280, flags=...) at kernel/qeventloop.cpp:201
#8  0x0468ab7e in QThread::exec (this=0x8bee9c0) at thread/qthread.cpp:490
#9  0x0476d35b in QInotifyFileSystemWatcherEngine::run (this=0x8bee9c0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0468ddf9 in QThreadPrivate::start (arg=0x8bee9c0) at thread/qthread_unix.cpp:266
#11 0x0664dcc9 in start_thread () from /lib/libpthread.so.0
#12 0x001e069e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xb12afb70 (LWP 6541)):
#0  0x00f2b416 in __kernel_vsyscall ()
#1  0x066524dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x001edd9d in pthread_cond_wait () from /lib/libc.so.6
#3  0x010b2877 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x11b11a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#4  0x010b28c1 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x11b11a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#5  0x0664dcc9 in start_thread () from /lib/libpthread.so.0
#6  0x001e069e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb7721720 (LWP 6534)):
[KCrash Handler]
#7  0x04915ee0 in ?? () from /usr/lib/dri/i965_dri.so
#8  0x04908687 in ?? () from /usr/lib/dri/i965_dri.so
#9  0x0490ab27 in ?? () from /usr/lib/dri/i965_dri.so
#10 0x0497afba in ?? () from /usr/lib/dri/i965_dri.so
#11 0x0038d9fb in KWin::SceneOpenGL::paintBackground (this=0x85684b8, region=...) at ../../kwin/scene_opengl.cpp:921
#12 0x003805d2 in KWin::Scene::paintGenericScreen (this=0x85684b8, orig_mask=<value optimized out>) at ../../kwin/scene.cpp:188
#13 0x0038dc05 in KWin::SceneOpenGL::paintGenericScreen (this=0x85684b8, mask=<value optimized out>, data=...) at ../../kwin/scene_opengl.cpp:909
#14 0x0037d620 in KWin::Scene::finalPaintScreen (this=0x85684b8, mask=32, region=..., data=...) at ../../kwin/scene.cpp:178
#15 0x003a133c in KWin::EffectsHandlerImpl::paintScreen (this=0x85503e8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:173
#16 0x0445c729 in KWin::StartupFeedbackEffect::paintScreen (this=0x8b60cb8, mask=32, region=..., data=...) at ../../../kwin/effects/startupfeedback/startupfeedback.cpp:166
#17 0x003a13c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x85503e8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#18 0x00a9c846 in KWin::Effect::paintScreen (this=0x8b90b10, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#19 0x003a13c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x85503e8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#20 0x043f0ca6 in KWin::LogoutEffect::paintScreen (this=0x8b5ee68, mask=32, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:207
#21 0x003a13c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x85503e8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#22 0x044143cf in KWin::ShadowEffect::paintScreen (this=0x8a8cef0, mask=<value optimized out>, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:189
#23 0x003a13c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x85503e8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#24 0x04429b33 in KWin::BlurEffect::paintScreen (this=0x8922610, mask=32, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:230
#25 0x003a13c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x85503e8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#26 0x043f706f in KWin::PresentWindowsEffect::paintScreen (this=0x8b0cb50, mask=32, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:205
#27 0x003a13c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x85503e8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#28 0x00a9c846 in KWin::Effect::paintScreen (this=0x8b13990, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#29 0x003a13c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x85503e8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#30 0x00a9c846 in KWin::Effect::paintScreen (this=0x8a8cea0, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#31 0x003a13c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x85503e8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#32 0x00a9c846 in KWin::Effect::paintScreen (this=0x8a6c4d0, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#33 0x003a13c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x85503e8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#34 0x00a9c846 in KWin::Effect::paintScreen (this=0x89041c8, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#35 0x003a13c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x85503e8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#36 0x00a9c846 in KWin::Effect::paintScreen (this=0x8556dc8, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#37 0x003a13c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x85503e8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#38 0x00a9c846 in KWin::Effect::paintScreen (this=0x8900df0, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#39 0x003a13c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x85503e8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#40 0x0444b142 in KWin::FlipSwitchEffect::paintScreen (this=0x8bafcf0, mask=32, region=..., data=...) at ../../../kwin/effects/flipswitch/flipswitch.cpp:148
#41 0x003a13c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x85503e8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#42 0x043d95f2 in KWin::DesktopGridEffect::paintScreen (this=0x8a8db18, mask=32, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:155
#43 0x003a13c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x85503e8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#44 0x00a9c846 in KWin::Effect::paintScreen (this=0x89849c8, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#45 0x003a13c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x85503e8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#46 0x00a9c846 in KWin::Effect::paintScreen (this=0x8b1dbf8, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#47 0x003a13c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x85503e8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#48 0x043d2c3f in KWin::BoxSwitchEffect::paintScreen (this=0x8b38858, mask=32, region=..., data=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:143
#49 0x003a13c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x85503e8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#50 0x0443ace4 in KWin::CubeEffect::paintScreen (this=0x8baca30, mask=32, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:698
#51 0x003a13c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x85503e8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#52 0x00a9c846 in KWin::Effect::paintScreen (this=0x8b12918, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#53 0x003a13c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x85503e8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#54 0x00a9c846 in KWin::Effect::paintScreen (this=0x8ae4d68, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#55 0x003a13c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x85503e8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#56 0x00a9c846 in KWin::Effect::paintScreen (this=0x8a74128, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#57 0x003a13c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x85503e8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#58 0x0443127c in KWin::CoverSwitchEffect::paintScreen (this=0x8912398, mask=32, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:126
#59 0x003a13c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x85503e8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#60 0x00a9c846 in KWin::Effect::paintScreen (this=0x8900e60, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#61 0x003a13c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x85503e8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#62 0x00a9c846 in KWin::Effect::paintScreen (this=0x8b37d08, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#63 0x003a13c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x85503e8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#64 0x00a9c846 in KWin::Effect::paintScreen (this=0x8901910, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#65 0x003a13c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x85503e8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#66 0x04426709 in KWin::ZoomEffect::paintScreen (this=0x8a6a2e8, mask=32, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:341
#67 0x003a13c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x85503e8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#68 0x0037ee04 in KWin::Scene::paintScreen (this=0x85684b8, mask=0xbf84ba84, region=0xbf84bb30) at ../../kwin/scene.cpp:137
#69 0x003957aa in KWin::SceneOpenGL::paint (this=0x85684b8, damage=..., toplevels=...) at ../../kwin/scene_opengl.cpp:772
#70 0x00379b57 in KWin::Workspace::performCompositing (this=0xb4d3cc00) at ../../kwin/composite.cpp:448
#71 0x047a2504 in QObject::event (this=0xb4d3cc00, e=0x85cd0c0) at kernel/qobject.cpp:1183
#72 0x012e2fdc in QApplicationPrivate::notify_helper (this=0x8494c70, receiver=0xb4d3cc00, e=0xbf84c070) at kernel/qapplication.cpp:4396
#73 0x012e904e in QApplication::notify (this=0xbf84c394, receiver=0xb4d3cc00, e=0xbf84c070) at kernel/qapplication.cpp:3798
#74 0x005e3f7a in KApplication::notify (this=0xbf84c394, receiver=0xb4d3cc00, event=0xbf84c070) at ../../kdeui/kernel/kapplication.cpp:311
#75 0x00302d0f in KWin::Application::notify (this=0xbf84c394, o=0xb4d3cc00, e=0xbf84c070) at ../../kwin/main.cpp:376
#76 0x0478fb3b in QCoreApplication::notifyInternal (this=0xbf84c394, receiver=0xb4d3cc00, event=0xbf84c070) at kernel/qcoreapplication.cpp:732
#77 0x047c1ad6 in sendEvent (this=0x84953f8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#78 QTimerInfoList::activateTimers (this=0x84953f8) at kernel/qeventdispatcher_unix.cpp:602
#79 0x047c1c37 in QEventDispatcherUNIX::processEvents (this=0x8476ba0, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#80 0x013a60d2 in QEventDispatcherX11::processEvents (this=0x8476ba0, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#81 0x0478e609 in QEventLoop::processEvents (this=0xbf84c2c4, flags=) at kernel/qeventloop.cpp:149
#82 0x0478ea8a in QEventLoop::exec (this=0xbf84c2c4, flags=...) at kernel/qeventloop.cpp:201
#83 0x0479300f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#84 0x012e1e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#85 0x00305d00 in kdemain (argc=3, argv=0xbf84c614) at ../../kwin/main.cpp:542
#86 0x080485ab in main (argc=3, argv=0xbf84c614) at kwin_dummy.cpp:3

Possible duplicates by query: bug 267059, bug 266303, bug 263386, bug 262155, bug 259634.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2011-02-28 15:08:22 UTC

*** This bug has been marked as a duplicate of bug 255260 ***