Bug 265960

Summary: Kwin crash when leaving full-screen flash program
Product: [Plasma] kwin Reporter: Vivek <vivek.ap>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: openSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description Vivek 2011-02-10 04:04:02 UTC
Application: kwin (4.6.00 (4.6.0) "release 375")
KDE Platform Version: 4.6.00 (4.6.0) "release 375"
Qt Version: 4.7.1
Operating System: Linux 2.6.34.7-0.7-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

I was watching a flash video stream on full screen.  I pressed the "Escape" key to leave full screen mode and kwin crashed.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f9a60a00760 (LWP 2154))]

Thread 2 (Thread 0x7f9a47eeb710 (LWP 2159)):
#0  0x00007f9a5c2ae39c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9a5f0c8634 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f9a5f3ea180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f9a5f0c8669 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f9a5f3f8254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f9a5c2a9a4f in start_thread () from /lib64/libpthread.so.0
#4  0x00007f9a6026782d in clone () from /lib64/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f9a60a00760 (LWP 2154)):
[KCrash Handler]
#6  0x00007f9a48b0ebf0 in ?? () from /usr/lib64/dri/i965_dri.so
#7  0x00007f9a48b03dc4 in ?? () from /usr/lib64/dri/i965_dri.so
#8  0x00007f9a48b05dca in ?? () from /usr/lib64/dri/i965_dri.so
#9  0x00007f9a605c26e5 in KWin::SceneOpenGL::paintBackground (this=<value optimized out>, region=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene_opengl.cpp:921
#10 0x00007f9a605b9e56 in KWin::Scene::paintGenericScreen (this=0x79b020, orig_mask=40) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene.cpp:188
#11 0x00007f9a605b6faa in KWin::Scene::finalPaintScreen (this=0x79b020, mask=40, region=<value optimized out>, data=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene.cpp:178
#12 0x00007f9a605d42af in KWin::EffectsHandlerImpl::paintScreen (this=<value optimized out>, mask=40, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:173
#13 0x00007f9a48237758 in KWin::SnowEffect::paintScreen (this=0xff0630, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/snow/snow.cpp:120
#14 0x00007f9a605d433c in KWin::EffectsHandlerImpl::paintScreen (this=0xfb57f0, mask=40, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#15 0x00007f9a48237cbb in KWin::StartupFeedbackEffect::paintScreen (this=0x104e690, mask=40, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/startupfeedback/startupfeedback.cpp:166
#16 0x00007f9a605d433c in KWin::EffectsHandlerImpl::paintScreen (this=0xfb57f0, mask=40, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#17 0x00007f9a5e6a5f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=40, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#18 0x00007f9a605d433c in KWin::EffectsHandlerImpl::paintScreen (this=0xfb57f0, mask=40, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#19 0x00007f9a481ddf4f in KWin::LogoutEffect::paintScreen (this=0x1022650, mask=40, region=..., data=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/logout/logout.cpp:207
#20 0x00007f9a605d433c in KWin::EffectsHandlerImpl::paintScreen (this=0xfb57f0, mask=40, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#21 0x00007f9a481f9ab2 in KWin::ShadowEffect::paintScreen (this=0x1034830, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/shadow/shadow.cpp:189
#22 0x00007f9a605d433c in KWin::EffectsHandlerImpl::paintScreen (this=0xfb57f0, mask=40, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#23 0x00007f9a4820c43e in KWin::BlurEffect::paintScreen (this=<value optimized out>, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/blur/blur.cpp:230
#24 0x00007f9a605d433c in KWin::EffectsHandlerImpl::paintScreen (this=0xfb57f0, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#25 0x00007f9a481e29e2 in KWin::PresentWindowsEffect::paintScreen (this=0x1039960, mask=8, region=..., data=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/presentwindows/presentwindows.cpp:205
#26 0x00007f9a605d433c in KWin::EffectsHandlerImpl::paintScreen (this=0xfb57f0, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#27 0x00007f9a5e6a5f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#28 0x00007f9a605d433c in KWin::EffectsHandlerImpl::paintScreen (this=0xfb57f0, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#29 0x00007f9a5e6a5f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#30 0x00007f9a605d433c in KWin::EffectsHandlerImpl::paintScreen (this=0xfb57f0, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#31 0x00007f9a5e6a5f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#32 0x00007f9a605d433c in KWin::EffectsHandlerImpl::paintScreen (this=0xfb57f0, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#33 0x00007f9a5e6a5f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#34 0x00007f9a605d433c in KWin::EffectsHandlerImpl::paintScreen (this=0xfb57f0, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#35 0x00007f9a481c92f3 in KWin::DesktopGridEffect::paintScreen (this=<value optimized out>, mask=8, region=..., data=...)
    at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/desktopgrid/desktopgrid.cpp:155
#36 0x00007f9a605d433c in KWin::EffectsHandlerImpl::paintScreen (this=0xfb57f0, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#37 0x00007f9a4820028d in KWin::SlideEffect::paintScreen (this=<value optimized out>, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/slide/slide.cpp:86
#38 0x00007f9a605d433c in KWin::EffectsHandlerImpl::paintScreen (this=0xfb57f0, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#39 0x00007f9a5e6a5f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#40 0x00007f9a605d433c in KWin::EffectsHandlerImpl::paintScreen (this=0xfb57f0, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#41 0x00007f9a5e6a5f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#42 0x00007f9a605d433c in KWin::EffectsHandlerImpl::paintScreen (this=0xfb57f0, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#43 0x00007f9a5e6a5f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#44 0x00007f9a605d433c in KWin::EffectsHandlerImpl::paintScreen (this=0xfb57f0, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#45 0x00007f9a482132c4 in KWin::CoverSwitchEffect::paintScreen (this=0x1075060, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/coverswitch/coverswitch.cpp:126
#46 0x00007f9a605d433c in KWin::EffectsHandlerImpl::paintScreen (this=0xfb57f0, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#47 0x00007f9a5e6a5f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#48 0x00007f9a605d433c in KWin::EffectsHandlerImpl::paintScreen (this=0xfb57f0, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#49 0x00007f9a5e6a5f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#50 0x00007f9a605d433c in KWin::EffectsHandlerImpl::paintScreen (this=0xfb57f0, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#51 0x00007f9a48209a9f in KWin::ZoomEffect::paintScreen (this=0x1054a50, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/zoom/zoom.cpp:341
#52 0x00007f9a605d433c in KWin::EffectsHandlerImpl::paintScreen (this=0xfb57f0, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#53 0x00007f9a605b95d5 in KWin::Scene::paintScreen (this=0x79b020, mask=0x7fff072a9a4c, region=0x7fff072a9b40) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene.cpp:137
#54 0x00007f9a605cc529 in KWin::SceneOpenGL::paint (this=0x79b020, damage=..., toplevels=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene_opengl.cpp:772
#55 0x00007f9a605b4787 in KWin::Workspace::performCompositing (this=0x75ff90) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/composite.cpp:448
#56 0x00007f9a5c637999 in QObject::event (this=0x75ff90, e=<value optimized out>) at kernel/qobject.cpp:1175
#57 0x00007f9a5b7c4cd4 in QApplicationPrivate::notify_helper (this=0x6359a0, receiver=0x75ff90, e=0x7fff072aa380) at kernel/qapplication.cpp:4445
#58 0x00007f9a5b7cd1ca in QApplication::notify (this=<value optimized out>, receiver=0x75ff90, e=0x7fff072aa380) at kernel/qapplication.cpp:4324
#59 0x00007f9a5fcdbec6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#60 0x00007f9a5c623e2c in QCoreApplication::notifyInternal (this=0x7fff072aa860, receiver=0x75ff90, event=0x7fff072aa380) at kernel/qcoreapplication.cpp:732
#61 0x00007f9a5c651658 in sendEvent (this=0x6363b0) at kernel/qcoreapplication.h:215
#62 QTimerInfoList::activateTimers (this=0x6363b0) at kernel/qeventdispatcher_unix.cpp:618
#63 0x00007f9a5c651d40 in QEventDispatcherUNIX::processEvents (this=0x612380, flags=...) at kernel/qeventdispatcher_unix.cpp:937
#64 0x00007f9a5b86accc in QEventDispatcherX11::processEvents (this=0x612380, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#65 0x00007f9a5c623262 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#66 0x00007f9a5c623475 in QEventLoop::exec (this=0x7fff072aa750, flags=...) at kernel/qeventloop.cpp:201
#67 0x00007f9a5c6278db in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#68 0x00007f9a60552caa in kdemain (argc=<value optimized out>, argv=0x7fff072aa8c0) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/main.cpp:542
#69 0x00007f9a601b5b7d in __libc_start_main () from /lib64/libc.so.6
#70 0x0000000000400699 in _start () at ../sysdeps/x86_64/elf/start.S:113

This bug may be a duplicate of or related to bug 252817.

Possible duplicates by query: bug 264493, bug 264258, bug 264097, bug 263386, bug 262155.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2011-02-10 14:21:28 UTC

*** This bug has been marked as a duplicate of bug 252817 ***