Bug 264493

Summary: kwin segfault @ wake from screensaver
Product: [Plasma] kwin Reporter: _ <b7792105>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Unlisted Binaries   
OS: Linux   
Latest Commit: Version Fixed In:

Description _ 2011-01-27 15:46:50 UTC
Version:           unspecified (using KDE 4.5.5) 
OS:                Linux

i've an i3-based laptop, running,

uname -a
	Linux dev001_timeline.loc 2.6.37-4-desktop #1 SMP PREEMPT 2011-01-22 16:58:24 +0100 x86_64 x86_64 x86_64 GNU/Linux

lsb_release -a
	LSB Version:    n/a
	Distributor ID: SUSE LINUX
	Description:    openSUSE 11.3 (x86_64)
	Release:        11.3
	Codename:       n/a

rpm -qa | grep -i kwin
	kwin-4.5.5-1.3.x86_64
	kwin-debuginfo-4.5.5-1.3.x86_64

rpm -q --whatprovides /usr/lib64/dri/i965_dri.so
	Mesa-7.10-56.1.x86_64

@ most (Not all ...) wakes from screen saver, as well as at other seemingly random times when i am not doing anything in particular, or nothing at all, for that matter, i get a kwin crash:

Application: KWin (kwin), signal: Segmentation fault
[KCrash Handler]
#6  0x00007f9b27b4eaa0 in ?? () from /usr/lib64/dri/i965_dri.so
#7  0x00007f9b27b422d9 in ?? () from /usr/lib64/dri/i965_dri.so
#8  0x00007f9b27b447da in ?? () from /usr/lib64/dri/i965_dri.so
#9  0x00007f9b3e6cffb5 in KWin::SceneOpenGL::paintBackground (this=<value optimized out>, region=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/scene_opengl.cpp:907
#10 0x00007f9b3e728d56 in KWin::Scene::paintGenericScreen (this=0x7fd5a0, orig_mask=32) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/scene.cpp:187
#11 0x00007f9b3e6fb03a in KWin::Scene::finalPaintScreen (this=0x7fd5a0, mask=32, region=<value optimized out>, data=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/scene.cpp:177
#12 0x00007f9b3e72c79c in KWin::EffectsHandlerImpl::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/effects.cpp:172
#13 0x00007f9b26fe7dff in KWin::LogoutEffect::paintScreen (this=0x1d5ec30, mask=32, region=..., data=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/effects/logout/logout.cpp:207
#14 0x00007f9b3e72c82c in KWin::EffectsHandlerImpl::paintScreen (this=0xb234d0, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/effects.cpp:168
#15 0x00007f9b2701042e in KWin::BlurEffect::paintScreen (this=<value optimized out>, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/effects/blur/blur.cpp:235
#16 0x00007f9b3e72c82c in KWin::EffectsHandlerImpl::paintScreen (this=0xb234d0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/effects.cpp:168
#17 0x00007f9b26fec7d2 in KWin::PresentWindowsEffect::paintScreen (this=0x1f73050, mask=0, region=..., data=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/effects/presentwindows/presentwindows.cpp:196
#18 0x00007f9b3e72c82c in KWin::EffectsHandlerImpl::paintScreen (this=0xb234d0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/effects.cpp:168
#19 0x00007f9b3cd8241f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/lib/kwineffects.cpp:227
#20 0x00007f9b3e72c82c in KWin::EffectsHandlerImpl::paintScreen (this=0xb234d0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/effects.cpp:168
#21 0x00007f9b3cd8241f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/lib/kwineffects.cpp:227
#22 0x00007f9b3e72c82c in KWin::EffectsHandlerImpl::paintScreen (this=0xb234d0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/effects.cpp:168
#23 0x00007f9b3cd8241f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/lib/kwineffects.cpp:227
#24 0x00007f9b3e72c82c in KWin::EffectsHandlerImpl::paintScreen (this=0xb234d0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/effects.cpp:168
#25 0x00007f9b3cd8241f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/lib/kwineffects.cpp:227
#26 0x00007f9b3e72c82c in KWin::EffectsHandlerImpl::paintScreen (this=0xb234d0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/effects.cpp:168
#27 0x00007f9b3cd8241f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/lib/kwineffects.cpp:227
#28 0x00007f9b3e72c82c in KWin::EffectsHandlerImpl::paintScreen (this=0xb234d0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/effects.cpp:168
#29 0x00007f9b26fd4228 in KWin::DesktopGridEffect::paintScreen (this=<value optimized out>, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/effects/desktopgrid/desktopgrid.cpp:155
#30 0x00007f9b3e72c82c in KWin::EffectsHandlerImpl::paintScreen (this=0xb234d0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/effects.cpp:168
#31 0x00007f9b26fcd662 in KWin::BoxSwitchEffect::paintScreen (this=0x197c300, mask=0, region=..., data=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/effects/boxswitch/boxswitch.cpp:142
#32 0x00007f9b3e72c82c in KWin::EffectsHandlerImpl::paintScreen (this=0xb234d0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/effects.cpp:168
#33 0x00007f9b27027e52 in KWin::CubeSlideEffect::paintScreen (this=<value optimized out>, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/effects/cube/cubeslide.cpp:111
#34 0x00007f9b3e72c82c in KWin::EffectsHandlerImpl::paintScreen (this=0xb234d0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/effects.cpp:168
#35 0x00007f9b3cd8241f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/lib/kwineffects.cpp:227
#36 0x00007f9b3e72c82c in KWin::EffectsHandlerImpl::paintScreen (this=0xb234d0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/effects.cpp:168
#37 0x00007f9b27016ff4 in KWin::CoverSwitchEffect::paintScreen (this=0x1ec9f60, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/effects/coverswitch/coverswitch.cpp:124
#38 0x00007f9b3e72c82c in KWin::EffectsHandlerImpl::paintScreen (this=0xb234d0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/effects.cpp:168
#39 0x00007f9b3cd8241f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/lib/kwineffects.cpp:227
#40 0x00007f9b3e72c82c in KWin::EffectsHandlerImpl::paintScreen (this=0xb234d0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/effects.cpp:168
#41 0x00007f9b2700fe31 in KWin::ZoomEffect::paintScreen (this=<value optimized out>, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/effects/zoom/zoom.cpp:73
#42 0x00007f9b3e72c82c in KWin::EffectsHandlerImpl::paintScreen (this=0xb234d0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/effects.cpp:168
#43 0x00007f9b3e7284ed in KWin::Scene::paintScreen (this=0x7fd5a0, mask=0x7fffe862320c, region=0x7fffe8623320) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/scene.cpp:137
#44 0x00007f9b3e75b659 in KWin::SceneOpenGL::paint (this=0x7fd5a0, damage=..., toplevels=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/scene_opengl.cpp:758
#45 0x00007f9b3e73c5ab in KWin::Workspace::performCompositing (this=0x723290) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/composite.cpp:454
#46 0x00007f9b3e769d75 in KWin::Workspace::qt_metacall (this=0x723290, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffe86234c0) at /usr/src/debug/kdebase-workspace-4.5.5/build/kwin/workspace.moc:583
#47 0x00007f9b3ad4dbbf in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#48 0x00007f9b3ad4b3ce in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#49 0x00007f9b39f34054 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#50 0x00007f9b39f3c64a in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#51 0x00007f9b3deac876 in KApplication::notify (this=0x7fffe8624110, receiver=0x723758, event=0x7fffe8623c50) at /usr/src/debug/kdelibs-4.5.5/kdeui/kernel/kapplication.cpp:310
#52 0x00007f9b3ad3a00c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#53 0x00007f9b3ad65249 in QTimerInfoList::activateTimers() () from /usr/lib64/libQtCore.so.4
#54 0x00007f9b3ad65860 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#55 0x00007f9b39fd562c in QEventDispatcherX11::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtGui.so.4
#56 0x00007f9b3ad39452 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#57 0x00007f9b3ad39655 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#58 0x00007f9b3ad3da4b in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#59 0x00007f9b3e768474 in kdemain (argc=<value optimized out>, argv=0x7fffe8624110) at /usr/src/debug/kdebase-workspace-4.5.5/kwin/main.cpp:531
#60 0x00007f9b3e35fb7d in __libc_start_main () from /lib64/libc.so.6
#61 0x0000000000400699 in _start () at ../sysdeps/x86_64/elf/start.S:113

still working on finding the actual, reproducible event trigger ...

Reproducible: Always
Comment 1 Thomas L├╝bking 2011-01-27 18:56:58 UTC

*** This bug has been marked as a duplicate of bug 252817 ***
Comment 2 _ 2011-01-27 19:45:27 UTC
thx.

added comment @ upstream:
https://bugs.freedesktop.org/show_bug.cgi?id=30509#c17