Bug 264031

Summary: Plasma crashed on 'System tray properties' dialog
Product: plasma4 Reporter: Alexey Chernov <4ernov>
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: andresbajotierra, aseigo
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Compiled Sources   
OS: Linux   
Latest Commit: Version Fixed In:

Description Alexey Chernov 2011-01-23 02:24:22 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.4 (KDE 4.5.4) (Compiled from sources)
Qt Version: 4.7.1
Operating System: Linux 2.6.36.1 x86_64

-- Information about the crash:
I opened 'System tray properties' dialog, firstly it freezed after showing and then in several minutes Plasma crashed.

-- Backtrace:
Application: Рабочее пространство Plasma (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fad0cca7760 (LWP 2469))]

Thread 2 (Thread 0x7facd57f4710 (LWP 9954)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:211
#1  0x00007fad0b671ab8 in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x24b4eb0, time=30000) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x24b4eb0, time=30000) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fad0b66500e in QThreadPoolThread::run (this=0x2b3cbc0) at concurrent/qthreadpool.cpp:140
#4  0x00007fad0b670e07 in QThreadPrivate::start (arg=0x2b3cbc0) at thread/qthread_unix.cpp:285
#5  0x00007fad0b3cdaca in start_thread (arg=<value optimized out>) at pthread_create.c:297
#6  0x00007fad098af58d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7fad0cca7760 (LWP 2469)):
[KCrash Handler]
#6  0x00007fad0c738838 in KIconEffect::fingerprint (this=0x48, group=0, state=0) at /usr/src/packages/kde4/4.5.4/kdelibs-4.5.4/kdeui/icons/kiconeffect.cpp:158
#7  0x00007fad0c73bd8f in KIconLoaderPrivate::makeCacheKey (this=<value optimized out>, name=<value optimized out>, group=<value optimized out>, overlays=<value optimized out>, 
    size=<value optimized out>, state=0) at /usr/src/packages/kde4/4.5.4/kdelibs-4.5.4/kdeui/icons/kiconloader.cpp:777
#8  0x00007fad0c73ec4f in KIconLoader::loadIcon (this=0x4690f20, _name=<value optimized out>, group=KIconLoader::Desktop, size=16, state=0, overlays=..., path_store=0x0, canReturnNull=false)
    at /usr/src/packages/kde4/4.5.4/kdelibs-4.5.4/kdeui/icons/kiconloader.cpp:1225
#9  0x00007fad0c73a552 in KIconEngine::paint (this=<value optimized out>, painter=0x7fff0024d2b0, rect=..., mode=<value optimized out>, state=<value optimized out>)
    at /usr/src/packages/kde4/4.5.4/kdelibs-4.5.4/kdeui/icons/kiconengine.cpp:83
#10 0x00007fad0a5b3b08 in QIcon::paint (this=0x7fff0024cb58, painter=0x7fff0024d2b0, rect=..., alignment=) at image/qicon.cpp:722
#11 0x00007fad0a8ad25f in QCommonStyle::drawControl (this=0x1360410, element=<value optimized out>, opt=0x7fff0024cac0, p=0x7fff0024d2b0, widget=0x1625950) at styles/qcommonstyle.cpp:2194
#12 0x00007fad0c792fc2 in KStyle::drawControl (this=0x1360410, element=QStyle::CE_ItemViewItem, option=0x7fff0024cac0, p=<value optimized out>, widget=0x1625950)
    at /usr/src/packages/kde4/4.5.4/kdelibs-4.5.4/kdeui/kernel/kstyle.cpp:2508
#13 0x00007facee36f763 in Oxygen::Style::drawControl (this=0x1360410, element=448, option=0x7fff0024cac0, p=0x7fff0024d2b0, widget=0x1625950)
    at /usr/src/packages/kde4/4.5.4/kdebase-workspace-4.5.4/kstyles/oxygen/oxygenstyle.cpp:1015
#14 0x00007fad0abeb220 in QStyledItemDelegate::paint (this=0x474db40, painter=0x7fff0024d2b0, option=<value optimized out>, index=...) at itemviews/qstyleditemdelegate.cpp:424
#15 0x00007fad0ab68f06 in QTreeView::drawRow (this=<value optimized out>, painter=<value optimized out>, option=<value optimized out>, index=<value optimized out>) at itemviews/qtreeview.cpp:1678
#16 0x00007fad0ab6178c in QTreeView::drawTree (this=<value optimized out>, painter=<value optimized out>, region=<value optimized out>) at itemviews/qtreeview.cpp:1441
#17 0x00007fad0ab61a93 in QTreeView::paintEvent (this=0x1625950, event=0x7fff0024df60) at itemviews/qtreeview.cpp:1274
#18 0x00007fad0a5492a0 in QWidget::event (this=0x1625950, event=0x7fff0024df60) at kernel/qwidget.cpp:8346
#19 0x00007fad0a9b8db4 in QFrame::event (this=0x1625950, e=0x7fff0024df60) at widgets/qframe.cpp:557
#20 0x00007fad0ab2056b in QAbstractItemView::viewportEvent (this=0x1625950, event=0x7fff0024df60) at itemviews/qabstractitemview.cpp:1619
#21 0x00007fad0ab67f05 in QTreeView::viewportEvent (this=0x1625950, event=0x7fff0024df60) at itemviews/qtreeview.cpp:1256
#22 0x00007fad0b786008 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x4fd75e0, event=0x7fff0024df60) at kernel/qcoreapplication.cpp:847
#23 0x00007fad0a4e3adc in QApplicationPrivate::notify_helper (this=0x135bd50, receiver=0x4fd75e0, e=0x7fff0024df60) at kernel/qapplication.cpp:4441
#24 0x00007fad0a4f0e89 in QApplication::notify (this=0x1351210, receiver=<value optimized out>, e=0x7fff0024df60) at kernel/qapplication.cpp:4324
#25 0x00007fad0c784cf1 in KApplication::notify (this=0x1351210, receiver=0x4fd75e0, event=0x7fff0024df60) at /usr/src/packages/kde4/4.5.4/kdelibs-4.5.4/kdeui/kernel/kapplication.cpp:310
#26 0x00007fad0b78636b in QCoreApplication::notifyInternal (this=0x1351210, receiver=0x4fd75e0, event=0x7fff0024df60) at kernel/qcoreapplication.cpp:732
#27 0x00007fad0a553696 in QCoreApplication::sendSpontaneousEvent (this=0x4eafef0, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x502a920) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#28 QWidgetPrivate::drawWidget (this=0x4eafef0, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, backingStore=0x502a920)
    at kernel/qwidget.cpp:5433
#29 0x00007fad0a5543a2 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=0, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x502a920) at kernel/qwidget.cpp:5640
#30 0x00007fad0a5541db in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=4, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x502a920) at kernel/qwidget.cpp:5627
#31 0x00007fad0a5541db in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=7, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x502a920) at kernel/qwidget.cpp:5627
#32 0x00007fad0a5541db in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=8, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x502a920) at kernel/qwidget.cpp:5627
#33 0x00007fad0a5541db in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=9, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x502a920) at kernel/qwidget.cpp:5627
#34 0x00007fad0a5541db in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=10, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x502a920) at kernel/qwidget.cpp:5627
#35 0x00007fad0a553371 in QWidgetPrivate::drawWidget (this=0x4d2c180, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x502a920) at kernel/qwidget.cpp:5486
#36 0x00007fad0a5543a2 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=1, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x502a920) at kernel/qwidget.cpp:5640
#37 0x00007fad0a553371 in QWidgetPrivate::drawWidget (this=0x44e7980, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x502a920) at kernel/qwidget.cpp:5486
#38 0x00007fad0a5543a2 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=1, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x502a920) at kernel/qwidget.cpp:5640
#39 0x00007fad0a553371 in QWidgetPrivate::drawWidget (this=0x4d8f330, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x502a920) at kernel/qwidget.cpp:5486
#40 0x00007fad0a5543a2 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=5, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x502a920) at kernel/qwidget.cpp:5640
#41 0x00007fad0a553371 in QWidgetPrivate::drawWidget (this=0x4d66d20, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x502a920) at kernel/qwidget.cpp:5486
#42 0x00007fad0a5543a2 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=1, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x502a920) at kernel/qwidget.cpp:5640
#43 0x00007fad0a5541db in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=2, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x502a920) at kernel/qwidget.cpp:5627
#44 0x00007fad0a5541db in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=4, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x502a920) at kernel/qwidget.cpp:5627
#45 0x00007fad0a553371 in QWidgetPrivate::drawWidget (this=0x5117420, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x502a920) at kernel/qwidget.cpp:5486
#46 0x00007fad0a5543a2 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=0, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x502a920) at kernel/qwidget.cpp:5640
#47 0x00007fad0a5541db in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=1, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x502a920) at kernel/qwidget.cpp:5627
#48 0x00007fad0a553371 in QWidgetPrivate::drawWidget (this=0x4d32520, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x502a920) at kernel/qwidget.cpp:5486
#49 0x00007fad0a77ea21 in QWidgetBackingStore::sync (this=0x502a920) at painting/qbackingstore.cpp:1333
#50 0x00007fad0a77ed15 in QWidgetBackingStore::sync (this=0x502a920, exposedWidget=0x4fb8740, exposedRegion=...) at painting/qbackingstore.cpp:1130
#51 0x00007fad0a573550 in QETWidget::translatePaintEvent (this=0x4fb8740, event=<value optimized out>) at kernel/qapplication_x11.cpp:5152
#52 0x00007fad0a58172d in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fff00251410) at kernel/qapplication_x11.cpp:3464
#53 0x00007fad0a5b1712 in x11EventSourceDispatch (s=0x135f350, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#54 0x00007fad0664b3fc in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#55 0x00007fad0664bce8 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#56 0x00007fad0664beac in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#57 0x00007fad0b7bb173 in QEventDispatcherGlib::processEvents (this=0x12c5d30, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#58 0x00007fad0a5b103e in QGuiEventDispatcherGlib::processEvents (this=0x7fff0024a550, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#59 0x00007fad0b784f62 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#60 0x00007fad0b785345 in QEventLoop::exec (this=0x7fff00251740, flags=) at kernel/qeventloop.cpp:201
#61 0x00007fad0b78b6ab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#62 0x00007facefca0d3f in kdemain (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/packages/kde4/4.5.4/kdebase-workspace-4.5.4/plasma/desktop/shell/main.cpp:118
#63 0x0000000000407acd in launch (argc=1, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=<value optimized out>, envs=<value optimized out>, reset_env=false, 
    tty=0x0, avoid_loops=false, startup_id_str=0x40b156 "0") at /usr/src/packages/kde4/4.5.4/kdelibs-4.5.4/kinit/kinit.cpp:723
#64 0x000000000040875c in handle_launcher_request (sock=8, who=<value optimized out>) at /usr/src/packages/kde4/4.5.4/kdelibs-4.5.4/kinit/kinit.cpp:1215
#65 0x0000000000408efa in handle_requests (waitForPid=<value optimized out>) at /usr/src/packages/kde4/4.5.4/kdelibs-4.5.4/kinit/kinit.cpp:1408
#66 0x00000000004093f7 in main (argc=4, argv=<value optimized out>, envp=<value optimized out>) at /usr/src/packages/kde4/4.5.4/kdelibs-4.5.4/kinit/kinit.cpp:1892

Possible duplicates by query: bug 263927, bug 262756, bug 261012, bug 258706, bug 254590.

Reported using DrKonqi
Comment 1 Dario Andres 2011-01-23 15:31:15 UTC
[Comment from a bug triager]
The backtrace is mostly the same the one in bug 258706.
- Check if the crash happens again if you repeat the situation.
Regards
Comment 2 Alexey Chernov 2011-01-23 20:42:36 UTC
Yeah, there're some familiar bugs suggested but I'm doubt if this is exact duplicate.
No, the crash isn't often reproducible, it was some freezes and delays with Plasma before it (for example, if I clicked on the button at the top right corner of the screen menu took 5-6 s to appear and all the windows became minimized as it appeared and restored when it was hidden) and finally it crashed. Not reproducible under normal conditions.
Comment 3 Aaron J. Seigo 2011-01-27 23:09:15 UTC

*** This bug has been marked as a duplicate of bug 258706 ***