Bug 263844

Summary: Crash when clicking on "Auto eth0" in sys tray
Product: Network Management Reporter: Dario Massarin <nekkar>
Component: Plasma WidgetAssignee: Sebastian K├╝gler <sebas>
Status: RESOLVED DUPLICATE    
Severity: crash CC: lamarque, wstephenson
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description Dario Massarin 2011-01-21 11:27:14 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.5.95 (4.6 RC2)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-24-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

I just clicked on my ethernet device ("Auto eth0" label) and the crash happened. This was when I was doing some tests with a new router, plugging / unplugging it some times. I don't know if this can be related to the problem.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb60d4720 (LWP 1601))]

Thread 4 (Thread 0xae0fab70 (LWP 1604)):
#0  0x00182416 in __kernel_vsyscall ()
#1  0x00756df6 in poll () from /lib/libc.so.6
#2  0x02ed0a1b in g_poll () from /lib/libglib-2.0.so.0
#3  0x02ec343c in ?? () from /lib/libglib-2.0.so.0
#4  0x02ec3848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x01a4359f in QEventDispatcherGlib::processEvents (this=0x96ef4d0, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#6  0x01a13609 in QEventLoop::processEvents (this=0xae0fa1d0, flags=) at kernel/qeventloop.cpp:149
#7  0x01a13a8a in QEventLoop::exec (this=0xae0fa1d0, flags=...) at kernel/qeventloop.cpp:201
#8  0x0190fb7e in QThread::exec (this=0x96ebcc8) at thread/qthread.cpp:490
#9  0x019f235b in QInotifyFileSystemWatcherEngine::run (this=0x96ebcc8) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x01912df9 in QThreadPrivate::start (arg=0x96ebcc8) at thread/qthread_unix.cpp:266
#11 0x0172cba8 in ?? () from /usr/lib/nvidia-current/libGL.so.1

Thread 3 (Thread 0xad8f9b70 (LWP 1605)):
#0  0x02ec29f6 in g_main_context_check () from /lib/libglib-2.0.so.0
#1  0x02ec345e in ?? () from /lib/libglib-2.0.so.0
#2  0x02ec3848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x01a4359f in QEventDispatcherGlib::processEvents (this=0x96c2d98, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#4  0x01a13609 in QEventLoop::processEvents (this=0xad8f91f0, flags=) at kernel/qeventloop.cpp:149
#5  0x01a13a8a in QEventLoop::exec (this=0xad8f91f0, flags=...) at kernel/qeventloop.cpp:201
#6  0x0190fb7e in QThread::exec (this=0x96f4320) at thread/qthread.cpp:490
#7  0x03534171 in Herqq::Upnp::HControlPointThread::run() () from /usr/lib/libHUpnp.so.0
#8  0x01912df9 in QThreadPrivate::start (arg=0x96f4320) at thread/qthread_unix.cpp:266
#9  0x0172cba8 in ?? () from /usr/lib/nvidia-current/libGL.so.1

Thread 2 (Thread 0xac18bb70 (LWP 1606)):
#0  0x00182416 in __kernel_vsyscall ()
#1  0x00756df6 in poll () from /lib/libc.so.6
#2  0x02ed0a1b in g_poll () from /lib/libglib-2.0.so.0
#3  0x02ec343c in ?? () from /lib/libglib-2.0.so.0
#4  0x02ec3848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x01a4359f in QEventDispatcherGlib::processEvents (this=0x95d8b98, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#6  0x01a13609 in QEventLoop::processEvents (this=0xac18b1d0, flags=) at kernel/qeventloop.cpp:149
#7  0x01a13a8a in QEventLoop::exec (this=0xac18b1d0, flags=...) at kernel/qeventloop.cpp:201
#8  0x0190fb7e in QThread::exec (this=0x9759e38) at thread/qthread.cpp:490
#9  0x019f235b in QInotifyFileSystemWatcherEngine::run (this=0x9759e38) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x01912df9 in QThreadPrivate::start (arg=0x9759e38) at thread/qthread_unix.cpp:266
#11 0x0172cba8 in ?? () from /usr/lib/nvidia-current/libGL.so.1

Thread 1 (Thread 0xb60d4720 (LWP 1601)):
[KCrash Handler]
#7  0x01a261b4 in err_method_notfound (object=<value optimized out>, method=<value optimized out>, func=0x1adcc48 "disconnect") at kernel/qobject.cpp:2280
#8  0x01a2d2c6 in QObject::disconnect (sender=0x96e4638, signal=0x0, receiver=0x9ce2bc0, method=0x4c75732 "2hasDefaultRouteChanged(bool)") at kernel/qobject.cpp:2767
#9  0x04c6509d in ?? () from /usr/lib/kde4/plasma_applet_networkmanagement.so
#10 0x04c65a6b in ?? () from /usr/lib/kde4/plasma_applet_networkmanagement.so
#11 0x04c6472b in ?? () from /usr/lib/kde4/plasma_applet_networkmanagement.so
#12 0x04c59339 in ?? () from /usr/lib/kde4/plasma_applet_networkmanagement.so
#13 0x01a1a8ca in QMetaObject::metacall (object=0x96e4638, cl=28165425, idx=158221880, argv=0x9fc3d80) at kernel/qmetaobject.cpp:237
#14 0x01a2d6ad in QMetaObject::activate (sender=0x95ba9e0, m=0x4cae66c, local_signal_index=3, argv=0x0) at kernel/qobject.cpp:3280
#15 0x04c9256f in Solid::Control::NetworkInterface::connectionStateChanged(int, int, int) () from /usr/lib/libsolidcontrol.so.4
#16 0x04c926eb in Solid::Control::NetworkInterface::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libsolidcontrol.so.4
#17 0x04c954ea in Solid::Control::WiredNetworkInterface::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libsolidcontrol.so.4
#18 0x01a1a8ca in QMetaObject::metacall (object=0x95ba9e0, cl=28165425, idx=0, argv=0xbfb714f0) at kernel/qmetaobject.cpp:237
#19 0x01a2d6ad in QMetaObject::activate (sender=0x95edcb8, m=0x4cd9a14, local_signal_index=2, argv=0x0) at kernel/qobject.cpp:3280
#20 0x04cc5c6f in NMNetworkInterface::connectionStateChanged(int, int, int) () from /usr/lib/kde4/solid_networkmanager07.so
#21 0x04cc5bd1 in NMNetworkInterface::stateChanged(unsigned int, unsigned int, unsigned int) () from /usr/lib/kde4/solid_networkmanager07.so
#22 0x04cc6ff0 in NMNetworkInterface::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/kde4/solid_networkmanager07.so
#23 0x04cca2ea in NMWiredNetworkInterface::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/kde4/solid_networkmanager07.so
#24 0x01a1a8ca in QMetaObject::metacall (object=0x95edcb8, cl=28165425, idx=157211832, argv=0x9626e18) at kernel/qmetaobject.cpp:237
#25 0x01a2d6ad in QMetaObject::activate (sender=0x9626e18, m=0x4cdaae4, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3280
#26 0x04cd0ddf in ?? () from /usr/lib/kde4/solid_networkmanager07.so
#27 0x04cd0e64 in ?? () from /usr/lib/kde4/solid_networkmanager07.so
#28 0x0085b9dc in QDBusConnectionPrivate::deliverCall (this=0x919dfd0, object=0x9626e18, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:919
#29 0x008671f7 in QDBusCallDeliveryEvent::placeMetaCall (this=0x9bfb258, object=0x9626e18) at qdbusintegrator_p.h:103
#30 0x01a276a2 in QObject::event (this=0x9626e18, e=0x1adc531) at kernel/qobject.cpp:1219
#31 0x03f84fdc in QApplicationPrivate::notify_helper (this=0x914f798, receiver=0x9626e18, e=0x9bfb258) at kernel/qapplication.cpp:4396
#32 0x03f8b04e in QApplication::notify (this=0x9145320, receiver=0x9626e18, e=0x9bfb258) at kernel/qapplication.cpp:3798
#33 0x01198f8a in KApplication::notify (this=0x9145320, receiver=0x9626e18, event=0x9bfb258) at ../../kdeui/kernel/kapplication.cpp:311
#34 0x01a14b3b in QCoreApplication::notifyInternal (this=0x9145320, receiver=0x9626e18, event=0x9bfb258) at kernel/qcoreapplication.cpp:732
#35 0x01a17d8b in sendEvent (receiver=0x0, event_type=0, data=0x90d5620) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#36 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x90d5620) at kernel/qcoreapplication.cpp:1373
#37 0x01a17f4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#38 0x01a43a74 in sendPostedEvents (s=0x9151b88) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#39 postEventSourceDispatch (s=0x9151b88) at kernel/qeventdispatcher_glib.cpp:277
#40 0x02ebf855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#41 0x02ec3668 in ?? () from /lib/libglib-2.0.so.0
#42 0x02ec3848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#43 0x01a43565 in QEventDispatcherGlib::processEvents (this=0x914ecd8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#44 0x04046be5 in QGuiEventDispatcherGlib::processEvents (this=0x914ecd8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#45 0x01a13609 in QEventLoop::processEvents (this=0xbfb72144, flags=) at kernel/qeventloop.cpp:149
#46 0x01a13a8a in QEventLoop::exec (this=0xbfb72144, flags=...) at kernel/qeventloop.cpp:201
#47 0x01a1800f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#48 0x03f83e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#49 0x00ae6fb7 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#50 0x080485bb in _start ()

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-03-30 13:43:23 UTC

*** This bug has been marked as a duplicate of bug 266097 ***