Bug 262155

Summary: kwin crashed after GL screensaver
Product: [Plasma] kwin Reporter: oleg.bashmurov
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash CC: pirronjm
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: New crash information added by DrKonqi

Description oleg.bashmurov 2011-01-05 08:26:07 UTC
Application: kwin (4.5.90 (4.6 RC1))
KDE Platform Version: 4.5.90 (4.6 RC1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-24-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

kwin crashed after GL screensaver when GL desktop effects is active

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77729f0 (LWP 1671))]

Thread 3 (Thread 0xb36aab70 (LWP 1746)):
#0  0x00adc416 in __kernel_vsyscall ()
#1  0x002fd371 in select () from /lib/libc.so.6
#2  0x08cf7872 in qt_safe_select (nfds=17, fdread=0x9e31608, fdwrite=0x9e3181c, fdexcept=0x9e31a30, orig_timeout=0x0) at kernel/qcore_unix.cpp:82
#3  0x08cfc329 in QEventDispatcherUNIX::select (this=0xa07ef18, nfds=17, readfds=0x9e31608, writefds=0x9e3181c, exceptfds=0x9e31a30, timeout=0x0) at kernel/qeventdispatcher_unix.cpp:632
#4  0x08cfceac in QEventDispatcherUNIXPrivate::doSelect (this=0x9e31510, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:219
#5  0x08cfdc25 in QEventDispatcherUNIX::processEvents (this=0xa07ef18, flags=...) at kernel/qeventdispatcher_unix.cpp:919
#6  0x08cca609 in QEventLoop::processEvents (this=0xb36aa280, flags=) at kernel/qeventloop.cpp:149
#7  0x08ccaa8a in QEventLoop::exec (this=0xb36aa280, flags=...) at kernel/qeventloop.cpp:201
#8  0x08bc6b7e in QThread::exec (this=0x9e42670) at thread/qthread.cpp:490
#9  0x08ca935b in QInotifyFileSystemWatcherEngine::run (this=0x9e42670) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x08bc9df9 in QThreadPrivate::start (arg=0x9e42670) at thread/qthread_unix.cpp:266
#11 0x0844ecc9 in start_thread () from /lib/libpthread.so.0
#12 0x0030469e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xb2ea1b70 (LWP 1747)):
#0  0x00adc416 in __kernel_vsyscall ()
#1  0x084534dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x00311d9d in pthread_cond_wait () from /lib/libc.so.6
#3  0x00f1e877 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x101d1a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#4  0x00f1e8c1 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x101d1a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#5  0x0844ecc9 in start_thread () from /lib/libpthread.so.0
#6  0x0030469e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb77729f0 (LWP 1671)):
[KCrash Handler]
#7  0x04b6fee0 in ?? () from /usr/lib/dri/i965_dri.so
#8  0x04b62687 in ?? () from /usr/lib/dri/i965_dri.so
#9  0x04b64b27 in ?? () from /usr/lib/dri/i965_dri.so
#10 0x04bd4fba in ?? () from /usr/lib/dri/i965_dri.so
#11 0x001e7f9b in KWin::SceneOpenGL::paintBackground (this=0x972dfe8, region=...) at ../../kwin/scene_opengl.cpp:934
#12 0x001dabb2 in KWin::Scene::paintGenericScreen (this=0x972dfe8, orig_mask=<value optimized out>) at ../../kwin/scene.cpp:188
#13 0x001e81a5 in KWin::SceneOpenGL::paintGenericScreen (this=0x972dfe8, mask=<value optimized out>, data=...) at ../../kwin/scene_opengl.cpp:922
#14 0x001d7c00 in KWin::Scene::finalPaintScreen (this=0x972dfe8, mask=40, region=..., data=...) at ../../kwin/scene.cpp:178
#15 0x001fb63c in KWin::EffectsHandlerImpl::paintScreen (this=0x9d0b648, mask=40, region=..., data=...) at ../../kwin/effects.cpp:173
#16 0x03cfdd51 in KWin::SnowEffect::paintScreen (this=0xa0ac530, mask=40, region=) at ../../../kwin/effects/snow/snow.cpp:120
#17 0x001fb6c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x9d0b648, mask=40, region=..., data=...) at ../../kwin/effects.cpp:169
#18 0x03cff639 in KWin::StartupFeedbackEffect::paintScreen (this=0xa093f90, mask=40, region=..., data=...) at ../../../kwin/effects/startupfeedback/startupfeedback.cpp:166
#19 0x001fb6c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x9d0b648, mask=40, region=..., data=...) at ../../kwin/effects.cpp:169
#20 0x004407d6 in KWin::Effect::paintScreen (this=0xa09b828, mask=40, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#21 0x001fb6c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x9d0b648, mask=40, region=..., data=...) at ../../kwin/effects.cpp:169
#22 0x03c93ca6 in KWin::LogoutEffect::paintScreen (this=0xa0cdf30, mask=40, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:207
#23 0x001fb6c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x9d0b648, mask=40, region=..., data=...) at ../../kwin/effects.cpp:169
#24 0x03ccca83 in KWin::BlurEffect::paintScreen (this=0x9d537e8, mask=40, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:230
#25 0x001fb6c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x9d0b648, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#26 0x03c99fcf in KWin::PresentWindowsEffect::paintScreen (this=0xa0e5380, mask=8, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:205
#27 0x001fb6c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x9d0b648, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#28 0x004407d6 in KWin::Effect::paintScreen (this=0xa0327e0, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#29 0x001fb6c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x9d0b648, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#30 0x004407d6 in KWin::Effect::paintScreen (this=0x9d61158, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#31 0x001fb6c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x9d0b648, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#32 0x004407d6 in KWin::Effect::paintScreen (this=0xa0c35c0, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#33 0x001fb6c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x9d0b648, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#34 0x03cddc34 in KWin::CubeEffect::paintScreen (this=0x9e6ddb8, mask=8, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:698
#35 0x001fb6c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x9d0b648, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#36 0x004407d6 in KWin::Effect::paintScreen (this=0xa01cf68, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#37 0x001fb6c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x9d0b648, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#38 0x004407d6 in KWin::Effect::paintScreen (this=0xa053810, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#39 0x001fb6c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x9d0b648, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#40 0x004407d6 in KWin::Effect::paintScreen (this=0xa100bd8, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#41 0x001fb6c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x9d0b648, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#42 0x03cd41cc in KWin::CoverSwitchEffect::paintScreen (this=0xa0dc838, mask=8, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:126
#43 0x001fb6c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x9d0b648, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#44 0x004407d6 in KWin::Effect::paintScreen (this=0x973b500, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#45 0x001fb6c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x9d0b648, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#46 0x004407d6 in KWin::Effect::paintScreen (this=0x9f3c168, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#47 0x001fb6c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x9d0b648, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#48 0x004407d6 in KWin::Effect::paintScreen (this=0x9dfd498, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#49 0x001fb6c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x9d0b648, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#50 0x03cc9659 in KWin::ZoomEffect::paintScreen (this=0x9d6e440, mask=8, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:341
#51 0x001fb6c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x9d0b648, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#52 0x001d93e4 in KWin::Scene::paintScreen (this=0x972dfe8, mask=0xbf9baad8, region=0xbf9bab74) at ../../kwin/scene.cpp:137
#53 0x001efdea in KWin::SceneOpenGL::paint (this=0x972dfe8, damage=..., toplevels=...) at ../../kwin/scene_opengl.cpp:771
#54 0x001d3f8c in KWin::Workspace::performCompositing (this=0x9a2c4b8) at ../../kwin/composite.cpp:435
#55 0x08cde504 in QObject::event (this=0x9a2c4b8, e=0x9780d18) at kernel/qobject.cpp:1183
#56 0x02e05fdc in QApplicationPrivate::notify_helper (this=0x9669930, receiver=0x9a2c4b8, e=0xbf9bb0b0) at kernel/qapplication.cpp:4396
#57 0x02e0c04e in QApplication::notify (this=0xbf9bb3d4, receiver=0x9a2c4b8, e=0xbf9bb0b0) at kernel/qapplication.cpp:3798
#58 0x007112ca in KApplication::notify (this=0xbf9bb3d4, receiver=0x9a2c4b8, event=0xbf9bb0b0) at ../../kdeui/kernel/kapplication.cpp:311
#59 0x0015d5ff in KWin::Application::notify (this=0xbf9bb3d4, o=0x9a2c4b8, e=0xbf9bb0b0) at ../../kwin/main.cpp:376
#60 0x08ccbb3b in QCoreApplication::notifyInternal (this=0xbf9bb3d4, receiver=0x9a2c4b8, event=0xbf9bb0b0) at kernel/qcoreapplication.cpp:732
#61 0x08cfdad6 in sendEvent (this=0x966a2d8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#62 QTimerInfoList::activateTimers (this=0x966a2d8) at kernel/qeventdispatcher_unix.cpp:602
#63 0x08cfdc37 in QEventDispatcherUNIX::processEvents (this=0x9669638, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#64 0x02ec90d2 in QEventDispatcherX11::processEvents (this=0x9669638, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#65 0x08cca609 in QEventLoop::processEvents (this=0xbf9bb304, flags=) at kernel/qeventloop.cpp:149
#66 0x08ccaa8a in QEventLoop::exec (this=0xbf9bb304, flags=...) at kernel/qeventloop.cpp:201
#67 0x08ccf00f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#68 0x02e04e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#69 0x001605f0 in kdemain (argc=1, argv=0xbf9bb654) at ../../kwin/main.cpp:542
#70 0x080485ab in main (argc=1, argv=0xbf9bb654) at kwin_dummy.cpp:3

Possible duplicates by query: bug 259634, bug 255260.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2011-01-05 15:19:48 UTC

*** This bug has been marked as a duplicate of bug 255260 ***
Comment 2 Juan Montano 2011-03-24 13:31:52 UTC
Created attachment 58305 [details]
New crash information added by DrKonqi

kwin (4.6.1 (4.6.1)) on KDE Platform 4.6.1 (4.6.1) using Qt 4.7.0

- What I was doing when the application crashed: A GL screensaver opened when I wasn't using the computer

-- Backtrace (Reduced):
#11 0x0057ea9b in KWin::SceneOpenGL::paintBackground (this=0x8412800, region=...) at ../../kwin/scene_opengl.cpp:921
#12 0x00571672 in KWin::Scene::paintGenericScreen (this=0x8412800, orig_mask=<value optimized out>) at ../../kwin/scene.cpp:188
#13 0x0057eca5 in KWin::SceneOpenGL::paintGenericScreen (this=0x8412800, mask=<value optimized out>, data=...) at ../../kwin/scene_opengl.cpp:909
#14 0x0056e6c0 in KWin::Scene::finalPaintScreen (this=0x8412800, mask=32, region=..., data=...) at ../../kwin/scene.cpp:178
#15 0x005923dc in KWin::EffectsHandlerImpl::paintScreen (this=0x870e7f0, mask=32, region=..., data=...) at ../../kwin/effects.cpp:173