Bug 261664

Summary: Digikam crashes while using gimp
Product: digikam Reporter: Paul M. Summitt <psummitt>
Component: Thumbs-EngineAssignee: Digikam Developers <digikam-bugs-null>
Status: RESOLVED FIXED    
Severity: crash CC: caulier.gilles
Priority: NOR    
Version: 1.5.0   
Target Milestone: ---   
Platform: Fedora RPMs   
OS: Linux   
Latest Commit: Version Fixed In: 6.3.0

Description Paul M. Summitt 2010-12-30 22:28:59 UTC
Application: digikam (1.5.0)
KDE Platform Version: 4.5.4 (KDE 4.5.4)
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-66.fc13.i686 i686
Distribution: "Fedora release 13 (Goddard)"

-- Information about the crash:
- What I was doing when the application crashed:  I was saving a file in GIMP that I had previously edited in Digikam

-- Backtrace:
Application: digiKam (digikam), signal: Aborted
[Current thread is 1 (Thread 0xb7866b40 (LWP 31837))]

Thread 9 (Thread 0xb57dab70 (LWP 31841)):
#0  0x002c6416 in __kernel_vsyscall ()
#1  0x00a4d22c in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:169
#2  0x03f8a6af in wait (this=0x89cb628, mutex=0x89cb624, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#3  QWaitCondition::wait (this=0x89cb628, mutex=0x89cb624, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#4  0x082d1724 in Digikam::ScanController::run (this=0x8982720) at /usr/src/debug/digikam-1.5.0/digikam/scancontroller.cpp:515
#5  0x03f8974f in QThreadPrivate::start (arg=0x8982720) at thread/qthread_unix.cpp:248
#6  0x00a49919 in start_thread (arg=0xb57dab70) at pthread_create.c:301
#7  0x00966d4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 8 (Thread 0xb4bffb70 (LWP 31876)):
#0  0x00a7fdb6 in clock_gettime (clock_id=1, tp=0xb4bfef48) at ../sysdeps/unix/clock_gettime.c:100
#1  0x040a06cb in qt_gettime () at kernel/qcore_unix.cpp:111
#2  0x040a4db6 in QTimerInfoList::updateCurrentTime (this=0xb4001adc) at kernel/qeventdispatcher_unix.cpp:340
#3  0x040a4dfb in QTimerInfoList::timerWait (this=0xb4001adc, tm=...) at kernel/qeventdispatcher_unix.cpp:443
#4  0x040a3688 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb4bff05c) at kernel/qeventdispatcher_glib.cpp:136
#5  0x040a371d in timerSourcePrepare (source=0xb4001aa8, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#6  0x00affa6a in IA__g_main_context_prepare (context=<value optimized out>, priority=0xb4bff0dc) at gmain.c:2280
#7  0x00affe81 in g_main_context_iterate (context=0xb4000478, block=1, dispatch=1, self=0xb4001ef0) at gmain.c:2571
#8  0x00b00449 in IA__g_main_context_iteration (context=0xb4000478, may_block=1) at gmain.c:2654
#9  0x040a347f in QEventDispatcherGlib::processEvents (this=0xb4001ed0, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#10 0x0407980a in QEventLoop::processEvents (this=0xb4bff220, flags=...) at kernel/qeventloop.cpp:149
#11 0x04079b4a in QEventLoop::exec (this=0xb4bff220, flags=...) at kernel/qeventloop.cpp:201
#12 0x03f872fe in QThread::exec (this=0x8c240a0) at thread/qthread.cpp:487
#13 0x0316f55e in Digikam::ImageFilterModelWorker::Thread::run (this=0x8c240a0) at /usr/src/debug/digikam-1.5.0/libs/models/imagefiltermodelthreads.h:66
#14 0x03f8974f in QThreadPrivate::start (arg=0x8c240a0) at thread/qthread_unix.cpp:248
#15 0x00a49919 in start_thread (arg=0xb4bffb70) at pthread_create.c:301
#16 0x00966d4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 7 (Thread 0xb3bffb70 (LWP 31877)):
#0  0x00affaeb in next_valid_source (context=<value optimized out>, priority=0xb3bff0dc) at gmain.c:2004
#1  IA__g_main_context_prepare (context=<value optimized out>, priority=0xb3bff0dc) at gmain.c:2305
#2  0x00affe81 in g_main_context_iterate (context=0x8c22d88, block=1, dispatch=1, self=0x8c232e0) at gmain.c:2571
#3  0x00b00449 in IA__g_main_context_iteration (context=0x8c22d88, may_block=1) at gmain.c:2654
#4  0x040a347f in QEventDispatcherGlib::processEvents (this=0x8c23330, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#5  0x0407980a in QEventLoop::processEvents (this=0xb3bff220, flags=...) at kernel/qeventloop.cpp:149
#6  0x04079b4a in QEventLoop::exec (this=0xb3bff220, flags=...) at kernel/qeventloop.cpp:201
#7  0x03f872fe in QThread::exec (this=0x8c23398) at thread/qthread.cpp:487
#8  0x0316f55e in Digikam::ImageFilterModelWorker::Thread::run (this=0x8c23398) at /usr/src/debug/digikam-1.5.0/libs/models/imagefiltermodelthreads.h:66
#9  0x03f8974f in QThreadPrivate::start (arg=0x8c23398) at thread/qthread_unix.cpp:248
#10 0x00a49919 in start_thread (arg=0xb3bffb70) at pthread_create.c:301
#11 0x00966d4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 6 (Thread 0xa6b28b70 (LWP 31885)):
#0  g_main_context_iterate (context=0xa4c490, block=1, dispatch=1, self=0xb4003c98) at gmain.c:2588
#1  0x00b00449 in IA__g_main_context_iteration (context=0xb4004868, may_block=1) at gmain.c:2654
#2  0x040a347f in QEventDispatcherGlib::processEvents (this=0xb4004018, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#3  0x0407980a in QEventLoop::processEvents (this=0xa6b281e0, flags=...) at kernel/qeventloop.cpp:149
#4  0x04079b4a in QEventLoop::exec (this=0xa6b281e0, flags=...) at kernel/qeventloop.cpp:201
#5  0x03f872fe in QThread::exec (this=0x8ff89d8) at thread/qthread.cpp:487
#6  0x0405ba1c in QInotifyFileSystemWatcherEngine::run (this=0x8ff89d8) at io/qfilesystemwatcher_inotify.cpp:248
#7  0x03f8974f in QThreadPrivate::start (arg=0x8ff89d8) at thread/qthread_unix.cpp:248
#8  0x00a49919 in start_thread (arg=0xa6b28b70) at pthread_create.c:301
#9  0x00966d4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 5 (Thread 0xab52ab70 (LWP 31892)):
#0  0x00a4c4bd in __pthread_mutex_unlock_usercnt (mutex=0xb4c4fd54) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0xb4c4fd54) at pthread_mutex_unlock.c:290
#2  0x00aff734 in IA__g_main_context_check (context=0xb4c4fd50, max_priority=2147483647, fds=0xaa2cc020, n_fds=1) at gmain.c:2467
#3  0x00b00066 in g_main_context_iterate (context=0xa4c490, block=1, dispatch=1, self=0xb3e34c60) at gmain.c:2588
#4  0x00b00449 in IA__g_main_context_iteration (context=0xb4c4fd50, may_block=1) at gmain.c:2654
#5  0x040a347f in QEventDispatcherGlib::processEvents (this=0xb4c4c7f0, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#6  0x0407980a in QEventLoop::processEvents (this=0xab52a1e0, flags=...) at kernel/qeventloop.cpp:149
#7  0x04079b4a in QEventLoop::exec (this=0xab52a1e0, flags=...) at kernel/qeventloop.cpp:201
#8  0x03f872fe in QThread::exec (this=0x92294f8) at thread/qthread.cpp:487
#9  0x0405ba1c in QInotifyFileSystemWatcherEngine::run (this=0x92294f8) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x03f8974f in QThreadPrivate::start (arg=0x92294f8) at thread/qthread_unix.cpp:248
#11 0x00a49919 in start_thread (arg=0xab52ab70) at pthread_create.c:301
#12 0x00966d4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 4 (Thread 0xa96feb70 (LWP 31991)):
#0  0x00a7fdb6 in clock_gettime (clock_id=1, tp=0xa96fdf08) at ../sysdeps/unix/clock_gettime.c:100
#1  0x040a06cb in qt_gettime () at kernel/qcore_unix.cpp:111
#2  0x040a4db6 in QTimerInfoList::updateCurrentTime (this=0xa9bcfc84) at kernel/qeventdispatcher_unix.cpp:340
#3  0x040a4dfb in QTimerInfoList::timerWait (this=0xa9bcfc84, tm=...) at kernel/qeventdispatcher_unix.cpp:443
#4  0x040a3688 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xa96fe01c) at kernel/qeventdispatcher_glib.cpp:136
#5  0x040a371d in timerSourcePrepare (source=0xa9bcfc50, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#6  0x00affa6a in IA__g_main_context_prepare (context=<value optimized out>, priority=0xa96fe09c) at gmain.c:2280
#7  0x00affe81 in g_main_context_iterate (context=0xa9936858, block=1, dispatch=1, self=0xa9c4cb38) at gmain.c:2571
#8  0x00b00449 in IA__g_main_context_iteration (context=0xa9936858, may_block=1) at gmain.c:2654
#9  0x040a347f in QEventDispatcherGlib::processEvents (this=0xb3f8ddb8, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#10 0x0407980a in QEventLoop::processEvents (this=0xa96fe1e0, flags=...) at kernel/qeventloop.cpp:149
#11 0x04079b4a in QEventLoop::exec (this=0xa96fe1e0, flags=...) at kernel/qeventloop.cpp:201
#12 0x03f872fe in QThread::exec (this=0xaef06a8) at thread/qthread.cpp:487
#13 0x0405ba1c in QInotifyFileSystemWatcherEngine::run (this=0xaef06a8) at io/qfilesystemwatcher_inotify.cpp:248
#14 0x03f8974f in QThreadPrivate::start (arg=0xaef06a8) at thread/qthread_unix.cpp:248
#15 0x00a49919 in start_thread (arg=0xa96feb70) at pthread_create.c:301
#16 0x00966d4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 3 (Thread 0x9f043b70 (LWP 25195)):
#0  0x002c6416 in __kernel_vsyscall ()
#1  0x00a4d22c in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:169
#2  0x03f88dc2 in QMutexPrivate::wait (this=0x89eb010, timeout=-1) at thread/qmutex_unix.cpp:84
#3  0x03f851ba in QMutex::lock (this=0x89f52cc) at thread/qmutex.cpp:205
#4  0x07cb7b39 in Digikam::LoadingCache::CacheLock::CacheLock (this=0x9f043160, cache=0x89fb2c8) at /usr/src/debug/digikam-1.5.0/libs/threadimageio/loadingcache.cpp:461
#5  0x07cd0c56 in Digikam::ThumbnailLoadingTask::execute (this=0xc170fd0) at /usr/src/debug/digikam-1.5.0/libs/threadimageio/thumbnailtask.cpp:136
#6  0x07caef20 in Digikam::LoadSaveThread::run (this=0x8c7be68) at /usr/src/debug/digikam-1.5.0/libs/threadimageio/loadsavethread.cpp:116
#7  0x07cef6e6 in Digikam::DynamicThread::DynamicThreadPriv::run (this=0x8c7eee0) at /usr/src/debug/digikam-1.5.0/libs/threads/dynamicthread.cpp:240
#8  0x03f7ffb9 in QThreadPoolThread::run (this=0xac19538) at concurrent/qthreadpool.cpp:106
#9  0x03f8974f in QThreadPrivate::start (arg=0xac19538) at thread/qthread_unix.cpp:248
#10 0x00a49919 in start_thread (arg=0x9f043b70) at pthread_create.c:301
#11 0x00966d4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 2 (Thread 0x9d0ffb70 (LWP 25196)):
[KCrash Handler]
#7  0x002c6416 in __kernel_vsyscall ()
#8  0x008b4bd1 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#9  0x008b64aa in abort () at abort.c:92
#10 0x003cb2c7 in __gnu_cxx::__verbose_terminate_handler () at ../../../../libstdc++-v3/libsupc++/vterminate.cc:93
#11 0x003c9126 in __cxxabiv1::__terminate (handler=0x3cb160 <__gnu_cxx::__verbose_terminate_handler()>) at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:38
#12 0x003c9163 in std::terminate () at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:48
#13 0x003c9d56 in __cxxabiv1::__cxa_pure_virtual () at ../../../../libstdc++-v3/libsupc++/pure.cc:50
#14 0x07cba7bc in Digikam::LoadingCache::notifyNewLoadingProcess (this=0x89fb2c8, process=0xc171290, description=...) at /usr/src/debug/digikam-1.5.0/libs/threadimageio/loadingcache.cpp:169
#15 0x07cd0b86 in Digikam::ThumbnailLoadingTask::execute (this=0xc1711b0) at /usr/src/debug/digikam-1.5.0/libs/threadimageio/thumbnailtask.cpp:115
#16 0x07caef20 in Digikam::LoadSaveThread::run (this=0x8c7be68) at /usr/src/debug/digikam-1.5.0/libs/threadimageio/loadsavethread.cpp:116
#17 0x07cef6e6 in Digikam::DynamicThread::DynamicThreadPriv::run (this=0x8c7eee0) at /usr/src/debug/digikam-1.5.0/libs/threads/dynamicthread.cpp:240
#18 0x03f7ffb9 in QThreadPoolThread::run (this=0xad8a650) at concurrent/qthreadpool.cpp:106
#19 0x03f8974f in QThreadPrivate::start (arg=0xad8a650) at thread/qthread_unix.cpp:248
#20 0x00a49919 in start_thread (arg=0x9d0ffb70) at pthread_create.c:301
#21 0x00966d4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 1 (Thread 0xb7866b40 (LWP 31837)):
#0  0x002c6416 in __kernel_vsyscall ()
#1  0x00a4d22c in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:169
#2  0x03f8a6af in wait (this=0x8c78d64, mutex=0x8c78d50, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#3  QWaitCondition::wait (this=0x8c78d64, mutex=0x8c78d50, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#4  0x03f8013f in QThreadPoolPrivate::waitForDone (this=0x8c78d00) at concurrent/qthreadpool.cpp:295
#5  0x03f805b1 in QThreadPool::~QThreadPool (this=0x8c245c0, __in_chrg=<value optimized out>) at concurrent/qthreadpool.cpp:428
#6  0x03f80613 in QThreadPool::~QThreadPool (this=0x8c245c0, __in_chrg=<value optimized out>) at concurrent/qthreadpool.cpp:430
#7  0x04089fbf in QObjectPrivate::deleteChildren (this=0x8c23c20) at kernel/qobject.cpp:1986
#8  0x04091236 in QObject::~QObject (this=0x8c7b330, __in_chrg=<value optimized out>) at kernel/qobject.cpp:975
#9  0x07ced589 in Digikam::ThreadManager::~ThreadManager (this=0x8c7b330, __in_chrg=<value optimized out>) at /usr/src/debug/digikam-1.5.0/libs/threads/threadmanager.cpp:215
#10 0x07ced61b in ~ThreadManagerCreator () at /usr/src/debug/digikam-1.5.0/libs/threads/threadmanager.cpp:195
#11 destroy () at /usr/src/debug/digikam-1.5.0/libs/threads/threadmanager.cpp:196
#12 0x07bdea2c in KCleanUpGlobalStatic::~KCleanUpGlobalStatic (this=0x7eb4b18, __in_chrg=<value optimized out>) at /usr/include/kde4/kglobal.h:62
#13 0x008b829f in __run_exit_handlers (status=1) at exit.c:78
#14 exit (status=1) at exit.c:100
#15 0x01488811 in ?? () from /usr/lib/libgdk-x11-2.0.so.0
#16 0x05aee22b in KApplication::xioErrhandler (this=0xbfdc8b2c, dpy=0x8879dc0) at /usr/src/debug/kdelibs-4.5.4/kdeui/kernel/kapplication.cpp:416
#17 0x05aee267 in kde_xio_errhandler (dpy=0x8879dc0) at /usr/src/debug/kdelibs-4.5.4/kdeui/kernel/kapplication.cpp:125
#18 0x00c4da57 in _XIOError (dpy=0x8879dc0) at XlibInt.c:3138
#19 0x00c55a43 in process_responses (dpy=<value optimized out>, wait_for_first_event=0, current_error=0x0, current_request=0) at xcb_io.c:247
#20 0x00c563e7 in _XEventsQueued (dpy=0x8879dc0, mode=2) at xcb_io.c:263
#21 0x00c3e9fb in XEventsQueued (dpy=0x8879dc0, mode=2) at Pending.c:44
#22 0x04d76446 in x11EventSourceCheck (s=0x88783e8) at kernel/qguieventdispatcher_glib.cpp:87
#23 0x00aff739 in IA__g_main_context_check (context=0x88774f8, max_priority=2147483647, fds=0xb201190, n_fds=24) at gmain.c:2469
#24 0x00b00066 in g_main_context_iterate (context=0xa4c490, block=1, dispatch=1, self=0x8875420) at gmain.c:2588
#25 0x00b00449 in IA__g_main_context_iteration (context=0x88774f8, may_block=1) at gmain.c:2654
#26 0x040a3446 in QEventDispatcherGlib::processEvents (this=0x8847e40, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#27 0x04d76336 in QGuiEventDispatcherGlib::processEvents (this=0x8847e40, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#28 0x0407980a in QEventLoop::processEvents (this=0xbfdc8a14, flags=...) at kernel/qeventloop.cpp:149
#29 0x04079b4a in QEventLoop::exec (this=0xbfdc8a14, flags=...) at kernel/qeventloop.cpp:201
#30 0x0407d807 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#31 0x04cc7828 in QApplication::exec () at kernel/qapplication.cpp:3585
#32 0x0834201b in main (argc=) at /usr/src/debug/digikam-1.5.0/digikam/main.cpp:195

Possible duplicates by query: bug 255852, bug 255227, bug 255226, bug 255225, bug 247977.

Reported using DrKonqi
Comment 1 caulier.gilles 2010-12-30 22:48:35 UTC
Probably the same problem than 255852

Gilles Caulier

*** This bug has been marked as a duplicate of bug 255852 ***
Comment 2 caulier.gilles 2019-08-15 13:01:42 UTC
Fixed with bug #255852