Bug 261471

Summary: Crashes when trying to delete photos or albums
Product: digikam Reporter: Ivor <ivor>
Component: Albums-TrashAssignee: Digikam Developers <digikam-bugs-null>
Status: RESOLVED FIXED    
Severity: major CC: caulier.gilles, david.claval, Julien
Priority: HI    
Version: 1.7.0   
Target Milestone: ---   
Platform: Microsoft Windows   
OS: Microsoft Windows   
Latest Commit: Version Fixed In: 6.0.0

Description Ivor 2010-12-28 19:01:03 UTC
Version:           1.7.0 (using KDE 4.4.4) 
OS:                MS Windows

Trying to delete photos I get a message saying "The process for trash protocol died unexpectedly" When I close this Digikam sometimes crashes. When it does I get the following error report:

Problem signature:
  Problem Event Name:	APPCRASH
  Application Name:	digikam.exe
  Application Version:	0.0.0.0
  Application Timestamp:	4d131d0d
  Fault Module Name:	ntdll.dll
  Fault Module Version:	6.0.6000.16386
  Fault Module Timestamp:	4549bdc9
  Exception Code:	c00000fd
  Exception Offset:	00061019
  OS Version:	6.0.6000.2.0.0.768.2
  Locale ID:	2057
  Additional Information 1:	b290
  Additional Information 2:	6d226c5024c25824011163d9887025bc
  Additional Information 3:	de71
  Additional Information 4:	9dcc3e1d9ad134f527b10a715800a644



Reproducible: Always

Steps to Reproduce:
Open Digikam
Select one or more images using ctrl click
Delete Key
click Move to Trash
Deletion fails
 
I am unable to delete photos at all, the whole program crashing in intermittent

Actual Results:  
At best the deletion fails, at worst Digikam crashes

Expected Results:  
Deleted the photos 

Images are ORF olympus RAW images. Windows Vista Home Basic.
Comment 1 david.claval 2011-01-13 08:47:31 UTC
I find the same error with windows seven 64 bits and files issues of an canon powershot G12.

digikam 1.7.0
Comment 2 caulier.gilles 2011-01-13 08:55:57 UTC

*** This bug has been marked as a duplicate of bug 229465 ***
Comment 3 caulier.gilles 2018-08-30 14:03:52 UTC
Not reproducible with 6.0.0