Bug 261012

Summary: Plasma chrashes after Amarok chrash
Product: plasma4 Reporter: Dominic Lyons <domlyons>
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: andresbajotierra
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Dominic Lyons 2010-12-22 22:53:46 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.4 (KDE 4.5.4)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-24-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

Trying to let Amarok 2.3.2 play a song. Amarok status bar said something like "generating playlist" but it wasn't generated even after some waiting. Dynamich playlists are enabled.

Trying to choose the file I want to play again let Amarok crash.

- Unusual behavior I noticed:

Amarok crashed but Dr. Konqui wasn't opened, instead Plasma crashed, too.

-- Backtrace:
Application: Plasma-Arbeitsfläche (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f5ff3242780 (LWP 1922))]

Thread 2 (Thread 0x7f5fcbfff700 (LWP 1926)):
#0  0x00007f5ff2c5b203 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f5fe796c009 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f5fe796c45c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f5ff030b1e6 in QEventDispatcherGlib::processEvents (this=0x18ee3e0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#4  0x00007f5ff02dda02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007f5ff02dddec in QEventLoop::exec (this=0x7f5fcbffed90, flags=) at kernel/qeventloop.cpp:201
#6  0x00007f5ff01e82fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007f5ff02bd5f8 in QInotifyFileSystemWatcherEngine::run (this=0x19834a0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f5ff01eb27e in QThreadPrivate::start (arg=0x19834a0) at thread/qthread_unix.cpp:266
#9  0x00007f5feff60971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#10 0x00007f5ff2c6792d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f5ff3242780 (LWP 1922)):
[KCrash Handler]
#6  0x00007f5ff0f23925 in QString (this=0x365005c, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:727
#7  KIconEffect::fingerprint (this=0x365005c, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:158
#8  0x00007f5ff0f2a954 in KIconLoaderPrivate::makeCacheKey (this=<value optimized out>, name=<value optimized out>, group=KIconLoader::Desktop, overlays=<value optimized out>, size=<value optimized out>, state=0) at ../../kdeui/icons/kiconloader.cpp:777
#9  0x00007f5ff0f31934 in KIconLoader::loadIcon (this=0x3fc7590, _name=<value optimized out>, group=KIconLoader::Desktop, size=16, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1225
#10 0x00007f5ff0f285e0 in KIconEngine::pixmap (this=<value optimized out>, size=..., mode=<value optimized out>, state=<value optimized out>) at ../../kdeui/icons/kiconengine.cpp:93
#11 0x00007f5fef4dde55 in QIcon::pixmap (this=<value optimized out>, size=..., mode=QIcon::Normal, state=51723456) at image/qicon.cpp:676
#12 0x00007f5ff0f88a84 in KStyle::drawKStylePrimitive (this=0x101ae50, widgetType=<value optimized out>, primitive=<value optimized out>, opt=<value optimized out>, r=..., pal=..., flags=..., p=0x7fffb5a476c0, widget=0x3014a10, kOpt=0x7fffb5a46890) at ../../kdeui/kernel/kstyle.cpp:833
#13 0x00007f5fe2b2f4e2 in ?? () from /usr/lib/kde4/plugins/styles/oxygen.so
#14 0x00007f5ff0f918ca in KStyle::drawControl (this=0x101ae50, element=<value optimized out>, option=0x7fffb5a474d0, p=<value optimized out>, widget=0x3014a10) at ../../kdeui/kernel/kstyle.cpp:1976
#15 0x00007f5fe2b41afb in ?? () from /usr/lib/kde4/plugins/styles/oxygen.so
#16 0x00007f5fef891e54 in QMenu::paintEvent (this=0x3014a10, e=<value optimized out>) at widgets/qmenu.cpp:2176
#17 0x00007f5fef47ec2e in QWidget::event (this=0x3014a10, event=0x7fffb5a47f70) at kernel/qwidget.cpp:8333
#18 0x00007f5fef89190b in QMenu::event (this=0x3014a10, e=0x7fffb5a47f70) at widgets/qmenu.cpp:2410
#19 0x00007f5fef428fdc in QApplicationPrivate::notify_helper (this=0xfd50c0, receiver=0x3014a10, e=0x7fffb5a47f70) at kernel/qapplication.cpp:4396
#20 0x00007f5fef42eaed in QApplication::notify (this=0xfbc4c0, receiver=0x3014a10, e=0x7fffb5a47f70) at kernel/qapplication.cpp:4277
#21 0x00007f5ff0f7c576 in KApplication::notify (this=0xfbc4c0, receiver=0x3014a10, event=0x7fffb5a47f70) at ../../kdeui/kernel/kapplication.cpp:310
#22 0x00007f5ff02decdc in QCoreApplication::notifyInternal (this=0xfbc4c0, receiver=0x3014a10, event=0x7fffb5a47f70) at kernel/qcoreapplication.cpp:732
#23 0x00007f5fef48567d in sendSpontaneousEvent (this=0x3fa4140, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, backingStore=0x3075a20) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#24 QWidgetPrivate::drawWidget (this=0x3fa4140, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, backingStore=0x3075a20) at kernel/qwidget.cpp:5420
#25 0x00007f5fef659408 in QWidgetBackingStore::sync (this=0x3075a20) at painting/qbackingstore.cpp:1328
#26 0x00007f5fef659769 in QWidgetBackingStore::sync (this=0x3075a20, exposedWidget=0x3014a10, exposedRegion=...) at painting/qbackingstore.cpp:1130
#27 0x00007f5fef4a34da in QETWidget::translatePaintEvent (this=0x3014a10, event=<value optimized out>) at kernel/qapplication_x11.cpp:5117
#28 0x00007f5fef4b004b in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fffb5a48d70) at kernel/qapplication_x11.cpp:3436
#29 0x00007f5fef4dc0e2 in x11EventSourceDispatch (s=0xfd8980, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#30 0x00007f5fe7968342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#31 0x00007f5fe796c2a8 in ?? () from /lib/libglib-2.0.so.0
#32 0x00007f5fe796c45c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#33 0x00007f5ff030b193 in QEventDispatcherGlib::processEvents (this=0xfa1070, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#34 0x00007f5fef4dba4e in QGuiEventDispatcherGlib::processEvents (this=0x7fffb5a45d10, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#35 0x00007f5ff02dda02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#36 0x00007f5ff02dddec in QEventLoop::exec (this=0x7fffb5a490a0, flags=) at kernel/qeventloop.cpp:201
#37 0x00007f5fef88cec5 in QMenu::exec (this=0x3014a10, p=<value optimized out>, action=0x0) at widgets/qmenu.cpp:2054
#38 0x00007f5fd4e3e70f in ?? () from /usr/lib/kde4/plasma_applet_systemtray.so
#39 0x00007f5fd4e2ce74 in ?? () from /usr/lib/kde4/plasma_applet_systemtray.so
#40 0x00007f5ff02f6b27 in QMetaObject::activate (sender=0x32d9df0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3280
#41 0x00007f5ff09afa92 in KJob::result (this=0x7fffb5a45d10, _t1=0x32d9df0) at ./kjob.moc:194
#42 0x00007f5ff09afd30 in KJob::emitResult (this=0x32d9df0) at ../../kdecore/jobs/kjob.cpp:312
#43 0x00007f5fd4805c73 in ?? () from /usr/lib/kde4/plasma_engine_statusnotifieritem.so
#44 0x00007f5fd4805ce0 in ?? () from /usr/lib/kde4/plasma_engine_statusnotifieritem.so
#45 0x00007f5ff02f6b27 in QMetaObject::activate (sender=0x2725fa0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3280
#46 0x00007f5fd47ffc7f in ?? () from /usr/lib/kde4/plasma_engine_statusnotifieritem.so
#47 0x00007f5fd4804be4 in ?? () from /usr/lib/kde4/plasma_engine_statusnotifieritem.so
#48 0x00007f5ff02f6b27 in QMetaObject::activate (sender=0x23ddb10, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3280
#49 0x00007f5fe8c9189c in DBusMenuImporter::slotMenuAboutToShow() () from /usr/lib/libdbusmenu-qt.so.2
#50 0x00007f5fe8c92a5c in DBusMenuImporter::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libdbusmenu-qt.so.2
#51 0x00007f5ff02f6b27 in QMetaObject::activate (sender=0x3014a10, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3280
#52 0x00007f5fef88ef40 in QMenu::qt_metacall (this=0x3014a10, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffb5a49b60) at .moc/release-shared/moc_qmenu.cpp:97
#53 0x00007f5ff02e7bf9 in QMetaMethod::invoke (this=0x7fffb5a49e10, object=0x3014a10, connectionType=<value optimized out>, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1575
#54 0x00007f5ff02e9306 in QMetaObject::invokeMethod (obj=0x3014a10, member=<value optimized out>, type=<value optimized out>, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1148
#55 0x00007f5fe8c8c7c1 in DBusMenuImporter::updateMenu() () from /usr/lib/libdbusmenu-qt.so.2
#56 0x00007f5fd48011bb in ?? () from /usr/lib/kde4/plasma_engine_statusnotifieritem.so
#57 0x00007f5fd48072d8 in ?? () from /usr/lib/kde4/plasma_engine_statusnotifieritem.so
#58 0x00007f5ff2835271 in Plasma::ServiceJob::qt_metacall (this=0x32d9df0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=<value optimized out>) at ./servicejob.moc:72
#59 0x00007f5fd4805cc0 in ?? () from /usr/lib/kde4/plasma_engine_statusnotifieritem.so
#60 0x00007f5ff02f0bde in QObject::event (this=0x32d9df0, e=0x7fffb5a45d10) at kernel/qobject.cpp:1219
#61 0x00007f5fef428fdc in QApplicationPrivate::notify_helper (this=0xfd50c0, receiver=0x32d9df0, e=0x2796db0) at kernel/qapplication.cpp:4396
#62 0x00007f5fef42eaed in QApplication::notify (this=0xfbc4c0, receiver=0x32d9df0, e=0x2796db0) at kernel/qapplication.cpp:4277
#63 0x00007f5ff0f7c576 in KApplication::notify (this=0xfbc4c0, receiver=0x32d9df0, event=0x2796db0) at ../../kdeui/kernel/kapplication.cpp:310
#64 0x00007f5ff02decdc in QCoreApplication::notifyInternal (this=0xfbc4c0, receiver=0x32d9df0, event=0x2796db0) at kernel/qcoreapplication.cpp:732
#65 0x00007f5ff02e1c22 in sendEvent (receiver=0x0, event_type=<value optimized out>, data=0xfa1560) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#66 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0xfa1560) at kernel/qcoreapplication.cpp:1373
#67 0x00007f5ff030b653 in sendPostedEvents (s=0xfd8760) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#68 postEventSourceDispatch (s=0xfd8760) at kernel/qeventdispatcher_glib.cpp:277
#69 0x00007f5fe7968342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#70 0x00007f5fe796c2a8 in ?? () from /lib/libglib-2.0.so.0
#71 0x00007f5fe796c45c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#72 0x00007f5ff030b193 in QEventDispatcherGlib::processEvents (this=0xfa1070, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#73 0x00007f5fef4dba4e in QGuiEventDispatcherGlib::processEvents (this=0x7fffb5a45d10, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#74 0x00007f5ff02dda02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#75 0x00007f5ff02dddec in QEventLoop::exec (this=0x7fffb5a4b0a0, flags=) at kernel/qeventloop.cpp:201
#76 0x00007f5ff02e1ebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#77 0x00007f5ff2f3eba3 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#78 0x00007f5ff2b9fd8e in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fffb5a4b478) at libc-start.c:226
#79 0x0000000000400669 in _start ()

This bug may be a duplicate of or related to bug 226596, bug 258706.

Possible duplicates by query: bug 258706, bug 254590, bug 251227, bug 248298, bug 247542.

Reported using DrKonqi
Comment 1 Dario Andres 2010-12-23 00:00:27 UTC
[Comment from a bug triager]
This issue is now being tracked at bug 258706. Merging. Thanks

*** This bug has been marked as a duplicate of bug 258706 ***