Bug 259869

Summary: crash when scanning for thumbnails
Product: digikam Reporter: Jon Nelson <jnelson-kde>
Component: Thumbs-EngineAssignee: Digikam Developers <digikam-bugs-null>
Status: RESOLVED FIXED    
Severity: crash CC: caulier.gilles
Priority: NOR    
Version: 1.5.0   
Target Milestone: ---   
Platform: openSUSE RPMs   
OS: Linux   
Latest Commit: Version Fixed In: 6.3.0

Description Jon Nelson 2010-12-14 18:17:57 UTC
Application: digikam (1.5.0)
KDE Platform Version: 4.5.4 (KDE 4.5.4) "release 9"
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-0.5-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

I was scanning for new thumbnails.


- Custom settings of the application:

I had migrated to the mysql internal storage engine.

The crash happens every single time.
I'll try again w/sqlite.

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
pthread_cond_wait@@GLIBC_2.3.2 ()
    at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
	in ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S
[Current thread is 1 (Thread 0x7fa41c9bf7c0 (LWP 31748))]

Thread 11 (Thread 0x7fa404e80710 (LWP 31750)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fa417c502bb in wait (this=<value optimized out>, mutex=0xbd8680, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0xbd8680, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00000000006b5a0d in Digikam::ScanController::run (this=0xc4bb10) at /usr/src/debug/digikam-1.5.0/digikam/scancontroller.cpp:515
#4  0x00007fa417c4fbf5 in QThreadPrivate::start (arg=0xc4bb10) at thread/qthread_unix.cpp:248
#5  0x00007fa41431ca4f in start_thread (arg=0x7fa404e80710) at pthread_create.c:297
#6  0x00007fa4162eb82d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 10 (Thread 0x7fa3fffff710 (LWP 31763)):
#0  0xffffffffff600177 in ?? ()
#1  0x00007fffdd5ff7a1 in ?? ()
#2  0x00007fa40f1062a3 in clock_gettime (clock_id=1, tp=0x7fa3ffffeb10) at ../sysdeps/unix/clock_gettime.c:100
#3  0x00007fa417d5c5ff in qt_gettime () at kernel/qcore_unix.cpp:111
#4  0x00007fa417d5ff4d in QTimerInfoList::updateCurrentTime (this=0xeb6ce0) at kernel/qeventdispatcher_unix.cpp:340
#5  0x00007fa417d602d5 in QTimerInfoList::timerWait (this=0xeb6ce0, tm=...) at kernel/qeventdispatcher_unix.cpp:443
#6  0x00007fa417d5ef0c in timerSourcePrepareHelper (src=<value optimized out>, timeout=0x7fa3ffffec2c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007fa417d5efb5 in timerSourcePrepare (source=<value optimized out>, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007fa40ee5df7f in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#9  0x00007fa40ee5ee69 in ?? () from /usr/lib64/libglib-2.0.so.0
#10 0x00007fa40ee5f510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#11 0x00007fa417d5f6d6 in QEventDispatcherGlib::processEvents (this=0xd7a700, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#12 0x00007fa417d36292 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007fa417d36495 in QEventLoop::exec (this=0x7fa3ffffedc0, flags=...) at kernel/qeventloop.cpp:201
#14 0x00007fa417c4d2cf in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#15 0x00007fa417c4fbf5 in QThreadPrivate::start (arg=0xf39e70) at thread/qthread_unix.cpp:248
#16 0x00007fa41431ca4f in start_thread (arg=0x7fa3fffff710) at pthread_create.c:297
#17 0x00007fa4162eb82d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#18 0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7fa3fefea710 (LWP 31764)):
#0  0x00007fa41431f0b4 in __pthread_mutex_lock (mutex=0xc197f8) at pthread_mutex_lock.c:61
#1  0x00007fa40ee5e742 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fa40ee5eff2 in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fa40ee5f510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007fa417d5f6d6 in QEventDispatcherGlib::processEvents (this=0xce8050, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#5  0x00007fa417d36292 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fa417d36495 in QEventLoop::exec (this=0x7fa3fefe9dc0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007fa417c4d2cf in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#8  0x00007fa417c4fbf5 in QThreadPrivate::start (arg=0xd4a970) at thread/qthread_unix.cpp:248
#9  0x00007fa41431ca4f in start_thread (arg=0x7fa3fefea710) at pthread_create.c:297
#10 0x00007fa4162eb82d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7fa3fe1b9710 (LWP 31765)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fa417c502bb in wait (this=<value optimized out>, mutex=0x7fa40009e2c8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x7fa40009e2c8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007fa419e84d58 in Digikam::ParkingThread::run (this=0x7fa40009e2b0) at /usr/src/debug/digikam-1.5.0/libs/threads/threadmanager.cpp:101
#4  0x00007fa417c4fbf5 in QThreadPrivate::start (arg=0x7fa40009e2b0) at thread/qthread_unix.cpp:248
#5  0x00007fa41431ca4f in start_thread (arg=0x7fa3fe1b9710) at pthread_create.c:297
#6  0x00007fa4162eb82d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7fa3fd9b8710 (LWP 31766)):
#0  0x00007fa417d5f15e in socketNotifierSourceCheck (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:99
#1  0x00007fa40ee5e718 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fa40ee5eff2 in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fa40ee5f510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007fa417d5f6d6 in QEventDispatcherGlib::processEvents (this=0xd0c410, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#5  0x00007fa417d36292 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fa417d36495 in QEventLoop::exec (this=0x7fa3fd9b7dc0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007fa417c4d2cf in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#8  0x00007fa417c4fbf5 in QThreadPrivate::start (arg=0xc16720) at thread/qthread_unix.cpp:248
#9  0x00007fa41431ca4f in start_thread (arg=0x7fa3fd9b8710) at pthread_create.c:297
#10 0x00007fa4162eb82d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7fa3fd1b7710 (LWP 31767)):
#0  0x00007fa41431f0b4 in __pthread_mutex_lock (mutex=0xb1e5e8) at pthread_mutex_lock.c:61
#1  0x00007fa40ee5e8e4 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fa40ee5f270 in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fa40ee5f510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007fa417d5f6d6 in QEventDispatcherGlib::processEvents (this=0xd44e40, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#5  0x00007fa417d36292 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fa417d36495 in QEventLoop::exec (this=0x7fa3fd1b6dc0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007fa417c4d2cf in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#8  0x00007fa417c4fbf5 in QThreadPrivate::start (arg=0xdf6b80) at thread/qthread_unix.cpp:248
#9  0x00007fa41431ca4f in start_thread (arg=0x7fa3fd1b7710) at pthread_create.c:297
#10 0x00007fa4162eb82d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7fa3bd6d0710 (LWP 31782)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fa3f9c2bd02 in Thread () from /usr/lib64/libvlccore.so.4
#2  0x00007fa41431ca4f in start_thread (arg=0x7fa3bd6d0710) at pthread_create.c:297
#3  0x00007fa4162eb82d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fa3bd4ce710 (LWP 31788)):
#0  0x00007fa40ee5df4b in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#1  0x00007fa40ee5ee69 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fa40ee5f510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fa417d5f6d6 in QEventDispatcherGlib::processEvents (this=0x1a06250, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00007fa417d36292 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fa417d36495 in QEventLoop::exec (this=0x7fa3bd4cdd80, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fa417c4d2cf in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007fa417d18458 in QInotifyFileSystemWatcherEngine::run (this=0x19d5bf0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fa417c4fbf5 in QThreadPrivate::start (arg=0x19d5bf0) at thread/qthread_unix.cpp:248
#9  0x00007fa41431ca4f in start_thread (arg=0x7fa3bd4ce710) at pthread_create.c:297
#10 0x00007fa4162eb82d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fa3b6a23710 (LWP 31796)):
#0  0x00007fa4162e26b3 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fa40ee5efd4 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fa40ee5f510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fa417d5f6d6 in QEventDispatcherGlib::processEvents (this=0x2daa610, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00007fa417d36292 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fa417d36495 in QEventLoop::exec (this=0x7fa3b6a22d80, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fa417c4d2cf in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007fa417d18458 in QInotifyFileSystemWatcherEngine::run (this=0x2da9500) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fa417c4fbf5 in QThreadPrivate::start (arg=0x2da9500) at thread/qthread_unix.cpp:248
#9  0x00007fa41431ca4f in start_thread (arg=0x7fa3b6a23710) at pthread_create.c:297
#10 0x00007fa4162eb82d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fa3b5a21710 (LWP 912)):
[KCrash Handler]
#6  0x00007fa419e69aaf in Digikam::ThumbnailLoadingTask::execute (this=0x5fcf6f0) at /usr/src/debug/digikam-1.5.0/libs/threadimageio/thumbnailtask.cpp:94
#7  0x00007fa419e49286 in Digikam::LoadSaveThread::run (this=0x2d03f80) at /usr/src/debug/digikam-1.5.0/libs/threadimageio/loadsavethread.cpp:116
#8  0x00007fa419e85c06 in Digikam::DynamicThread::DynamicThreadPriv::run (this=0x2d0a2b0) at /usr/src/debug/digikam-1.5.0/libs/threads/dynamicthread.cpp:240
#9  0x00007fa417c46035 in QThreadPoolThread::run (this=0x7fa3ac1ce360) at concurrent/qthreadpool.cpp:106
#10 0x00007fa417c4fbf5 in QThreadPrivate::start (arg=0x7fa3ac1ce360) at thread/qthread_unix.cpp:248
#11 0x00007fa41431ca4f in start_thread (arg=0x7fa3b5a21710) at pthread_create.c:297
#12 0x00007fa4162eb82d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fa41c9bf7c0 (LWP 31748)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fa417c4ed23 in QMutexPrivate::wait (this=0xb1b4c0, timeout=-1) at thread/qmutex_unix.cpp:84
#2  0x00007fa417c4b485 in QMutex::lock (this=0xbdaae0) at thread/qmutex.cpp:205
#3  0x00007fa419e67447 in Digikam::ThumbnailLoadThread::slotThumbnailLoaded (this=0x2d03f80, description=..., thumb=...) at /usr/src/debug/digikam-1.5.0/libs/threadimageio/thumbnailloadthread.cpp:557
#4  0x00007fa419e6784e in Digikam::ThumbnailLoadThread::slotThumbnailsAvailable (this=0x2d03f80) at /usr/src/debug/digikam-1.5.0/libs/threadimageio/thumbnailloadthread.cpp:526
#5  0x00007fa419e67a94 in Digikam::ThumbnailLoadThread::qt_metacall (this=0x2d03f80, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x2bea0c0)
    at /usr/src/debug/digikam-1.5.0/build/digikam/thumbnailloadthread.moc:93
#6  0x00007fa417d48509 in QObject::event (this=0x2d03f80, e=0x2403700) at kernel/qobject.cpp:1248
#7  0x00007fa416eb24d4 in QApplicationPrivate::notify_helper (this=0xa9f070, receiver=0x2d03f80, e=0x2403700) at kernel/qapplication.cpp:4302
#8  0x00007fa416ebaaca in QApplication::notify (this=<value optimized out>, receiver=0x2d03f80, e=0x2403700) at kernel/qapplication.cpp:4185
#9  0x00007fa41865c816 in KApplication::notify (this=0x7fffdd54ba10, receiver=0x2d03f80, event=0x2403700) at /usr/src/debug/kdelibs-4.5.4/kdeui/kernel/kapplication.cpp:310
#10 0x00007fa417d36e4c in QCoreApplication::notifyInternal (this=0x7fffdd54ba10, receiver=0x2d03f80, event=0x2403700) at kernel/qcoreapplication.cpp:726
#11 0x00007fa417d3a5ba in sendEvent (receiver=0x0, event_type=0, data=0xa5c550) at kernel/qcoreapplication.h:215
#12 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xa5c550) at kernel/qcoreapplication.cpp:1367
#13 0x00007fa417d5f173 in sendPostedEvents (s=<value optimized out>) at kernel/qcoreapplication.h:220
#14 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#15 0x00007fa40ee5ea93 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#16 0x00007fa40ee5f270 in ?? () from /usr/lib64/libglib-2.0.so.0
#17 0x00007fa40ee5f510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#18 0x00007fa417d5f67f in QEventDispatcherGlib::processEvents (this=0xa62000, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#19 0x00007fa416f5314e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#20 0x00007fa417d36292 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#21 0x00007fa417d36495 in QEventLoop::exec (this=0x7fffdd54b850, flags=...) at kernel/qeventloop.cpp:201
#22 0x00007fa417d3a88b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#23 0x0000000000722fd5 in main (argc=11121920, argv=0x7fffdd54c100) at /usr/src/debug/digikam-1.5.0/digikam/main.cpp:195

Possible duplicates by query: bug 256481, bug 256161, bug 255930, bug 255256, bug 253728.

Reported using DrKonqi
Comment 1 caulier.gilles 2010-12-15 10:10:37 UTC

*** This bug has been marked as a duplicate of bug 255256 ***
Comment 2 caulier.gilles 2019-08-15 13:01:03 UTC
Fixed with bug #255256