Bug 259376

Summary: Plasma freezes after logging in
Product: [Plasma] plasma4 Reporter: xbonio
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED UNMAINTAINED    
Severity: normal CC: germano.massullo, ivan, notmart
Priority: NOR    
Version: 4.8.3   
Target Milestone: ---   
Platform: Unlisted Binaries   
OS: Linux   
Latest Commit: Version Fixed In:
Sentry Crash Report:
Attachments: plasma-desktop-appletsrc
plasma-desktop-appletsrc
Caterpillar's plasma-desktop-appletsrc

Description xbonio 2010-12-09 21:51:36 UTC
Version:           unspecified (using KDE 4.5.85) 
OS:                Linux

Plasma freezes every time I log in. It takes about 15 seconds and then plays startup sound, and everything is okay. Greets

Reproducible: Always
Comment 1 Marco Martin 2010-12-11 19:12:00 UTC
can you paste plasma-desktop-appletsrc?
Comment 2 xbonio 2010-12-11 22:23:41 UTC
Created attachment 54440 [details]
plasma-desktop-appletsrc
Comment 3 Marco Martin 2010-12-18 15:08:12 UTC
it's uhm.. empty?
is it just that file also on logins after the first?
Comment 4 Ivan D Vasin 2011-12-06 16:52:40 UTC
Plasma also freezes for me after login and also occasionally afterward (every half hour or so).  the whole panel and the whole desktop both freeze, as do all plasma bars (panels?  applets?), such as the Activity Manager.  i suspect it's all caused by bug #287002, which appears to be a fault of the network manager applet.

i'll attach my plasma-desktop-appletsrc for reference.
Comment 5 Ivan D Vasin 2011-12-06 16:53:45 UTC
Created attachment 66439 [details]
plasma-desktop-appletsrc
Comment 6 Germano Massullo 2011-12-06 17:47:50 UTC
in bug 287002 people think it is plasma nm related. I removed the plasma nm from KDE main panel and rebooted, but I still have this bug.
I also noticed that immediately after KDE login, if I switch off the laptop's wireless power switch, sometimes I get a complete and not recoverable computer freeze.
Comment 7 Germano Massullo 2011-12-06 18:03:06 UTC
Created attachment 66444 [details]
Caterpillar's plasma-desktop-appletsrc
Comment 8 Myriam Schweingruber 2012-05-21 22:19:30 UTC
Is this still valid with kde 4.8.3 or later?
Comment 9 Germano Massullo 2012-05-21 22:20:40 UTC
I confirm on KDE 4.8.3
Comment 10 Myriam Schweingruber 2012-05-21 23:13:53 UTC
Thank you for the fast feedback.
Comment 11 Nate Graham 2018-06-08 19:52:14 UTC
Hello!

This bug report was filed for KDE Plasma 4, which reached end-of-support status in August 2015. KDE Plasma 5's desktop shell has been almost completely rewritten for better performance and usability, so it is likely that this bug is already resolved in Plasma 5.

Accordingly, we hope you understand why we must close this bug report. If the issue described  here is still present in KDE Plasma 5.12 or later, please feel free to open a new ticket in the "plasmashell" product after reading https://community.kde.org/Get_Involved/Bug_Reporting

If you would like to get involved in KDE's bug triaging effort so that future mass bug closes like this are less likely, please read https://community.kde.org/Get_Involved#Bug_Triaging

Thanks for your understanding!

Nate Graham