Bug 259344

Summary: Erro de chamada
Product: [Plasma] kwin Reporter: Gerson Oaida <gerson.oaida>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description Gerson Oaida 2010-12-09 17:05:27 UTC
Application: kwin (4.5.1 (KDE 4.5.1))
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-22-generic-pae i686
Distribution: Ubuntu 10.10

-- Information about the crash:
Sempre que o kwin chama algum aplicativo, dolphi, adobe ou outros , aprsenta erro e fecha.

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Aborted
[Current thread is 1 (Thread 0xb31dd720 (LWP 2467))]

Thread 2 (Thread 0xa9bc5b70 (LWP 2739)):
#0  0xb3cdfe36 in clock_gettime (clock_id=-1278328844, tp=0xa9bc50f0) at ../sysdeps/unix/clock_gettime.c:100
#1  0xb66c350b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0xb679a6e5 in QTimerInfoList::updateCurrentTime (this=0x9e635b0) at kernel/qeventdispatcher_unix.cpp:339
#4  0xb679a72a in QTimerInfoList::timerWait (this=0x9e635b0, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb679bcab in QEventDispatcherUNIX::processEvents (this=0x9e82280, flags=...) at kernel/qeventdispatcher_unix.cpp:906
#6  0xb6768609 in QEventLoop::processEvents (this=0xa9bc5280, flags=) at kernel/qeventloop.cpp:149
#7  0xb6768a8a in QEventLoop::exec (this=0xa9bc5280, flags=...) at kernel/qeventloop.cpp:201
#8  0xb6664b7e in QThread::exec (this=0x9b10e08) at thread/qthread.cpp:490
#9  0xb674735b in QInotifyFileSystemWatcherEngine::run (this=0x9b10e08) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb6667df9 in QThreadPrivate::start (arg=0x9b10e08) at thread/qthread_unix.cpp:266
#11 0xb65f1cc9 in start_thread (arg=0xa9bc5b70) at pthread_create.c:304
#12 0xb75506ae in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb31dd720 (LWP 2467)):
[KCrash Handler]
#7  0xb7703424 in __kernel_vsyscall ()
#8  0xb74aa941 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#9  0xb74ade42 in abort () at abort.c:92
#10 0xb76da4af in KWin::EffectWindowImpl::unrefWindow (this=0x9fb7da0) at ../../kwin/effects.cpp:1289
#11 0xb0039d42 in KWin::DesktopGridEffect::finish (this=0x9c39418) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:1322
#12 0xb003c93b in KWin::DesktopGridEffect::prePaintScreen (this=0x9c39418, data=..., time=176) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:146
#13 0xb76dc85b in KWin::EffectsHandlerImpl::prePaintScreen (this=0x9bace18, data=..., time=176) at ../../kwin/effects.cpp:158
#14 0xb76c10f6 in KWin::Scene::paintScreen (this=0x9b70b70, mask=0xbfe26828, region=0xbfe268f4) at ../../kwin/scene.cpp:116
#15 0xb76cae7b in KWin::SceneXrender::paint (this=0x9b70b70, damage=..., toplevels=...) at ../../kwin/scene_xrender.cpp:278
#16 0xb76bbbe4 in KWin::Workspace::performCompositing (this=0x9b6a990) at ../../kwin/composite.cpp:454
#17 0xb762cc1e in KWin::Workspace::qt_metacall (this=0x9b6a990, _c=QMetaObject::InvokeMetaMethod, _id=190, _a=0xbfe26a1c) at ./workspace.moc:583
#18 0xb676f8ca in QMetaObject::metacall (object=0x9b6a990, cl=2467, idx=190, argv=0xbfe26a1c) at kernel/qmetaobject.cpp:237
#19 0xb67826ad in QMetaObject::activate (sender=0x9b6ac40, m=0xb689c5a4, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3280
#20 0xb67d41e7 in QTimer::timeout (this=0x9b6ac40) at .moc/release-shared/moc_qtimer.cpp:134
#21 0xb67881ce in QTimer::timerEvent (this=0x9b6ac40, e=0xbfe26f70) at kernel/qtimer.cpp:271
#22 0xb677c504 in QObject::event (this=0x9b6ac40, e=0x6) at kernel/qobject.cpp:1183
#23 0xb5c4efdc in QApplicationPrivate::notify_helper (this=0x9a5fff8, receiver=0x9b6ac40, e=0xbfe26f70) at kernel/qapplication.cpp:4396
#24 0xb5c5504e in QApplication::notify (this=0xbfe27274, receiver=0x9b6ac40, e=0xbfe26f70) at kernel/qapplication.cpp:3798
#25 0xb72a068a in KApplication::notify (this=0xbfe27274, receiver=0x9b6ac40, event=0xbfe26f70) at ../../kdeui/kernel/kapplication.cpp:310
#26 0xb7649aef in KWin::Application::notify (this=0xbfe27274, o=0x9b6ac40, e=0xbfe26f70) at ../../kwin/main.cpp:372
#27 0xb6769b3b in QCoreApplication::notifyInternal (this=0xbfe27274, receiver=0x9b6ac40, event=0xbfe26f70) at kernel/qcoreapplication.cpp:732
#28 0xb679bad6 in sendEvent (this=0x9a60780) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#29 QTimerInfoList::activateTimers (this=0x9a60780) at kernel/qeventdispatcher_unix.cpp:602
#30 0xb679bc37 in QEventDispatcherUNIX::processEvents (this=0x9a43968, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#31 0xb5d120d2 in QEventDispatcherX11::processEvents (this=0x9a43968, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#32 0xb6768609 in QEventLoop::processEvents (this=0xbfe271c4, flags=) at kernel/qeventloop.cpp:149
#33 0xb6768a8a in QEventLoop::exec (this=0xbfe271c4, flags=...) at kernel/qeventloop.cpp:201
#34 0xb676d00f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#35 0xb5c4de07 in QApplication::exec () at kernel/qapplication.cpp:3672
#36 0xb764bc54 in kdemain (argc=1, argv=0xbfe274d4) at ../../kwin/main.cpp:531
#37 0x080485ab in main (argc=1, argv=0xbfe274d4) at kwin_dummy.cpp:3

Possible duplicates by query: bug 259194, bug 255890, bug 254654, bug 248647, bug 246503.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2010-12-09 17:31:07 UTC

*** This bug has been marked as a duplicate of bug 244813 ***