Bug 258711

Summary: Connection to Open-Xchange server 5 (calendar) fails with KDE 4.7 and KDE 4.6
Product: [Applications] korganizer Reporter: Ralph Moenchmeyer <rm>
Component: generalAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED UNMAINTAINED    
Severity: normal CC: smartins
Priority: NOR    
Version: 4.6 beta2   
Target Milestone: ---   
Platform: OpenSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description Ralph Moenchmeyer 2010-12-03 17:43:28 UTC
Version:           4.6 beta2 (using KDE 4.5.80) 
OS:                Linux

I am running Opensuse 11.3, KDE 4.6 Beta 1 (RPMs from Opensuse Factory repository). 

With KDE 4.5.3 I had a working connection from Kontact/Korganizer to an Open-Xchange 5 server. 

With KDE 4.6 beta my trials to set up a conncetion to the Open-Xchange server fail. I tried both from the Akonadi configuration windows and the dialogs for setting up a calendar within Kontact/Korganizer. I tried a plain http-connection and a https-connection.

When clicking the button for a test of the connection a popup appears with the following error-message: 

Fehler beim Verbinden: rsion=
 
No error-messages on the command line. My login-data are valid. 

Anything I can do or test to resolve the problem ?  


   

Reproducible: Always

Steps to Reproduce:
Start Akonadi , start Kontact, change to Korganizer, open the settings dialog for the Calendar configuration of Korganizer, use the subwindow for adding Calendar resources, choose Open-Xchange, enter https://your_ox5_address, username and password 

Actual Results:  
Popup with error message "Fehler beim Verbinden: rsion="

Expected Results:  
Working connection of Akonadi with th OX5 calendar.
Comment 1 Ralph Moenchmeyer 2010-12-15 00:17:47 UTC
A similar problem arises of course for the OX5 addressbooks. None of them works any longer with KDE 4.6 Beta - as the connection from Kontact to the OX5 server cannot be established. 

Has anyone tested KDE 4.6 Beta 1 or 2 for an Open-Xchange 5 server ? 

As I said KDE 4.5 worked perfectly together with OX 5 .... I really hope that this will be true for KDE 4.6, too ......
Comment 2 Ralph Moenchmeyer 2010-12-16 16:38:41 UTC
I did some more experiments: 
I tried to connect to one of the calendars of the open-xchange server 5 via webdav.ical, i.e. the old method used before KDE 3.4.  

Serveraddress: 
http://myox5server/servlet/webdav.ical?calendarfolder=3046&enabledelete=yes

Then I succeeded in reading the calendarfolder specified.  

However, writing a new appointment/event to that calendar fails. Error message from Akonadi resource: 
 
Eine Ressource lässt sich am angegebenen Bestimmungsort nicht erstellen, bis eine oder mehrere Zwischenglieder (Ordner) erstellt wurden.

My free translation: A resource cannot be created at the specified location until some or more intermediate objects (folders) are generated. 

Furthermore, I tried to access the very same calendarfolder from a KDE 4.5 Korganizer with a standard OX-connection - no problems with reading and writing.
Comment 3 Sergio Martins 2010-12-31 01:01:44 UTC
(In reply to comment #0)
> Version:           4.6 beta2 (using KDE 4.5.80) 
> OS:                Linux
> 
> I am running Opensuse 11.3, KDE 4.6 Beta 1 (RPMs from Opensuse Factory
> repository). 
> 
> With KDE 4.5.3 I had a working connection from Kontact/Korganizer to an
> Open-Xchange 5 server. 
> 
> With KDE 4.6 beta my trials to set up a conncetion to the Open-Xchange server
> fail. I tried both from the Akonadi configuration windows and the dialogs for
> setting up a calendar within Kontact/Korganizer. I tried a plain
> http-connection and a https-connection.

Which resource? Did you add a "traditional" calendar resource, then choose open-xchange?
Comment 4 Ralph Moenchmeyer 2011-01-02 13:54:24 UTC
(In reply to comment #3)
> 
> Which resource? Did you add a "traditional" calendar resource, then choose
> open-xchange?

I am not at my flat at the moment. So I cannot check. I will look at it again when I am back. (Although this may become a laborious effort as I will have to reinstall 4.6 Beta 2 again and change from the Factory to the Unstable branches of Opensuse's repositories. In the Factory branches they apparently do not offer 4.6 rpm versions of Kontact at the moment. And I erased 4.6 completely on my test machine in a moment of frustration over other major problems. I'll see whether I can set up a virtual machine for an unstable system on one of my machines.)   

However, I remember quite clearly that I used the only chance that the configuration menus and popups of Kontact 4.6 Beta offered to connect to an Open-Xchange server. And this was a major and direct option - named Open-Xchange Server" - within the first level of the lists of options. It lead to a dialog where I could fill in the OX server adress, the user, the password. Which did not help much as described. 

An option to connect to an Open-Xchange server did not (!) appear within the subsection for "traditional" resources/calendars - though there was an impressive variety of other options and suboptions (Kolab, caldav, remote calendar files, etc.). I had expected an option for an Open-Xchange server there and looked carefully - but nothing - at least at the time when I experimented with 4.6, i.e. in the beginning of December.

Actually the lack of an Open-Xchange option within the traditional resource list made me try a conventional "webdav.ical" connection (see comment 2). 

But I will have a look at it again.
Comment 5 Ralph Moenchmeyer 2011-03-14 19:16:32 UTC
Hi, I just wanted to say that the problem was solved with KDE 4.6.1. 

I now can use the resources as expected. Calendar, addressbook, task folder, ....

Therefore, I change the status to solved.
Comment 6 Ralph Moenchmeyer 2011-07-31 09:51:23 UTC
I have to reopen this bug because of two reasons: 

Reason 1: 
My comment from 2011-03-14 was/is wrong and nonsense. I have checked my admin logs and the reason that everything seemed to work with KDE 4.6.1 was due to the fact that I had looked at an KDE installation from the Opensuse KDE Factory repository at that time. The KDEPIM, Kmail, Korganizer RPM versions in this repository were old ones - from KDE 4.4 actually and not the ones for KDE 4.6.1. (Although the rest was KDE 4.6.1 stuff). 

Opensuse had kept up this policy to mix older KDEPIM versions with new KDE versions for quite a long time.

Reason 2: 
I have now installed KDE 4.7.0. The RPMs are those of the present KDE Factory repository for Opensuse 11.4. However, here Korganizer actually is of version 4.7. The problem now is the same as before - a connection to an old OpenXchange 5 server fails. 

The reason - as far as I can see - is that you assume the mechanisms of an OpenXchange 6 server where the login is based on Ajax technologies. One can see that you add the user and passwort data to the server address in the form 

http://ox-server/ajax/login?action=login&name=rmo&password=%25gaupe%25

But there is no Ajax in OpenXchange 5 ! 

The result is the message "Fehler beim Verbinden: rsion="

Unfortunately, Akonadi does not provide any option to connect to older OpenXchange servers any more. 

It think it should be easy to remedy this as Kontact, Korganizer of version 4.4.x had a working interface. 

Or are there any other suggestions to get a KOrganizer connection to an old OpenXchange 5 working?
Comment 7 Ralph Moenchmeyer 2011-07-31 18:23:00 UTC
I should add that the connections to an OX 6 server indeed work as expected. I tested Kontact 4.7 together with an OX 6 this afternoon. 

Only the connections to OX servers of version 5 do not work.
Comment 8 Denis Kurz 2016-09-24 18:49:26 UTC
This bug has only been reported for versions before 4.14, which have been unsupported for at least two years now. Can anyone tell if this bug still present?

If noone confirms this bug for a Framework-based version of korganizer (version 5.0 or later, as part of KDE Applications 15.08 or later), it gets closed in about three months.
Comment 9 Denis Kurz 2017-01-07 21:36:14 UTC
Just as announced in my last comment, I close this bug. If you encounter it again in a recent version (at least 5.0 aka 15.08), please open a new one unless it already exists. Thank you for all your input.