Bug 256146

Summary: Error reset Task Windows panel
Product: [Plasma] plasma4 Reporter: William Diaz Pabón <widipa>
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: angelarose82, asraniel
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:
Sentry Crash Report:

Description William Diaz Pabón 2010-11-05 14:26:54 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-22-generic-pae i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
Error reset Task Windows panel, Kubuntu 10.10, lenguaje English

-- Backtrace:
Application: Plasma Workspace (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb3300720 (LWP 1460))]

Thread 3 (Thread 0xa9c69b70 (LWP 1465)):
#0  0xb3b8ae36 in clock_gettime () from /lib/librt.so.1
#1  0xb66d850b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0xb67af6e5 in QTimerInfoList::updateCurrentTime (this=0x88e15a4) at kernel/qeventdispatcher_unix.cpp:339
#4  0xb67af72a in QTimerInfoList::timerWait (this=0x88e15a4, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb67ad7a8 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xa9c690ac) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb67ad83d in timerSourcePrepare (source=0x0, timeout=0xb3b8eff4) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb3af8e6a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0xb3af9279 in ?? () from /lib/libglib-2.0.so.0
#9  0xb3af9848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0xb67ad59f in QEventDispatcherGlib::processEvents (this=0x88e0fb0, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#11 0xb677d609 in QEventLoop::processEvents (this=0xa9c69280, flags=) at kernel/qeventloop.cpp:149
#12 0xb677da8a in QEventLoop::exec (this=0xa9c69280, flags=...) at kernel/qeventloop.cpp:201
#13 0xb6679b7e in QThread::exec (this=0x88deef8) at thread/qthread.cpp:490
#14 0xb675c35b in QInotifyFileSystemWatcherEngine::run (this=0x88deef8) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb667cdf9 in QThreadPrivate::start (arg=0x88deef8) at thread/qthread_unix.cpp:266
#16 0xb6606cc9 in start_thread () from /lib/libpthread.so.0
#17 0xb77596ae in clone () from /lib/libc.so.6

Thread 2 (Thread 0xa8359b70 (LWP 3295)):
#0  0xb7861424 in __kernel_vsyscall ()
#1  0xb660b4dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb7766dad in pthread_cond_wait () from /lib/libc.so.6
#3  0xb4729877 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0xb48281a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#4  0xb47298c1 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0xb48281a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#5  0xb6606cc9 in start_thread () from /lib/libpthread.so.0
#6  0xb77596ae in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb3300720 (LWP 1460)):
[KCrash Handler]
#7  QMutex::lock (this=0x79) at thread/qmutex.cpp:151
#8  0xb6781724 in QCoreApplication::postEvent (receiver=0x9d13d40, event=0x94c3340, priority=0) at kernel/qcoreapplication.cpp:1141
#9  0xb6781aac in QCoreApplication::postEvent (receiver=0x9d13d40, event=0x94c3340) at kernel/qcoreapplication.cpp:1094
#10 0xb67902c4 in QObject::deleteLater (this=0x9d13d40) at kernel/qobject.cpp:2131
#11 0xb5d0b0bc in QX11Data::xdndHandleFinished (this=0x8149d18, xe=0xbfa2c8bc, passive=false) at kernel/qdnd_x11.cpp:1254
#12 0xb5ce5716 in QApplication::x11ClientMessage (this=0x813b338, w=0x95f0150, event=0xbfa2c8bc, passive_only=16) at kernel/qapplication_x11.cpp:3107
#13 0xb5cf6af4 in QApplication::x11ProcessEvent (this=0x813b338, event=0xbfa2c8bc) at kernel/qapplication_x11.cpp:3668
#14 0xb5d2636a in x11EventSourceDispatch (s=0x8149500, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#15 0xb3af5855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#16 0xb3af9668 in ?? () from /lib/libglib-2.0.so.0
#17 0xb3af9848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#18 0xb67ad565 in QEventDispatcherGlib::processEvents (this=0x8124ce8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#19 0xb5d25be5 in QGuiEventDispatcherGlib::processEvents (this=0x8124ce8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#20 0xb677d609 in QEventLoop::processEvents (this=0xbfa2cbb4, flags=) at kernel/qeventloop.cpp:149
#21 0xb677da8a in QEventLoop::exec (this=0xbfa2cbb4, flags=...) at kernel/qeventloop.cpp:201
#22 0xb678200f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#23 0xb5c62e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#24 0xb782a86e in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#25 0x080485bb in _start ()

Possible duplicates by query: bug 255482, bug 255338, bug 254704, bug 254578, bug 254435.

Reported using DrKonqi
Comment 1 Beat Wolf 2010-11-06 15:00:20 UTC

*** This bug has been marked as a duplicate of bug 255482 ***
Comment 2 Beat Wolf 2010-11-18 13:52:52 UTC
*** Bug 256616 has been marked as a duplicate of this bug. ***