Bug 256108

Summary: Dolphin crashes when opening mp3 file
Product: [Applications] dolphin Reporter: Ryan Kohn <ryan>
Component: generalAssignee: Peter Penz <peter.penz19>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: 16.12.2   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description Ryan Kohn 2010-11-05 03:01:24 UTC
Application: dolphin (1.4)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-25-generic i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
I navigated to an mp3 on my local hard drive. I clicked to open it (in default application Audacity) and Dolphin crashed. The file still opened successfully in Audacity.

 -- Backtrace:
Application: Dolphin (dolphin), signal: Aborted
[Current thread is 1 (Thread 0xb78c1710 (LWP 28639))]

Thread 4 (Thread 0xb60f4b70 (LWP 28657)):
#0  0x008aa422 in __kernel_vsyscall ()
#1  0x03d61d33 in ?? () from /lib/tls/i686/cmov/libc.so.6
#2  0x03cf8697 in ?? () from /lib/tls/i686/cmov/libc.so.6
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 3 (Thread 0xb47b9b70 (LWP 28659)):
#0  0x008aa422 in __kernel_vsyscall ()
#1  0x0055c342 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x03d61a34 in pthread_cond_timedwait () from /lib/tls/i686/cmov/libc.so.6
#3  0x04ab3ce7 in ?? () from /usr/lib/libxine.so.1
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 2 (Thread 0xb3fb8b70 (LWP 28661)):
[KCrash Handler]
#6  0x008aa422 in __kernel_vsyscall ()
#7  0x03cb1651 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0x03cb4a82 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0x03ce849d in ?? () from /lib/tls/i686/cmov/libc.so.6
#10 0x03cf2591 in ?? () from /lib/tls/i686/cmov/libc.so.6
#11 0x03cf3de8 in ?? () from /lib/tls/i686/cmov/libc.so.6
#12 0x03cf6ecd in free () from /lib/tls/i686/cmov/libc.so.6
#13 0x07669a5d in qFree (ptr=0xb5724ed0) at global/qmalloc.cpp:60
#14 0x076b92b0 in QString::free (d=0x0) at tools/qstring.cpp:1108
#15 0x003271cb in ~QString (this=0x8429eb8, uri=..., type=...) at /usr/include/qt4/QtCore/qstring.h:869
#16 Nepomuk::ResourceManagerPrivate::data (this=0x8429eb8, uri=..., type=...) at ../../../nepomuk/core/resourcemanager.cpp:72
#17 0x0033fdb3 in Resource (this=0xb3fb80d0, uri=..., type=...) at ../../../nepomuk/core/resource.cpp:91
#18 0x00312d59 in Nepomuk::Variant::toResource (this=0xb5724f8c) at ../../../nepomuk/core/variant.cpp:921
#19 0x0031247c in Nepomuk::Variant::toResourceList (this=0xb5724f8c) at ../../../nepomuk/core/variant.cpp:1162
#20 0x080a989f in KLoadMetaDataThread::formatValue (this=0x89fc228, value=...) at ../../../../apps/dolphin/src/panels/information/kloadmetadatathread.cpp:189
#21 0x080aa77c in KLoadMetaDataThread::run (this=0x89fc228) at ../../../../apps/dolphin/src/panels/information/kloadmetadatathread.cpp:121
#22 0x0766f32e in QThreadPrivate::start (arg=0x89fc228) at thread/qthread_unix.cpp:248
#23 0x0055796e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#24 0x03d54a4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb78c1710 (LWP 28639)):
#0  0x008aa422 in __kernel_vsyscall ()
#1  0x03d61d33 in ?? () from /lib/tls/i686/cmov/libc.so.6
#2  0x03cf8697 in ?? () from /lib/tls/i686/cmov/libc.so.6
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Possible duplicates by query: bug 254941, bug 236787, bug 220599, bug 214793.

Reported using DrKonqi
Comment 1 Peter Penz 2010-11-12 21:45:12 UTC

*** This bug has been marked as a duplicate of bug 235166 ***