Bug 255744

Summary: Akregator 1.6.2 crashes on start
Product: [Applications] akregator Reporter: Fabrice Laussy <fabrice.laussy>
Component: generalAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: kretz, mail, vcunat, yodayado
Priority: NOR    
Version: 4.9.2   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:
Sentry Crash Report:
Attachments: New crash information added by DrKonqi
New crash information added by DrKonqi

Description Fabrice Laussy 2010-10-31 15:22:12 UTC
Application: akregator (1.6.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-25-generic x86_64
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
Appears to run in list of processes but messes up the logo in taskbar and does not respond to mouse or anything.

No other components (like kmail, kontact, etc.) seem to crash in this way.

The crash can be reproduced every time.

 -- Backtrace:
Application: Akregator (akregator), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fc775929780 (LWP 4433))]

Thread 2 (Thread 0x7fc75b100710 (LWP 4434)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:211
#1  0x00007fc772fc2692 in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x1b881a0, time=30000) at thread/qwaitcondition_unix.cpp:85
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1b881a0, time=30000) at thread/qwaitcondition_unix.cpp:159
#3  0x00007fc772fb7a79 in QThreadPoolThread::run (this=0x1bbb840) at concurrent/qthreadpool.cpp:140
#4  0x00007fc772fc1775 in QThreadPrivate::start (arg=0x1bbb840) at thread/qthread_unix.cpp:248
#5  0x00007fc76da7d9ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#6  0x00007fc77250770d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fc775929780 (LWP 4433)):
[KCrash Handler]
#5  0x00007fc7619fa03f in c4_PtrArray::SetAt (this=0x1bdea80, ptr_=<value optimized out>) at ../../../../akregator/plugins/mk4storage/metakit/src/univ.inl:60
#6  c4_FormatB::Define (this=0x1bdea80, ptr_=<value optimized out>) at ../../../../akregator/plugins/mk4storage/metakit/src/format.cpp:410
#7  0x00007fc7619fbc0e in c4_HandlerSeq::Prepare (this=0x1b776b0, ptr_=0x7fff8ec386b8, selfDesc_=<value optimized out>) at ../../../../akregator/plugins/mk4storage/metakit/src/handler.cpp:321
#8  0x00007fc7619f9a6a in c4_FormatV::SetupAllSubviews (this=0x1b7cb10) at ../../../../akregator/plugins/mk4storage/metakit/src/format.cpp:963
#9  0x00007fc7619f9e56 in c4_FormatV::Get (this=0x1b73c10, index_=0, length_=@0x7fff8ec3874c) at ../../../../akregator/plugins/mk4storage/metakit/src/format.cpp:1027
#10 0x00007fc7619fb686 in c4_Handler::GetBytes (this=0x1b73c10, index_=-1899788888, buf_=..., copySmall_=false) at ../../../../akregator/plugins/mk4storage/metakit/src/handler.cpp:53
#11 0x00007fc761a08062 in c4_Sequence::Get (this=0x1b7b080, index_=0, propId_=<value optimized out>, buf_=...) at ../../../../akregator/plugins/mk4storage/metakit/src/viewx.cpp:319
#12 0x00007fc761a08b74 in c4_Reference::GetData (this=<value optimized out>) at ../../../../akregator/plugins/mk4storage/metakit/include/mk4.inl:421
#13 c4_ViewRef::operator c4_View (this=<value optimized out>) at ../../../../akregator/plugins/mk4storage/metakit/src/viewx.cpp:587
#14 0x00007fc761a03460 in c4_Storage::Description (this=<value optimized out>, name_=<value optimized out>) at ../../../../akregator/plugins/mk4storage/metakit/src/store.cpp:342
#15 0x00007fc761a03e79 in c4_Storage::GetAs (this=<value optimized out>, 
    description_=0x7fc761a12ce0 "articles[guid:S,title:S,hash:I,guidIsHash:I,guidIsPermaLink:I,description:S,link:S,comments:I,commentsLink:S,status:I,pubDate:I,tags[tag:S],hasEnclosure:I,enclosureUrl:S,enclosureType:S,enclosureLengt"...) at ../../../../akregator/plugins/mk4storage/metakit/src/store.cpp:261
#16 0x00007fc761a0d7f0 in FeedStorageMK4Impl (this=0x1abefc0, url=<value optimized out>, main=<value optimized out>) at ../../../../akregator/plugins/mk4storage/feedstoragemk4impl.cpp:154
#17 0x00007fc761a1111d in Akregator::Backend::StorageMK4Impl::StorageMK4ImplPrivate::createFeedStorage (this=0x16ef4a0, url=...) at ../../../../akregator/plugins/mk4storage/storagemk4impl.cpp:77
#18 0x00007fc76352af7c in Akregator::Feed::loadArticles (this=0x1be1a50) at ../../../akregator/src/feed.cpp:234
#19 0x00007fc76352e804 in Akregator::Feed::fromOPML (e=<value optimized out>, storage=<value optimized out>) at ../../../akregator/src/feed.cpp:174
#20 0x00007fc763539af5 in Akregator::FeedList::parseChildNodes (this=0x1b57790, node=<value optimized out>, parent=0x19b09b0) at ../../../akregator/src/feedlist.cpp:237
#21 0x00007fc763539d46 in Akregator::FeedList::parseChildNodes (this=0x1b57790, node=<value optimized out>, parent=0x183c260) at ../../../akregator/src/feedlist.cpp:255
#22 0x00007fc76353a566 in Akregator::FeedList::readFromOpml (this=0x1b57790, doc=<value optimized out>) at ../../../akregator/src/feedlist.cpp:295
#23 0x00007fc76357583b in Akregator::LoadFeedListCommand::Private::handleDocument (this=0x1545f80, doc=...) at ../../../akregator/src/loadfeedlistcommand.cpp:68
#24 0x00007fc7635762c3 in Akregator::LoadFeedListCommand::Private::doLoad (this=0x1545f80) at ../../../akregator/src/loadfeedlistcommand.cpp:173
#25 0x00007fc763576692 in Akregator::LoadFeedListCommand::qt_metacall (this=0x19c3d10, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff8ec39d80) at ./loadfeedlistcommand.moc:78
#26 0x00007fc7730c8e3f in QMetaObject::activate (sender=0x19abe90, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x1b73c00) at kernel/qobject.cpp:3293
#27 0x00007fc7730d065f in QSingleShotTimer::timerEvent (this=0x19abe90) at kernel/qtimer.cpp:308
#28 0x00007fc7730c5a63 in QObject::event (this=0x19abe90, e=0x7fff8ec3a4e0) at kernel/qobject.cpp:1212
#29 0x00007fc773a2a22c in QApplicationPrivate::notify_helper (this=0x1465a80, receiver=0x19abe90, e=0x7fff8ec3a4e0) at kernel/qapplication.cpp:4300
#30 0x00007fc773a306fb in QApplication::notify (this=0x7fff8ec3a7e0, receiver=0x19abe90, e=0x7fff8ec3a4e0) at kernel/qapplication.cpp:4183
#31 0x00007fc774735526 in KApplication::notify (this=0x7fff8ec3a7e0, receiver=0x19abe90, event=0x7fff8ec3a4e0) at ../../kdeui/kernel/kapplication.cpp:302
#32 0x00007fc7730b606c in QCoreApplication::notifyInternal (this=0x7fff8ec3a7e0, receiver=0x19abe90, event=0x7fff8ec3a4e0) at kernel/qcoreapplication.cpp:704
#33 0x00007fc7730e2d42 in QCoreApplication::sendEvent (this=0x146be80) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#34 QTimerInfoList::activateTimers (this=0x146be80) at kernel/qeventdispatcher_unix.cpp:603
#35 0x00007fc7730df824 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#36 0x00007fc76d1068c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#37 0x00007fc76d10a748 in ?? () from /lib/libglib-2.0.so.0
#38 0x00007fc76d10a8fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#39 0x00007fc7730df513 in QEventDispatcherGlib::processEvents (this=0x143b7a0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#40 0x00007fc773ada46e in QGuiEventDispatcherGlib::processEvents (this=0x1b73c10, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#41 0x00007fc7730b4992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#42 0x00007fc7730b4d6c in QEventLoop::exec (this=0x7fff8ec3a780, flags=) at kernel/qeventloop.cpp:201
#43 0x00007fc7730b8aab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#44 0x000000000040971d in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../akregator/src/main.cpp:103

This bug may be a duplicate of or related to bug 116482, bug 251398.

Possible duplicates by query: bug 253082, bug 251398, bug 246990, bug 246975, bug 244268.

Reported using DrKonqi
Comment 1 Marek Paƛnikowski 2010-11-30 15:02:30 UTC
Created attachment 53888 [details]
New crash information added by DrKonqi

akregator (1.6.0) on KDE Platform 4.5.80 (4.6 Beta1) using Qt 4.7.0

- What I was doing when the application crashed:
I was trying to open akregator after running "killall akregator" in krunner.

Using Chakra Linux.

-- Backtrace (Reduced):
#7  0xb11cbba2 in c4_PtrArray::SetAt (this=0x9bb2f68, ptr_=0xbfeeb39c) at /home/phil/buildroot/desktop-testing/kdepim/src/kdepim-4.5.80/akregator/plugins/mk4storage/metakit/src/univ.inl:60
#8  c4_FormatB::Define (this=0x9bb2f68, ptr_=0xbfeeb39c) at /home/phil/buildroot/desktop-testing/kdepim/src/kdepim-4.5.80/akregator/plugins/mk4storage/metakit/src/format.cpp:410
#9  0xb11ce7ca in c4_HandlerSeq::Prepare (this=0x99ef9c8, ptr_=0xbfeeb39c, selfDesc_=true)
    at /home/phil/buildroot/desktop-testing/kdepim/src/kdepim-4.5.80/akregator/plugins/mk4storage/metakit/src/handler.cpp:321
#10 0xb11d1d73 in c4_Persist::LoadAll (this=0x9bb2ae0) at /home/phil/buildroot/desktop-testing/kdepim/src/kdepim-4.5.80/akregator/plugins/mk4storage/metakit/src/persist.cpp:1026
#11 0xb11d5c3a in c4_Storage (this=0x9bb23b0, fname_=0x9bb2900 "/home/marek/.kde4/share/apps/akregator/Archive/http___www.chip.pl_RSS.mk4", mode_=1)
    at /home/phil/buildroot/desktop-testing/kdepim/src/kdepim-4.5.80/akregator/plugins/mk4storage/metakit/src/store.cpp:202
Comment 2 Simon 2010-12-11 09:36:49 UTC
Created attachment 54417 [details]
New crash information added by DrKonqi

akregator (1.6.5) on KDE Platform 4.5.4 (KDE 4.5.4) using Qt 4.7.1

- What I was doing when the application crashed: Just starting the application. It crashed aat the time it was showing the window.

-- Backtrace (Reduced):
#6  0x00007f10a2ab1dd3 in c4_PtrArray::SetAt (this=0x1a56e60, nIndex=<value optimized out>, newElement=0x147e9d0)
    at /usr/src/debug/kde-base/akregator-4.4.8/akregator-4.4.8/akregator/plugins/mk4storage/metakit/src/univ.inl:60
#7  0x00007f10a2abaac8 in c4_FormatB::Define (this=<value optimized out>, ptr_=<value optimized out>)
    at /usr/src/debug/kde-base/akregator-4.4.8/akregator-4.4.8/akregator/plugins/mk4storage/metakit/src/format.cpp:410
#8  0x00007f10a2abc5c1 in c4_HandlerSeq::Prepare (this=0x1a554f0, ptr_=0x7fff9ba32368, selfDesc_=<value optimized out>)
    at /usr/src/debug/kde-base/akregator-4.4.8/akregator-4.4.8/akregator/plugins/mk4storage/metakit/src/handler.cpp:321
#9  0x00007f10a2ab9594 in c4_FormatV::SetupAllSubviews (this=0x1a55390) at /usr/src/debug/kde-base/akregator-4.4.8/akregator-4.4.8/akregator/plugins/mk4storage/metakit/src/format.cpp:963
#10 0x00007f10a2ab9a66 in c4_FormatV::Get (this=0x1a56e60, index_=0, length_=@0x7fff9ba323cc)
    at /usr/src/debug/kde-base/akregator-4.4.8/akregator-4.4.8/akregator/plugins/mk4storage/metakit/src/format.cpp:1027
Comment 3 Matthias Kretz 2012-10-25 13:39:33 UTC
Hi, I have the same problem. I don't need to post my backtrace as it is the same as already posted here.

Before this problem started I had a GPU crash, which took down the X server. I was able to sync and unmount via SysRq keys, but I assume some file, that Akregator is now trying to parse, got into an unexpected state. I'll try to find the relevant file.
Comment 4 Matthias Kretz 2012-10-25 14:05:31 UTC
There were three mk4 files in my Akregator archives that I had to delete in order for Akregator to start again. You'll find one of them at http://compeng.uni-frankfurt.de/~kretz/https___github.com_MetaScale_nt2_commits_master.atom.mk4 . The feed URL for this archive file is: https://github.com/MetaScale/nt2/commits/master.atom

(Attaching to this bugreport won't work because the file is too big.)
Comment 5 Jekyll Wu 2013-06-20 13:33:20 UTC
*** Bug 321426 has been marked as a duplicate of this bug. ***
Comment 6 Christophe Marin 2015-03-01 19:01:42 UTC

*** This bug has been marked as a duplicate of bug 116482 ***