Bug 255057

Summary: Plasma crashes when printer-applet is unloaded
Product: [Plasma] plasma4 Reporter: J Queiroz <zekkerj>
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: asraniel
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description J Queiroz 2010-10-23 18:36:21 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.32-25-generic x86_64
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
Just tried to unload printer-applet, and plasma crashed.

By the way, I still haven't found a way to prevent printer-applet to load, as I don't have a printer, and don't want to use it...

-- Backtrace:
Application: Espa├žo de trabalho do Plasma (plasma-desktop), signal: Segmentation fault
[KCrash Handler]
#6  QCoreApplication::postEvent (receiver=<value optimized out>, event=<value optimized out>, priority=<value optimized out>) at kernel/qcoreapplication.cpp:1133
#7  0x00007f4b967b24b3 in StatusNotifierItemJob::contextMenuReady (this=0x28d7f20, menu=0x28d8fb0) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#8  0x00007f4b967b2520 in StatusNotifierItemJob::qt_metacall (this=0x28d7f20, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff855a7dc0) at ./statusnotifieritemjob.moc:75
#9  0x0000003641785da7 in QMetaObject::activate (sender=<value optimized out>, m=<value optimized out>, local_signal_index=<value optimized out>, argv=<value optimized out>)
    at kernel/qobject.cpp:3280
#10 0x00007f4b967ac4bf in StatusNotifierItemSource::contextMenuReady (this=0x28d7f20, _t1=0x28d8fb0) at ./statusnotifieritemsource.moc:109
#11 0x00007f4b967b1424 in StatusNotifierItemSource::qt_metacall (this=0x28d9220, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff855a7eb0) at ./statusnotifieritemsource.moc:90
#12 0x0000003641785da7 in QMetaObject::activate (sender=<value optimized out>, m=<value optimized out>, local_signal_index=<value optimized out>, argv=<value optimized out>)
    at kernel/qobject.cpp:3280
#13 0x000000364be17f0c in DBusMenuImporter::slotMenuAboutToShow() () from /usr/lib/libdbusmenu-qt.so.2
#14 0x000000364be1907c in DBusMenuImporter::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libdbusmenu-qt.so.2
#15 0x0000003641785da7 in QMetaObject::activate (sender=<value optimized out>, m=<value optimized out>, local_signal_index=<value optimized out>, argv=<value optimized out>)
    at kernel/qobject.cpp:3280
#16 0x000000364d82b2a0 in QMenu::qt_metacall (this=<value optimized out>, _c=<value optimized out>, _id=<value optimized out>, _a=<value optimized out>) at .moc/release-shared/moc_qmenu.cpp:97
#17 0x0000003641776ee6 in QMetaMethod::invoke (this=<value optimized out>, object=<value optimized out>, connectionType=<value optimized out>, returnValue=) at kernel/qmetaobject.cpp:1575
#18 0x00000036417785f6 in QMetaObject::invokeMethod (obj=<value optimized out>, member=<value optimized out>, type=<value optimized out>, ret=) at kernel/qmetaobject.cpp:1148
#19 0x000000364be12f81 in DBusMenuImporter::updateMenu() () from /usr/lib/libdbusmenu-qt.so.2
#20 0x00007f4b967ad9fb in StatusNotifierItemSource::contextMenu (this=0x28d9220, x=949, y=715) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:474
#21 0x00007f4b967b3b08 in StatusNotifierItemJob::start (this=0x28d7f20) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:43
#22 0x0000003656ba25a1 in Plasma::ServiceJob::qt_metacall (this=<value optimized out>, _c=<value optimized out>, _id=<value optimized out>, _a=<value optimized out>) at ./servicejob.moc:72
#23 0x00007f4b967b2500 in StatusNotifierItemJob::qt_metacall (this=0x28d7f20, _c=24356496, _id=0, _a=0x173a680) at ./statusnotifieritemjob.moc:70
#24 0x000000364177fe7e in QObject::event (this=<value optimized out>, e=<value optimized out>) at kernel/qobject.cpp:1219
#25 0x000000364d3ca6ec in QApplicationPrivate::notify_helper (this=<value optimized out>, receiver=<value optimized out>, e=<value optimized out>) at kernel/qapplication.cpp:4396
#26 0x000000364d3d01dd in QApplication::notify (this=<value optimized out>, receiver=<value optimized out>, e=<value optimized out>) at kernel/qapplication.cpp:4277
#27 0x000000364c434536 in KApplication::notify (this=<value optimized out>, receiver=<value optimized out>, event=<value optimized out>) at ../../kdeui/kernel/kapplication.cpp:310
#28 0x000000364176e0ac in QCoreApplication::notifyInternal (this=<value optimized out>, receiver=<value optimized out>, event=<value optimized out>) at kernel/qcoreapplication.cpp:732
#29 0x0000003641770fd2 in QCoreApplication::sendEvent (receiver=<value optimized out>, event_type=<value optimized out>, data=<value optimized out>)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#30 QCoreApplicationPrivate::sendPostedEvents (receiver=<value optimized out>, event_type=<value optimized out>, data=<value optimized out>) at kernel/qcoreapplication.cpp:1373
#31 0x000000364179a643 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#32 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#33 0x0000003644c3e8c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#34 0x0000003644c42748 in ?? () from /lib/libglib-2.0.so.0
#35 0x0000003644c428fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#36 0x000000364179a183 in QEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#37 0x000000364d47c97e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#38 0x000000364176cdd2 in QEventLoop::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qeventloop.cpp:149
#39 0x000000364176d1bc in QEventLoop::exec (this=<value optimized out>, flags=<value optimized out>) at kernel/qeventloop.cpp:201
#40 0x000000364177126b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#41 0x000000364b03cd06 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../../plasma/desktop/shell/main.cpp:118
#42 0x00007f4ba4c96c4d in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fff855a9c38) at libc-start.c:226
#43 0x00000000004006c9 in _start ()

Possible duplicates by query: bug 254990, bug 254704, bug 254699, bug 254578, bug 254280.

Reported using DrKonqi
Comment 1 Beat Wolf 2010-10-24 10:35:41 UTC

*** This bug has been marked as a duplicate of bug 254699 ***