Bug 254654

Summary: KWin crashed when "all desktops" used
Product: [Plasma] kwin Reporter: Alex SchiFFer <alex.schiffer>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description Alex SchiFFer 2010-10-19 14:38:26 UTC
Application: kwin (4.5.1 (KDE 4.5.1))
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-22-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed: was trying to swith desktops using the screen corner points

- Unusual behavior I noticed: sometimes windows from the different desktops mixed in one (from 3d and 4th to 3d or 4th :)), but didn't response and for a while became to work properly

- Custom settings of the application: my g-card is onboard, opengl source for graphical effects was failing every reboot (effects swithced themselves off), so i use xrender - slower, but self-restorable after the halt and almost never hanged the system.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KWin (kwin), signal: Aborted
[Current thread is 1 (Thread 0xb78cf720 (LWP 1922))]

Thread 2 (Thread 0xaeb6fb70 (LWP 1929)):
#0  0x00c37416 in __kernel_vsyscall ()
#1  0x0046e381 in select () from /lib/libc.so.6
#2  0x0349a872 in qt_safe_select (nfds=19, fdread=0xb4d00cf8, fdwrite=0xb4d00f0c, fdexcept=0xb4d01120, orig_timeout=0x0) at kernel/qcore_unix.cpp:82
#3  0x0349f329 in QEventDispatcherUNIX::select (this=0x9627ae0, nfds=19, readfds=0xb4d00cf8, writefds=0xb4d00f0c, exceptfds=0xb4d01120, timeout=0x0) at kernel/qeventdispatcher_unix.cpp:632
#4  0x0349feac in QEventDispatcherUNIXPrivate::doSelect (this=0xb4d00c00, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:219
#5  0x034a0c25 in QEventDispatcherUNIX::processEvents (this=0x9627ae0, flags=...) at kernel/qeventdispatcher_unix.cpp:919
#6  0x0346d609 in QEventLoop::processEvents (this=0xaeb6f280, flags=) at kernel/qeventloop.cpp:149
#7  0x0346da8a in QEventLoop::exec (this=0xaeb6f280, flags=...) at kernel/qeventloop.cpp:201
#8  0x03369b7e in QThread::exec (this=0x95ada38) at thread/qthread.cpp:490
#9  0x0344c35b in QInotifyFileSystemWatcherEngine::run (this=0x95ada38) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0336cdf9 in QThreadPrivate::start (arg=0x95ada38) at thread/qthread_unix.cpp:266
#11 0x0033acc9 in start_thread () from /lib/libpthread.so.0
#12 0x004756ae in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb78cf720 (LWP 1922)):
[KCrash Handler]
#7  0x00c37416 in __kernel_vsyscall ()
#8  0x003cf941 in raise () from /lib/libc.so.6
#9  0x003d2e42 in abort () from /lib/libc.so.6
#10 0x001e64af in KWin::EffectWindowImpl::unrefWindow (this=0x998afe8) at ../../kwin/effects.cpp:1289
#11 0x06dd6d42 in KWin::DesktopGridEffect::finish (this=0x9520200) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:1322
#12 0x06dd993b in KWin::DesktopGridEffect::prePaintScreen (this=0x9520200, data=..., time=493) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:146
#13 0x001e885b in KWin::EffectsHandlerImpl::prePaintScreen (this=0x94f6d10, data=..., time=493) at ../../kwin/effects.cpp:158
#14 0x06de722b in KWin::FadeDesktopEffect::prePaintScreen (this=0x951e850, data=..., time=493) at ../../../kwin/effects/fadedesktop/fadedesktop.cpp:63
#15 0x001e885b in KWin::EffectsHandlerImpl::prePaintScreen (this=0x94f6d10, data=..., time=493) at ../../kwin/effects.cpp:158
#16 0x06dccfa3 in KWin::BoxSwitchEffect::prePaintScreen (this=0x9583038, data=..., time=493) at ../../../kwin/effects/boxswitch/boxswitch.cpp:137
#17 0x001e885b in KWin::EffectsHandlerImpl::prePaintScreen (this=0x94f6d10, data=..., time=493) at ../../kwin/effects.cpp:158
#18 0x0027ed30 in KWin::Effect::prePaintScreen (this=0x9598630, data=..., time=493) at ../../../kwin/lib/kwineffects.cpp:222
#19 0x001e885b in KWin::EffectsHandlerImpl::prePaintScreen (this=0x94f6d10, data=..., time=493) at ../../kwin/effects.cpp:158
#20 0x06df1f2e in KWin::MinimizeAnimationEffect::prePaintScreen (this=0x95a3ae8, data=..., time=493) at ../../../kwin/effects/minimizeanimation/minimizeanimation.cpp:64
#21 0x001e885b in KWin::EffectsHandlerImpl::prePaintScreen (this=0x94f6d10, data=..., time=493) at ../../kwin/effects.cpp:158
#22 0x06deb297 in KWin::LoginEffect::prePaintScreen (this=0x9582ff8, data=..., time=493) at ../../../kwin/effects/login/login.cpp:52
#23 0x001e885b in KWin::EffectsHandlerImpl::prePaintScreen (this=0x94f6d10, data=..., time=493) at ../../kwin/effects.cpp:158
#24 0x001cd0f6 in KWin::Scene::paintScreen (this=0x9574708, mask=0xbfab3378, region=0xbfab3444) at ../../kwin/scene.cpp:116
#25 0x001d6e7b in KWin::SceneXrender::paint (this=0x9574708, damage=..., toplevels=...) at ../../kwin/scene_xrender.cpp:278
#26 0x001c7be4 in KWin::Workspace::performCompositing (this=0x94df8b0) at ../../kwin/composite.cpp:454
#27 0x00138c1e in KWin::Workspace::qt_metacall (this=0x94df8b0, _c=QMetaObject::InvokeMetaMethod, _id=190, _a=0xbfab356c) at ./workspace.moc:583
#28 0x034748ca in QMetaObject::metacall (object=0x94df8b0, cl=1922, idx=190, argv=0xbfab356c) at kernel/qmetaobject.cpp:237
#29 0x034876ad in QMetaObject::activate (sender=0x94dfb60, m=0x35a15a4, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3280
#30 0x034d91e7 in QTimer::timeout (this=0x94dfb60) at .moc/release-shared/moc_qtimer.cpp:134
#31 0x0348d1ce in QTimer::timerEvent (this=0x94dfb60, e=0xbfab3ac0) at kernel/qtimer.cpp:271
#32 0x03481504 in QObject::event (this=0x94dfb60, e=0x6) at kernel/qobject.cpp:1183
#33 0x02826fdc in QApplicationPrivate::notify_helper (this=0x93e3ff8, receiver=0x94dfb60, e=0xbfab3ac0) at kernel/qapplication.cpp:4396
#34 0x0282d04e in QApplication::notify (this=0xbfab3dc4, receiver=0x94dfb60, e=0xbfab3ac0) at kernel/qapplication.cpp:3798
#35 0x009df68a in KApplication::notify (this=0xbfab3dc4, receiver=0x94dfb60, event=0xbfab3ac0) at ../../kdeui/kernel/kapplication.cpp:310
#36 0x00155aef in KWin::Application::notify (this=0xbfab3dc4, o=0x94dfb60, e=0xbfab3ac0) at ../../kwin/main.cpp:372
#37 0x0346eb3b in QCoreApplication::notifyInternal (this=0xbfab3dc4, receiver=0x94dfb60, event=0xbfab3ac0) at kernel/qcoreapplication.cpp:732
#38 0x034a0ad6 in sendEvent (this=0x93e4780) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#39 QTimerInfoList::activateTimers (this=0x93e4780) at kernel/qeventdispatcher_unix.cpp:602
#40 0x034a0c37 in QEventDispatcherUNIX::processEvents (this=0x93c7998, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#41 0x028ea0d2 in QEventDispatcherX11::processEvents (this=0x93c7998, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#42 0x0346d609 in QEventLoop::processEvents (this=0xbfab3d14, flags=) at kernel/qeventloop.cpp:149
#43 0x0346da8a in QEventLoop::exec (this=0xbfab3d14, flags=...) at kernel/qeventloop.cpp:201
#44 0x0347200f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#45 0x02825e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#46 0x00157c54 in kdemain (argc=3, argv=0xbfab4024) at ../../kwin/main.cpp:531
#47 0x080485ab in main (argc=3, argv=0xbfab4024) at kwin_dummy.cpp:3

Possible duplicates by query: bug 248647, bug 246503, bug 244813.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2010-10-19 14:48:23 UTC

*** This bug has been marked as a duplicate of bug 244813 ***