Bug 254285

Summary: Kmail cannot include/insert remote images in signatures
Product: [Applications] kmail Reporter: Metin Amiroff <amiroff>
Component: generalAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED WORKSFORME    
Severity: wishlist CC: luigi.toscano, solerman
Priority: NOR    
Version: 1.13.5   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description Metin Amiroff 2010-10-15 19:11:26 UTC
Version:           1.13.5 (using KDE 4.5.2) 
OS:                Linux

Signatures in Kmail can include images. But, mails sent with these signatures look as they have attachments. Ability to insert remote images (from urls) will solve this problem. Unfortunately, Kmail does not allow custom html code as a signature and does not provide ability to insert _remote_ image urls via wysiwyg signature composer.

Reproducible: Always




Many corporations use corporate signatures which include specific images/banners. Because images get embedded into mail source, attaching them to signatures is bad, because email messages look as if they have attachments, although being displayed inline. This causes confusion for users and spam filters. Including an image tag to a remote image within a signature solves this problem. Either offer fully customisible html signatures or add ability to insert remote images.
Comment 1 Myriam Schweingruber 2012-08-18 08:12:52 UTC
Thank you for your feature request. Kmail1 is currently unmaintained so we are closing all wishes. Please feel free to reopen a feature request for Kmail2 if it has not already been implemented.
Thank you for your understanding.
Comment 2 Luigi Toscano 2012-08-18 23:50:37 UTC
Instead of creating a new feature request, please confirm here if the wishlist is still valid for kmail2
Comment 3 Solerman Kaplon 2016-11-24 11:52:06 UTC
Works for me in kmail 5.1.3
Comment 4 Christophe Giboudeaux 2016-12-13 06:34:23 UTC
Thanks for the feedback.