Bug 253940

Summary: KWin's 3d effects available on a Intel 82945G/GZ only marking "Disable functionality checks"
Product: [Plasma] kwin Reporter: Moreno <moreno-mg>
Component: compositingAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED WORKSFORME    
Severity: normal Keywords: investigated, triaged
Priority: NOR    
Version: git master   
Target Milestone: ---   
Platform: Mandriva RPMs   
OS: Linux   
Latest Commit: Version Fixed In:

Description Moreno 2010-10-12 11:42:04 UTC
Version:           SVN (using Devel) 
OS:                Linux

Hello, this is my first bug report in bugs.kde.org.

A few days ago I reported this https://qa.mandriva.com/show_bug.cgi?id=61172 problem with Mandriva Cooker.
The PC with this problem is an Atom330 with a Intel 82945G/GZ video card.
The version of the KDE packages is 4.5.71-0.svn1183606.


When I marking "Disable functionality checks" all the 3d effects work perfectly.
If I forgot to do this it's impossible correct the problem and I must remove manually kwinrc before make login.

I think there are not stability problems, I played a 1080p movie inside the cube without any problem.

It's possible found more information (x configuration, x log) in the Mandriva's bug report.

Bye Bye, Moreno



Reproducible: Always
Comment 1 Thomas L├╝bking 2010-10-12 15:14:51 UTC
assuming you intend to use opengl compositing - what's your mesa version? (and also the xf86-video-intel version...)
Comment 2 Moreno 2010-10-12 19:09:46 UTC
Hi

Mesa -> mesa-7.9-1mdv2011.0.i586.rpm
Intel driver -> x11-driver-video-intel-2.13.0

In these weeks I changed various version of these package without success.

I almost sure which in the past, all worked correctly with KDE 4.4.3.
Tomorrow I will boot the machine with one CD Live with this version of KDE.


Bye Bye, Moreno
Comment 3 Moreno 2010-10-13 06:50:19 UTC
Hi 

I confirm with a Mandriva 2010.1 the 3d effect work out if the box on my Intel video card.

This version of Mandriva have:

- KDE 4.4.3
- Mesa 7.8.1 (Mesa is innocent, I used this version until 06 october)
- x11-driver-video-intel 2.11.0


Bye Bye, Moreno
Comment 4 Andrew Crouthamel 2018-09-20 21:58:46 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days, the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please set the bug status as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 5 Andrew Crouthamel 2018-10-21 05:07:25 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!