Bug 252824

Summary: Kwin crashed after screensaver work more 30 sec
Product: [Plasma] kwin Reporter: sql_debuger
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: openSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description sql_debuger 2010-09-30 08:21:06 UTC
Application: kwin (4.5.1 (KDE 4.5.1) "release 3")
KDE Platform Version: 4.5.1 (KDE 4.5.1) "release 3"
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-0.3-default i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:
I set my screensaver as Cub (GL). After start screensaver 30 sec later I press ctrl-key.

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[KCrash Handler]
#7  intel_region_buffer (intel=0x816eb88, region=0x0, flag=2) at intel_regions.c:498
#8  0xafe7c372 in intelClearWithBlit (ctx=0x816eb88, mask=2) at intel_blit.c:266
#9  0xafe74268 in intelClear (ctx=0x816eb88, mask=2) at intel_clear.c:173
#10 0xafebae56 in _mesa_Clear (mask=<value optimized out>) at main/clear.c:178
#11 0xb77812db in KWin::SceneOpenGL::paintBackground (this=0x8129708, region=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/scene_opengl.cpp:892
#12 0xb77e7ed4 in KWin::Scene::paintGenericScreen (this=0x8129708, orig_mask=32) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/scene.cpp:187
#13 0xb77b5490 in KWin::Scene::finalPaintScreen (this=0x8129708, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/scene.cpp:177
#14 0xb77ebb73 in KWin::EffectsHandlerImpl::paintScreen (this=0x849ed98, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/effects.cpp:172
#15 0xaf30e862 in KWin::LogoutEffect::paintScreen (this=0x84d3938, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/effects/logout/logout.cpp:207
#16 0xb77ebbef in KWin::EffectsHandlerImpl::paintScreen (this=0x849ed98, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/effects.cpp:168
#17 0xaf32a7ef in KWin::ShadowEffect::paintScreen (this=0x84eff48, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/effects/shadow/shadow.cpp:189
#18 0xb77ebbef in KWin::EffectsHandlerImpl::paintScreen (this=0x849ed98, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/effects.cpp:168
#19 0xaf33a401 in KWin::BlurEffect::paintScreen (this=0x84eb8d0, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/effects/blur/blur.cpp:219
#20 0xb77ebbef in KWin::EffectsHandlerImpl::paintScreen (this=0x849ed98, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/effects.cpp:168
#21 0xaf313834 in KWin::PresentWindowsEffect::paintScreen (this=0x84f3728, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/effects/presentwindows/presentwindows.cpp:196
#22 0xb77ebbef in KWin::EffectsHandlerImpl::paintScreen (this=0x849ed98, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/effects.cpp:168
#23 0xb6e662ca in KWin::Effect::paintScreen (this=0x84d5208, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/lib/kwineffects.cpp:227
#24 0xb77ebbef in KWin::EffectsHandlerImpl::paintScreen (this=0x849ed98, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/effects.cpp:168
#25 0xb6e662ca in KWin::Effect::paintScreen (this=0x84d74a0, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/lib/kwineffects.cpp:227
#26 0xb77ebbef in KWin::EffectsHandlerImpl::paintScreen (this=0x849ed98, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/effects.cpp:168
#27 0xb6e662ca in KWin::Effect::paintScreen (this=0x84d6058, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/lib/kwineffects.cpp:227
#28 0xb77ebbef in KWin::EffectsHandlerImpl::paintScreen (this=0x849ed98, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/effects.cpp:168
#29 0xb6e662ca in KWin::Effect::paintScreen (this=0x84eb850, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/lib/kwineffects.cpp:227
#30 0xb77ebbef in KWin::EffectsHandlerImpl::paintScreen (this=0x849ed98, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/effects.cpp:168
#31 0xb6e662ca in KWin::Effect::paintScreen (this=0x84cca38, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/lib/kwineffects.cpp:227
#32 0xb77ebbef in KWin::EffectsHandlerImpl::paintScreen (this=0x849ed98, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/effects.cpp:168
#33 0xaf2f9c36 in KWin::DesktopGridEffect::paintScreen (this=0x84e6fb8, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/effects/desktopgrid/desktopgrid.cpp:155
#34 0xb77ebbef in KWin::EffectsHandlerImpl::paintScreen (this=0x849ed98, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/effects.cpp:168
#35 0xaf3317ad in KWin::SlideEffect::paintScreen (this=0x84ef6f0, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/effects/slide/slide.cpp:86
#36 0xb77ebbef in KWin::EffectsHandlerImpl::paintScreen (this=0x849ed98, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/effects.cpp:168
#37 0xaf2f271a in KWin::BoxSwitchEffect::paintScreen (this=0x84ee0c0, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/effects/boxswitch/boxswitch.cpp:142
#38 0xb77ebbef in KWin::EffectsHandlerImpl::paintScreen (this=0x849ed98, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/effects.cpp:168
#39 0xb6e662ca in KWin::Effect::paintScreen (this=0x84edb88, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/lib/kwineffects.cpp:227
#40 0xb77ebbef in KWin::EffectsHandlerImpl::paintScreen (this=0x849ed98, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/effects.cpp:168
#41 0xb6e662ca in KWin::Effect::paintScreen (this=0x84faa88, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/lib/kwineffects.cpp:227
#42 0xb77ebbef in KWin::EffectsHandlerImpl::paintScreen (this=0x849ed98, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/effects.cpp:168
#43 0xb6e662ca in KWin::Effect::paintScreen (this=0x84d53c0, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/lib/kwineffects.cpp:227
#44 0xb77ebbef in KWin::EffectsHandlerImpl::paintScreen (this=0x849ed98, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/effects.cpp:168
#45 0xaf339caa in KWin::ZoomEffect::paintScreen (this=0x84d21f0, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/effects/zoom/zoom.cpp:73
#46 0xb77ebbef in KWin::EffectsHandlerImpl::paintScreen (this=0x849ed98, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/effects.cpp:168
#47 0xb77e75b1 in KWin::Scene::paintScreen (this=0x8129708, mask=0xbfff1cb4, region=0xbfff1d74) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/scene.cpp:137
#48 0xb782085a in KWin::SceneOpenGL::paint (this=0x8129708, damage=..., toplevels=...) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/scene_opengl.cpp:748
#49 0xb77fd7b4 in KWin::Workspace::performCompositing (this=0xb01fc950) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/composite.cpp:454
#50 0xb7830afb in KWin::Workspace::qt_metacall (this=0xb01fc950, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfff1e8c)
    at /usr/src/debug/kdebase-workspace-4.5.1/build/kwin/workspace.moc:583
#51 0xb6835efd in QMetaObject::metacall (object=0xb01fc950, cl=QMetaObject::InvokeMetaMethod, idx=190, argv=0xbfff1e8c) at kernel/qmetaobject.cpp:237
#52 0xb6844fe8 in QMetaObject::activate (sender=0xb01fcc00, m=0xb694c5a4, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3295
#53 0xb6891a35 in QTimer::timeout (this=0xb01fcc00) at .moc/release-shared/moc_qtimer.cpp:134
#54 0xb684a8e6 in QTimer::timerEvent (this=0xb01fcc00, e=0xbfff23e0) at kernel/qtimer.cpp:271
#55 0xb6842774 in QObject::event (this=0xb01fcc00, e=0xbfff23e0) at kernel/qobject.cpp:1212
#56 0xb5d69c64 in QApplicationPrivate::notify_helper (this=0x806f768, receiver=0xb01fcc00, e=0xbfff23e0) at kernel/qapplication.cpp:4302
#57 0xb5d71bf7 in QApplication::notify (this=0xbfff2714, receiver=0xb01fcc00, e=0xbfff23e0) at kernel/qapplication.cpp:3706
#58 0xb7336361 in KApplication::notify (this=0xbfff2714, receiver=0xb01fcc00, event=0xbfff23e0) at /usr/src/debug/kdelibs-4.5.1/kdeui/kernel/kapplication.cpp:310
#59 0xb7792c4f in KWin::Application::notify (this=0xbfff2714, o=0xb01fcc00, e=0xbfff23e0) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/main.cpp:372
#60 0xb682fe0e in QCoreApplication::notifyInternal (this=0xbfff2714, receiver=0xb01fcc00, event=0xbfff23e0) at kernel/qcoreapplication.cpp:726
#61 0xb685e70e in sendEvent (this=0x806fee0) at kernel/qcoreapplication.h:215
#62 QTimerInfoList::activateTimers (this=0x806fee0) at kernel/qeventdispatcher_unix.cpp:618
#63 0xb685effd in QEventDispatcherUNIX::processEvents (this=0x8054b08, flags=...) at kernel/qeventdispatcher_unix.cpp:939
#64 0xb5e1af5a in QEventDispatcherX11::processEvents (this=0x8054b08, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#65 0xb682f11d in QEventLoop::processEvents (this=0xbfff2664, flags=...) at kernel/qeventloop.cpp:149
#66 0xb682f319 in QEventLoop::exec (this=0xbfff2664, flags=...) at kernel/qeventloop.cpp:201
#67 0xb6833c70 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#68 0xb5d67164 in QApplication::exec () at kernel/qapplication.cpp:3581
#69 0xb782f04b in kdemain (argc=1, argv=0xbfff2964) at /usr/src/debug/kdebase-workspace-4.5.1/kwin/main.cpp:531
#70 0x0804860b in main (argc=1, argv=0xbfff2964) at /usr/src/debug/kdebase-workspace-4.5.1/build/kwin/kwin_dummy.cpp:3

Possible duplicates by query: bug 252817.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2010-09-30 14:50:56 UTC

*** This bug has been marked as a duplicate of bug 252817 ***