Bug 252410

Summary: NM applet crashed after /etc/init.d/network restart
Product: Network Management Reporter: Dawid Wróbel <me>
Component: KDED ModuleAssignee: Will Stephenson <wstephenson>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: OpenSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description Dawid Wróbel 2010-09-26 12:01:12 UTC
Application: kded4 ($Id: kded.cpp 1156841 2010-07-29 19:59:05Z zander $)
KDE Platform Version: 4.5.1 (KDE 4.5.1) "release 3"
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-0.3-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

I simply restarted network by invoking /etc/init.d/network restart
NM applet crashed almost immediately afterwards.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KDE Daemon (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fe9d7372760 (LWP 2140))]

Thread 2 (Thread 0x7fe9b91f1710 (LWP 32633)):
#0  0xffffffffff600177 in ?? ()
#1  0x00007fffd4bff7a1 in ?? ()
#2  0x00007fe9d1ebe2a3 in clock_gettime () from /lib64/librt.so.1
#3  0x00007fe9d60b25ff in qt_gettime () at kernel/qcore_unix.cpp:111
#4  0x00007fe9d60b5f4d in QTimerInfoList::updateCurrentTime (this=0x8c08e0) at kernel/qeventdispatcher_unix.cpp:340
#5  0x00007fe9d60b62d5 in QTimerInfoList::timerWait (this=0x8c08e0, tm=...) at kernel/qeventdispatcher_unix.cpp:443
#6  0x00007fe9d60b4f0c in timerSourcePrepareHelper (src=<value optimized out>, timeout=0x7fe9b91f0c8c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007fe9d60b4fb5 in timerSourcePrepare (source=<value optimized out>, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007fe9d1c15f7f in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#9  0x00007fe9d1c16e69 in ?? () from /usr/lib64/libglib-2.0.so.0
#10 0x00007fe9d1c17510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#11 0x00007fe9d60b56d6 in QEventDispatcherGlib::processEvents (this=0x92f980, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#12 0x00007fe9d608c292 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007fe9d608c495 in QEventLoop::exec (this=0x7fe9b91f0e20, flags=...) at kernel/qeventloop.cpp:201
#14 0x00007fe9d5fa32cf in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#15 0x00007fe9d5fa5bf5 in QThreadPrivate::start (arg=0x8a5e20) at thread/qthread_unix.cpp:248
#16 0x00007fe9d5d17a4f in start_thread () from /lib64/libpthread.so.0
#17 0x00007fe9d4b0782d in clone () from /lib64/libc.so.6
#18 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fe9d7372760 (LWP 2140)):
[KCrash Handler]
#6  0x0000000000000090 in ?? ()
#7  0x00007fe9d60927a9 in QMetaObject::cast (this=0x7fe9bc761940, obj=0x8de9a0) at kernel/qmetaobject.cpp:266
#8  0x00007fe9bc9d0f7a in qobject_cast<Knm::InterfaceConnection const*> (first=0x8de9a0, second=0xa29be0) at /usr/include/QtCore/qobject.h:468
#9  activatableLessThan (first=0x8de9a0, second=0xa29be0) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:183
#10 0x00007fe9bc9d1a4a in QAlgorithmsPrivate::qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=..., end=..., 
    t=@0x8fa620, lessThan=0x7fe9bc9d0f10 <activatableLessThan(Knm::Activatable const*, Knm::Activatable const*)>) at /usr/include/QtCore/qalgorithms.h:356
#11 0x00007fe9bc9d17f7 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=0x87eb80, activatable=0x8ca240)
    at /usr/include/QtCore/qalgorithms.h:187
#12 SortedActivatableList::handleAdd (this=0x87eb80, activatable=0x8ca240) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:96
#13 0x00007fe9bc9c20b3 in ActivatableList::notifyOnAddActivatable (this=<value optimized out>, activatable=0x8ca240) at /usr/src/debug/networkmanagement/libs/service/activatablelist.cpp:99
#14 0x00007fe9bc9c59be in WirelessNetworkInterfaceActivatableProvider::handleAdd (this=<value optimized out>, addedConnection=<value optimized out>)
    at /usr/src/debug/networkmanagement/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:143
#15 0x00007fe9bc9c35bd in NetworkInterfaceActivatableProvider::init (this=0x8c68e0) at /usr/src/debug/networkmanagement/libs/service/networkinterfaceactivatableprovider.cpp:64
#16 0x00007fe9bc9c2afd in NetworkInterfaceMonitor::networkInterfaceAdded (this=<value optimized out>, uni=...) at /usr/src/debug/networkmanagement/libs/service/networkinterfacemonitor.cpp:87
#17 0x00007fe9bc9be11d in NetworkInterfaceMonitor::qt_metacall (this=0x9825a0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffd4ad2d10)
    at /usr/src/debug/networkmanagement/build/libs/service/moc_networkinterfacemonitor.cpp:75
#18 0x00007fe9d60a0a1f in QMetaObject::activate (sender=0x807180, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffd4ad2d10) at kernel/qobject.cpp:3295
#19 0x00007fe9c0db7505 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=<value optimized out>, _t1=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.5.1/build/libs/solid/control/networkmanager.moc:107
#20 0x00007fe9c0db7ad7 in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x807180, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffd4ad2e30)
    at /usr/src/debug/kdebase-workspace-4.5.1/build/libs/solid/control/networkmanager_p.moc:81
#21 0x00007fe9d60a0a1f in QMetaObject::activate (sender=0x8b9250, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffd4ad2e30) at kernel/qobject.cpp:3295
#22 0x00007fe9c0993b85 in Solid::Control::Ifaces::NetworkManager::networkInterfaceAdded (this=<value optimized out>, _t1=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.5.1/build/libs/solid/control/ifaces/networkmanager.moc:115
#23 0x00007fe9bbc8904a in NMNetworkManager::deviceAdded (this=0x8b9250, objpath=...) at /usr/src/debug/kdebase-workspace-4.5.1/solid/networkmanager-0.7/manager.cpp:199
#24 0x00007fe9bbc92d69 in NMNetworkManager::qt_metacall (this=0x8b9250, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffd4ad2ff0)
    at /usr/src/debug/kdebase-workspace-4.5.1/build/solid/networkmanager-0.7/manager.moc:95
#25 0x00007fe9d60a0a1f in QMetaObject::activate (sender=0x88f150, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffd4ad2ff0) at kernel/qobject.cpp:3295
#26 0x00007fe9bbc85aa2 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=<value optimized out>, _t1=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.5.1/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:155
#27 0x00007fe9bbc8df84 in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x88f150, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fffd4ad3430)
    at /usr/src/debug/kdebase-workspace-4.5.1/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:102
#28 0x00007fe9d34d1188 in QDBusConnectionPrivate::deliverCall (this=0x804d50, object=0x88f150, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:904
#29 0x00007fe9d34ddecf in QDBusCallDeliveryEvent::placeMetaCall (this=<value optimized out>, object=<value optimized out>) at qdbusintegrator_p.h:101
#30 0x00007fe9d609e509 in QObject::event (this=0x88f150, e=0x8c95e0) at kernel/qobject.cpp:1248
#31 0x00007fe9d52614d4 in QApplicationPrivate::notify_helper (this=0x690f60, receiver=0x88f150, e=0x8c95e0) at kernel/qapplication.cpp:4302
#32 0x00007fe9d5269aca in QApplication::notify (this=<value optimized out>, receiver=0x88f150, e=0x8c95e0) at kernel/qapplication.cpp:4185
#33 0x00007fe9d6cf21e6 in KApplication::notify (this=0x7fffd4ad3f10, receiver=0x88f150, event=0x8c95e0) at /usr/src/debug/kdelibs-4.5.1/kdeui/kernel/kapplication.cpp:310
#34 0x00007fe9d608ce4c in QCoreApplication::notifyInternal (this=0x7fffd4ad3f10, receiver=0x88f150, event=0x8c95e0) at kernel/qcoreapplication.cpp:726
#35 0x00007fe9d60905ba in sendEvent (receiver=0x0, event_type=0, data=0x60f500) at kernel/qcoreapplication.h:215
#36 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60f500) at kernel/qcoreapplication.cpp:1367
#37 0x00007fe9d60b5173 in sendPostedEvents (s=<value optimized out>) at kernel/qcoreapplication.h:220
#38 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#39 0x00007fe9d1c16a93 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#40 0x00007fe9d1c17270 in ?? () from /usr/lib64/libglib-2.0.so.0
#41 0x00007fe9d1c17510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#42 0x00007fe9d60b567f in QEventDispatcherGlib::processEvents (this=0x616ba0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#43 0x00007fe9d530214e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#44 0x00007fe9d608c292 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#45 0x00007fe9d608c495 in QEventLoop::exec (this=0x7fffd4ad3e60, flags=...) at kernel/qeventloop.cpp:201
#46 0x00007fe9d609088b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#47 0x00007fe9c7d654a7 in kdemain (argc=1, argv=0x672360) at /usr/src/debug/kdelibs-4.5.1/kded/kded.cpp:894
#48 0x00000000004074a9 in launch (argc=1, _name=0x40b267 "kded4", args=<value optimized out>, cwd=0x0, envc=<value optimized out>, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x40b0f7 "0") at /usr/src/debug/kdelibs-4.5.1/kinit/kinit.cpp:723
#49 0x0000000000409cba in main (argc=4, argv=0x7fffd4ad4f08, envp=0x7fffd4ad4f30) at /usr/src/debug/kdelibs-4.5.1/kinit/kinit.cpp:1835

Reported using DrKonqi
Comment 1 Christoph Feck 2010-11-08 23:09:27 UTC

*** This bug has been marked as a duplicate of bug 210878 ***