Bug 250988

Summary: Regression: KWin Pack Window Up/Down/Right/Left is broken
Product: [Plasma] kwin Reporter: Jimmy Kloss <jimmy.kloss>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Gentoo Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Jimmy Kloss 2010-09-12 17:22:10 UTC
Version:           unspecified (using KDE 4.5.1) 
OS:                Linux

Since KDE 3.x I use the KWin Pack Window Up/Down/Right/Left feature with keyboard shortcuts Meta + Up/Down/Right/Left, which btw. is handy it should become the default ;-)

Since the update from KDE 4.4.5 to 4.5.1 (Gentoo ebuilds) the following regression accured:

While moving a window with the keyboard shortcut from one side of the desktop to another the window completely disappears. It's still listed in the Taskbar and even the Pager shows it's new position on the desktop, but it's actually gone out of sight. The window preview also doesn't show a picture of it anymore. The only way to get the window back to a visible state is to maximize and unmaximize it.

Reproducible: Always

Steps to Reproduce:
1. Start an app (appears e.g. in top left corner)
2. Press Meta+Right (not a default shortcut yet) to call KWin Pack Window Right
3. Window is gone
4. Maximize + unmaximize it via Taskbar
5. It's visible again (with borked/default size)

Actual Results:  
Window disappears

Expected Results:  
Window moves to given edge
Comment 1 Thomas L├╝bking 2010-09-12 17:42:31 UTC
fixed in 4.5.2

*** This bug has been marked as a duplicate of bug 241049 ***