Bug 249890

Summary: Invalid Handshake
Product: [Applications] amarok Reporter: Matteo Agostinelli <agostinelli>
Component: Services/AmpacheAssignee: Amarok Developers <amarok-bugs-dist>
Status: RESOLVED DUPLICATE    
Severity: wishlist CC: kdebugs, nhn
Priority: NOR    
Version: 2.3.1   
Target Milestone: 2.3.2   
Platform: Arch Linux   
OS: Linux   
Latest Commit: Version Fixed In:

Description Matteo Agostinelli 2010-09-02 13:24:13 UTC
Version:           2.3.1 (using KDE 4.5.0) 
OS:                Linux

Currently if an Ampache session times out, you get an error message saying 'Authentication Error' - 'Error Invalid Handshake - Login Failed version too old'. Then the only way to re-connect to the server is either quitting and re-starting Amarok or disabling and re-enabling the Ampache service from the Settings.

Reproducible: Always

Steps to Reproduce:
Connect to an Ampache session and wait until it times out

Actual Results:  
Only way to reconnect is to restart Amarok or disabling and re-enabling the Ampache server

Expected Results:  
Amarok sends a new Handshake request automatically

Some additional infos could be found at this page: http://ampache.org/wiki/dev:xmlapi
Comment 1 Myriam Schweingruber 2010-09-02 15:35:05 UTC

*** This bug has been marked as a duplicate of bug 215750 ***
Comment 2 Matteo Agostinelli 2010-09-02 16:18:32 UTC
I think I found the issue here: after the session times out, Amarok is issuing a ping (/server/xml.server.php?action=ping), but for some reason the server replies with an ACL error instead of the expected version information. (I don't know why I get an ACL error since the service is working properly apart from this glitch and the Ampache ACL configuration is correct).

Looking at the Amarok code, it is assumed that if no version information is returned then the Ampache version is set to '100000' (line 357, AmpacheService.cpp). This causes the next authentications to fail due to wrong version.

Now I am not sure how to fix this... maybe a dev can comment?
Comment 3 Matteo Agostinelli 2010-09-02 16:19:29 UTC
Also I am not 100% sure if this is a duplicate of bug 215750, since I don't get crashes in this case...
Comment 4 Matteo Agostinelli 2010-09-02 16:24:56 UTC

*** This bug has been marked as a duplicate of bug 215750 ***
Comment 5 Matteo Agostinelli 2010-09-02 16:26:16 UTC
Actually, after a second read, it looks like it is duplicate... closing.