Bug 24982

Summary: automatic adjustment of column width
Product: [Frameworks and Libraries] kdelibs Reporter: esigra
Component: generalAssignee: Stephan Kulow <coolo>
Status: RESOLVED UPSTREAM    
Severity: wishlist CC: cfeck, karaluh, kde-2011.08, kollix
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Compiled Sources   
OS: Linux   
Latest Commit: Version Fixed In:

Description esigra 2001-04-30 09:37:13 UTC
(*** This bug was imported into bugs.kde.org ***)

Package:           kdelibs
Version:           unknown (using KDE 2.2.0 \6alpha1)
Severity:          wishlist
Installed from:    compiled sources
Compiler:          gcc version 2.95.3 20010315 (release)
OS:                Linux (i686) release 2.4.4
OS/Compiler notes: 

In a multicolumn list view (like the like Subject/From/Date/... list views in Kmail and Knode):

When I doubleclick on a column label border the width of the column before that border should be resized to fit it's content. When I press a keyboard shortcut (like for example Ctrl++) all widths of the columns should be resized to fit their content.

(Submitted via bugs.kde.org)
(Called from KBugReport dialog)
Comment 1 John Firebaugh 2002-09-15 08:22:04 UTC
*** Bug 45126 has been marked as a duplicate of this bug. ***
Comment 2 Martin Koller 2005-01-19 22:25:47 UTC
Double clicking as described works already.
Comment 3 Rolf Viehmann 2005-06-29 21:53:31 UTC
Double clicking works, but the keyboard shortcut is something I would really love to have, and it should be easy to implement, so please make it happen, it's one of the very few details I would really appreciate very much.
Comment 4 Lars DIECKOW 2007-03-21 20:47:43 UTC
*** This bug has been confirmed by popular vote. ***
Comment 5 Lars DIECKOW 2007-03-21 21:01:35 UTC
Ctrl + Gray Plus works in Windows Explorer (in list view) and the default open/save dialog (in list view) and in many other Windows applications which use a table widget, for instance Āµtorrent. This feature is not officially documented, but see <http://www.scottandmichelle.net/scott/code/index2.mv?codenum=004>.
Comment 6 karaluh 2009-05-06 10:33:42 UTC
I think overall column management needs serious improvements. Think of something like Amarok 1.4 playlist view, only better.
Comment 7 Christoph Feck 2011-07-25 15:49:13 UTC
kdelibs no longer contains KDE specific subclasses of QTreeView since KDE4. Please report this for the applications that are lacking this feature.

If you think it is possible to implement this for all tree views, please report an enhancement request to Nokia via https://bugreports.qt.nokia.com/secure/Dashboard.jspa
Comment 8 Christoph Feck 2013-12-29 19:20:00 UTC
*** Bug 147708 has been marked as a duplicate of this bug. ***