Bug 248298

Summary: Plasma crash
Product: plasma4 Reporter: carlo <carlo.7322>
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: kde
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: openSUSE RPMs   
OS: Linux   
Latest Commit: Version Fixed In:

Description carlo 2010-08-18 22:08:10 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.00 (KDE 4.5.0)
Qt Version: 4.6.3
Operating System: Linux 2.6.34-12-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed: I quit Amarok from the sys. tray via right click. It took about a second after before plasma crashed. I don't know whether it is relevant but I have no icon visible for amarok in the sys. tray, it is enabled in Amaroks' settings but the icon is not there, just a space in the area it should be, if I right click in this 'space' then the normal Amarok menu comes up. I did try to find out why this Icon is missing, deleting amaroks' files in ~.kde4, but this didn't help. Also I have previously deleted plasma config files to reset to default desktop, not sure if this creates this problem. Thanks.

-- Backtrace:
Application: Plasma Workspace (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  0x00007f3eabf91935 in QString (this=0x255005c, group=0, state=0) at /usr/include/QtCore/qstring.h:714
#7  KIconEffect::fingerprint (this=0x255005c, group=0, state=0) at /usr/src/debug/kdelibs-4.5.0/kdeui/icons/kiconeffect.cpp:158
#8  0x00007f3eabf92f54 in KIconLoaderPrivate::makeCacheKey (this=0x2550034, name=<value optimized out>, group=KIconLoader::Desktop, overlays=<value optimized out>, size=16, state=0)
    at /usr/src/debug/kdelibs-4.5.0/kdeui/icons/kiconloader.cpp:772
#9  0x00007f3eac0c80dd in KIconLoader::loadIcon (this=0x2560260, _name=<value optimized out>, group=KIconLoader::Desktop, size=16, state=0, overlays=..., path_store=0x0, canReturnNull=false)
    at /usr/src/debug/kdelibs-4.5.0/kdeui/icons/kiconloader.cpp:1213
#10 0x00007f3eac0c8fc0 in KIconEngine::pixmap (this=<value optimized out>, size=..., mode=<value optimized out>, state=<value optimized out>)
    at /usr/src/debug/kdelibs-4.5.0/kdeui/icons/kiconengine.cpp:93
#11 0x00007f3eaa5b8d55 in QIcon::pixmap (this=<value optimized out>, size=<value optimized out>, mode=<value optimized out>, state=<value optimized out>) at image/qicon.cpp:678
#12 0x00007f3eac0194a7 in KStyle::drawKStylePrimitive (this=0x728840, widgetType=<value optimized out>, primitive=<value optimized out>, opt=<value optimized out>, r=..., pal=<value optimized out>, 
    flags=..., p=0x7ffff95ea040, widget=0x17caec0, kOpt=0x7ffff95e9210) at /usr/src/debug/kdelibs-4.5.0/kdeui/kernel/kstyle.cpp:833
#13 0x00007f3e9a7c52a2 in Oxygen::Style::drawKStylePrimitive (this=0x728840, widgetType=KStyle::WT_MenuItem, primitive=65536, opt=0x7ffff95e9e50, r=..., palette=..., flags=..., p=0x7ffff95ea040, 
    widget=0x17caec0, kOpt=0x7ffff95e9210) at /usr/src/debug/kdebase-workspace-4.5.0/kstyles/oxygen/oxygenstyle.cpp:1149
#14 0x00007f3eabfa44af in KStyle::drawControl (this=0x728840, element=<value optimized out>, option=0x7ffff95e9e50, p=0x7ffff95ea040, widget=0x17caec0)
    at /usr/src/debug/kdelibs-4.5.0/kdeui/kernel/kstyle.cpp:1976
#15 0x00007f3e9a7c598b in Oxygen::Style::drawControl (this=0x728840, element=QStyle::CE_MenuItem, option=0x7ffff95e9e50, p=0x7ffff95ea040, widget=0x17caec0)
    at /usr/src/debug/kdebase-workspace-4.5.0/kstyles/oxygen/oxygenstyle.cpp:1015
#16 0x00007f3eaa934ed4 in QMenu::paintEvent (this=0x17caec0, e=0x7ffff95ea910) at widgets/qmenu.cpp:2185
#17 0x00007f3eaa566d6e in QWidget::event (this=0x17caec0, event=0x7ffff95ea910) at kernel/qwidget.cpp:8190
#18 0x00007f3eaa939bcb in QMenu::event (this=0x17caec0, e=0x7ffff95ea910) at widgets/qmenu.cpp:2421
#19 0x00007f3eaa5164d4 in QApplicationPrivate::notify_helper (this=0x685c00, receiver=0x17caec0, e=0x7ffff95ea910) at kernel/qapplication.cpp:4302
#20 0x00007f3eaa51eaca in QApplication::notify (this=<value optimized out>, receiver=0x17caec0, e=0x7ffff95ea910) at kernel/qapplication.cpp:4185
#21 0x00007f3eabfa70b6 in KApplication::notify (this=0x67a590, receiver=0x17caec0, event=0x7ffff95ea910) at /usr/src/debug/kdelibs-4.5.0/kdeui/kernel/kapplication.cpp:310
#22 0x00007f3eab341e4c in QCoreApplication::notifyInternal (this=0x67a590, receiver=0x17caec0, event=0x7ffff95ea910) at kernel/qcoreapplication.cpp:726
#23 0x00007f3eaa5621b2 in sendSpontaneousEvent (this=0x204aca0, pdev=0x200f0a8, rgn=..., offset=..., flags=5, sharedPainter=0x0, backingStore=0x253c860)
    at ../../src/corelib/kernel/qcoreapplication.h:218
#24 QWidgetPrivate::drawWidget (this=0x204aca0, pdev=0x200f0a8, rgn=..., offset=..., flags=5, sharedPainter=0x0, backingStore=0x253c860) at kernel/qwidget.cpp:5363
#25 0x00007f3eaa716231 in QWidgetBackingStore::sync (this=0x253c860) at painting/qbackingstore.cpp:1300
#26 0x00007f3eaa7164f9 in QWidgetBackingStore::sync (this=0x253c860, exposedWidget=0x17caec0, exposedRegion=...) at painting/qbackingstore.cpp:1105
#27 0x00007f3eaa590490 in QETWidget::translatePaintEvent (this=0x17caec0, event=<value optimized out>) at kernel/qapplication_x11.cpp:5094
#28 0x00007f3eaa59138b in QApplication::x11ProcessEvent (this=0x67a590, event=0x7ffff95eb700) at kernel/qapplication_x11.cpp:3413
#29 0x00007f3eaa5b7492 in x11EventSourceDispatch (s=0x689350, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#30 0x00007f3ea6ec3a93 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#31 0x00007f3ea6ec4270 in ?? () from /usr/lib64/libglib-2.0.so.0
#32 0x00007f3ea6ec4510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#33 0x00007f3eab36a67f in QEventDispatcherGlib::processEvents (this=0x67afc0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#34 0x00007f3eaa5b714e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#35 0x00007f3eab341292 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#36 0x00007f3eab341495 in QEventLoop::exec (this=0x7ffff95eba20, flags=...) at kernel/qeventloop.cpp:201
#37 0x00007f3eaa936065 in QMenu::exec (this=<value optimized out>, p=..., action=0x0) at widgets/qmenu.cpp:2063
#38 0x00007f3e8d648cbc in SystemTray::DBusSystemTrayWidget::showContextMenu (this=0x2542850, job=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.5.0/plasma/generic/applets/systemtray/protocols/dbussystemtray/dbussystemtraywidget.cpp:124
#39 0x00007f3e8d63a1dc in SystemTray::DBusSystemTrayWidget::qt_metacall (this=0x2542850, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7ffff95ebd00)
    at /usr/src/debug/kdebase-workspace-4.5.0/build/plasma/generic/applets/systemtray/moc_dbussystemtraywidget.cpp:82
#40 0x00007f3eab355a1f in QMetaObject::activate (sender=0x20f2770, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7ffff95ebd00) at kernel/qobject.cpp:3295
#41 0x00007f3eab7117b2 in KJob::result(KJob*) () from /usr/lib64/libkdecore.so.5
#42 0x00007f3eab7117f0 in KJob::emitResult() () from /usr/lib64/libkdecore.so.5
#43 0x00007f3e8d00be73 in StatusNotifierItemJob::contextMenuReady (this=0x20f2770, menu=0x17caec0)
    at /usr/src/debug/kdebase-workspace-4.5.0/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#44 0x00007f3e8d00bee0 in StatusNotifierItemJob::qt_metacall (this=0x20f2770, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7ffff95ebeb0)
    at /usr/src/debug/kdebase-workspace-4.5.0/build/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.moc:75
#45 0x00007f3eab355a1f in QMetaObject::activate (sender=0x24cc510, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7ffff95ebeb0) at kernel/qobject.cpp:3295
#46 0x00007f3e8d00bb5f in StatusNotifierItemSource::contextMenuReady (this=<value optimized out>, _t1=0x17caec0)
    at /usr/src/debug/kdebase-workspace-4.5.0/build/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.moc:109
#47 0x00007f3e8d01122c in StatusNotifierItemSource::qt_metacall (this=0x24cc510, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7ffff95ebf90)
    at /usr/src/debug/kdebase-workspace-4.5.0/build/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.moc:90
#48 0x00007f3eab355a1f in QMetaObject::activate (sender=0x2183630, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3295
#49 0x00007f3ea920ed30 in DBusMenuImporter::slotMenuAboutToShow() () from /usr/lib64/libdbusmenu-qt.so.2
#50 0x00007f3ea921546c in DBusMenuImporter::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/libdbusmenu-qt.so.2
#51 0x00007f3eab355a1f in QMetaObject::activate (sender=0x17caec0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3295
#52 0x00007f3eaa938198 in QMenu::qt_metacall (this=0x17caec0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7ffff95ec3d0) at .moc/release-shared/moc_qmenu.cpp:97
#53 0x00007f3eab349ebf in QMetaMethod::invoke (this=0x7ffff95ec620, object=0x17caec0, connectionType=Qt::DirectConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., 
    val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1533
#54 0x00007f3eab34ad20 in QMetaObject::invokeMethod (obj=0x17caec0, member=<value optimized out>, type=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., 
    val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1113
#55 0x00007f3ea920e4c1 in DBusMenuImporter::updateMenu() () from /usr/lib64/libdbusmenu-qt.so.2
#56 0x00007f3e8d00b74b in StatusNotifierItemSource::contextMenu (this=0x24cc510, x=1402, y=52)
    at /usr/src/debug/kdebase-workspace-4.5.0/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:465
#57 0x00007f3e8d00dbb7 in StatusNotifierItemJob::start (this=0x20f2770) at /usr/src/debug/kdebase-workspace-4.5.0/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:43
#58 0x00007f3ea2938055 in slotStart (this=0x20f2770, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=<value optimized out>) at /usr/src/debug/kdelibs-4.5.0/plasma/servicejob.cpp:37
#59 Plasma::ServiceJob::qt_metacall (this=0x20f2770, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=<value optimized out>)
    at /usr/src/debug/kdelibs-4.5.0/build/plasma/servicejob.moc:72
#60 0x00007f3e8d00bec0 in StatusNotifierItemJob::qt_metacall (this=0x20f2770, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7ffff95ecf20)
    at /usr/src/debug/kdebase-workspace-4.5.0/build/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.moc:70
#61 0x00007f3eab355a1f in QMetaObject::activate (sender=0x1ff0c10, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3295
#62 0x00007f3eab35adbf in QSingleShotTimer::timerEvent (this=0x1ff0c10) at kernel/qtimer.cpp:308
#63 0x00007f3eab35322e in QObject::event (this=0x1ff0c10, e=0x7ffff95ed6d0) at kernel/qobject.cpp:1212
#64 0x00007f3eaa5164d4 in QApplicationPrivate::notify_helper (this=0x685c00, receiver=0x1ff0c10, e=0x7ffff95ed6d0) at kernel/qapplication.cpp:4302
#65 0x00007f3eaa51eaca in QApplication::notify (this=<value optimized out>, receiver=0x1ff0c10, e=0x7ffff95ed6d0) at kernel/qapplication.cpp:4185
#66 0x00007f3eabfa70b6 in KApplication::notify (this=0x67a590, receiver=0x1ff0c10, event=0x7ffff95ed6d0) at /usr/src/debug/kdelibs-4.5.0/kdeui/kernel/kapplication.cpp:310
#67 0x00007f3eab341e4c in QCoreApplication::notifyInternal (this=0x67a590, receiver=0x1ff0c10, event=0x7ffff95ed6d0) at kernel/qcoreapplication.cpp:726
#68 0x00007f3eab36d0c9 in sendEvent (this=0x689280) at kernel/qcoreapplication.h:215
#69 QTimerInfoList::activateTimers (this=0x689280) at kernel/qeventdispatcher_unix.cpp:618
#70 0x00007f3eab369fd4 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#71 0x00007f3ea6ec3a93 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#72 0x00007f3ea6ec4270 in ?? () from /usr/lib64/libglib-2.0.so.0
#73 0x00007f3ea6ec4510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#74 0x00007f3eab36a67f in QEventDispatcherGlib::processEvents (this=0x67afc0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#75 0x00007f3eaa5b714e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#76 0x00007f3eab341292 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#77 0x00007f3eab341495 in QEventLoop::exec (this=0x7ffff95eda60, flags=...) at kernel/qeventloop.cpp:201
#78 0x00007f3eab34588b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#79 0x00007f3e9b95b1fb in kdemain (argc=1, argv=0x674020) at /usr/src/debug/kdebase-workspace-4.5.0/plasma/desktop/shell/main.cpp:118
#80 0x00000000004074a9 in _start ()

Possible duplicates by query: bug 247542.

Reported using DrKonqi
Comment 1 Nicolas L. 2010-08-19 02:37:03 UTC

*** This bug has been marked as a duplicate of bug 247542 ***