Bug 247571

Summary: Crash while browsing in album view
Product: digikam Reporter: René Krell <renda.krell>
Component: Database-AlbumsAssignee: Digikam Developers <digikam-bugs-null>
Status: RESOLVED FIXED    
Severity: crash CC: caulier.gilles, marcel.wiesweg
Priority: NOR    
Version: 1.3.0   
Target Milestone: ---   
Platform: openSUSE RPMs   
OS: Linux   
Latest Commit: Version Fixed In: 7.0.0

Description René Krell 2010-08-12 22:51:39 UTC
Application: digikam (1.3.0)
KDE Platform Version: 4.5.00 (KDE 4.5.0)
Qt Version: 4.6.3
Operating System: Linux 2.6.34-12-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
I was browsing in album view with photos, only, no videos. The crash happened more times, each time after a few minutes of browsing.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f6fd8e2f7c0 (LWP 12863))]

Thread 15 (Thread 0x7f6fc10cb710 (LWP 12865)):
#0  0x00007f6fd07fb39c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f6fd412a2bb in wait (this=<value optimized out>, mutex=0xc24a80, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0xc24a80, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00000000006aa43d in Digikam::ScanController::run (this=0xc0d3e0) at /usr/src/debug/digikam-1.3.0/digikam/scancontroller.cpp:516
#4  0x00007f6fd4129bf5 in QThreadPrivate::start (arg=0xc0d3e0) at thread/qthread_unix.cpp:248
#5  0x00007f6fd07f6a4f in start_thread () from /lib64/libpthread.so.0
#6  0x00007f6fd27c582d in clone () from /lib64/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 14 (Thread 0x7f6fc08ca710 (LWP 12868)):
#0  0x00007f6fd07f90b4 in pthread_mutex_lock () from /lib64/libpthread.so.0
#1  0x00007f6fcb338fae in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f6fcb339e69 in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f6fcb33a510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f6fd42396d6 in QEventDispatcherGlib::processEvents (this=0xd2f550, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#5  0x00007f6fd4210292 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f6fd4210495 in QEventLoop::exec (this=0x7f6fc08c9dc0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f6fd41272cf in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#8  0x00007f6fd4129bf5 in QThreadPrivate::start (arg=0xd55df0) at thread/qthread_unix.cpp:248
#9  0x00007f6fd07f6a4f in start_thread () from /lib64/libpthread.so.0
#10 0x00007f6fd27c582d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 13 (Thread 0x7f6fbfebc710 (LWP 12869)):
#0  0x00007f6fd07f90c7 in pthread_mutex_lock () from /lib64/libpthread.so.0
#1  0x00007f6fcb338def in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f6fcb339e69 in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f6fcb33a510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f6fd42396d6 in QEventDispatcherGlib::processEvents (this=0xcc7e20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#5  0x00007f6fd4210292 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f6fd4210495 in QEventLoop::exec (this=0x7f6fbfebbdc0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f6fd41272cf in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#8  0x00007f6fd4129bf5 in QThreadPrivate::start (arg=0xd2ed90) at thread/qthread_unix.cpp:248
#9  0x00007f6fd07f6a4f in start_thread () from /lib64/libpthread.so.0
#10 0x00007f6fd27c582d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 12 (Thread 0x7f6fbf42b710 (LWP 12870)):
#0  0x00007f6fd07fb39c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f6fd412a2bb in wait (this=<value optimized out>, mutex=0xcc7028, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0xcc7028, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007f6fd634d1f8 in Digikam::ParkingThread::run (this=0xcc7010) at /usr/src/debug/digikam-1.3.0/libs/threads/threadmanager.cpp:101
#4  0x00007f6fd4129bf5 in QThreadPrivate::start (arg=0xcc7010) at thread/qthread_unix.cpp:248
#5  0x00007f6fd07f6a4f in start_thread () from /lib64/libpthread.so.0
#6  0x00007f6fd27c582d in clone () from /lib64/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 11 (Thread 0x7f6fbec2a710 (LWP 12871)):
#0  0x00007f6fcb338806 in g_main_context_release () from /usr/lib64/libglib-2.0.so.0
#1  0x00007f6fcb33a008 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f6fcb33a510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f6fd42396d6 in QEventDispatcherGlib::processEvents (this=0xd29860, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00007f6fd4210292 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f6fd4210495 in QEventLoop::exec (this=0x7f6fbec29dc0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f6fd41272cf in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007f6fd4129bf5 in QThreadPrivate::start (arg=0xcd0060) at thread/qthread_unix.cpp:248
#8  0x00007f6fd07f6a4f in start_thread () from /lib64/libpthread.so.0
#9  0x00007f6fd27c582d in clone () from /lib64/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 10 (Thread 0x7f6fbe429710 (LWP 12872)):
#0  0x00007f6fcb33965b in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#1  0x00007f6fcb339ff2 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f6fcb33a510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f6fd42396d6 in QEventDispatcherGlib::processEvents (this=0xcd27c0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00007f6fd4210292 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f6fd4210495 in QEventLoop::exec (this=0x7f6fbe428dc0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f6fd41272cf in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007f6fd4129bf5 in QThreadPrivate::start (arg=0xcc5d80) at thread/qthread_unix.cpp:248
#8  0x00007f6fd07f6a4f in start_thread () from /lib64/libpthread.so.0
#9  0x00007f6fd27c582d in clone () from /lib64/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7f6faccd6710 (LWP 12881)):
#0  0x00007f6fd07fb709 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f6fb6930951 in metronom_sync_loop () from /usr/lib64/libxine.so.1
#2  0x00007f6fd07f6a4f in start_thread () from /lib64/libpthread.so.0
#3  0x00007f6fd27c582d in clone () from /lib64/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7f6fab899710 (LWP 12882)):
#0  0x00007f6fd07fb709 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f6fb693e98f in video_out_loop () from /usr/lib64/libxine.so.1
#2  0x00007f6fd07f6a4f in start_thread () from /lib64/libpthread.so.0
#3  0x00007f6fd27c582d in clone () from /lib64/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f6fab098710 (LWP 12883)):
#0  0x00007f6fcb339ddd in ?? () from /usr/lib64/libglib-2.0.so.0
#1  0x00007f6fcb33a510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f6fd42396d6 in QEventDispatcherGlib::processEvents (this=0x2006b40, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#3  0x00007f6fd4210292 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#4  0x00007f6fd4210495 in QEventLoop::exec (this=0x7f6fab097d70, flags=...) at kernel/qeventloop.cpp:201
#5  0x00007f6fd41272cf in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#6  0x00007f6fb6b8e3b4 in ?? () from /usr/lib64/kde4/plugins/phonon_backend/phonon_xine.so
#7  0x00007f6fd4129bf5 in QThreadPrivate::start (arg=0x20065a0) at thread/qthread_unix.cpp:248
#8  0x00007f6fd07f6a4f in start_thread () from /lib64/libpthread.so.0
#9  0x00007f6fd27c582d in clone () from /lib64/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f6faa691710 (LWP 12884)):
#0  0x00007f6fd27d2b5f in __libc_enable_asynccancel () from /lib64/libc.so.6
#1  0x00007f6fd27bc698 in poll () from /lib64/libc.so.6
#2  0x00007f6fd224d41f in ?? () from /usr/lib64/libpulse.so.0
#3  0x00007f6fd223f1e6 in pa_mainloop_poll () from /usr/lib64/libpulse.so.0
#4  0x00007f6fd223f819 in pa_mainloop_iterate () from /usr/lib64/libpulse.so.0
#5  0x00007f6fd223f8d0 in pa_mainloop_run () from /usr/lib64/libpulse.so.0
#6  0x00007f6fd224d3bb in ?? () from /usr/lib64/libpulse.so.0
#7  0x00007f6fc97c38e8 in ?? () from /usr/lib64/libpulsecommon-0.9.21.so
#8  0x00007f6fd07f6a4f in start_thread () from /lib64/libpthread.so.0
#9  0x00007f6fd27c582d in clone () from /lib64/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f6fa5e8f710 (LWP 12885)):
#0  0x00007f6fd07fb39c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f6fb694296b in ao_loop () from /usr/lib64/libxine.so.1
#2  0x00007f6fd07f6a4f in start_thread () from /lib64/libpthread.so.0
#3  0x00007f6fd27c582d in clone () from /lib64/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f6fa568e710 (LWP 12886)):
#0  0x00007f6fd27bc6b3 in poll () from /lib64/libc.so.6
#1  0x00007f6fcb339fd4 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f6fcb33a510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f6fd42396d6 in QEventDispatcherGlib::processEvents (this=0x22bb920, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00007f6fd4210292 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f6fd4210495 in QEventLoop::exec (this=0x7f6fa568dd80, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f6fd41272cf in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007f6fd41f2458 in QInotifyFileSystemWatcherEngine::run (this=0x22ba4e0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f6fd4129bf5 in QThreadPrivate::start (arg=0x22ba4e0) at thread/qthread_unix.cpp:248
#9  0x00007f6fd07f6a4f in start_thread () from /lib64/libpthread.so.0
#10 0x00007f6fd27c582d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f6fa2dbb710 (LWP 12893)):
#0  0x00007f6fd07f90b4 in pthread_mutex_lock () from /lib64/libpthread.so.0
#1  0x00007f6fcb338519 in g_main_context_acquire () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f6fcb339de5 in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f6fcb33a510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f6fd42396d6 in QEventDispatcherGlib::processEvents (this=0x2dec7c0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#5  0x00007f6fd4210292 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f6fd4210495 in QEventLoop::exec (this=0x7f6fa2dbad80, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f6fd41272cf in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#8  0x00007f6fd41f2458 in QInotifyFileSystemWatcherEngine::run (this=0x2deb9b0) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f6fd4129bf5 in QThreadPrivate::start (arg=0x2deb9b0) at thread/qthread_unix.cpp:248
#10 0x00007f6fd07f6a4f in start_thread () from /lib64/libpthread.so.0
#11 0x00007f6fd27c582d in clone () from /lib64/libc.so.6
#12 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f6f9edb3710 (LWP 12957)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f6fd63224d0 in Digikam::PreviewLoadingTask::execute (this=0x5ca1f70) at /usr/src/debug/digikam-1.3.0/libs/threadimageio/previewtask.cpp:165
#8  0x00007f6fd6311596 in Digikam::LoadSaveThread::run (this=0x5e70620) at /usr/src/debug/digikam-1.3.0/libs/threadimageio/loadsavethread.cpp:127
#9  0x00007f6fd634e0a6 in Digikam::DynamicThreadPriv::run (this=0x5e6e430) at /usr/src/debug/digikam-1.3.0/libs/threads/dynamicthread.cpp:237
#10 0x00007f6fd4120035 in QThreadPoolThread::run (this=0x5a031f0) at concurrent/qthreadpool.cpp:106
#11 0x00007f6fd4129bf5 in QThreadPrivate::start (arg=0x5a031f0) at thread/qthread_unix.cpp:248
#12 0x00007f6fd07f6a4f in start_thread () from /lib64/libpthread.so.0
#13 0x00007f6fd27c582d in clone () from /lib64/libc.so.6
#14 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f6fd8e2f7c0 (LWP 12863)):
#0  0x00007f6fd07fb709 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f6fd41299b5 in thread_sleep (ti=0x7fffb4508440) at thread/qthread_unix.cpp:398
#2  0x00007f6fd4129b20 in QThread::msleep (msecs=<value optimized out>) at thread/qthread_unix.cpp:424
#3  0x00007f6fb6ba45c2 in ?? () from /usr/lib64/kde4/plugins/phonon_backend/phonon_xine.so
#4  0x00007f6fb6ba46d9 in ?? () from /usr/lib64/kde4/plugins/phonon_backend/phonon_xine.so
#5  0x00007f6fd8808cc7 in ?? () from /usr/lib64/libphonon.so.4
#6  0x00007f6fd8808e09 in ?? () from /usr/lib64/libphonon.so.4
#7  0x00007f6fd272a4e1 in __run_exit_handlers () from /lib64/libc.so.6
#8  0x00007f6fd272a535 in exit () from /lib64/libc.so.6
#9  0x00007f6fd33f5cb8 in qt_xio_errhandler () at kernel/qapplication_x11.cpp:744
#10 0x00007f6fd4b2a068 in KApplication::xioErrhandler (this=0x7fffb4508a00, dpy=0xa90510) at /usr/src/debug/kdelibs-4.5.0/kdeui/kernel/kapplication.cpp:416
#11 0x00007f6fd0f8aa3e in _XIOError () from /usr/lib64/libX11.so.6
#12 0x00007f6fd0f915a5 in ?? () from /usr/lib64/libX11.so.6
#13 0x00007f6fd0f9190c in _XEventsQueued () from /usr/lib64/libX11.so.6
#14 0x00007f6fd0f7a7ef in XEventsQueued () from /usr/lib64/libX11.so.6
#15 0x00007f6fd342cfec in x11EventSourceCheck (s=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:85
#16 0x00007f6fcb339718 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#17 0x00007f6fcb339ff2 in ?? () from /usr/lib64/libglib-2.0.so.0
#18 0x00007f6fcb33a510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#19 0x00007f6fd423967f in QEventDispatcherGlib::processEvents (this=0xa4b5c0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#20 0x00007f6fd342d14e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#21 0x00007f6fd4210292 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#22 0x00007f6fd4210495 in QEventLoop::exec (this=0x7fffb4508840, flags=...) at kernel/qeventloop.cpp:201
#23 0x00007f6fd421488b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#24 0x00000000007139c5 in main (argc=11029504, argv=0x7fffb4509100) at /usr/src/debug/digikam-1.3.0/digikam/main.cpp:195

Possible duplicates by query: bug 244560.

Reported using DrKonqi
Comment 1 Johannes Wienke 2010-08-12 23:26:35 UTC
This is strange. The interesting symbol is missing eventhough it must be a call to a digikam function of the same class.

Marcel, any idea?
Comment 2 René Krell 2010-08-13 08:56:31 UTC
(In reply to comment #1)
> This is strange. The interesting symbol is missing eventhough it must be a call
> to a digikam function of the same class.
> ...

Unfortunately, I cannot figure out which else debug symbols to install, there is no library shown which this missing symbol is coming from. If you still need this information, do you have an idea?
Comment 3 René Krell 2010-08-13 08:59:13 UTC
Anyway, by the crash backtrace it looks like a duplicate of bug 244560.

*** This bug has been marked as a duplicate of bug 244560 ***
Comment 4 caulier.gilles 2019-12-25 15:41:53 UTC
Not reproducible using digiKam 7.0.0 beta1.