Bug 246503

Summary: KWin suddenly crashed when minimizing KDevelop
Product: [Plasma] kwin Reporter: Vishesh Handa <me>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Compiled Sources   
OS: Linux   
Latest Commit: Version Fixed In:

Description Vishesh Handa 2010-08-02 12:28:54 UTC
Application: kwin (4.5.62 (KDE 4.5.62 (KDE 4.6 >= 20100729)))
KDE Platform Version: 4.5.62 (KDE 4.5.62 (KDE 4.6 >= 20100729)) (Compiled from sources)
Qt Version: 4.6.3
Operating System: Linux 2.6.34-ARCH i686

-- Information about the crash:
- What I was doing when the application crashed:

KDevelop was renaming a class for me, and it had a procesing dialog open. I was minimizing KDevelop to do something else when KWin crashed.  

Other stuff you should know -
* I'm using trunk and Blur and CoverSwitch don't work.
* Last week they used to work and present windows never worked. Present Windows now works. 
* The only thing I've done in the last 1 week is update kde completely.

-- Backtrace:
Application: KWin (kwin), signal: Aborted
[KCrash Handler]
#7  0xb774d424 in __kernel_vsyscall ()
#8  0xb581bd61 in raise () from /lib/libc.so.6
#9  0xb581d5ee in abort () from /lib/libc.so.6
#10 0xb771c98e in KWin::EffectWindowImpl::unrefWindow (this=0x8989d68) at /home/vishesh/kde/src/kdebase/workspace/kwin/effects.cpp:1308
#11 0xafeadf94 in KWin::DesktopGridEffect::finish (this=0x8d33950) at /home/vishesh/kde/src/kdebase/workspace/kwin/effects/desktopgrid/desktopgrid.cpp:1322
#12 0xafea62d4 in KWin::DesktopGridEffect::prePaintScreen (this=0x8d33950, data=..., time=2) at /home/vishesh/kde/src/kdebase/workspace/kwin/effects/desktopgrid/desktopgrid.cpp:146
#13 0xb7717afc in KWin::EffectsHandlerImpl::prePaintScreen (this=0x8cb1aa0, data=..., time=2) at /home/vishesh/kde/src/kdebase/workspace/kwin/effects.cpp:159
#14 0xb72dd41c in KWin::Effect::prePaintScreen (this=0x8d6d2a0, data=..., time=2) at /home/vishesh/kde/src/kdebase/workspace/kwin/lib/kwineffects.cpp:222
#15 0xb7717afc in KWin::EffectsHandlerImpl::prePaintScreen (this=0x8cb1aa0, data=..., time=2) at /home/vishesh/kde/src/kdebase/workspace/kwin/effects.cpp:159
#16 0xafee4e4d in KWin::SlidingPopupsEffect::prePaintScreen (this=0x8cceae0, data=..., time=2) at /home/vishesh/kde/src/kdebase/workspace/kwin/effects/slidingpopups/slidingpopups.cpp:52
#17 0xb7717afc in KWin::EffectsHandlerImpl::prePaintScreen (this=0x8cb1aa0, data=..., time=2) at /home/vishesh/kde/src/kdebase/workspace/kwin/effects.cpp:159
#18 0xafee0387 in KWin::SlideEffect::prePaintScreen (this=0x8d0ffd0, data=..., time=2) at /home/vishesh/kde/src/kdebase/workspace/kwin/effects/slide/slide.cpp:60
#19 0xb7717afc in KWin::EffectsHandlerImpl::prePaintScreen (this=0x8cb1aa0, data=..., time=2) at /home/vishesh/kde/src/kdebase/workspace/kwin/effects.cpp:159
#20 0xafec30e5 in KWin::MinimizeAnimationEffect::prePaintScreen (this=0x8c27920, data=..., time=2) at /home/vishesh/kde/src/kdebase/workspace/kwin/effects/minimizeanimation/minimizeanimation.cpp:64
#21 0xb7717afc in KWin::EffectsHandlerImpl::prePaintScreen (this=0x8cb1aa0, data=..., time=2) at /home/vishesh/kde/src/kdebase/workspace/kwin/effects.cpp:159
#22 0xafe9ba98 in KWin::BoxSwitchEffect::prePaintScreen (this=0x8d310d0, data=..., time=2) at /home/vishesh/kde/src/kdebase/workspace/kwin/effects/boxswitch/boxswitch.cpp:138
#23 0xb7717afc in KWin::EffectsHandlerImpl::prePaintScreen (this=0x8cb1aa0, data=..., time=2) at /home/vishesh/kde/src/kdebase/workspace/kwin/effects.cpp:159
#24 0xafebc393 in KWin::LoginEffect::prePaintScreen (this=0x8c0f1d8, data=..., time=2) at /home/vishesh/kde/src/kdebase/workspace/kwin/effects/login/login.cpp:52
#25 0xb7717afc in KWin::EffectsHandlerImpl::prePaintScreen (this=0x8cb1aa0, data=..., time=2) at /home/vishesh/kde/src/kdebase/workspace/kwin/effects.cpp:159
#26 0xafee9de3 in KWin::ZoomEffect::prePaintScreen (this=0x8d33660, data=..., time=2) at /home/vishesh/kde/src/kdebase/workspace/kwin/effects/zoom/zoom.cpp:59
#27 0xb7717afc in KWin::EffectsHandlerImpl::prePaintScreen (this=0x8cb1aa0, data=..., time=2) at /home/vishesh/kde/src/kdebase/workspace/kwin/effects.cpp:159
#28 0xb76fc961 in KWin::Scene::paintScreen (this=0x8cb2590, mask=0xbfc405ac, region=0xbfc4067c) at /home/vishesh/kde/src/kdebase/workspace/kwin/scene.cpp:116
#29 0xb770341e in KWin::SceneXrender::paint (this=0x8cb2590, damage=..., toplevels=...) at /home/vishesh/kde/src/kdebase/workspace/kwin/scene_xrender.cpp:280
#30 0xb76f6e0f in KWin::Workspace::performCompositing (this=0x86801b0) at /home/vishesh/kde/src/kdebase/workspace/kwin/composite.cpp:454
#31 0xb766a801 in KWin::Workspace::qt_metacall (this=0x86801b0, _c=QMetaObject::InvokeMetaMethod, _id=186, _a=0xbfc4075c) at /home/vishesh/kde/build/kdebase/workspace/kwin/workspace.moc:583
#32 0xb6862eba in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#33 0xb6871f9b in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#34 0xb68bc567 in QTimer::timeout() () from /usr/lib/libQtCore.so.4
#35 0xb687709e in QTimer::timerEvent(QTimerEvent*) () from /usr/lib/libQtCore.so.4
#36 0xb686f644 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#37 0xb5dccf14 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#38 0xb5dd10fe in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#39 0xb6e2cf82 in KApplication::notify (this=0xbfc40fb4, receiver=0x8680460, event=0xbfc40ca0) at /home/vishesh/kde/src/kdelibs/kdeui/kernel/kapplication.cpp:284
#40 0xb768ca92 in KWin::Application::notify (this=0xbfc40fb4, o=0x8680460, e=0xbfc40ca0) at /home/vishesh/kde/src/kdebase/workspace/kwin/main.cpp:372
#41 0xb685cecb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#42 0xb688a80e in ?? () from /usr/lib/libQtCore.so.4
#43 0xb688a968 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#44 0xb5e79ed6 in ?? () from /usr/lib/libQtGui.so.4
#45 0xb685c119 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#46 0xb685c38a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#47 0xb6860c6f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#48 0xb5dca637 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#49 0xb768da35 in kdemain (argc=3, argv=0xbfc411c4) at /home/vishesh/kde/src/kdebase/workspace/kwin/main.cpp:531
#50 0x080487b9 in main (argc=3, argv=0xbfc411c4) at /home/vishesh/kde/build/kdebase/workspace/kwin/kwin_dummy.cpp:3

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2010-08-02 15:10:11 UTC
a) since from the BT this seems very much to be a dupe oof bug #244813 - any chance you triggered the desktop grid? (ie. attempted to switch workspaces)
Since you're compiling trunk: there's a patch attempt you could try.

b) "Other stuff you should know..."
please do not mix up bugreports. chances are great that any notion w/o correlation to the main bug are simply overseen.

> I'm using trunk and Blur and CoverSwitch don't work.... Last week they used to work and present windows never worked. Present Windows now works. 
Non working Blur and CS effects hint that you're using the XRender backend but i wouldn't know any reason why present windows should not "work"
-> what does that mean precisely:
do you get a notion that i can't be loaded or is the shortcut/screencorner to trigger it inoperative. in the latter case try using a screencorner/shortcut instead to trigger the effect or assign another shortcut.

*** This bug has been marked as a duplicate of bug 244813 ***
Comment 2 Vishesh Handa 2010-08-02 15:52:46 UTC
Yes, I may have accidentally triggered Desktop-Grid. I'll apply the patch and try it out. :)

I didn't mean to mix up bug reports. I just thought that the Additional Info may help you diagnose the bug better. I don't plan to file bug reports for (b) right now. I'm sure it's something with my system as the effects work fine on the stable-version. Thanks for pointing out that it might have something to do with XRender. I'll check it out.