Bug 242076

Summary: Plasma crash after 100% CPU usage
Product: plasma4 Reporter: mathew <meta>
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: asraniel
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description mathew 2010-06-18 15:26:48 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-22-generic-pae i686
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
Noticed plasma-workspace was chewing 100% CPU. Was shutting down windows ready for a reboot to try and deal with it.

Recently updated kpackagekit, but that's the only KDE package updated while it has been running.

 -- Backtrace:
Application: Plasma Workspace (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb55c2aa0 (LWP 30250))]

Thread 2 (Thread 0xa4d18b70 (LWP 30254)):
#0  0xb77be430 in __kernel_vsyscall ()
#1  0xb5f10b86 in poll () from /lib/tls/i686/cmov/libc.so.6
#2  0xb59764eb in g_poll () from /lib/libglib-2.0.so.0
#3  0xb59690ac in ?? () from /lib/libglib-2.0.so.0
#4  0xb59694b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0xb6ce060f in QEventDispatcherGlib::processEvents (this=0x9ac7b70, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#6  0xb6cb3059 in QEventLoop::processEvents (this=0xa4d18290, flags=) at kernel/qeventloop.cpp:149
#7  0xb6cb34aa in QEventLoop::exec (this=0xa4d18290, flags=...) at kernel/qeventloop.cpp:201
#8  0xb6baf5a8 in QThread::exec (this=0x9b4c0a0) at thread/qthread.cpp:487
#9  0xb6c92c1b in QInotifyFileSystemWatcherEngine::run (this=0x9b4c0a0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb6bb232e in QThreadPrivate::start (arg=0x9b4c0a0) at thread/qthread_unix.cpp:248
#11 0xb6b2396e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#12 0xb5f1ea4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb55c2aa0 (LWP 30250)):
[KCrash Handler]
#6  0xb6f602c6 in QString (this=0x24, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:714
#7  KIconEffect::fingerprint (this=0x24, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:158
#8  0xb6f6ca54 in KIconLoader::loadIcon (this=0x9d26d60, _name=..., group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false)
    at ../../kdeui/icons/kiconloader.cpp:1085
#9  0xb6f64bf8 in KIconEngine::actualSize (this=0xb507910, size=..., mode=QIcon::Normal, state=QIcon::Off) at ../../kdeui/icons/kiconengine.cpp:80
#10 0xb62994b6 in QIcon::actualSize (this=0xa018f44, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:700
#11 0xb5353dc3 in Plasma::IconWidgetPrivate::decoration (this=0xa018ec8, option=0x9631dc8, useHoverEffect=false, usePressedEffect=false) at ../../plasma/widgets/iconwidget.cpp:701
#12 0xb53559d7 in Plasma::IconWidget::paint (this=0x9fda178, painter=0xbfb6eb4c, option=0x9631dc8, widget=0x0) at ../../plasma/widgets/iconwidget.cpp:1013
#13 0xb686cf2c in _q_paintItem (item=<value optimized out>, painter=<value optimized out>, option=0x9631dc8, widget=0x0, useWindowOpacity=false, painterStateProtection=true)
    at graphicsview/qgraphicsscene.cpp:4243
#14 0xb686fb1a in _q_paintIntoCache (pix=<value optimized out>, item=<value optimized out>, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x9631dc8, 
    painterStateProtection=<value optimized out>) at graphicsview/qgraphicsscene.cpp:4281
#15 0xb6889620 in QGraphicsScenePrivate::drawItemHelper (this=0x9631c68, item=0x9fda180, painter=0xbfb70974, option=0x9631dc8, widget=0x9a80150, painterStateProtection=true)
    at graphicsview/qgraphicsscene.cpp:4574
#16 0xb688a044 in QGraphicsScenePrivate::draw (this=0x9631c68, item=0x9fda180, painter=0xbfb70974, viewTransform=0xbfb707ac, transformPtr=0xbfb6f530, exposedRegion=0x9ab6234, widget=0x9a80150, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4827
#17 0xb688acb3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x9631c68, item=0x9fda180, painter=0xbfb70974, viewTransform=0xbfb707ac, exposedRegion=0x9ab6234, widget=0x9a80150, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#18 0xb688a0d4 in QGraphicsScenePrivate::draw (this=0x9631c68, item=0x98ec8c8, painter=0xbfb70974, viewTransform=0xbfb707ac, transformPtr=0xbfb6fa30, exposedRegion=0x9ab6234, widget=0x9a80150, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4841
#19 0xb688acb3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x9631c68, item=0x98ec8c8, painter=0xbfb70974, viewTransform=0xbfb707ac, exposedRegion=0x9ab6234, widget=0x9a80150, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#20 0xb688a0d4 in QGraphicsScenePrivate::draw (this=0x9631c68, item=0x98f21c8, painter=0xbfb70974, viewTransform=0xbfb707ac, transformPtr=0xbfb6ff30, exposedRegion=0x9ab6234, widget=0x9a80150, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4841
#21 0xb688acb3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x9631c68, item=0x98f21c8, painter=0xbfb70974, viewTransform=0xbfb707ac, exposedRegion=0x9ab6234, widget=0x9a80150, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#22 0xb688a0d4 in QGraphicsScenePrivate::draw (this=0x9631c68, item=0x97f40f8, painter=0xbfb70974, viewTransform=0xbfb707ac, transformPtr=0xbfb70430, exposedRegion=0x9ab6234, widget=0x9a80150, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4841
#23 0xb688acb3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x9631c68, item=0x97f40f8, painter=0xbfb70974, viewTransform=0xbfb707ac, exposedRegion=0x9ab6234, widget=0x9a80150, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#24 0xb688b6be in QGraphicsScenePrivate::drawItems (this=0x9631c68, painter=0xbfb70974, viewTransform=0xbfb707ac, exposedRegion=0x9ab6234, widget=0x9a80150) at graphicsview/qgraphicsscene.cpp:4619
#25 0xb68a5beb in QGraphicsView::paintEvent (this=0x9ab8ac8, event=0xbfb71094) at graphicsview/qgraphicsview.cpp:3393
#26 0xb22ecc79 in PanelView::paintEvent (this=0x9ab8ac8, event=0xbfb71094) at ../../../../plasma/desktop/shell/panelview.cpp:1300
#27 0xb62356b6 in QWidget::event (this=0x9ab8ac8, event=0xbfb71094) at kernel/qwidget.cpp:8144
#28 0xb6631fd3 in QFrame::event (this=0x9ab8ac8, e=0xbfb71094) at widgets/qframe.cpp:557
#29 0xb66cc382 in QAbstractScrollArea::viewportEvent (this=0x0, e=0x24) at widgets/qabstractscrollarea.cpp:1036
#30 0xb68a206b in QGraphicsView::viewportEvent (this=0x9ab8ac8, event=0xbfb71094) at graphicsview/qgraphicsview.cpp:2787
#31 0xb66cec65 in QAbstractScrollAreaPrivate::viewportEvent (this=0x9bc6878, o=0x9a80150, e=0xbfb71094) at widgets/qabstractscrollarea_p.h:100
#32 QAbstractScrollAreaFilter::eventFilter (this=0x9bc6878, o=0x9a80150, e=0xbfb71094) at widgets/qabstractscrollarea_p.h:116
#33 0xb6cb3cda in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x952b818, receiver=0x9a80150, event=0xbfb71094) at kernel/qcoreapplication.cpp:819
#34 0xb61d74b9 in QApplicationPrivate::notify_helper (this=0x952b818, receiver=0x9a80150, e=0xbfb71094) at kernel/qapplication.cpp:4296
#35 0xb61de0f9 in QApplication::notify (this=0x9525798, receiver=0x9a80150, e=0xbfb71094) at kernel/qapplication.cpp:4265
#36 0xb6fa9f2a in KApplication::notify (this=0x9525798, receiver=0x9a80150, event=0xbfb71094) at ../../kdeui/kernel/kapplication.cpp:302
#37 0xb6cb4a3b in QCoreApplication::notifyInternal (this=0x9525798, receiver=0x9a80150, event=0xbfb71094) at kernel/qcoreapplication.cpp:704
#38 0xb623e9d6 in QCoreApplication::sendSpontaneousEvent (this=0x9ab7180, pdev=0x9a75ccc, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x9abbe20)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#39 QWidgetPrivate::drawWidget (this=0x9ab7180, pdev=0x9a75ccc, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x9abbe20) at kernel/qwidget.cpp:5339
#40 0xb623f815 in QWidgetPrivate::paintSiblingsRecursive (this=0x9ab5ed0, pdev=0x9a75ccc, siblings=..., index=3, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x9abbe20)
    at kernel/qwidget.cpp:5452
#41 0xb623f64e in QWidgetPrivate::paintSiblingsRecursive (this=0x9ab5ed0, pdev=0x9a75ccc, siblings=..., index=4, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x9abbe20)
    at kernel/qwidget.cpp:5439
#42 0xb623f64e in QWidgetPrivate::paintSiblingsRecursive (this=0x9ab5ed0, pdev=0x9a75ccc, siblings=..., index=5, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x9abbe20)
    at kernel/qwidget.cpp:5439
#43 0xb623f64e in QWidgetPrivate::paintSiblingsRecursive (this=0x9ab5ed0, pdev=0x9a75ccc, siblings=..., index=6, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x9abbe20)
    at kernel/qwidget.cpp:5439
#44 0xb623f64e in QWidgetPrivate::paintSiblingsRecursive (this=0x9ab5ed0, pdev=0x9a75ccc, siblings=..., index=7, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x9abbe20)
    at kernel/qwidget.cpp:5439
#45 0xb623f64e in QWidgetPrivate::paintSiblingsRecursive (this=0x9ab5ed0, pdev=0x9a75ccc, siblings=..., index=8, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x9abbe20)
    at kernel/qwidget.cpp:5439
#46 0xb623f64e in QWidgetPrivate::paintSiblingsRecursive (this=0x9ab5ed0, pdev=0x9a75ccc, siblings=..., index=9, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x9abbe20)
    at kernel/qwidget.cpp:5439
#47 0xb623e725 in QWidgetPrivate::drawWidget (this=0x9ab5ed0, pdev=0x9a75ccc, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x9abbe20) at kernel/qwidget.cpp:5388
#48 0xb6415890 in QWidgetBackingStore::sync (this=0x9abbe20) at painting/qbackingstore.cpp:1291
#49 0xb622eb93 in QWidgetPrivate::syncBackingStore (this=0x9ab5ed0) at kernel/qwidget.cpp:1672
#50 0xb6235e76 in QWidget::event (this=0x9ab8ac8, event=0xd2411f0) at kernel/qwidget.cpp:8291
#51 0xb6631fd3 in QFrame::event (this=0x9ab8ac8, e=0xd2411f0) at widgets/qframe.cpp:557
#52 0xb66ccd97 in QAbstractScrollArea::event (this=0x9ab8ac8, e=0xd2411f0) at widgets/qabstractscrollarea.cpp:989
#53 0xb68a4216 in QGraphicsView::event (this=0x9ab8ac8, event=0xd2411f0) at graphicsview/qgraphicsview.cpp:2666
#54 0xb22ed613 in PanelView::event (this=0x9ab8ac8, event=0xd2411f0) at ../../../../plasma/desktop/shell/panelview.cpp:1314
#55 0xb61d74dc in QApplicationPrivate::notify_helper (this=0x952b818, receiver=0x9ab8ac8, e=0xd2411f0) at kernel/qapplication.cpp:4300
#56 0xb61de0f9 in QApplication::notify (this=0x9525798, receiver=0x9ab8ac8, e=0xd2411f0) at kernel/qapplication.cpp:4265
#57 0xb6fa9f2a in KApplication::notify (this=0x9525798, receiver=0x9ab8ac8, event=0xd2411f0) at ../../kdeui/kernel/kapplication.cpp:302
#58 0xb6cb4a3b in QCoreApplication::notifyInternal (this=0x9525798, receiver=0x9ab8ac8, event=0xd2411f0) at kernel/qcoreapplication.cpp:704
#59 0xb6cb7473 in QCoreApplication::sendEvent (receiver=0x9ab8ac8, event_type=77, data=0x94c3270) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#60 QCoreApplicationPrivate::sendPostedEvents (receiver=0x9ab8ac8, event_type=77, data=0x94c3270) at kernel/qcoreapplication.cpp:1345
#61 0xb6cb75dd in QCoreApplication::sendPostedEvents (receiver=0x9ab8ac8, event_type=77) at kernel/qcoreapplication.cpp:1238
#62 0xb6887326 in QGraphicsViewPrivate::dispatchPendingUpdateRequests (this=0x9631c68) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:184
#63 QGraphicsScenePrivate::_q_processDirtyItems (this=0x9631c68) at graphicsview/qgraphicsscene.cpp:509
#64 0xb6887876 in QGraphicsScene::qt_metacall (this=0x9635a78, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0xc30ce20) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#65 0xb5292d3a in Plasma::Corona::qt_metacall (this=0x9635a78, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0xc30ce20) at ./corona.moc:107
#66 0xb22dcfad in DesktopCorona::qt_metacall (this=0x9635a78, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0xc30ce20) at ./desktopcorona.moc:86
#67 0xb6cb9c9a in QMetaObject::metacall (object=0x9635a78, cl=QMetaObject::InvokeMetaMethod, idx=18, argv=0xc30ce20) at kernel/qmetaobject.cpp:237
#68 0xb6cc4336 in QMetaCallEvent::placeMetaCall (this=0xc5d6448, object=0x9635a78) at kernel/qobject.cpp:561
#69 0xb6cc53fe in QObject::event (this=0x9635a78, e=0xc5d6448) at kernel/qobject.cpp:1248
#70 0xb6883554 in QGraphicsScene::event (this=0x9635a78, event=0xc5d6448) at graphicsview/qgraphicsscene.cpp:3500
#71 0xb61d74dc in QApplicationPrivate::notify_helper (this=0x952b818, receiver=0x9635a78, e=0xc5d6448) at kernel/qapplication.cpp:4300
#72 0xb61de05e in QApplication::notify (this=0x9525798, receiver=0x9635a78, e=0xc5d6448) at kernel/qapplication.cpp:3704
#73 0xb6fa9f2a in KApplication::notify (this=0x9525798, receiver=0x9635a78, event=0xc5d6448) at ../../kdeui/kernel/kapplication.cpp:302
#74 0xb6cb4a3b in QCoreApplication::notifyInternal (this=0x9525798, receiver=0x9635a78, event=0xc5d6448) at kernel/qcoreapplication.cpp:704
#75 0xb6cb7473 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x94c3270) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#76 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x94c3270) at kernel/qcoreapplication.cpp:1345
#77 0xb6cb75dd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#78 0xb6ce0adf in QCoreApplication::sendPostedEvents (s=0x952dad0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#79 postEventSourceDispatch (s=0x952dad0) at kernel/qeventdispatcher_glib.cpp:276
#80 0xb59655e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#81 0xb59692d8 in ?? () from /lib/libglib-2.0.so.0
#82 0xb59694b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#83 0xb6ce05d5 in QEventDispatcherGlib::processEvents (this=0x952b478, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#84 0xb6297135 in QGuiEventDispatcherGlib::processEvents (this=0x952b478, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#85 0xb6cb3059 in QEventLoop::processEvents (this=0xbfb73194, flags=) at kernel/qeventloop.cpp:149
#86 0xb6cb34aa in QEventLoop::exec (this=0xbfb73194, flags=...) at kernel/qeventloop.cpp:201
#87 0xb6cb769f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#88 0xb61d7577 in QApplication::exec () at kernel/qapplication.cpp:3579
#89 0xb22e505e in kdemain (argc=1, argv=0x951c758) at ../../../../plasma/desktop/shell/main.cpp:112
#90 0x0804e133 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=0, envs=0x94fa098 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x8051465 "0") at ../../kinit/kinit.cpp:717
#91 0x0804ec6d in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#92 0x0804f190 in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1402
#93 0x0804fe4f in main (argc=4, argv=0xbfb73c44, envp=0xbfb73c58) at ../../kinit/kinit.cpp:1845

Reported using DrKonqi
Comment 1 Beat Wolf 2010-06-18 16:14:36 UTC
i can't find the dupe, but i think this is fixed in trunk. please test again with kde 4.5. thank you
Comment 2 Christoph Feck 2011-05-03 16:57:10 UTC

*** This bug has been marked as a duplicate of bug 258706 ***