Bug 240802

Summary: Phonon prevents audio device from going to power saving mode
Product: [Frameworks and Libraries] phonon-backend-gstreamer Reporter: Alexander van Loon <a.vanloon>
Component: generalAssignee: Harald Sitter <sitter>
Severity: normal CC: martin.sandsmark, myriam, robert.ryan, sitter, tdfischer
Priority: NOR    
Version: 4.4.4   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: Power Management settings 1
Power Management settings 2
Powersave profile settings 1
Powersave profile settings 2
Powersave profile settings 3
Screenshot of powertop, first
Screenshot of powertop, second

Description Alexander van Loon 2010-06-05 12:59:39 UTC
Version:           4.4.0 (KDE SC 4.4.2) (using KDE 4.4.2) 
OS:                Linux

First of all, I don’t understand the ambiguity presented to me by the choice of the application version. The version number of Kubuntu’s meta package called ‘phonon’ is 4:4.6.2-0ubuntu5.

I already filed this bug on 13-02-2010 on Ubuntu Launchpad here – https://bugs.launchpad.net/ubuntu/+bug/521424 – however, the Kubuntu developers haven’t fixed it yet and the Phonon developers haven’t taken any action yet either. That’s why I’m filing the bug at KDE’s Bugzilla as well, in the hope that the Phonon developers don’t forget about the bug. I’d like to refer to the description of the bug on Ubuntu Launchpad, if the Phonon developers don’t mind. The description there includes or the details as far as I know.

Short summary: the application powertop informs me that the audio devices of my notebook are permanently being used. they don’t go to a power saving state when no sound is playing, and all which is ever playing on my notebook is the login sound of KDE. This happens only with Kubuntu 10.04, not with Ubuntu 10.04. Most likely Phonon is the culprit. This happens with the Xine backend for Phonon, but also with the GStreamer backend (a Phonon developer suspected the problem was limited to the Xine backend).

Reproducible: Always

Steps to Reproduce:
I have only seen this problem on my Acer TravelMate TimeLine 8371 notebook, which uses a Realtek ALC269 audio chip. I haven’t been able to verify if the problem occurs on other computers. Then install Kubuntu 10.04, start up and log in to KDE. Install the application powertop from Kubuntu’s package repository. Then open a terminal and start it as superuser (sudo). After a while, possible requiring action on other suggestions to save power, the message that the audio device is being used 100% or slightly less of the time comes up.

Actual Results:  
The audio device is being stressed unnecessarily, decreasing the battery life of the notebook.

Expected Results:  
If the audio device isn’t being used it should go in a power saving state.

Please the bug report in Launchpad for that.
Comment 1 Myriam Schweingruber 2010-06-05 18:37:48 UTC
I can't reproduce this here on a Lenovo W500 laptop, using KDE SC 4.5.beta 1, and had no problems either with KDE SC 4.4.3 previously. Maybe updating your KDE to a more recent release could help. Please see http://kubuntu.org/news for more information. The latest release is KDE SC 4.4.4 in the Kubuntu backports PPA.
Comment 2 Alexander van Loon 2010-06-05 21:03:04 UTC
Thank you for your quick response. I updated to KDE SC 4.4.4 by using Kubuntu’s Updates PPA and restarted my notebook. Unfortunately after consulting powertop, the problem is still there.

Given the fact that you can’t reproduce the problem, I suspect it is a problem specific to Kubuntu (which distribution did you use to test?) or my hardware, or a combination of both.

I think it would be useful to try to reproduce the problem using a different distribution on the same notebook, for example OpenSUSE and Chakra. I think I’ll do that soon, I’ll report back to tell if those distributions also give this problem.
Comment 3 Myriam Schweingruber 2010-06-05 21:59:07 UTC
I don't think it is Kubuntu related since I also use that distribution. You should check your ACPI settings and check if you have all necessary kernel modules loaded
Comment 4 Alexander van Loon 2010-06-06 10:58:48 UTC
This part I don’t understand, could you please provide more detailed instructions on how I would accomplish those two tasks?
Comment 5 Myriam Schweingruber 2010-06-06 12:51:27 UTC
The ACPI settings are what you can set in the SystemSettings -> Power management. This can only work if the kernel module for ACPI is loaded, of course, so check the Capabilities section in the Power management.
Comment 6 Alexander van Loon 2010-06-06 16:07:16 UTC
In the ‘Capabilities’ section of ‘System Settings’ → ‘Power Management’ I see the following information, after numbers of CPU’s and batteries:

Supported suspend methods: Suspend to disk, Suspend to RAM
DPMS Support: working
ConsoliKit Runtime Support: working
Status: No issues found with your configuration

But I can change nothing here, so I’m missing something then? You wrote I should be able to change something there? How to make sure the kernel module is loaded?
Comment 7 Myriam Schweingruber 2010-06-07 00:13:26 UTC
It is loaded, else you wouldn't see those options. Of course you can't change settings in Capabilities, try the Settings part.
Comment 8 Alexander van Loon 2010-06-12 12:20:35 UTC
Created attachment 47934 [details]
Power Management settings 1
Comment 9 Alexander van Loon 2010-06-12 12:20:57 UTC
Created attachment 47935 [details]
Power Management settings 2
Comment 10 Alexander van Loon 2010-06-12 12:24:24 UTC
Created attachment 47936 [details]
Powersave profile settings 1
Comment 11 Alexander van Loon 2010-06-12 12:25:01 UTC
Created attachment 47937 [details]
Powersave profile settings 2
Comment 12 Alexander van Loon 2010-06-12 12:26:34 UTC
Created attachment 47938 [details]
Powersave profile settings 3
Comment 13 Alexander van Loon 2010-06-12 12:30:36 UTC
I uploaded screenshots of all the settings, hopefully this is the information which was necessary. I can see nothing wrong there, I haven’t made any modifications to the settings, they’re the default settings of Kubuntu.
Comment 14 Myriam Schweingruber 2010-06-12 12:41:47 UTC
No need to upload all these images, I told you your kernel module was running correctly. But reading the various comments in the Launchpad bug, I don't know if this is really only Phonon related, since knotify could also be involved. We will have to dig deeper to check that out.

I still can't reproduce this here, but I use the VLC backend (not released yet), which might be the difference to your settings. But since you can reproduce with both the xine and the gstreamer backend, it might not be backend related after all. I will ping the developers about that.
Comment 15 Alexander van Loon 2010-08-24 22:34:55 UTC
After the last comment here, two more people reported in the Launchpad bug report that they are also affected. One user mentions though that it doesn't seem to be related to knotify or kmix. The only pattern so far seems to be that only (K)ubuntu users are affected. You mentioned you would ask the developers, what do they know?
Comment 16 Myriam Schweingruber 2010-08-25 11:53:02 UTC
Confirmed by downstream reports. I just pinged the developer, the problem is likely a lack of time.
Comment 17 Robert Ryan 2011-06-06 16:42:35 UTC
I'm also experiencing this on the latest debian sid package.
Comment 18 Myriam Schweingruber 2011-06-15 08:47:54 UTC
We are sorry, but the xine backend is deprecated since upstream development is stalled. Please use one of the two other backends instead.
Comment 19 Alexander van Loon 2011-06-15 23:03:55 UTC
But in my first comment I also mentioned that the GStreamer backend is affected. Could the component please be changed to GStreamer then?
Comment 20 Myriam Schweingruber 2011-06-16 02:09:33 UTC
Comment 21 Torrie Fischer 2011-09-23 12:50:50 UTC
Are you using pulseaudio?
Comment 22 Alexander van Loon 2011-09-25 21:21:07 UTC
I'm not sure because my laptop is now sent away for repairs and it had GNOME 3 installed. When I get it back in a few days I'll check if the problem is still reproducible with the latest KDE version.
Comment 23 Alexander van Loon 2011-10-04 11:19:25 UTC
Created attachment 64197 [details]
Screenshot of powertop, first

So I got my notebook back and installed the latest Kubuntu beta on it, then downloaded all updates. Now powertop gives different numbers, showing the use of the audio devices is 0% when my notebook is idle and not playing any audio.
Comment 24 Alexander van Loon 2011-10-04 11:22:30 UTC
Created attachment 64198 [details]
Screenshot of powertop, second

I'm not sure how to interpret this information, but it seems to be more evidence that the bug has now been solved, because powertop indicates that power management for the audio devices is working properly. Can the bug be closed now?
Comment 25 Torrie Fischer 2011-10-04 12:38:02 UTC
Closing at your request. If the problem resurfaces, feel free to reopen. We're pretty confident things should be fixed now though.