Bug 238759

Summary: Proxy Settings on Kubuntu 10.04 - no way to enter authentication details
Product: systemsettings Reporter: Dmitry Vinokurov <df6.626>
Component: kcm_proxyAssignee: Konqueror Developers <konq-bugs>
Severity: normal CC: udippel, wedge009
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Dmitry Vinokurov 2010-05-25 06:34:53 UTC
Version:           unspecified (using KDE 4.4.2) 
OS:                Linux

I choosed 'Manually specify' at Settings->Network Settings->Proxy and set up my proxy settings. But there is no way to set 'username:' and 'password', this fields are grayed out all the time. 'Prompt as needed' seems not to work too -- I don't get any prompt. So KDE apps has no access to internet. Applications with their own proxy settings work fine.

This problem was discussed earlier at http://ubuntuforums.org/showthread.php?p=9302385 but wasn't solved.

Reproducible: Always

Steps to Reproduce:
Proxy with auth somewhere at the net. Manually specify proxy settings at Settings->Network Settings->Proxy. For example try to visit some website with Konqueror.

Actual Results:  
No way to set username and password, fields are grayed. KDE doesn't ask for username and password. KDE apps couldn't get to the internet.

Expected Results:  
Either KDE should ask for username and password or it should be possible to set username and password fields at Proxy settings. I expect KDE apps to get the internet, like firefox, aptitude (via apt.conf) and apps which use shell $http_proxy do.
Comment 1 Uwe Dippel 2010-05-26 10:15:35 UTC
This should be set to 'critical', because it is a showstopper for everyone who tried to use KDE in the organisational environment.
Comment 2 Tommi Tervo 2010-05-26 10:40:30 UTC

*** This bug has been marked as a duplicate of bug 232626 ***
Comment 3 Dmitry Vinokurov 2010-05-29 07:41:47 UTC
(In reply to comment #2)
> *** This bug has been marked as a duplicate of bug 232626 ***

As I understand bug 232626 is about grayed login&password fields only and this bug is about no way to enter authentication details at all, KDE doesn't prompt for it.

So I doubt that 232626 and 238759 are the same bug. And I agree with Uwe Dippel that this bug should be 'critical', now our Kubuntu work machines have no internet in all KDE apps.
Comment 4 Wedge009 2010-08-18 07:51:47 UTC
I confirm that this is a critical issue at my work office as well. This is a huge stumbling block for adoption of KDE, and by extension, Linux, in the workplace.