Bug 23700

Summary: tables and divs don't play nicely (testcase)
Product: konqueror Reporter: davidhj
Component: khtmlAssignee: Konqueror Developers <konq-bugs>
Status: RESOLVED WORKSFORME    
Severity: normal    
Priority: NOR    
Version: 3.0   
Target Milestone: ---   
Platform: Mandrake RPMs   
OS: Linux   
Latest Commit: Version Fixed In:

Description davidhj 2001-04-04 18:53:14 UTC
(*** This bug was imported into bugs.kde.org ***)

Package:           khtml
Version:           3.0 (using KDE 2.1.0 )
Severity:          normal
Installed from:    Linux-Mandrake 7.2 (unsupported)
Compiler:          gcc version 2.95.3 19991030 (prerelease)
OS:                Linux 2.2.17-21mdk i686
OS/Compiler notes: 

Here is some valid HTML 4.01:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<title>test</title>
</head>
<body bgcolor="#8888FF">
<TABLE ALIGN="left"><TR><TD>
 blahafdsssssssss sssssss ssssssssssss blahafdsssss ssssssss sssssssssss ssss blahaf dsssss sssssssssssssssssssssss blahafdssssssssssssssssssssssssssss
</TD></TR></TABLE>
<DIV ALIGN="center">Default options for all domains<</DIV>
</BODY>
</HTML>

On my Konqueror this renders with the "Def" of default vertically down the side of the table. Add a bit more HTML and the "def" disappears altogether.

This is kinda ugly. Removing the 'align="left"' of the table fixes it.

cheers
David

(Submitted via bugs.kde.org)
(Called from KBugReport dialog)
Comment 1 Maksim Orlovich 2002-09-30 03:55:08 UTC
Looks fine with post-3.1Beta2 CVS -- the text is placed on the right of the    
table iff the entire word "Default" fits, and if it doesn't, it is placed  
below the table.  So looks like the table work in CVS fixed it.