Bug 236900

Summary: Dolphin spits after abolition.
Product: [Applications] dolphin Reporter: Usul <muad.dib57>
Component: generalAssignee: Peter Penz <peter.penz19>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: 16.12.2   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description Usul 2010-05-08 21:04:56 UTC
Application: dolphin (1.4)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-22-generic i686
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
I wanted to abolish a video file and while abolition was made, Dolphin spat.


 -- Backtrace:
Application: Dolphin (dolphin), signal: Aborted
[Current thread is 1 (Thread 0xb77b9710 (LWP 15440))]

Thread 5 (Thread 0xb5e98b70 (LWP 15445)):
#0  0x0071ef22 in pthread_mutex_lock () from /lib/tls/i686/cmov/libpthread.so.0
#1  0x0395ab66 in pthread_mutex_lock () from /lib/tls/i686/cmov/libc.so.6
#2  0x052c049e in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x056ac60f in QEventDispatcherGlib::processEvents (this=0x9186318, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#4  0x0567f059 in QEventLoop::processEvents (this=0xb5e98290, flags=) at kernel/qeventloop.cpp:149
#5  0x0567f4aa in QEventLoop::exec (this=0xb5e98290, flags=...) at kernel/qeventloop.cpp:201
#6  0x0557b5a8 in QThread::exec (this=0x925d6d8) at thread/qthread.cpp:487
#7  0x0565ec1b in QInotifyFileSystemWatcherEngine::run (this=0x925d6d8) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x0557e32e in QThreadPrivate::start (arg=0x925d6d8) at thread/qthread_unix.cpp:248
#9  0x0071c96e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#10 0x0394da0e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 4 (Thread 0xb43b9b70 (LWP 15461)):
#0  0x009f1422 in __kernel_vsyscall ()
#1  0x00721342 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x0395a9f4 in pthread_cond_timedwait () from /lib/tls/i686/cmov/libc.so.6
#3  0x0604bce7 in ?? () from /usr/lib/libxine.so.1
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 3 (Thread 0xb2b24b70 (LWP 19674)):
#0  0x009f1422 in __kernel_vsyscall ()
#1  0x0393deab in write () from /lib/tls/i686/cmov/libc.so.6
#2  0x038e71c4 in _IO_file_write () from /lib/tls/i686/cmov/libc.so.6
#3  0x038e6e4f in ?? () from /lib/tls/i686/cmov/libc.so.6
#4  0x038e7116 in _IO_file_xsputn () from /lib/tls/i686/cmov/libc.so.6
#5  0x038c1f58 in ?? () from /lib/tls/i686/cmov/libc.so.6
#6  0x038bce13 in vfprintf () from /lib/tls/i686/cmov/libc.so.6
#7  0x03960d9d in __fprintf_chk () from /lib/tls/i686/cmov/libc.so.6
#8  0x055752c6 in fprintf (msgType=QtWarningMsg, buf=0x22 <Address 0x22 out of bounds>) at /usr/include/bits/stdio2.h:99
#9  qt_message_output (msgType=QtWarningMsg, buf=0x22 <Address 0x22 out of bounds>) at global/qglobal.cpp:2216
#10 0x055754aa in qt_message (msgType=<value optimized out>, msg=0x56e9627 "%s: %s failure: %s", ap=0xb2b23b24 "x\226n\005\207\226n\005\274Sy\005") at global/qglobal.cpp:2296
#11 0x05575689 in qWarning (msg=0x56e9627 "%s: %s failure: %s") at global/qglobal.cpp:2378
#12 0x0557d637 in report_error (code=<value optimized out>, where=0x56e9678 "QMutex::lock()", what=0x56e9687 "cv wait") at thread/qmutex_unix.cpp:61
#13 0x0557d865 in QMutexPrivate::wait (this=0x904c700, timeout=-1) at thread/qmutex_unix.cpp:99
#14 0x05579052 in QMutex::lock (this=0xb53035e0) at thread/qmutex.cpp:167
#15 0x008c4000 in ?? () from /usr/lib/libsopranoclient.so.1
#16 0x001bea30 in Nepomuk::MainModel::executeQuery (this=0x91887a0, query=..., language=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...) at ../../../nepomuk/core/nepomukmainmodel.cpp:213
#17 0x002623cd in Soprano::FilterModel::executeQuery(QString const&, Soprano::Query::QueryLanguage, QString const&) const () from /usr/lib/libsoprano.so.4
#18 0x001b2335 in Nepomuk::ResourceData::determineUri (this=0xb5313a00) at ../../../nepomuk/core/resourcedata.cpp:671
#19 0x001b36a0 in Nepomuk::ResourceData::load (this=0xb5313a00) at ../../../nepomuk/core/resourcedata.cpp:414
#20 0x001b419b in Nepomuk::ResourceData::property (this=0xb5313a00, uri=...) at ../../../nepomuk/core/resourcedata.cpp:271
#21 0x001d1cb7 in Nepomuk::Resource::property (this=0xb2b24294, uri=...) at ../../../nepomuk/core/resource.cpp:280
#22 0x001d4d41 in Nepomuk::Resource::rating (this=0xb2b24294) at ../../../nepomuk/core/resource.cpp:800
#23 0x080aa1e9 in KLoadMetaDataThread::run (this=0x939d860) at ../../../../apps/dolphin/src/panels/information/kloadmetadatathread.cpp:95
#24 0x0557e32e in QThreadPrivate::start (arg=0x939d860) at thread/qthread_unix.cpp:248
#25 0x0071c96e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#26 0x0394da0e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 2 (Thread 0xb3325b70 (LWP 19676)):
#0  0x009f1422 in __kernel_vsyscall ()
#1  0x00721015 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x0395a99d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x0557d8c2 in QMutexPrivate::wait (this=0xb5304990, timeout=-1) at thread/qmutex_unix.cpp:84
#4  0x05579052 in QMutex::lock (this=0xb5313a2c) at thread/qmutex.cpp:167
#5  0x001b35e6 in QMutexLocker::relock (this=0xb5313a00) at /usr/include/qt4/QtCore/qmutex.h:120
#6  QMutexLocker (this=0xb5313a00) at /usr/include/qt4/QtCore/qmutex.h:102
#7  Nepomuk::ResourceData::load (this=0xb5313a00) at ../../../nepomuk/core/resourcedata.cpp:409
#8  0x001b419b in Nepomuk::ResourceData::property (this=0xb5313a00, uri=...) at ../../../nepomuk/core/resourcedata.cpp:271
#9  0x001d1cb7 in Nepomuk::Resource::property (this=0xb3325294, uri=...) at ../../../nepomuk/core/resource.cpp:280
#10 0x001d4d41 in Nepomuk::Resource::rating (this=0xb3325294) at ../../../nepomuk/core/resource.cpp:800
#11 0x00f83f16 in KLoadMetaDataThread::run (this=0x946da88) at ../../../../apps/dolphin/src/panels/information/kloadmetadatathread.cpp:95
#12 0x0557e32e in QThreadPrivate::start (arg=0x946da88) at thread/qthread_unix.cpp:248
#13 0x0071c96e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#14 0x0394da0e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb77b9710 (LWP 15440)):
[KCrash Handler]
#6  0x009f1422 in __kernel_vsyscall ()
#7  0x038aa651 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0x038ada82 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0x038e149d in ?? () from /lib/tls/i686/cmov/libc.so.6
#10 0x038eb591 in ?? () from /lib/tls/i686/cmov/libc.so.6
#11 0x038ee710 in ?? () from /lib/tls/i686/cmov/libc.so.6
#12 0x038eff9c in malloc () from /lib/tls/i686/cmov/libc.so.6
#13 0x0083fc07 in operator new(unsigned int) () from /usr/lib/libstdc++.so.6
#14 0x0052502d in qMetaTypeConstructHelper<KFileItem> (t=0x904a7a0) at /usr/include/qt4/QtCore/qmetatype.h:138
#15 0x0568b3d8 in QMetaType::construct (type=297, copy=0x904a7a0) at kernel/qmetatype.cpp:1116
#16 0x056a23b7 in construct (x=0xbfc6d54c, copy=0x904a7a0) at kernel/qvariant.cpp:177
#17 0x03f56943 in construct (x=0xbfc6d54c, copy=0x904a7a0) at kernel/qguivariant.cpp:182
#18 0x0569e52f in QVariant::create (this=0xbfc6d54c, type=297, copy=0x904a7a0) at kernel/qvariant.cpp:1363
#19 0x0569e888 in QVariant (this=0xbfc6d54c, typeOrUserType=6, copy=0x3c50, flags=0) at kernel/qvariant.cpp:1647
#20 0x0051ed3c in qVariantFromValue<KFileItem> (this=0x9150d08, index=..., role=128082943) at /usr/include/qt4/QtCore/qvariant.h:449
#21 fromValue<KFileItem> (this=0x9150d08, index=..., role=128082943) at /usr/include/qt4/QtCore/qvariant.h:332
#22 KDirModel::data (this=0x9150d08, index=..., role=128082943) at ../../kio/kio/kdirmodel.cpp:690
#23 0x00f51d96 in DolphinModel::data (this=0x9150d08, index=..., role=0) at ../../../../apps/dolphin/src/dolphinmodel.cpp:121
#24 0x0453e3c8 in QSortFilterProxyModel::data (this=0x91655a0, index=..., role=128082943) at itemviews/qsortfilterproxymodel.cpp:1678
#25 0x00548a56 in QModelIndex::data (this=0x97f6c90, option=..., index=..., labelLayout=0xbfc6d7e0, infoLayout=0xbfc6d7dc, textBoundingRect=0xbfc6d768)
    at /usr/include/qt4/QtCore/qabstractitemmodel.h:398
#26 KFileItemDelegate::Private::fileItem (this=0x97f6c90, option=..., index=..., labelLayout=0xbfc6d7e0, infoLayout=0xbfc6d7dc, textBoundingRect=0xbfc6d768) at ../../kio/kio/kfileitemdelegate.cpp:305
#27 KFileItemDelegate::Private::layoutTextItems (this=0x97f6c90, option=..., index=..., labelLayout=0xbfc6d7e0, infoLayout=0xbfc6d7dc, textBoundingRect=0xbfc6d768)
    at ../../kio/kio/kfileitemdelegate.cpp:679
#28 0x0054af5d in KFileItemDelegate::paint (this=0x9263dc8, painter=0xbfc6de0c, option=..., index=...) at ../../kio/kio/kfileitemdelegate.cpp:1245
#29 0x00f4fab1 in DolphinFileItemDelegate::paint (this=0x9263dc8, painter=0xbfc6de0c, option=..., index=...) at ../../../../apps/dolphin/src/dolphinfileitemdelegate.cpp:77
#30 0x044f0088 in QTreeView::drawRow (this=0x927aa20, painter=0xbfc6de0c, option=..., index=...) at itemviews/qtreeview.cpp:1670
#31 0x044fa4a9 in QTreeView::drawTree (this=0x927aa20, painter=0xbfc6de0c, region=...) at itemviews/qtreeview.cpp:1433
#32 0x044fd5bd in QTreeView::paintEvent (this=0x927aa20, event=0xbfc6e764) at itemviews/qtreeview.cpp:1266
#33 0x00f44e9f in DolphinDetailsView::paintEvent (this=0x927aa20, event=0xbfc6e764) at ../../../../apps/dolphin/src/dolphindetailsview.cpp:396
#34 0x03f6a6b6 in QWidget::event (this=0x927aa20, event=0xbfc6e764) at kernel/qwidget.cpp:8144
#35 0x04366fd3 in QFrame::event (this=0x927aa20, e=0xbfc6e764) at widgets/qframe.cpp:557
#36 0x04401382 in QAbstractScrollArea::viewportEvent (this=0x3c50, e=0x6) at widgets/qabstractscrollarea.cpp:1036
#37 0x044b5bd7 in QAbstractItemView::viewportEvent (this=0x927aa20, event=0xbfc6e764) at itemviews/qabstractitemview.cpp:1610
#38 0x044f6f7c in QTreeView::viewportEvent (this=0x927aa20, event=0xbfc6e764) at itemviews/qtreeview.cpp:1248
#39 0x04403c65 in QAbstractScrollAreaPrivate::viewportEvent (this=0x90b0a08, o=0x9356e30, e=0xbfc6e764) at widgets/qabstractscrollarea_p.h:100
#40 QAbstractScrollAreaFilter::eventFilter (this=0x90b0a08, o=0x9356e30, e=0xbfc6e764) at widgets/qabstractscrollarea_p.h:116
#41 0x0567fcda in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x8e15500, receiver=0x9356e30, event=0xbfc6e764) at kernel/qcoreapplication.cpp:819
#42 0x03f0c4b9 in QApplicationPrivate::notify_helper (this=0x8e15500, receiver=0x9356e30, e=0xbfc6e764) at kernel/qapplication.cpp:4296
#43 0x03f130f9 in QApplication::notify (this=0xbfc6f4f4, receiver=0x9356e30, e=0xbfc6e764) at kernel/qapplication.cpp:4265
#44 0x0117cf2a in KApplication::notify (this=0xbfc6f4f4, receiver=0x9356e30, event=0xbfc6e764) at ../../kdeui/kernel/kapplication.cpp:302
#45 0x05680a3b in QCoreApplication::notifyInternal (this=0xbfc6f4f4, receiver=0x9356e30, event=0xbfc6e764) at kernel/qcoreapplication.cpp:704
#46 0x03f739d6 in QCoreApplication::sendSpontaneousEvent (this=0x97f7190, pdev=0x8f1821c, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x8f18150)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#47 QWidgetPrivate::drawWidget (this=0x97f7190, pdev=0x8f1821c, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x8f18150) at kernel/qwidget.cpp:5339
#48 0x0414a7d7 in QWidgetBackingStore::sync (this=0x8f18150) at painting/qbackingstore.cpp:1283
#49 0x03f63b93 in QWidgetPrivate::syncBackingStore (this=0x8e0c6b0) at kernel/qwidget.cpp:1672
#50 0x03f6ae76 in QWidget::event (this=0x8ef48d8, event=0x91cfc70) at kernel/qwidget.cpp:8291
#51 0x04385bc7 in QMainWindow::event (this=0x8ef48d8, event=0x91cfc70) at widgets/qmainwindow.cpp:1433
#52 0x0126eb04 in KMainWindow::event (this=0x8ef48d8, ev=0x91cfc70) at ../../kdeui/widgets/kmainwindow.cpp:1103
#53 0x012b688f in KXmlGuiWindow::event (this=0x8ef48d8, ev=0x91cfc70) at ../../kdeui/xmlgui/kxmlguiwindow.cpp:131
#54 0x03f0c4dc in QApplicationPrivate::notify_helper (this=0x8e15500, receiver=0x8ef48d8, e=0x91cfc70) at kernel/qapplication.cpp:4300
#55 0x03f130f9 in QApplication::notify (this=0xbfc6f4f4, receiver=0x8ef48d8, e=0x91cfc70) at kernel/qapplication.cpp:4265
#56 0x0117cf2a in KApplication::notify (this=0xbfc6f4f4, receiver=0x8ef48d8, event=0x91cfc70) at ../../kdeui/kernel/kapplication.cpp:302
#57 0x05680a3b in QCoreApplication::notifyInternal (this=0xbfc6f4f4, receiver=0x8ef48d8, event=0x91cfc70) at kernel/qcoreapplication.cpp:704
#58 0x05683473 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x8df6ce0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#59 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8df6ce0) at kernel/qcoreapplication.cpp:1345
#60 0x056835dd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#61 0x056acadf in QCoreApplication::sendPostedEvents (s=0x8e19b10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#62 postEventSourceDispatch (s=0x8e19b10) at kernel/qeventdispatcher_glib.cpp:276
#63 0x052bc5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#64 0x052c02d8 in ?? () from /lib/libglib-2.0.so.0
#65 0x052c04b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#66 0x056ac5d5 in QEventDispatcherGlib::processEvents (this=0x8df69c0, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#67 0x03fcc135 in QGuiEventDispatcherGlib::processEvents (this=0x8df69c0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#68 0x0567f059 in QEventLoop::processEvents (this=0xbfc6f454, flags=) at kernel/qeventloop.cpp:149
#69 0x0567f4aa in QEventLoop::exec (this=0xbfc6f454, flags=...) at kernel/qeventloop.cpp:201
#70 0x0568369f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#71 0x03f0c577 in QApplication::exec () at kernel/qapplication.cpp:3579
#72 0x0807bbcf in main (argc=5, argv=0xbfc6f6d4) at ../../../../apps/dolphin/src/main.cpp:101

Reported using DrKonqi
Comment 1 Peter Penz 2010-08-16 18:32:17 UTC

*** This bug has been marked as a duplicate of bug 235166 ***