Bug 236265

Summary: Janelas fecham sozinhas
Product: [Applications] dolphin Reporter: Frederico Matos <fredymatosibs>
Component: generalAssignee: Peter Penz <peter.penz19>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: 16.12.2   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description Frederico Matos 2010-05-04 04:26:48 UTC
Application: dolphin (1.4)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-21-generic i686
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
Sempre que estou navegando o gerenciador de arquivos a janela fecha automaticamente se explicac√£o perdendo tudo que eu estava fazendo...

 -- Backtrace:
Application: Dolphin (dolphin), signal: Aborted
[Current thread is 1 (Thread 0xb7849710 (LWP 9630))]

Thread 16 (Thread 0xb5de1b70 (LWP 9637)):
#0  0x0060d422 in __kernel_vsyscall ()
#1  0x006e8cf3 in ?? () from /lib/tls/i686/cmov/libc.so.6
#2  0x0067f697 in ?? () from /lib/tls/i686/cmov/libc.so.6
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 15 (Thread 0xb44b9b70 (LWP 9780)):
#0  0x0060d422 in __kernel_vsyscall ()
#1  0x006e8cf3 in ?? () from /lib/tls/i686/cmov/libc.so.6
#2  0x0067f697 in ?? () from /lib/tls/i686/cmov/libc.so.6
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 14 (Thread 0xb3affb70 (LWP 9782)):
[KCrash Handler]
#6  0x0060d422 in __kernel_vsyscall ()
#7  0x00638651 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0x0063ba82 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0x0066f49d in ?? () from /lib/tls/i686/cmov/libc.so.6
#10 0x00679591 in ?? () from /lib/tls/i686/cmov/libc.so.6
#11 0x0067c395 in ?? () from /lib/tls/i686/cmov/libc.so.6
#12 0x0067df9c in malloc () from /lib/tls/i686/cmov/libc.so.6
#13 0x07e1cb8d in qMalloc (size=186) at global/qmalloc.cpp:55
#14 0x07e2599b in QByteArray::resize (this=0xb3afe2ac, size=0) at tools/qbytearray.cpp:1370
#15 0x07e6be73 in QString::toUtf8 (this=0xa71ee44) at tools/qstring.cpp:3527
#16 0x00a71359 in QDBusMessagePrivate::toDBusMessage (message=..., error=0xb3afeb24) at qdbusmessage.cpp:131
#17 0x00a69161 in QDBusConnectionPrivate::sendWithReply (this=0xb3b01900, message=..., sendMode=1, timeout=-1) at qdbusintegrator.cpp:1799
#18 0x00a53edb in QDBusConnection::call (this=0xb3b1e880, message=..., mode=6, timeout=-1) at qdbusconnection.cpp:516
#19 0x00a7485f in QDBusAbstractInterface::callWithArgumentList (this=0xb3afef28, mode=QDBus::Block, method=..., args=...) at qdbusabstractinterface.cpp:440
#20 0x00a77b98 in QDBusAbstractInterface::call (this=0xb3afef28, mode=QDBus::AutoDetect, method=..., arg1=..., arg2=..., arg3=..., arg4=..., arg5=..., arg6=..., arg7=..., arg8=...)
    at qdbusabstractinterface.cpp:694
#21 0x00a77dfc in QDBusAbstractInterface::call (this=0xb3afef28, method=..., arg1=..., arg2=..., arg3=..., arg4=..., arg5=..., arg6=..., arg7=..., arg8=...) at qdbusabstractinterface.cpp:637
#22 0x00aed8e6 in Nepomuk::ResourceData::determineUri (this=0xa501680) at ../../../nepomuk/core/resourcedata.cpp:702
#23 0x00aee6a0 in Nepomuk::ResourceData::load (this=0xa501680) at ../../../nepomuk/core/resourcedata.cpp:414
#24 0x00aef280 in Nepomuk::ResourceData::allProperties (this=0xa501680) at ../../../nepomuk/core/resourcedata.cpp:218
#25 0x00b0d440 in Nepomuk::Resource::properties (this=0xb3aff294) at ../../../nepomuk/core/resource.cpp:238
#26 0x080aa48f in KLoadMetaDataThread::run (this=0xa3ebd88) at ../../../../apps/dolphin/src/panels/information/kloadmetadatathread.cpp:113
#27 0x07e2232e in QThreadPrivate::start (arg=0xa3ebd88) at thread/qthread_unix.cpp:248
#28 0x0052c96e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#29 0x006dba0e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 13 (Thread 0xb32feb70 (LWP 9784)):
#0  0x0060d422 in __kernel_vsyscall ()
#1  0x006e8cf3 in ?? () from /lib/tls/i686/cmov/libc.so.6
#2  0x0067f697 in ?? () from /lib/tls/i686/cmov/libc.so.6
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 12 (Thread 0xb2afdb70 (LWP 9786)):
#0  0x0060d422 in __kernel_vsyscall ()
#1  0x00533af9 in __lll_lock_wait () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x005310d1 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#3  0x006e899d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#4  0x07e218c2 in QMutexPrivate::wait (this=0xa6904f8, timeout=-1) at thread/qmutex_unix.cpp:84
#5  0x07e1d052 in QMutex::lock (this=0xa85b4c0) at thread/qmutex.cpp:167
#6  0x00801000 in ?? () from /usr/lib/libsopranoclient.so.1
#7  0x00af9a30 in Nepomuk::MainModel::executeQuery (this=0xa24c8e0, query=..., language=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...) at ../../../nepomuk/core/nepomukmainmodel.cpp:213
#8  0x001be3cd in Soprano::FilterModel::executeQuery(QString const&, Soprano::Query::QueryLanguage, QString const&) const () from /usr/lib/libsoprano.so.4
#9  0x00aed335 in Nepomuk::ResourceData::determineUri (this=0xb3b04960) at ../../../nepomuk/core/resourcedata.cpp:671
#10 0x00aee6a0 in Nepomuk::ResourceData::load (this=0xb3b04960) at ../../../nepomuk/core/resourcedata.cpp:414
#11 0x00aef280 in Nepomuk::ResourceData::allProperties (this=0xb3b04960) at ../../../nepomuk/core/resourcedata.cpp:218
#12 0x00b0d440 in Nepomuk::Resource::properties (this=0xb2afd294) at ../../../nepomuk/core/resource.cpp:238
#13 0x080aa48f in KLoadMetaDataThread::run (this=0xa4a0e20) at ../../../../apps/dolphin/src/panels/information/kloadmetadatathread.cpp:113
#14 0x07e2232e in QThreadPrivate::start (arg=0xa4a0e20) at thread/qthread_unix.cpp:248
#15 0x0052c96e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#16 0x006dba0e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 11 (Thread 0xb22fcb70 (LWP 9788)):
#0  0x0060d422 in __kernel_vsyscall ()
#1  0x006e8cf3 in ?? () from /lib/tls/i686/cmov/libc.so.6
#2  0x0067f697 in ?? () from /lib/tls/i686/cmov/libc.so.6
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 10 (Thread 0xb1afbb70 (LWP 9791)):
#0  0x0060d422 in __kernel_vsyscall ()
#1  0x00531015 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x006e899d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x07e218c2 in QMutexPrivate::wait (this=0xa478e98, timeout=-1) at thread/qmutex_unix.cpp:84
#4  0x07e1d052 in QMutex::lock (this=0xa4025dc) at thread/qmutex.cpp:167
#5  0x00aee5e6 in QMutexLocker::relock (this=0xa4025b0) at /usr/include/qt4/QtCore/qmutex.h:120
#6  QMutexLocker (this=0xa4025b0) at /usr/include/qt4/QtCore/qmutex.h:102
#7  Nepomuk::ResourceData::load (this=0xa4025b0) at ../../../nepomuk/core/resourcedata.cpp:409
#8  0x00aef19b in Nepomuk::ResourceData::property (this=0xa4025b0, uri=...) at ../../../nepomuk/core/resourcedata.cpp:271
#9  0x00b0ccb7 in Nepomuk::Resource::property (this=0xb1afb294, uri=...) at ../../../nepomuk/core/resource.cpp:280
#10 0x00b0fd41 in Nepomuk::Resource::rating (this=0xb1afb294) at ../../../nepomuk/core/resource.cpp:800
#11 0x080aa1e9 in KLoadMetaDataThread::run (this=0xa499a68) at ../../../../apps/dolphin/src/panels/information/kloadmetadatathread.cpp:95
#12 0x07e2232e in QThreadPrivate::start (arg=0xa499a68) at thread/qthread_unix.cpp:248
#13 0x0052c96e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#14 0x006dba0e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 9 (Thread 0xb12fab70 (LWP 9792)):
#0  0x0060d422 in __kernel_vsyscall ()
#1  0x00531015 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x006e899d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x07e218c2 in QMutexPrivate::wait (this=0xa478e98, timeout=-1) at thread/qmutex_unix.cpp:84
#4  0x07e1d052 in QMutex::lock (this=0xa4025dc) at thread/qmutex.cpp:167
#5  0x00aee5e6 in QMutexLocker::relock (this=0xa4025b0) at /usr/include/qt4/QtCore/qmutex.h:120
#6  QMutexLocker (this=0xa4025b0) at /usr/include/qt4/QtCore/qmutex.h:102
#7  Nepomuk::ResourceData::load (this=0xa4025b0) at ../../../nepomuk/core/resourcedata.cpp:409
#8  0x00aef19b in Nepomuk::ResourceData::property (this=0xa4025b0, uri=...) at ../../../nepomuk/core/resourcedata.cpp:271
#9  0x00b0ccb7 in Nepomuk::Resource::property (this=0xb12fa294, uri=...) at ../../../nepomuk/core/resource.cpp:280
#10 0x00b0fd41 in Nepomuk::Resource::rating (this=0xb12fa294) at ../../../nepomuk/core/resource.cpp:800
#11 0x080aa1e9 in KLoadMetaDataThread::run (this=0xa3e4330) at ../../../../apps/dolphin/src/panels/information/kloadmetadatathread.cpp:95
#12 0x07e2232e in QThreadPrivate::start (arg=0xa3e4330) at thread/qthread_unix.cpp:248
#13 0x0052c96e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#14 0x006dba0e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 8 (Thread 0xb0af9b70 (LWP 9804)):
#0  0x0060d422 in __kernel_vsyscall ()
#1  0x006e8cf3 in ?? () from /lib/tls/i686/cmov/libc.so.6
#2  0x0067f697 in ?? () from /lib/tls/i686/cmov/libc.so.6
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 7 (Thread 0xb02f8b70 (LWP 9806)):
#0  0x0060d422 in __kernel_vsyscall ()
#1  0x006e8cf3 in ?? () from /lib/tls/i686/cmov/libc.so.6
#2  0x0067f697 in ?? () from /lib/tls/i686/cmov/libc.so.6
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 6 (Thread 0xadf60b70 (LWP 9810)):
#0  0x0060d422 in __kernel_vsyscall ()
#1  0x00531015 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x006e899d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x07e218c2 in QMutexPrivate::wait (this=0xb3b072d0, timeout=-1) at thread/qmutex_unix.cpp:84
#4  0x07e1d072 in QMutex::lock (this=0xb3b2be70) at thread/qmutex.cpp:205
#5  0x00800b88 in ?? () from /usr/lib/libsopranoclient.so.1
#6  0x00802346 in ?? () from /usr/lib/libsopranoclient.so.1
#7  0x0019b47c in ?? () from /usr/lib/libsoprano.so.4
#8  0x00aed444 in Nepomuk::ResourceData::determineUri (this=0xb3b11308) at ../../../nepomuk/core/resourcedata.cpp:712
#9  0x00aee6a0 in Nepomuk::ResourceData::load (this=0xb3b11308) at ../../../nepomuk/core/resourcedata.cpp:414
#10 0x00aef19b in Nepomuk::ResourceData::property (this=0xb3b11308, uri=...) at ../../../nepomuk/core/resourcedata.cpp:271
#11 0x00b0ccb7 in Nepomuk::Resource::property (this=0xadf60294, uri=...) at ../../../nepomuk/core/resource.cpp:280
#12 0x00b0fd41 in Nepomuk::Resource::rating (this=0xadf60294) at ../../../nepomuk/core/resource.cpp:800
#13 0x080aa1e9 in KLoadMetaDataThread::run (this=0xa2de688) at ../../../../apps/dolphin/src/panels/information/kloadmetadatathread.cpp:95
#14 0x07e2232e in QThreadPrivate::start (arg=0xa2de688) at thread/qthread_unix.cpp:248
#15 0x0052c96e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#16 0x006dba0e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 5 (Thread 0xafaf7b70 (LWP 9811)):
#0  0x0060d422 in __kernel_vsyscall ()
#1  0x00531015 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x006e899d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x07e218c2 in QMutexPrivate::wait (this=0xa293410, timeout=-1) at thread/qmutex_unix.cpp:84
#4  0x07e1d052 in QMutex::lock (this=0xa29362c) at thread/qmutex.cpp:167
#5  0x00aee5e6 in QMutexLocker::relock (this=0xa293600) at /usr/include/qt4/QtCore/qmutex.h:120
#6  QMutexLocker (this=0xa293600) at /usr/include/qt4/QtCore/qmutex.h:102
#7  Nepomuk::ResourceData::load (this=0xa293600) at ../../../nepomuk/core/resourcedata.cpp:409
#8  0x00aef19b in Nepomuk::ResourceData::property (this=0xa293600, uri=...) at ../../../nepomuk/core/resourcedata.cpp:271
#9  0x00b0ccb7 in Nepomuk::Resource::property (this=0xafaf7294, uri=...) at ../../../nepomuk/core/resource.cpp:280
#10 0x00b0fd41 in Nepomuk::Resource::rating (this=0xafaf7294) at ../../../nepomuk/core/resource.cpp:800
#11 0x080aa1e9 in KLoadMetaDataThread::run (this=0xa631678) at ../../../../apps/dolphin/src/panels/information/kloadmetadatathread.cpp:95
#12 0x07e2232e in QThreadPrivate::start (arg=0xa631678) at thread/qthread_unix.cpp:248
#13 0x0052c96e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#14 0x006dba0e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 4 (Thread 0xaf2f6b70 (LWP 9812)):
#0  0x0060d422 in __kernel_vsyscall ()
#1  0x00531015 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x006e899d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x07e218c2 in QMutexPrivate::wait (this=0xa478e98, timeout=-1) at thread/qmutex_unix.cpp:84
#4  0x07e1d052 in QMutex::lock (this=0xa4025dc) at thread/qmutex.cpp:167
#5  0x00aee5e6 in QMutexLocker::relock (this=0xa4025b0) at /usr/include/qt4/QtCore/qmutex.h:120
#6  QMutexLocker (this=0xa4025b0) at /usr/include/qt4/QtCore/qmutex.h:102
#7  Nepomuk::ResourceData::load (this=0xa4025b0) at ../../../nepomuk/core/resourcedata.cpp:409
#8  0x00aef19b in Nepomuk::ResourceData::property (this=0xa4025b0, uri=...) at ../../../nepomuk/core/resourcedata.cpp:271
#9  0x00b0ccb7 in Nepomuk::Resource::property (this=0xaf2f6294, uri=...) at ../../../nepomuk/core/resource.cpp:280
#10 0x00b0fd41 in Nepomuk::Resource::rating (this=0xaf2f6294) at ../../../nepomuk/core/resource.cpp:800
#11 0x080aa1e9 in KLoadMetaDataThread::run (this=0xa64bef0) at ../../../../apps/dolphin/src/panels/information/kloadmetadatathread.cpp:95
#12 0x07e2232e in QThreadPrivate::start (arg=0xa64bef0) at thread/qthread_unix.cpp:248
#13 0x0052c96e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#14 0x006dba0e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 3 (Thread 0xad75fb70 (LWP 9814)):
#0  0x0060d422 in __kernel_vsyscall ()
#1  0x006e8cf3 in ?? () from /lib/tls/i686/cmov/libc.so.6
#2  0x0067f697 in ?? () from /lib/tls/i686/cmov/libc.so.6
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 2 (Thread 0xacf5eb70 (LWP 9816)):
#0  0x0060d422 in __kernel_vsyscall ()
#1  0x00531015 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x006e899d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x07e218c2 in QMutexPrivate::wait (this=0xb3b13c70, timeout=-1) at thread/qmutex_unix.cpp:84
#4  0x07e1d052 in QMutex::lock (this=0xb3b13b74) at thread/qmutex.cpp:167
#5  0x00aee5e6 in QMutexLocker::relock (this=0xb3b13b48) at /usr/include/qt4/QtCore/qmutex.h:120
#6  QMutexLocker (this=0xb3b13b48) at /usr/include/qt4/QtCore/qmutex.h:102
#7  Nepomuk::ResourceData::load (this=0xb3b13b48) at ../../../nepomuk/core/resourcedata.cpp:409
#8  0x00aef19b in Nepomuk::ResourceData::property (this=0xb3b13b48, uri=...) at ../../../nepomuk/core/resourcedata.cpp:271
#9  0x00b0ccb7 in Nepomuk::Resource::property (this=0xacf5e294, uri=...) at ../../../nepomuk/core/resource.cpp:280
#10 0x00b0fd41 in Nepomuk::Resource::rating (this=0xacf5e294) at ../../../nepomuk/core/resource.cpp:800
#11 0x080aa1e9 in KLoadMetaDataThread::run (this=0xa722118) at ../../../../apps/dolphin/src/panels/information/kloadmetadatathread.cpp:95
#12 0x07e2232e in QThreadPrivate::start (arg=0xa722118) at thread/qthread_unix.cpp:248
#13 0x0052c96e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#14 0x006dba0e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb7849710 (LWP 9630)):
#0  0x0060d422 in __kernel_vsyscall ()
#1  0x006e8cf3 in ?? () from /lib/tls/i686/cmov/libc.so.6
#2  0x0067f697 in ?? () from /lib/tls/i686/cmov/libc.so.6
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Reported using DrKonqi
Comment 1 Peter Penz 2010-08-16 18:06:51 UTC

*** This bug has been marked as a duplicate of bug 235166 ***